07:02:48 <ianychoi> #startmeeting OpenStack I18n meeting
07:02:48 <openstack> Meeting started Thu Nov 17 07:02:48 2016 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:02:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:02:51 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:03:10 <ianychoi> Hi How are you all?
07:03:59 <eumel8> good!
07:04:06 <ianychoi> Nice :)
07:04:17 <eumel8> lots of work, daily business
07:04:19 <eumel8> :)
07:04:51 <ianychoi> Me too, and recently I am working on generating install-guide PDFs from rsts... it needs more work than I first expected..
07:05:01 <ianychoi> #topic Review on last meeting actions
07:05:13 <ianychoi> #link http://eavesdrop.openstack.org/meetings/openstack_i18n_meeting/2016/openstack_i18n_meeting.2016-11-10-13.01.html
07:05:30 <ianychoi> There were a few actions from the last meeting: ianychoi and eumel8
07:05:42 <ianychoi> eumel8, thanks a lot for attending the last infra team meeting!
07:06:09 <ianychoi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-11-15-19.02.html
07:06:20 <ianychoi> Number 7 describes the conversation :)
07:06:22 <eumel8> yes
07:06:40 <eumel8> for me was attending the infra team meeting on Tuesday
07:07:20 <eumel8> we've got two volunteers to support the zanata server upgrade to xenial
07:07:22 <ianychoi> I sent an e-mail to aeng the result, because Zanata team wants to know status
07:07:29 <eumel8> sure
07:07:34 <ianychoi> eumel8, yep so nice :)
07:08:10 <eumel8> process looks good to me, but I was unsure if we want an upgrade or a complete new installation?
07:08:23 <ianychoi> And for me, I have submitted feedback and sent a mail to Heidi copying to katomo :)
07:08:29 <ianychoi> (mascot)
07:08:47 <ianychoi> Also, for i18n-spec use cases, I am writting it
07:08:47 <katomo> I read it. thanks
07:08:48 <ianychoi> #link https://etherpad.openstack.org/p/i18n-specs-use-cases
07:08:58 <ianychoi> katomo, np :)
07:09:18 <ianychoi> #link https://review.openstack.org/#/c/397098/
07:09:52 <ianychoi> This is my initial commit for i18n-specs and I think we might polish a template: https://review.openstack.org/#/c/397098/1/template.rst to make more appropriate into i18n team
07:12:09 <eumel8> very good, ianychoi
07:12:27 <ianychoi> eumel8, thanks :) Any recommendations on use-cases?
07:12:40 <eumel8> no
07:12:42 <eumel8> not yet
07:13:07 <ianychoi> And please review https://review.openstack.org/#/c/397098/ eumel8 and katomo :)
07:13:14 <eumel8> ok
07:13:16 <katomo> sure
07:13:57 <ianychoi> I think I might need to send an e-mail for spec use-cases to current core reviewers and language coordinators..
07:14:07 <ianychoi> Thanks a lot!
07:14:51 <ianychoi> #topic open discussions
07:15:39 <ianychoi> Actually, I was busy on other work rather than i18n... but today I have fixed for i18n: https://review.openstack.org/#/c/398730/
07:16:54 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-i18n/2016-November/002592.html
07:17:07 <katomo> good finding. sorry for breakage Mitaka translation. fix release is undergoing.
07:17:09 <ianychoi> For this, it would be much better if more i18n members will share opinions
07:17:27 <katomo> hm
07:17:41 <ianychoi> katomo, one more worse thing was that I reviewed the previous patch... I should have found the bug....
07:18:23 <katomo> ugo
07:18:32 <katomo> no worries
07:18:39 <ianychoi> katomo, after fixing it, would you change http://docs.openstack.org/ja/ to link Newton?
07:18:49 <ianychoi> Newton install guides for Japanese
07:18:51 <katomo> yeah
07:19:01 <ianychoi> I will take care of Korean version
07:19:36 <ianychoi> Thanks
07:22:00 <ianychoi> katomo, one question: for install-guides, just >75% for install-guides would be okay, or >75% for both install-guides and common would be needed?
07:22:24 <katomo> systematically, no need
07:22:55 <ianychoi> Hmm.. then the decision would be dependent to languages?
07:23:05 <katomo> also, "common" for stable branch mainly contains "get started" content.
07:23:27 <katomo> therefore, I myself don't think it is so important.
07:24:12 <ianychoi> Since.. I think Chinese and French have good ratio for install-guides (>75) but more translation on common seems to be needed. If they want to publish install-guides, then I want to add translation jobs of install-guides for both two + other languages (I need to check ratio)
07:24:35 <ianychoi> eumel8, for German, 56.54% :)
07:25:21 <katomo> I see
07:25:26 <eumel8> I know
07:25:40 <ianychoi> katomo, sorry for lots of question.. :) But would you update progress for blueprints? https://blueprints.launchpad.net/openstack-i18n
07:26:02 <katomo> sorry, no progress.
07:26:45 <ianychoi> katomo, that's fine. What I want to ask is that for example, https://blueprints.launchpad.net/openstack-i18n/+spec/release-notes-translation -> I think all things were done, right?
07:28:09 <katomo> ah, yep
07:28:17 <ianychoi> eumel8, you can +2 :)
07:28:35 <ianychoi> i18n-specs has the same previlege as openstack/i18n :)
07:28:45 <eumel8> too shy
07:29:28 <ianychoi> haha eumel8 is so expert on i18n with puppet :)
07:30:31 <eumel8> +2
07:30:34 <ianychoi> Hmm.. I think I need to triage bugs on openstack-i18n: https://bugs.launchpad.net/openstack-i18n
07:31:15 <ianychoi> #action ianychoi will triage bugs in openstack-i18n: https://bugs.launchpad.net/openstack-i18n
07:31:24 <eumel8> russian and chinese
07:32:30 <ianychoi> Yep on Barcelona Summit, I asked adiantum for defining bug management process for local languages with project contributors.
07:33:05 <ianychoi> After i18n-spec is ready, I think I need to ask adiantum to write a simple spec :)
07:33:38 <eumel8> ok
07:33:48 <ianychoi> Currently, I like this: uploading bugs into openstack-i18n
07:34:06 <ianychoi> Thanks to that, I now know that more local people are interested in i18n activities
07:36:46 <eumel8> yes, I tried always to collect more people to the team
07:37:10 <ianychoi> Thanks a lot :)
07:37:22 <ianychoi> By the way.. because it is just open discussion, have you seen this?
07:37:24 <ianychoi> http://www.ubergizmo.com/2016/11/google-translate-neural-machine-translation/
07:38:04 <ianychoi> I have seen this article in Korean yesterday, and I thought that our activities will be easier thanks to AI :)
07:39:35 <eumel8> the next logical thing for machine learning
07:39:49 <ianychoi> The world is really changing.....
07:40:27 <ianychoi> eumel8, aha and how about translation checksite you think?
07:40:58 <eumel8> maybe we can use this Google API sometimes in Zanata
07:41:16 <eumel8> translation checksite ... I don't know
07:41:50 <eumel8> have you talked to cloudnull last time?
07:41:51 <ianychoi> Hmm... current issue might be DevStack vs. ansible?
07:42:13 <eumel8> yes, and ansible without container
07:42:15 <ianychoi> eumel8, I shared to you for the last talk with cloudnull about a week ago. Have you seen it?
07:42:40 <eumel8> yes
07:43:00 <ianychoi> I asked cloudnull for performance and their opinion on difference between devstack and ansible
07:45:27 <eumel8> when sent you the message?
07:45:44 <ianychoi> Hmm... I don't know how I help for translation checksite. But at least revising http://specs.openstack.org/openstack-infra/infra-specs/specs/translation_check_site.html from your draft on Etherpad may attract more members
07:45:54 <ianychoi> About one week ago.. I will check it
07:46:34 <ianychoi> #link http://eavesdrop.openstack.org/irclogs/%23openstack-ansible/%23openstack-ansible.2016-11-09.log.html#t2016-11-09T16:07:20
07:47:33 <jftalta> Hi all
07:47:37 <ianychoi> jftalta, hi!
07:48:07 <katomo> Hi jftalta
07:48:10 <ianychoi> eumel8, http://paste.openstack.org/show/589541/ (I have just copied)
07:48:36 <jftalta> I am heading to office bu train. Internet connection is pretty bad
07:48:46 <eumel8> thx
07:48:55 <ianychoi> jftalta, have you arrived at your office? :) Huk train... thanks for today participation!
07:48:57 <jftalta> s/bu/by
07:49:24 <jftalta> No, not yet.
07:49:37 <eumel8> ianychoi: we have to think about it. It depends more on the infra team as on ansible.
07:49:55 <jftalta> Hi eumel8
07:50:00 <eumel8> At the moment I would say, without container it makes no sence
07:50:16 <eumel8> hi jftalta!
07:50:28 <eumel8> sense
07:51:49 <eumel8> I could test the horizon container installation from ansible on a plain ubuntu vm.
07:52:05 <ianychoi> eumel8, what I currently want is to just open horizon translation checksite around on the 2nd to 3rd week on the next January. I need to check schedule again, but since we have not enough time, I just want to deploy horizon with translation once
07:52:18 <ianychoi> just once. To collect feedback
07:52:20 <eumel8> but then you have duplicated code if you need adjustments on the origin
07:52:37 <ianychoi> eumel8, yep I completely agree with you
07:53:06 <ianychoi> But.. hmm.. for Ocata, I am not sure whether container based approach will be successfully landed in next January or not.
07:53:35 <ianychoi> For DevStack, I think I can ask just once to infra team members.. if they are willing to
07:53:38 <eumel8> I think we have to start still with a work around
07:53:45 <eumel8> not nice, I know
07:53:45 <ianychoi> I prefer container approach :)
07:54:20 <ianychoi> But.. I also want to have one translation checksite during Ocata cycle :)
07:54:45 <jftalta> container aoproach : +1
07:54:59 <ianychoi> Then.. how about just DevStack for next January and at the same time developing container-based approach?
07:55:04 <eumel8> how often you want a upgrade of the site?
07:55:22 <ianychoi> I hope that container-based approach will be successfully landed on P-cycle
07:55:53 <ianychoi> For Ocata cycle, it seems to be difficult... This is my current thinking just considering with timeline...
07:56:21 <ianychoi> eumel8, for Ocata, I think just once around soft string freeze would be sufficient
07:56:32 <ianychoi> Ideally, daily or weekly refresh
07:56:45 <eumel8> maybe the openstack-ansible team has also requirements for a test environment what we can also use in the future.
07:56:56 <ianychoi> eumel8, oh nice :)
07:57:08 <eumel8> I mean NOT ideally :-))
07:57:46 <ianychoi> haha okay. For this refresh period maybe we need to ask to language coordinators
07:57:55 <ianychoi> For me, just once per week is good
07:58:04 <eumel8> but with one new installation around soft string we can deal with the infra team
07:58:41 <ianychoi> as far as i know, container based approach may prevent from lots of dealing with the infra team, right?
07:58:45 <eumel8> weekly is not possible if you need the infra team personaly
07:59:16 <ianychoi> I want a kind of automatic refresh mechanism.. but I am not sure
07:59:28 <eumel8> I think it's caused for root access to the machine to enter the container
07:59:55 <eumel8> that was my understanding from my talk with pleia2
07:59:56 <ianychoi> eumel8, maybe you will have root access for containers if it will be implemented
08:00:07 <eumel8> we will see
08:00:11 <ianychoi> Hmm.. time is up
08:00:12 <eumel8> time is over :)
08:00:26 <ianychoi> Let's move to #openstack-i18n channel if we need to discuss more
08:00:38 <ianychoi> Thanks you all, eumel8 , katomo and jftalta !
08:00:41 <ianychoi> #endmeeting