13:00:48 <ianychoi> #startmeeting OpenStack I18n Meeting
13:00:49 <openstack> Meeting started Thu Jan 5 13:00:48 2017 UTC and is due to finish in 60 minutes. The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:52 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:01:21 <ianychoi> Hello jftalta!
13:01:35 <jftalta> Hello ianychoi !
13:02:04 <jftalta> all my best for 2017 !
13:02:18 <ianychoi> 2017 has already come !
13:02:41 <eumel8> morning!
13:02:52 <ianychoi> Hi eumel8 !
13:02:54 <jftalta> Hi eumel8
13:03:01 <eumel8> 2 minutes late
13:03:23 <jftalta> ;)
13:03:46 <ianychoi> That's fine :) Okay.. let's first start with general meeting logistics so that we can have more time on discussion
13:04:04 <ianychoi> #topic Review on last meeting actions
13:04:12 <ianychoi> #link http://eavesdrop.openstack.org/meetings/openstack_i18n_meeting/2016/openstack_i18n_meeting.2016-12-22-13.03.html
13:04:59 <ianychoi> One action from ianychoi and jftalta was to apply themes on French landing page after current patch is merged. I will start to do after this week
13:06:13 <jftalta> Ok. The french version of Mitaka installation guide is on line, indeed.
13:06:27 <ianychoi> jftalta, that's nice!
13:06:43 <ianychoi> #topic Zanata upgrade status
13:07:11 <ianychoi> #link https://etherpad.openstack.org/p/i18n-zanata-test-for-translate-dev
13:07:19 <jftalta> #link http://docs.openstack.org/fr/
13:07:28 <ianychoi> jftalta, helped to test #13 and 15. Thanks a lot!
13:07:59 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-i18n/2016-December/002632.html
13:09:00 <eumel8> what is work status O?
13:09:07 <ianychoi> Steve Kowalik suggested good test items. Although I am not currently familiar with some of the parts too much, I will take care of this.
13:09:22 <ianychoi> eumel8, 'O' means that test has performed and it works well!
13:09:33 <eumel8> ah, very good
13:10:26 <amotoki> hi, happy new year
13:10:38 <ianychoi> amotoki, hello!
13:11:02 <jftalta> Hi amotoki !
13:11:26 <eumel8> hi amotiki, you too
13:11:40 <amotoki> glad to hear that French team has a new landing page :)
13:12:02 <eumel8> ianychoi: something to help? or it seems all tests pass through
13:12:14 <ianychoi> After Zanata test, then I will discuss with clarkb to upgrade to newer version of Zanata
13:13:01 <ianychoi> eumel8, two parts are mainly remained: 1) po file import & export and 2) seeing Zanata raw log messages for warning and/or errors
13:13:34 <jftalta> New Zanata version witj glossary management feature !
13:13:39 <jftalta> *with
13:13:48 <ianychoi> For 1), I am finding how I am able to use current infra scripts with translate-dev.o.o and for 2), Alex Eng said that he will be able to help it
13:14:18 <eumel8> ok
13:14:20 <ianychoi> #link https://translate.zanata.org/
13:14:27 <amotoki> Upgrading zanata sounds nice. however let me raise one question.
13:14:35 <amotoki> the soft string-freeze is now two week away.
13:14:53 <amotoki> do we have enough time to test a new translation infra?
13:15:07 <ianychoi> And.. this from Zanata team has 3.9.6 version, which may be a good reference
13:15:58 <ianychoi> amotoki, I really wanted to incorporate newer version of Zanata before Soft StringFreeze. However, it seems that we do not have enough time..
13:16:14 <amotoki> I might be conservative. I am playing such role :)
13:17:10 <ianychoi> That's fine :) Now I do not want to change Zanata version in translate.o.o within Pike cycle
13:17:26 <ianychoi> Sorry Ocata cycle
13:17:35 <amotoki> we have three weeks before the final RC week. we can be optimistic :)
13:18:06 <amotoki> #link https://releases.openstack.org/ocata/schedule.html
13:18:23 <ianychoi> It actually depends on how we test completely with newer version of Zanata and Xenial..
13:18:38 <ianychoi> amotoki, thanks a lot for such remainder
13:19:17 <ianychoi> Good news is that clarkb is kindly waiting for current test results to upgrade newer version of Zanata
13:19:45 <ianychoi> (I have seen his IRC meeting on infra channel yesterday night - UTC based)
13:19:53 <ianychoi> s/meeting/message
13:20:13 <amotoki> ianychoi: is there a way to revert the translate site to the current version if we have some critical problem?
13:20:57 <amotoki> if we have a feasible way, IMHO it sounds good to move it forward.
13:21:20 <ianychoi> amotoki, oh good question. Since Zanata installation is based on Puppet, I think it is possible but we need to check database side.
13:21:48 <amotoki> what in my mind is our translation memory and related stuff.
13:22:25 <ianychoi> eumel8, could you look at how database backup is done in puppet-zanata?
13:23:08 <amotoki> and our comments and history on Zanata. I am not sure that puppet installation can help it.
13:24:28 <ianychoi> I need to figure out 1) which database configuration is used in translate-dev and translate.o.o and 2) how database can be backed up and restored from..
13:24:39 <amotoki> I think nobody knows it now. I believe it is worth checked before the upgrade!
13:24:51 <amotoki> ianychoi: totally agree
13:24:59 <ianychoi> Okay, then I will ask with infra team members thanks a lot, amotoki !
13:25:30 <ianychoi> #action ianychoi will figure out how Zanata database can be backed up and restored from old backup(s) regarding Zanata upgrade
13:25:37 <amotoki> anyway we don't lose all. we have PO files in our git repos.
13:25:59 <ianychoi> amotoki, thanks a lot for this important point!
13:26:06 <ianychoi> Then.. moving on the next topic?
13:26:38 <jftalta> ok for me
13:26:53 <ianychoi> #topic Pike PTG
13:27:12 <ianychoi> #link http://www.openstack.org/ptg
13:27:39 <eumel8> couldn't see anything regarding backups: https://git.openstack.org/cgit/openstack-infra/system-config/tree/modules/openstack_project/manifests/translate.pp
13:27:47 <ianychoi> eumel8, thanks!
13:27:53 <eumel8> normaly it would be configured in mysql class
13:28:06 <ianychoi> I am planning to go to PTG and I will usually stay in Doc team's room but I will also go to infra, Horizon, and other team's rooms
13:28:08 <eumel8> mysql::backup - something like that
13:28:50 <amotoki> ianychoi: do you mean you stay Atlanta on Mon and Tue?
13:29:06 <ianychoi> So now I will propose to specify "Documentation / I18n" in PTG homepage, although I need to confirm again with Lana, Docs team PTL.
13:29:37 <eumel8> ianychoi: what's with your PTL nomination? :-)
13:29:47 <ianychoi> amotoki, Mon and Tue are definitely and I am now arranging my schedule up to Wed and Thu
13:30:07 <ianychoi> eumel8, PTL nomination for Pike cycle?
13:30:29 <eumel8> sure
13:30:49 <amotoki> I will be there but perhaps I will join OSC and horizon on Mon/Tue and neutron on Wed-Fri.
13:31:46 <ianychoi> eumel8, now I want to do also with Pike cycle, if you and other members agree and nominate me :)
13:32:25 <ianychoi> amotoki, oh nice! Let's meet in Atlanta then.. although we each may be busy :)
13:32:30 <amotoki> ianychoi: you can nominate yourself anyway though :)
13:32:43 <jftalta> +1
13:32:56 <ianychoi> eumel8, but I think it is difficult for me to run for next Q-cycle
13:33:35 <eumel8> ianychoi: we count on you and I think you have already decided this for you
13:33:51 <ianychoi> since I am supposed to server Korean user group leader up to next year. Last December, there was an election in Korean community
13:34:14 <ianychoi> So I think it is difficult for me to run for next Q-cycle
13:34:50 <amotoki> it sounds interesting too :)
13:34:51 <eumel8> so, we have a plan and can work through the PTG
13:35:17 <eumel8> ianychoi: you have our support all the time :)
13:35:18 <ianychoi> For me, P cycle is relatively short and I want to make a good transition with upcoming Forum
13:35:33 <ianychoi> eumel8, thanks a lot :)
13:35:37 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/109658.html
13:35:55 <ianychoi> The link is what I wrote and shared with you today
13:36:02 <eumel8> yeah
13:36:39 <ianychoi> In my opinion, our voice in this transition period (Ocata and Pike cycle) would be so important
13:37:40 <ianychoi> amotoki, I appreciate your kind help from various sides all the time
13:37:41 <eumel8> ianychoi: you have still some ideas for the Forum?
13:38:22 <amotoki> I can leave a comment on the forum at Boston and later, but I hope more feedback from translators!
13:38:40 <ianychoi> One idea is to propose extra AUCs for translators who highly influence with local communities
13:38:59 <amotoki> I have many hats and mainly my hat is a developer, so more global inputs would be appreciated.
13:39:51 <jftalta> amotoki: what kind of inputs do you need ?
13:40:29 <amotoki> jftalta: inputs on a topic ianychoi raised at the above mail
13:40:32 <ianychoi> AUCs and ATCs are different. For I18n, currently translating more than 300 words within latest two cycles are regarded as ATCs. However, some aspects for translators may be related with AUCs
13:42:19 <amotoki> we need to gather feedbacks from the i18n/l10n communities and input them to the foundation so that the summit will be more comfortable and useful for translators.
13:42:33 <jftalta> Don't you think that 300 words is a too low limit ?
13:42:39 <amotoki> that's the background of this discussion.
13:43:34 <ianychoi> jftalta, I agree with this. Which number of words would be appropriate?
13:43:44 <amotoki> IMHO 300 words is a reasonable threshold for ATC, but I am not sure it is reasonable for AUC.
13:44:21 <amotoki> Based on my impression, folks recognized as AUC contributed more (in the past)
13:44:54 <amotoki> of course the criteria of AUC is under discussion (I think(
13:45:23 <ianychoi> For developers, ATCs are regarded with at least one commit within latest 2 release cycles. 300 words would be too small comparing to 1 commit?
13:45:39 <ianychoi> The criteria of ATC is related with question.
13:45:51 <jftalta> Reviews also matter, not only translations
13:46:04 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-docs/2016-November/009294.html
13:46:27 <amotoki> jftalta: really good point!
13:47:02 <ianychoi> And this is for AUC criteria, then IMO 300 words may be too small..
13:47:20 <jftalta> ianychoi: +1
13:47:29 <persia> Reviews don't grant ATC (which has been a discussion point about ATCs in the past). Some software commits are lots less than 300 words. Rather than mirroring other processes, I strongly recommend selecting new ones that include anyone who should be considered a translator.
13:47:30 <ianychoi> jftalta, then 300 words for translation or review would be a good idea for ATC recognition?
13:48:11 <amotoki> my vote is more words for reviews, e.g. 600 or 1000 words
13:48:44 <ianychoi> persia, Thanks. I understand your point but some translation review may change all the sentences..
13:48:50 <amotoki> but a bigger question is how to evaluate the number of reviews with quality
13:49:36 <ianychoi> jftalta, amotoki : question: how review quality will be measured?
13:49:47 <ianychoi> or at least translation quality?
13:50:12 <amotoki> persia: good point. so far "review" is not a requirement of ATC. IMO it is better to follow the other criteria applied to other projects.
13:50:32 <jftalta> ianychoi: quality ? no idea...
13:50:53 <ianychoi> jftalta, Haha neither from me
13:51:00 <amotoki> ianychoi: it is a difficult question. JP community has a difficulty on how to evaluate potential "reviewers"......
13:51:35 <amotoki> it is not easy to share/see review comments of others on the current Zanata platform.
13:52:22 <ianychoi> By the way, when I see https://releases.openstack.org/ocata/schedule.html amotoki shared,
13:52:40 <ianychoi> Tomorrow is the deadline for extra ATC
13:52:51 <amotoki> core reviewers of other projects can see other reviewers' comments on the gerrit, but it is not easy on our Zanata :(
13:53:16 <ianychoi> I will take care of proposing extra ATCs by seeing Zanata statistics
13:53:38 <amotoki> ianychoi: I think it is better to follow the conventions on the extra ATC for Ocata.
13:54:26 <amotoki> time check: 5 minites left
13:54:36 <ianychoi> amotoki, yep following the current logistics for proposing extra ATCs would be better now..
13:54:51 <ianychoi> #topic Discussing core reviewers with language teams
13:55:06 <jftalta> time flies
13:55:16 <ianychoi> I wanted to raise this topic but I will postpone it to the next week
13:55:23 <ianychoi> #topic
13:55:25 <ianychoi> #topic Asking for reviewing i18n-specs
13:55:34 <ianychoi> #link https://review.openstack.org/#/q/project:openstack/i18n-specs
13:55:44 <ianychoi> Please also review i18n-specs :)
13:56:19 <amotoki> how about sending topics proposed in i18n-specs to the i18n ML?
13:56:47 <ianychoi> Although my work is a little bit slow, I am polishing i18n-specs to well display in specs.openstack.org
13:57:09 <ianychoi> amotoki, can I see some examples how proposed topics are sent to mailing lists?
13:57:25 <ianychoi> from other projects maybe?
13:57:43 <amotoki> ianychoi: I don't know how to automate it. I think we need to send them manually
13:57:58 <ianychoi> amotoki, aha I see
13:58:02 <amotoki> :)
13:58:26 <ianychoi> Then the next step for i18n-specs will be to fill out with content: https://etherpad.openstack.org/p/i18n-specs-use-cases would be examples
13:59:20 <ianychoi> Okay.. no time is left..
13:59:42 <ianychoi> If you have more things to be discussed, please call me in #openstack-i18n channel.
13:59:53 <ianychoi> Thanks a lot today, jftalta , eumel8 , and amotoki !
14:00:03 <eumel8> thx, bye :)
14:00:05 <ianychoi> #endmeeting