13:02:10 <ianychoi> #startmeeting OpenStack I18n Meeting
13:02:11 <openstack> Meeting started Thu Mar  2 13:02:10 2017 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:15 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:02:30 <ianychoi> #topic Status: Zanata upgrade
13:02:57 <ianychoi> jpich, have you seen the upgraded translation platform: https://translate.openstack.org/ ?
13:03:12 <jpich> I did!
13:03:43 <ianychoi> jpich, it runs on Xenial with Java 8 & Wildfly 10 (Open JBoss)
13:04:02 <jpich> What are the major changes to look forward to?
13:05:04 <ianychoi> jpich, http://docs.zanata.org/en/latest/release-notes/#396
13:05:29 <jpich> Thanks!
13:05:47 <ianychoi> Actually, there have been lots of changes - it is difficult to tell which are the major but for me I can retrieve the list of contributors in a project & version
13:06:24 <ianychoi> Bug fixes, better UXs for several menus, and so on.. :)
13:06:39 <tonotuwo> hi
13:06:51 <ianychoi> tonotuwo, hello! Are u a translator?
13:07:08 <jpich> Cool :)
13:07:10 <tonotuwo> I am Suh
13:07:31 <ianychoi> tonotuwo, aha Suhartono from Indonesian?
13:08:16 <ianychoi> #info Zanata has upgraded to 3.9.6. If there is some issue, please tell me or #openstack-infra irc channel
13:09:29 <ianychoi> Hmm less people today but fine :)
13:09:56 <ianychoi> #topic Pike translation goal & priorities
13:10:37 <ianychoi> After the Zanata upgrade today, I have set that Pike translation plan is TBD: https://translate.openstack.org/
13:11:23 <ianychoi> jpich, tripleo-ui would be cycle-trailing not cycle-with-intermediary
13:11:59 <jpich> ianychoi: Yes, it's corrected now :) https://review.openstack.org/#/c/438932/
13:12:49 <ianychoi> Thanks for the correction. Then, for Ocata what would be the best translation period?
13:13:20 <amotoki> hi
13:13:28 <ianychoi> amotoki, hi!
13:13:53 <jpich> Feature and string freezes will be 2 weeks after the usual deadlines... * looking at https://releases.openstack.org/pike/schedule.html *
13:14:13 <jpich> Maybe between R-3 and R+1/2?
13:14:44 <jpich> I'm not sure how that's usually handled for cycle-with-milestones, do translators usually way for the soft freeze before getting started?
13:15:25 <zzxwill> Hi ianychoi, eumel8.
13:16:34 <ianychoi> jpich, let's differentiate soft & hard stringfreezes and cycle-trailing. If tripleo-ui makes a stable branch around hard stringfreeze, then it would be great to consider the translation with other projects. If not, we might need to consider in different period maybe
13:16:37 <ianychoi> zzxwill, hi!
13:17:53 <amotoki> jpich: ianychoi: IMHO each project has some kind of feature freeze at some time and we would have less string changes after that.
13:18:13 <jftalta> Hi all. Sorry for the delay
13:18:22 <ianychoi> jpich, for example, "Mar 06 - Mar 10" is Ocata cycle-trailing Deadline, then when would be the final deadline for translators to translate tripleo-ui?
13:18:27 <ianychoi> jftalta, hello!
13:18:33 <jpich> ianychoi: Hard string freeze is more like to be around R-1 for us. I think we prefer to wait until the RC (R-0) to cut the stable branch though
13:19:08 <ianychoi> jpich, then, the final deadline for translation input for tripleo-ui would be R+0?
13:19:17 <jpich> ianychoi: Because Ocata is our first i18n release and we found so many i18n bugs (missing strings) we've been very bad about string changes this cycle :( I'm not sure it's a good example
13:19:39 <tonotuwo> sorry my nickmane is tonotuwo instead of suh
13:20:11 <jpich> ianychoi: Oh, no I think up to R+1 at least would be ok for translations, we can totally have an extra RC for the translations
13:20:11 <ianychoi> jpich, sorry for that. I now just want to estimate when would be the best deadline for translation final input for tripleo-ui in Pike cycle
13:20:24 <amotoki> one idea is that tripleo project declares when you would like to release ocata.
13:21:07 <jpich> amotoki: The cycle-trailing deadline for Ocata is next week and we will release then
13:21:12 <amotoki> from our past experience, it works to set the deadline to several days before the release
13:21:44 <amotoki> most works arounds the release are now automated
13:22:06 <ianychoi> amotoki, I agree. jpich for Pike cycle, then I think the translation period for tripleo-ui would be: from the time when tripleo-ui have stable/pike branch for the first time to around R+1 (the final deadline for translation input - triplo-ui team will share)
13:22:49 <ianychoi> jpich, it means.. there would be no soft stringfreeze on tripleo-ui, would it be fine? I think tripleo-ui has less strings than horizon so IMO it would be fine
13:22:51 <jpich> amotoki: I think there was/is too much string churn in Ocata because of the i18n bugs so giving a deadline of Monday/Tuesday (2-3 days before the release) is unfair :) I think most of the translations for Ocata will be done during/for the first stable point release
13:23:20 <jpich> ianychoi: That seems ok to me, that way the developers only need to learn about one new deadline at a time :) I will keep you informed.
13:23:35 <amotoki> jpich: I agree. this was what we have in horizon several releases ago
13:24:05 <jpich> Indeed. tripleo-ui is still a baby-i18n project for now!! Still learning
13:24:07 <amotoki> s/have/had/
13:24:18 <ianychoi> jftalta, zzxwill: we are discussing now Pike translation priorities
13:24:26 <ianychoi> tonotuwo ^
13:24:31 <jftalta> ok
13:24:46 <tonotuwo> ok
13:24:57 <ianychoi> Any other additional interests on a specific project?
13:25:08 <ianychoi> Or priority change would be needed?
13:25:20 <ianychoi> #link https://translate.openstack.org/
13:25:27 <amotoki> I think the deadline for the first release is no so important.
13:25:45 <amotoki> ore important thing is to announce that we will have stable update soon and your translations have a chance to be imported in near future.
13:25:50 <ianychoi> I moved Ocata translation plan on the bottom and Pike is currently TBD
13:26:38 <jpich> amotoki: Good point
13:26:45 <amotoki> especially for young projects
13:26:46 <ianychoi> amotoki, I usually say "from now we need to focus on master version" and "from now is hard stringfreeze and we need to focus on stable version". However, cycle-trailing project will have stable version in different timing
13:27:11 <amotoki> ianychoi: cycle-trailing and manuals.
13:27:21 <ianychoi> Then, I am worried that some translators would be confused: master vs. stable versions
13:27:54 <jftalta> ianychoi, I'm confused. What's the current topic ?...
13:28:19 <ianychoi> jftalta, translation priority with cycle-trailing release model (e.g., tripleo-ui) :)
13:28:40 <amotoki> but the topic is "Pike translation goal & priorities" :(
13:29:10 <ianychoi> Haha sorry
13:29:19 <ianychoi> When I set the topic only jpich were here :)
13:29:25 <jftalta> ok, thanks ;)
13:29:33 <amotoki> :)
13:30:03 <jftalta> ianychoi, ah,ok. Sorry :(
13:30:06 <ianychoi> In Ocata, High: Horizon, Dashboard-auth, neutron-lbaas-dashboard
13:30:20 <ianychoi> Medium: Trove / Sahara / Murano Dashboard
13:30:31 <ianychoi> Low: Magnum UI & Designate Dashboard
13:31:12 <ianychoi> IMO I would like to keep the same list but.. can I move lower for the project which has no i18n cross project liaison?
13:31:43 <jftalta> What would you think of raising Magnum priority in Pike cycle ?
13:31:48 <ianychoi> + tripleo-ui wants to include in the list. Which priority would be recommended?
13:32:16 <ianychoi> jftalta, Magnum has i18n cross project liaison - so if others agree, then I am okay to change to High
13:32:50 <ianychoi> jftalta, oh current low, then changing to medium?
13:33:02 <jftalta> High ?
13:33:18 <jpich> ianychoi: Maybe let's start with Low for tripleo-ui, while the project is still learning to be more translators-friendly and respect string freezes?
13:33:32 <ianychoi> zzxwill, jftalta proposed to change magnum priority from low to high. Agreed?
13:33:51 <ianychoi> tonotuwo, how about you?
13:34:08 <zzxwill> And the translation amount for tripleo-ui is small.
13:34:13 <tonotuwo> only monitoring
13:34:15 <ianychoi> jpich, good suggestion - thanks :)
13:34:31 <amotoki> ianychoi: I don't think high for magnum-ui is appropriate
13:34:33 <ianychoi> tonotuwo, you can say just +1 or -1 simply :)
13:34:53 <tonotuwo> :)
13:34:57 <zzxwill> Ianychoi, I have no idea as I am not familiar with Manum project.
13:34:59 <jftalta> jpich, +1
13:35:21 <amotoki> it is an optional project, so there is no reason to mark it high..... IMO
13:35:29 <ianychoi> amotoki, hmm, would there be some reason for that? jftalta may be Magnum-holic :) aha
13:36:23 <jftalta> amotoki, zzxwill, magnum deals with containers and containers clusters
13:36:54 <amotoki> I think when we determine high priority project adoption rate (e.g. project navigator or user survey) needs to be considered.
13:37:05 <jftalta> ianychoi, yes I am ;)
13:37:06 <zzxwill> Then +1 for magnum
13:38:27 <ianychoi> https://www.openstack.org/software/project-navigator/
13:38:52 <ianychoi> Magnum adoption is 11% - within top 10 for optional services (including horizon)
13:40:15 <jftalta> imho, Ocata will speed up magnum and containers adoption
13:41:05 <amotoki> so isn't the priority Medium?
13:41:39 <ianychoi> Hmm, let's set magnum higher: Dashboard - Horizon > Dashboard Authorization Page > neutron-lbaas-dashboard [High] > Magnum UI > Trove Dashboard > Sahara Dashboard [Medium] > Murano Dashboard > Designate Dashboard > TripleO-UI [Low]
13:41:58 <ianychoi> jftalta, the highest in medium :)
13:41:59 <amotoki> we have only three priorites: high, medium and low, so 'high' almost equals to 'Essential'
13:42:18 <jpich> Sounds reasonable to me
13:42:26 <ianychoi> amotoki, how about such interpretation? :)
13:42:55 <amotoki> ianychoi: just my interpretation ;P
13:43:19 <ianychoi> amotoki, my asking is about " > " within high, medium and low :)
13:43:33 <zzxwill> How about API docs (Nova, Neutron, Glance, Senlin)?
13:43:36 <jftalta> Humm... Ok, I agree. +1 :)
13:44:02 <ianychoi> zzxwill, unfortunately API docs are not currently in translation target
13:44:14 <ianychoi> zzxwill, only api-quick-start is the target
13:44:34 <zzxwill> Yes, I mean that. The usage of API.
13:44:36 <ianychoi> For documetation, I18n team has set higher priority on user side documentation
13:44:38 <zzxwill> Thanks Ian.
13:44:53 <amotoki> ianychoi: what do you mean by '>' ?
13:45:36 <ianychoi> amotoki, ranking, for example:  1. Dashboard - Horizon > 2. Dashboard Authorization Page > 3. neutron-lbaas-dashboard [High]
13:46:16 <ianychoi> zzxwill, for api-quick-start zh_CN: would you tell https://review.openstack.org/#/c/439979/ contributors to contribute in translate.openstack.org?
13:46:17 <amotoki> I see. neutron-lbaas-dashboard can be set to Medium (or low)
13:46:34 <amotoki> perhaps we mark it High only because it was previously covered by horizon translation.
13:47:06 <ianychoi> zzxwill, their changes look very nice: https://review.openstack.org/#/c/439979/1/api-quick-start/source/locale/zh_CN/LC_MESSAGES/api-quick-start.po However, PO files should be managed by translation platform Zanata
13:47:36 <ianychoi> zzxwill, it would be so nice if we encourage the contributor to change in Zanata rather than changing po file directly
13:48:04 <ianychoi> amotoki, Okay thanks for explanation. Then I will set the bottom in medium
13:48:31 <ianychoi> #topic Discussion: ATC criteria
13:48:33 <zzxwill> You mean api-quick-start code contributor? ianychoi?
13:49:03 <ianychoi> zzxwill, yep the committer for the patch: https://review.openstack.org/#/c/439979/ jiansong <jian.song@easystack.cn> & JunhuiHe <junhui.he@easystack.cn>
13:49:31 <ianychoi> #link https://review.openstack.org/#/c/437188/1/doc/source/official_translator.rst
13:50:34 <ianychoi> Zanata has upgraded to 3.9.6 and retrieving the list of contributors would be fine. So, in Pike cycle, I would like to go ahead how to automate ATC status for I18n team rather than proposing as extra ATCs.
13:50:36 <zzxwill> Got it. I did the same stupid thing at the first time:)
13:51:07 <ianychoi> zzxwill, haha it may be because of lack of kind explanation from I18n team - for this, let's tentatively consider
13:51:29 <jpich> Automated ATC status sounds awesome
13:51:31 <ianychoi> To accomplish this, I need to define ATC status for I18n team precisely
13:52:23 <ianychoi> Previously, we agreed that translators who contributed >= 300 words within the latest 2 cycle are regarded as ATCs
13:52:50 <ianychoi> But.. >= 300 words is just translation? And including review?
13:53:06 <zzxwill> Seldom a code contributor knows the existence of Zanata as far as I know. ianyrchoi.
13:53:22 <zzxwill> 300 seems not enough, I believe for ATC:(
13:53:37 <ianychoi> In my opinion, if ">= 300 words translation" is regarded as one commit, then ">= 300 words review" can be also regarded as one commit
13:53:38 <zzxwill> We need to encourage review.
13:53:43 <jftalta> zzxwill, +1
13:53:50 <zzxwill> So including review +1
13:54:17 <ianychoi> zzxwill, jftalta let's just consider the similar criteria for "one commit merge" in code and/or documentation
13:54:36 <amotoki> one thing to note is that review count is limited to folks with 'Reviewer' status.
13:55:03 <ianychoi> zzxwill, jftalta: you mean than ">= 300 words translation" as one commit is unfair? ">= 500 words translation" as one commit would be appropriate?
13:55:17 <zzxwill> Yes amotoki. I just granted a few 'reviewer' for zh_CN.
13:55:48 <ianychoi> zzxwill, how many reviewers are in zh_CN team?
13:55:52 <jftalta> ianychoi, yes, at least
13:56:29 <ianychoi> jftalta, zzxwill note that after the fixing, later change of such criteria will be difficult
13:57:26 <ianychoi> I will submit ATC calculation for translators into the real ATC extraction script Foundation uses
13:57:28 <zzxwill> 16 from 87.
13:57:55 <ianychoi> So I do not want to conclude the exact criteria now
13:58:07 <ianychoi> But please keep thinking on more :)
13:58:11 <jftalta> ianychoi, ok. I'm aware of this.
13:58:25 <ianychoi> jftalta, thanks :)
13:59:01 <ianychoi> For other topics, let's skip on the next
13:59:07 <jftalta> ok
13:59:18 <ianychoi> I will determine translation priority soon based on today discussion
13:59:21 <amotoki> the logo on Zanata is too big ? :)
13:59:35 <ianychoi> amotoki, haha Thanks for the comment
13:59:46 <amotoki> :)
13:59:48 <ianychoi> #action ianychoi will decrease the logo size in translate.o.o
13:59:51 <ianychoi> Thanks you all!
13:59:57 <ianychoi> Thank you :)
14:00:00 <ianychoi> #endmeeting