13:05:47 <ianychoi> #startmeeting OpenStack I18n Meeting
13:05:48 <openstack> Meeting started Thu Mar 16 13:05:47 2017 UTC and is due to finish in 60 minutes. The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:05:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:05:52 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:06:03 <ianychoi> jftalta, jpich, amotoki: sorry for late start
13:06:28 <ianychoi> Todays it seems that there are 4 members
13:06:39 <ianychoi> #topic Boston Summit & Forum schedule is now available
13:07:02 <ianychoi> jpich, amotoki, jftalta : will you come to Boston Summit?
13:07:07 <jpich> No
13:07:09 <ianychoi> #link https://www.openstack.org/summit/boston-2017/summit-schedule/#day=2017-05-08
13:07:15 <ianychoi> Schedule is now available
13:07:28 <amotoki> ianychoi: hope so. my sessions was accepted.
13:07:37 <amotoki> sessions -> session
13:07:38 <ianychoi> jpich, I understand since you attended to PTG
13:07:43 <ianychoi> amotoki, oh congratulation!
13:07:56 <jpich> Congrats, amotoki :)
13:08:05 <amotoki> thanks. no related to i18n though
13:08:19 <jftalta> I will. I've got my pass, flight tickets and accomodation :)
13:08:25 <ianychoi> I am now arranging with Foundation for discounts of language coordinators
13:08:28 <ianychoi> jftalta, wow congrats!
13:08:43 <ianychoi> I hope that more language coordinators will come to Boston Summit.
13:09:08 <ianychoi> amotoki, fine :)
13:09:22 <ianychoi> I accepted two presentations - one is for I18n and the other is for Korea user group
13:09:46 <ianychoi> So I definitely go to Boston Summit
13:10:06 <ianychoi> And.. in my opinion, Boston Summit is very welcome for translators
13:10:07 <jftalta> thanks to the presentation, we've got free pass
13:10:41 <ianychoi> jftalta, yep, and also I am now arranging something more with Foundation. I will let you (language coordinators) know in details soon (hopefully)
13:10:49 <jftalta> ok
13:11:08 <ianychoi> #topic Zanata upgrade status
13:11:17 <ianychoi> #link http://eavesdrop.openstack.org/irclogs/%23openstack-infra/%23openstack-infra.2017-03-15.log.html#t2017-03-15T20:12:47
13:11:58 <ianychoi> I talked with Clark Boylan - Infra team and the team wants to delete the old production (Zanata 3.7.3) if current Zanata 3.9 production works fine.
13:12:37 <ianychoi> About 15 hours ago, there were openstackid problem - but it was not related to Zanata and it quickly recovered
13:12:53 <ianychoi> jftalta, jpich: how do you feel new Zanata (3.9)?
13:13:33 <jftalta> I checked it out and it seems to work fine for me. Embedded glossary is very convenient :)
13:13:46 <jpich> I'm embarrassed to say I don't see much difference from my side, so it looks good to me :-)
13:14:01 <ianychoi> amotoki, have you experienced new Zanata?
13:14:23 <amotoki> ianychoi: a bit :) Honestly I am not sure what are changed though
13:15:55 <ianychoi> amotoki, haha if you have the similar experience, I think deleting old production instance would be fine
13:16:13 <amotoki> +1 for deleting the old one
13:16:16 <ianychoi> jpich, jftalta: Then I will tell infra team that I18n team is ready for deleting the old production instance
13:16:21 <ianychoi> amotoki, thanks
13:16:50 <jftalta> #link http://docs.zanata.org/en/latest/release-notes/#new-feature
13:18:14 <jftalta> ianychoi, update of the glossary implies submitting a I18n patch, right ?
13:18:29 <ianychoi> jftalta, right and it was done :)
13:19:29 <ianychoi> I am waiting for replies.. :)
13:19:29 <jftalta> ok
13:19:33 <ianychoi> jftalta, thanks
13:19:37 <amotoki> I see a new field "description" in glossary.
13:19:57 <amotoki> we may need to discuss the glossary format in the i18n repo a bit later.
13:20:06 <ianychoi> amotoki, +1
13:20:22 <jftalta> +1
13:21:01 <ianychoi> #topic Finalizing Pike translation goal & priorities
13:21:26 <ianychoi> I would like to finalize the priority shared on the last week
13:22:13 <ianychoi> One thing I am worried about now is that there weren't lots of feedback from translation goal & priorities
13:23:00 <ianychoi> That's why I originally wanted to determine translation goal & priorities during Forum - but I agree that deciding this during initial phase of entire release period is better as an official team
13:23:45 <ianychoi> jftalta, amotoki: any concern for finalizing the translation goal & priority?
13:24:34 <jftalta> none for me
13:24:34 <amotoki> I am okay to set the initial priority now.
13:25:27 <jftalta> ianychoi: oh, not sure I understood your question well ...
13:25:52 <amotoki> It might be better to add some note to Zanata top page that any feedback on priority is always welcome and/or it will be discussed in the Forum in Boston summit.
13:25:54 <amotoki> just an idea.
13:26:16 <ianychoi> jftalta, what I meant is a few people responded to the plan & priority
13:26:21 <ianychoi> amotoki, good idea - thanks
13:27:04 <jftalta> ianychoi: I was talking about question "any concern for finalizing..."
13:27:29 <ianychoi> jftalta, just I want to ask opinions on finalizing the plan & priority
13:28:22 <jftalta> ok
13:28:45 <ianychoi> #action ianychoi will update the translation plan & priority discussed on translate.o.o dashboard
13:28:51 <ianychoi> #topic Thoughts on ATC criteria
13:29:00 <ianychoi> #link https://review.openstack.org/#/c/437188/1/doc/source/official_translator.rst
13:29:49 <ianychoi> I think it might be a little bit trivial but I want to make sure what I18n made the criteria of ATC for translators
13:30:33 <ianychoi> Let's suppose that
13:30:39 <ianychoi> Case 1: one translator "translate"d 150 words and "review"ed 150 words
13:30:57 <ianychoi> Case 2: the other translator "translate"d 150 words and "review"ed 151 words
13:31:19 <ianychoi> Case 3: the third translator "translate"d 0 words but "review"ed 301 words
13:32:01 <ianychoi> IMO only 3 is valid for ATC status because we regard "300 words" contribution for one aspect as a commit
13:32:10 <ianychoi> jftalta, amotoki: what do you think about it?
13:33:56 <jftalta> from a technical/logical point of view, you are right. But from the contributor's point of view, it's unfair.
13:34:56 <ianychoi> jpich, can I ask your opinion on three cases?
13:35:41 <jpich> ianychoi: I'd tend to agree with jftalta's opinion, I don't know about the technical limitations but these 3 people sound to me like they should get ATC status :)
13:36:31 <ianychoi> amotoki, your thoughts?
13:37:35 <ianychoi> jftalta, jpich: yes. the calculation and considering is possible
13:37:36 <amotoki> all three sounds good.
13:37:44 <ianychoi> Okay :)
13:38:04 <ianychoi> Let's regard all three cases as ATCs in I18n team!
13:38:14 <amotoki> one thing to note
13:38:18 <jpich> :)
13:38:27 <ianychoi> Correction: ATCs in OpenStack, and APCs in I18n team
13:38:41 <amotoki> generally speaking, reviewing tends to be easier than transaltion.
13:38:54 <amotoki> if we have good transaltions, we can review easily :)
13:39:23 <amotoki> but perhaps most reviewers review more from what I checked
13:39:47 <ianychoi> amotoki, oh really? I have not observed with such perspective
13:40:01 <jpich> ianychoi: What is the acronym meaning? (Sorry!)
13:40:32 <amotoki> APC means Active Project (Program?) Contributor
13:40:35 <ianychoi> jpich, ATC is Active Technical Contributor and APC is Active Project Contributor :) That's prertty fine
13:40:44 <jpich> Ah, P for Project! Ok :)
13:40:51 <ianychoi> I did not know them exactly about 2 years ago
13:41:03 <amotoki> APC has a right to vote for PTL of a corespoding project.
13:41:28 <jpich> Very good
13:41:59 <ianychoi> For review metric, then the possible idea would be 300 words for translations and/or 600 words for reviews by weighting to 1/2 for review contribution
13:42:25 <ianychoi> For example, 150 words translation + 200 reviews => No, since 150 + 2/200 = 250
13:42:38 <ianychoi> But 150 words translation + 300 reviews => Yes, since 150 + 2/300 = 300
13:42:46 <amotoki> i might be wrong, but when I tested zanata_users.py I got a bit bigger number of review words.
13:43:03 <ianychoi> amotoki, hmm... then let me check it
13:43:11 <ianychoi> Let's discuss this later
13:43:22 <amotoki> but it might be confusing..... I think we can start with 1:1 weight for translations and reviews
13:43:27 <jpich> Another thought is that it might get complicated to explain the system. Wasn't one of the goals to encourage more reviews? Maybe valuing them the same (same weight) as a translation would help
13:43:35 <ianychoi> We have sufficient time to determine https://review.openstack.org/#/c/437188/1/doc/source/official_translator.rst
13:44:12 <jftalta> jpich: +1
13:44:16 <ianychoi> jpich, thanks for your thought
13:44:48 <ianychoi> #action ianychoi will observe translation & review stats and see which metric have higher counts
13:44:55 <ianychoi> Let's move on the next topic
13:44:59 <ianychoi> #topic Release note translation criteria
13:45:08 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-i18n/2017-March/002822.html
13:45:16 <ianychoi> I am +1 for amotoki's suggestion
13:45:38 <ianychoi> And, sorry for amotoki: I think I delayed it too much
13:45:51 <amotoki> ianychoi: np
13:46:15 <amotoki> personally I am a reader of English version :)
13:47:24 <jftalta> so am I
13:47:45 <ianychoi> I respect rsimai's opinion but for me the value of more publication to translated versions for new release notes is higher than a little bit embarassment with the mix of English and translated language
13:48:42 <ianychoi> To more enhance it, we need more volunteer who would like to investigate on how to improve
13:49:10 <ianychoi> For me I have more priority in Stackalytics part during Pike cycle and hope that I will see this after Pike cycle if there is no volunteer
13:49:32 <amotoki> my opinion is totally same as ianychoi.
13:50:16 <ianychoi> Okay, then let's go forward with amotoki's idea with release note criteria
13:50:24 <jftalta> ok
13:50:28 <ianychoi> #topic Translation checksite using OpenStackAnsible
13:50:37 <ianychoi> #link https://review.openstack.org/#/c/440825/
13:51:06 <ianychoi> I asked reviews to OpenStackAnsible team and Andy (PTL) did his first review on that
13:51:20 <ianychoi> eumel8 said that he would respond it by this week.
13:51:38 <ianychoi> Note that this is another goal of I18n team during Pike cycle
13:51:45 <ianychoi> #topic Log translation discussion
13:52:04 <ianychoi> amotoki, again thanks a lot for your kind input into openstack-operators
13:52:24 <ianychoi> I sent a message to Torii-san today afternoon
13:52:43 <ianychoi> I also sent a message to an ambassador in Chinese team
13:53:00 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-operators/2017-March/012946.html
13:53:13 <ianychoi> Hope that Chinese team will respond in openstack-operators mailing list
13:53:37 <amotoki> I saw the forwarded mail in openstack jp team. no one seem to need translations so far.
13:53:45 <ianychoi> Also, I sent an e-mail to IBM people and they said that they are discussing and they will respond by this week
13:53:56 <amotoki> I asked some operators in jp-ops Slack channel and got the same responses.
13:54:08 <ianychoi> Matt - Nova PTL suggested me to also ask to Product Working Group.
13:54:32 <ianychoi> I actually do not know Product Working Group too much, but would be a good idea to also ask to Product Working Group?
13:55:04 <jftalta> I agree with eumel8. imo, it's not a topic...
13:55:28 <amotoki> Product WG mainly focuses on gathering what we want and input them to developer side.
13:55:54 <ianychoi> eumul8: "- Log translation discussion. The message is clear: nobody wants logfile translation instead unique identifier. Let's skip the logs and focus on the real important things! " => That was Frank's message what he shared with me and jftalta
13:56:31 <jftalta> yes, that's what I meant
13:56:54 <ianychoi> amotoki, hmm it seems that their feedback would be also important. Yep more asking & discussion is good I think. I will also ask Product WG soon
13:57:20 <ianychoi> But still personally, removing one functionality for translation is sad
13:57:36 <amotoki> sad :)
13:57:39 <amotoki> sad ?
13:57:44 <ianychoi> However, if nobody uses it, then removing would be nice
13:57:56 <ianychoi> The decision would be un-recoverable
13:57:59 <amotoki> let's translate it if we feel it useful :)
13:58:05 <ianychoi> amotoki, +1 :)
13:58:40 <ianychoi> This is why I want to more ask with more side and Doug - prev Release Mgmt. PTL would think in the similar way
13:58:52 <ianychoi> #topic Open discussions
13:59:02 <amotoki> before we close the meeting, let me share one bug on stackalytics: bug 1669768
13:59:02 <openstack> bug 1669768 in openstack i18n ""language" filter does not work" [Medium,Triaged] https://launchpad.net/bugs/1669768
13:59:13 <ianychoi> amotoki, yep that's what I want to fix it
13:59:15 <amotoki> it would be nice if someone investigates it
13:59:35 <ianychoi> amotoki, I can see it after my PDF implemenation in Docs team is finished
13:59:47 <amotoki> ianychoi: nice
13:59:51 <ianychoi> It is now 95%... I think
14:00:26 <ianychoi> And for a next step, I am asking one Korean contributor to propose & implement a spec: translated PDF support
14:00:59 <ianychoi> Also, I am now doing my best to have successful transition from prev. design summit to forum
14:01:13 <ianychoi> :)
14:01:26 <ianychoi> Thanks you so much today, jpich jftalta amotoki
14:01:30 <ianychoi> Let's finish it :)
14:01:34 <jpich> Thanks :)
14:01:34 <ianychoi> #endmeeting