13:10:58 <ianychoi> #startmeeting OpenStack I18n Meeting
13:10:59 <openstack> Meeting started Thu Mar 30 13:10:58 2017 UTC and is due to finish in 60 minutes. The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:11:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:11:03 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:11:20 <ianychoi> Thanks a lot for today coming - tono and jftalta
13:11:34 <tono> ok
13:12:00 <ianychoi> #topic Boston Summit & Forum preparation
13:12:26 <ianychoi> #action ianychoi will submit a topic for Forum by April 2
13:12:52 <ianychoi> #action ianychoi will contact zzxwill - since he is a key person for Boston Summit presentations
13:13:06 <ianychoi> I don't have nothing more for Boston Summit & Forum
13:14:07 <ianychoi> tono, jftalta any idea for Boston Summit & Forum?
13:14:20 <tono> What do you have so far?12
13:14:38 <ianychoi> tono, so far? What means?
13:14:40 <jpich> (Hi! Sorry I'm late)
13:14:48 <ianychoi> jpich, hello!
13:14:53 <jftalta> jpich, hi
13:15:11 <tono> I do not follow your preparation, sorry
13:15:28 <ianychoi> tono, aha I see. I18n team will have two presentations on Boston Summit
13:15:38 <tono> OK
13:16:42 <tono> jpich, hi
13:16:44 <ianychoi> For Forum, http://forumtopics.openstack.org/cfp/details/6 is one topic and the due for Forum topic submission is April 2. So I would like more consider other topics for I18n team
13:19:20 <ianychoi> Hmm, let's move on to the next topic
13:19:32 <ianychoi> #topic Toward for official language coordinator & defining I18n cores
13:20:54 <ianychoi> I would like to have more time on this topic today
13:21:04 <jftalta> ok
13:21:14 <ianychoi> Because remaining topics are also related to this topic I think.
13:22:16 <ianychoi> Actually, I joined I18n team in 2014 and I don't know how current language coordinators became historically but as far as I know most language coordinators became coordinators as a pioneer in each language team
13:22:52 <ianychoi> For example, ujuc is Korean I18n language coordinator and he was the guy who first requested to join OpenStack translation for Korean
13:23:46 <ianychoi> I wanna respect them as pioneers and changing language coordinators is mainly dependent to the culture of each language team I think.
13:23:52 <amotoki> i think nothing is different in case of ja team
13:23:54 <ianychoi> But... for example, Indonesian
13:24:03 <ianychoi> Hi amotoki :)
13:24:14 <ianychoi> tono recently has contributed a lot for translations
13:24:39 <jftalta> In France, translators have the same point of view
13:24:50 <ianychoi> I tried to contact current Indonesian language coordinator by e-mail about six months ago (maybe) but I still have not received any replies yet
13:24:52 <jftalta> I mean same as yours
13:25:30 <ianychoi> In this case, I may need to change the language coordinator in such team
13:25:56 <jftalta> I understand
13:26:12 <ianychoi> For this case of view, I wanna incorporate the concept of official language coordinators
13:26:36 <ianychoi> For example, recently Romanian requested to create Romanian translation support in Zanata
13:27:29 <ianychoi> There have been no translation by now. However, in this case, language coordinator may exist or having no language coordinator would be another approach
13:27:59 <tono> the first time when joinung, i can define myself as coordinator, reviewer, or just regular translator.
13:28:51 <ianychoi> Official language coordinators would be needed for several points of view - 1) Communication with I18n PTL well (IRC, e-mail, anything is okay for me but it would be dependent to different future PTLs) 2) monitor language translation effort in language team 3) collect feedback from translators in each language team
13:29:22 <tono> But now, I must to request to be translator.
13:29:29 <amotoki> what does 2) mean?
13:30:08 <ianychoi> 4) review activities for qualified translation 5) following I18n translation priority & participating in deciding the priority and plan
13:30:40 <ianychoi> amotoki, for example, seeing whether translators in each language team translate well or not
13:30:53 <jftalta> 6) update and streamline the glossary
13:31:01 <ianychoi> PTL cannot observe all things whether each language team going well or not
13:31:18 <jftalta> sure
13:31:34 <ianychoi> But I wanna resolve some issues if the language team has difficulties - for example, how to better communicate with translators & reviewers
13:31:47 <ianychoi> We can share such tips since we are all in I18n team
13:32:01 <ianychoi> jftalta, thanks for 6) - yep also important I think
13:32:18 <amotoki> honestly it is not easy who is making good translation and is worth reviewers (as Zanata does not provide a way to discuss/communicate translators well)
13:32:35 <amotoki> we can only who is active in translation
13:33:30 <amotoki> s/can only/can know only/
13:33:45 <jftalta> for example, within the french team, there are more than 30 Zanata users, but only 4 active translators
13:33:46 <ianychoi> amotoki, yep but I would like language coordinators to investigate at least.. for example, how many translators & reviewers parcipated in last OpenStack release cycle? The amount is increased or decreased?
13:34:21 <amotoki> ianychoi: good idea
13:34:26 <ianychoi> I think jftalta and katomo already identified such things :)
13:35:05 <ianychoi> And the 7) may be to participate in review activities in openstack/i18n and openstack/i18n-specs
13:35:48 <ianychoi> But 7) is controversial - than I meant is that using Gerrit seems not too easy for translators
13:36:54 <jftalta> It's better if the coordinator has development skills
13:37:01 <amotoki> when I was a coordinator, I tried to coordinate several discussion inside a lang team (for example glossary discussion) and setup some communication tools for team communication
13:37:12 <ianychoi> For me, i18n-specs would be useful for translators but Gerrit usage prevents from more involving review activities me and amotoki think
13:37:42 <jftalta> amotoki, I did the same for the french team
13:37:53 <ianychoi> amotoki suggested me to make use of blueprints and I think it is still a good idea but Foundation now tries to encourage to use Storyboard
13:38:13 <amotoki> I think this is one of important roles of language coordinator (as a local language team)
13:38:37 <ianychoi> I18n might need to better idenify pros and cons for different tools and need to choose the best tool for the team
13:38:58 <amotoki> from the i18n perspective, the list of roles might be a bit different
13:39:46 <ianychoi> amotoki, yep currently, i18n-cores are more involved in the ownership for openstack/i18n repository I think
13:40:31 <ianychoi> i18n-cores would be i18n perspective and the list of roles for official language coordinators might be different from i18n-cores but still important
13:41:05 <amotoki> yeah, more involvement would be nice
13:41:30 <ianychoi> #link https://zanata.atlassian.net/browse/ZNTA-1843
13:42:01 <ianychoi> Such activities would be related to the repo for openstack/i18n :)
13:42:23 <ianychoi> (For the detail of the link, let's discuss on the next IRC meetings)
13:43:00 <ianychoi> tono, what is your feeling when seeing the current discussion on official language coordinator?
13:43:31 <amotoki> hmm... it sounds like infra thing rather than translation thing to me even though it is related to i18n
13:43:41 <ianychoi> tono, unfortunately, current Indonesian language coordinator has not replied still yet. So I wanna nominate you as Indonesian language coordinator
13:43:52 <tono> very difficult to find members for translator
13:44:21 <amotoki> of course language coordinators can send feedback to such tools but isn't it too much requirement to be involved in maintaining such tools.
13:44:31 <ianychoi> amotoki, yep but infra team cannot deal with all I18n things. Someone in I18n team needs to take care of and/or keep track of such activities
13:45:19 <amotoki> ianychoi: exactly, but it is not a requirement for language coordinator. That's my point
13:45:25 <ianychoi> tono, is there a user group in Indonesia? Have you been community meetups in Indonesia?
13:45:54 <ianychoi> amotoki, I agree with you. Such activities are more related to i18n-cores than language coordiantors
13:46:04 <ianychoi> s/coordintors/coordinators
13:46:28 <tono> there are many user groups, but not openstack
13:47:26 <tono> none user group for i18n
13:47:36 <ianychoi> tono, hmm I see
13:48:19 <tono> Openstack is not so popular in Indonesia
13:48:44 <adiantum> looks like there is Ug in Indonesia on https://groups.openstack.org/groups/indonesia
13:48:50 <adiantum> hi all!
13:48:57 <ianychoi> adiantum, oh hi all! How have you been? :)
13:49:18 <adiantum> ianychoi: thank you, fine =)
13:49:24 <jftalta> adiantum, hi
13:49:42 <tono> thank adiantum
13:49:48 <ianychoi> adiantum, just quick question: are you going to Boston Summit? Have you already registered to the Summit?
13:50:52 <adiantum> ianychoi: i alrady registered, but still not sure about attending
13:51:20 <ianychoi> For current topic, I don't want to decide anything now and still more thinking and feedback are needed
13:51:32 <jftalta> ok
13:51:42 <tono> https://groups.openstack.org/groups/indonesia
13:51:46 <ianychoi> I might be better to consider to discuss with more current language coordinators as possible
13:51:53 <ianychoi> #topic Open discussions
13:52:06 <tono> not active any more
13:52:41 <ianychoi> adiantum, aha.. I see. For I18n perspective, it would be so nice if at least one Russian translator (or coordinator) will join to many I18n activities during Boston Summit
13:52:57 <ianychoi> There are many other topics I shared in https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting
13:53:19 <ianychoi> But since we do not have sufficient time, please feel free to share anything in open discussion
13:53:33 <adiantum> ianychoi: i'll ask team if anybody going attending, hopefully i can attend
13:53:49 <ianychoi> adiantum, thanks a lot :)
13:54:29 <ianychoi> amotoki, by the way, thanks for initiating http://lists.openstack.org/pipermail/openstack-i18n/2017-March/002864.html
13:54:56 <ianychoi> #link https://blueprints.launchpad.net/openstack-i18n/+spec/python35-support
13:55:02 <ianychoi> Also the blurprint ^
13:55:07 <ianychoi> s/blurprint/blueprint haha
13:55:12 <amotoki> you're welcome. it was a long standing item in my todos
13:55:22 <ianychoi> blur.. print.. sorry haha
13:57:19 <ianychoi> jpich, by the way I am still translating tripleo-ui in master
13:57:38 <jpich> ianychoi: Thank you! :)
13:57:45 <ianychoi> jpich, I think I can finish translations by the end of this week and then I will backport to stable-ocata :)
13:57:52 <ianychoi> jpich, np :)
13:58:07 <jpich> I wanted to speak with the German translator but I don't think he is around this week... We will have to remove the German translation because it fell to 40% :(
13:58:25 <jpich> I'm looking forward to the backport, thank you!
13:58:41 <ianychoi> jpich, I will ask to Robert :)
13:59:00 <ianychoi> #action ianychoi will ask tripleo-ui translation for German to Robert Simai
13:59:13 <jpich> I know it's Low priority (and even No Priority for Ocata) so no worries, I just wanted to let people know before removing
13:59:20 <ianychoi> jpich, I see
13:59:32 <jpich> Thanks for the action item :)
13:59:41 <ianychoi> tono, jftalta, amotoki, adiantum, jpich: Thanks a lot for today meeting!
13:59:52 <ianychoi> and Let's find better ways for I18n team :)
13:59:52 <tono> ok
13:59:58 <adiantum> thank you =)
14:00:08 <ianychoi> #endmeeting