07:04:46 <ianychoi> #startmeeting OpenStack I18n Meeting
07:04:47 <openstack> Meeting started Thu Apr 20 07:04:46 2017 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:04:50 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:05:21 <ianychoi> #topic user survey translation support
07:06:45 <ianychoi> During the 1st PTG, I met Lauren and after coming to my country, I started to talk with Heidy for user survey translation
07:07:14 <tono> I have done the survey
07:07:42 <ianychoi> tono, yep but it was in English
07:07:48 <ianychoi> s/Heidy/Heidi
07:08:29 <tono> They send me in bahasa Indonesia
07:08:29 <ianychoi> #link https://www.openstack.org/user-survey/survey-2017/landing?BackURL=/user-survey/survey-2017/
07:08:56 <ianychoi> tono, really? the link is in English but you saw questions in Indonesian?
07:09:30 <tono> Yep
07:10:07 <ianychoi> That looks so nice :) At least, I saw questions in Korean
07:10:40 <ianychoi> On early March, Heidi organized a meeting with me and Jimmy - www.openstack.org developer
07:11:10 <ianychoi> At that time, we thought that translating user survey questions in Zanata would be so nice
07:11:11 <tono> I am still browsing the user survey
07:12:05 <ianychoi> And a few hours ago, I have just seen that smarcet - also a developer on www.openstack.org and also openstackid authentication started work to create a pot file for user survey
07:12:25 <ianychoi> #link https://raw.githubusercontent.com/OpenStackweb/openstack-org/feature/survey_translation/gettext/pot/survey.pot
07:13:08 <ianychoi> I have heard that the pot file is not currently uploaded into Zanata but hope that it will be solved soon and then I think Zanata will support translation for user survey
07:13:34 <tono> the user survey does not work very well in my PC
07:14:12 <ianychoi> tono, how the user survey did not work well? Not it does not work because the survey period was already finished
07:14:24 <ianychoi> s/Not/Now
07:17:44 <ianychoi> jpich, I have a question. How did you extract pot files from json files? Using some sort of Python libraries?
07:18:24 <tono> I mean the link of the user survey not working very well, the link from yours
07:18:34 <jpich> ianychoi: It's a nodejs library (tripleo-ui runs on nodejs) of some sort, called json2pot. It's made to work specifically with the format used by react-intl though
07:20:07 <ianychoi> jpich, aha.. I see thanks :) I am not sure how OpenStackWeb team created the pot file but I was curious because tripleo-ui and openstackweb are both in web sides
07:20:30 <ianychoi> tono, I see. It does not work well since the survey was finished
07:20:32 <jpich> :)
07:20:37 <ianychoi> Okay..
07:21:13 <ianychoi> #topic Zanata survey
07:21:37 <ianychoi> #link https://docs.google.com/forms/d/e/1FAIpQLSeqxia866yOv1GZEmCqCenzT31RO6gzndJ1w7QetRr6NvGvfQ/viewform?usp=sf_link
07:21:54 <ianychoi> Please do this survey - the survey was initiated from Zanata development team.
07:22:13 <ianychoi> I will distribute it to openstack and openstack-dev mailing lists
07:22:38 <ianychoi> #action ianychoi will distribute Zanata survey questionnaires to openstack and openstack-dev mailing lists
07:23:15 <ianychoi> I hope that our feedback will improve Zanata better :)
07:23:16 <tono> I had filled the survey, and submitted
07:23:30 <ianychoi> tono, wow good :)
07:25:45 <ianychoi> #topic Summit presentations
07:26:00 <ianychoi> Since Summit presentations are not here, I would like to skip this topic.
07:26:22 <tono> ok
07:26:51 <ianychoi> #topic Review on the last meeting items
07:27:02 <ianychoi> #link http://eavesdrop.openstack.org/meetings/openstack_i18n_meeting/2017/openstack_i18n_meeting.2017-04-13-13.07.html
07:27:25 <ianychoi> This is the last meeting minute and I have mentioned Stackalytics, python 3 support, and tagging for i18n
07:28:05 <ianychoi> For Stackalytics, I asked my colleague in Korea to see Stackalytics source codes.
07:28:37 <ianychoi> He is looking Stackalytics to support to see statistics by languages.
07:29:14 <ianychoi> By the way, during Forum, one interesting topic has been rised: "Should we kill Stackalytics ?" by ttx
07:29:30 <tono> what is the issue in those topics ?
07:29:39 <ianychoi> #link http://forumtopics.openstack.org/cfp/details/78
07:30:14 <ianychoi> #link http://stackalytics.com/?metric=translations&language=indonesian
07:30:44 <ianychoi> tono, the link should list Indonesian translators but you now see all translators
07:31:44 <tono> Other Indonesians do not actively translate
07:32:11 <ianychoi> tono, yep but that would be another issue
07:33:07 <ianychoi> For python 3 support, AFAIK amotoki started his working. Let's more wait for such support during Pike cycle
07:34:04 <amotoki> it seems I was pinged. what?
07:34:17 <tono> stackalytics do not connect very well to other document menu
07:34:29 <ianychoi> amotoki, just informational : you are doing Python 3 support in I18n repository
07:34:48 <amotoki> ianychoi: actually it was blocked by 'importable python path'
07:34:50 <ianychoi> tono, would you identify which translation projects are not listed?
07:35:39 <amotoki> i have no idea on python3 testing at now. without python 3 test, the blueprint is already completed. that's all
07:35:51 <tono> still trying to find them
07:36:20 <ianychoi> amotoki, oh really? Sorry I have not tracked with such thing. Okay.. You mean that Python 3 gate job with Jenkins for i18n repository is needed?
07:37:21 <ianychoi> tono, yep if you find them later, please share to me or i18n mailing list
07:37:23 <amotoki> ianychoi: without testing, how can we prevent regressions?
07:37:57 <amotoki> we support python3 NOW, but I am not sure a new change is compatible with py3.
07:38:40 <tono> ok, I got problem on my internet connection
07:39:19 <ianychoi> amotoki, agreed. So currently, my understanding is that i18n repository is needed to support to add Python 3 testing jobs - 1) in tox.ini and 2) adding Jenkins gate job
07:39:54 <ianychoi> And source codes are now compatible with Python 3.
07:40:18 <amotoki> ianychoi: but we need to import python modules to be tested into unit test codes
07:40:44 <ianychoi> amotoki, aha.... unit test codes... I see. Thanks - much clearer now
07:41:37 <amotoki> I proposed to move the code to importable paths but IIRC it was blocked by a discussion on i18n-tool? repo
07:41:56 <amotoki> and I abandoned my patch to keep my review list clean
07:43:33 <ianychoi> amotoki, yep the things are related with i18n-tools. Now I think that adding more repositories is not a good idea. I will make it clearer soon.
07:44:04 <ianychoi> amotoki, thanks. I might have missed some details.
07:44:28 <amotoki> no problem. I am okay with either way
07:44:37 <ianychoi> amotoki, I see :)
07:45:39 <ianychoi> And.. for i18n tagging (in openstack/governance to see which projects are managed with translations), I need to propose such tag in openstack/governance repository.
07:46:03 <ianychoi> Recently, Docs team's "docs:follows-policy" tag has been merged: https://review.openstack.org/#/c/445536/
07:46:28 <ianychoi> I will propose i18n tagging similar with the details in that link
07:46:50 <ianychoi> #topic open discussions
07:46:53 <jpich> Great :)
07:47:37 <ianychoi> jpich, my English prevents me speeding up such work although we already discussed around two months ago (Pike PTG) :(
07:47:53 <jpich> No problems, these things take time
07:47:56 <ianychoi> But now the link is a good reference how to propose a tag
07:48:50 <ianychoi> Any issues, topics, or questions on today meeting?
07:50:42 <ianychoi> And.. personally, I have got a new job.
07:50:51 <jpich> Congratulations!
07:50:56 <ianychoi> jpich, thanks you :)
07:51:02 <tono> For Indonesia translation, doc.oprnstack.org does not link very well to other document menu
07:51:29 <ianychoi> So I need to travel to Oslo next week to more discuss my responsibility in my new job
07:51:50 <ianychoi> After then, I will go to Boston Summit and come back to Korea
07:52:00 <jpich> Oslo!! Busy times
07:52:30 <ianychoi> It will be a long trip - total 3 weeks and I might not run IRC meetings for next 3 weeks.
07:53:00 <ianychoi> For the next IRC meeting, I will ask other meeting chairs to run the IRC meeting
07:53:20 <ianychoi> jpich, yep it would be much nearer to your country than Korea :)
07:53:37 <jpich> Yes!! Only one timezone apart I think (...or maybe two??!)
07:53:48 <ianychoi> tono, which link? Please specify documents then I18n people can help your problems
07:55:12 <ianychoi> tono, you better know Indonesian document status but i18n people from other countries have difficulty in seeing Indonesian documents. If you have such problems, please specify the document and say that you want to link such documents to docs.o.o. Then other i18n people will help you :)
07:55:33 <ianychoi> jpich, I think so!
07:56:02 <ianychoi> tono, your Internet connections seems not good today but fine :)
07:56:27 <tono> yep,
07:56:50 <ianychoi> tono, you better know Indonesian document status but i18n people from other countries have difficulty in seeing Indonesian documents. If you have such problems, please specify the document and say that you want to link such documents to docs.o.o. Then other i18n people will help you :)
07:56:57 <ianychoi> (copying and pasting)
07:57:04 <tono> For Indonesia translation, doc.openstack.org does not link very well to other document menu
07:57:33 <ianychoi> tono, you want to link more documents in docs.openstack.org/id ?
07:58:02 <ianychoi> tono, or Indonesian people usually see docs.openstack.org not docs.openstack.org/id ?
07:58:34 <ianychoi> I originally understood the former
07:58:52 <tono> OK, I will share the problems in i18n
07:59:06 <ianychoi> tono, thanks a lot :)
07:59:14 <tono> ok
07:59:36 <ianychoi> Thank you for participating in today irc meeting - tono, jpich and amotoki
07:59:54 <tono> By
08:00:04 <ianychoi> #endmeeting