13:00:58 <ianychoi> #startmeeting OpenStack I18n Meeting
13:00:58 <openstack> Meeting started Thu Jul 20 13:00:58 2017 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:02 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:01:20 <eumel8> here we are
13:01:26 <ianychoi> I have heard that eumel8 is in parallel meeting.
13:01:47 <eumel8> already, but with a low prio
13:01:58 <ianychoi> eumel8, oh I see :)
13:02:03 <eumel8> normaly it's finished since 1 min
13:02:27 <ianychoi> jftalta, hello!
13:02:40 <eumel8> hi jftalta
13:02:46 <jftalta> ianychoi, Hi !
13:03:09 <jftalta> hi eumel8 ! It's been a long time !
13:03:20 <eumel8> true
13:03:41 <ianychoi> :) jftalta: Were u on vacation? Or when is your vacation?
13:04:13 <jftalta> First two weeks of august
13:04:30 <ianychoi> jftalta, aha I see - so great!
13:04:40 <eumel8> save the holiday for Australia :)
13:04:50 <ianychoi> Haha :)
13:05:05 <ianychoi> Let me proceed today agenda first..
13:05:11 <ianychoi> #link https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting#Agenda_for_next_meeting
13:05:20 <ianychoi> #topic Changes on Docs team - how it affects to I18n team
13:05:53 <ianychoi> #link http://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html
13:05:54 <jftalta> we have plenty of holydays in France, so I'm saving a couple of weeks for Australia ;)
13:06:01 <ianychoi> jftalta, great!
13:06:29 <ianychoi> This is a spec for migration of openstack-manuals documents in Docs team
13:06:58 <ianychoi> There are lots of details and now I recognize recent two changes
13:07:27 <ianychoi> One is URL schema change for documentation. For example, docs.openstack.org/developer/i18n URL was changed to https://docs.openstack.org/i18n/latest/
13:07:45 <eumel8> yeah, lots of text
13:08:16 <ianychoi> The other is that Operators guide has been deleted
13:08:56 <ianychoi> #link https://review.openstack.org/#/c/483937/
13:09:07 <ianychoi> It means that some translated documents also need to be deleted
13:09:31 <eumel8> is the user-guide also deleted? This site seems a little broken: https://docs.openstack.org/user-guide/
13:09:33 <ianychoi> For example, https://docs.openstack.org/ja/ has https://docs.openstack.org/ja/ops-guide/ link but it needs to be deleted (I will propose the patch)
13:09:48 <eumel8> ok
13:09:51 <ianychoi> I think the URL scheme is changed to https://docs.openstack.org/user/
13:10:17 <eumel8> but there is a lower content
13:10:33 <eumel8> lot's of google search matches are empty
13:10:37 <ianychoi> Yep it might be that user guides are being moved to project repositories
13:11:52 <ianychoi> Since I am now too busy, I could not figure out the details of documentation status and asettle would be the best PTL who manages it but I think she is also busy on tracking and managing :) - It is so great job and now what I want to do is that I18n team at least needs to follow changes from Docs team
13:12:06 <asettle> Sorry sorry what?
13:12:08 <asettle> Here I am!
13:12:36 <eumel8> hi asettle ;)
13:12:39 <asettle> o/ hello
13:13:13 <ianychoi> asettle, I have just shared that some Docs urls are already changed and we are noticing that user-guide has less content and I said that it might be because the content is moving to actual project repositories
13:13:22 <ianychoi> Sorry for calling u :)
13:13:35 <asettle> It is indeed moving :)
13:13:36 <asettle> Not at all!
13:13:40 <asettle> :)
13:13:52 <asettle> If you guys have any questions, please do not hesitate to ping :)
13:13:53 <ianychoi> :)
13:14:21 <jftalta> Sorry, I have been disturbed by colleagues who suddenly shown up in my office...
13:14:21 <eumel8> :)
13:14:35 <jftalta> asettle, Hi !
13:15:56 <asettle> Hi jftalta :)
13:16:02 <asettle> damn those colleagues :P
13:16:25 <ianychoi> Now I also notice that https://docs.openstack.org/ja/user-guide/ is not working
13:16:52 <ianychoi> I will propose to delete such links in https://docs.openstack.org/ja/ and add Japanease team as reviewers
13:17:04 <eumel8> +1
13:17:11 <ianychoi> #action ianychoi will investigate in some missing links in https://docs.openstack.org/ja/
13:17:57 <ianychoi> Note that I mainly first track Japanese team landing page since the page has the largest number of translated documents :)
13:18:20 <ianychoi> #topic String Freeze periods are coming
13:18:43 <ianychoi> #link https://releases.openstack.org/pike/schedule.html
13:19:03 <ianychoi> Next week (Jul 24 - Jul 28) is for Soft StringFreeze in Pike cycle
13:19:23 <ianychoi> I have not found string freeze managers in I18n team unfortunately.
13:20:13 <ianychoi> If we do not find relevant string freeze managers, then I think I need to do some minimal notice & actions for String Freezes...
13:21:20 <jftalta> would be a good thing, if you can
13:21:53 <ianychoi> jftalta, I am unfortunately too busy now...
13:22:18 <ianychoi> But thanks :)
13:22:24 <jftalta> Ianychoi, I know, I know
13:22:32 <ianychoi> jftalta, :)
13:22:56 <ianychoi> #topic extra ATC status for I18n team
13:23:38 <ianychoi> Last weekdays were for extra ATC proposing deadline and I safely proposed extra ATCs for I18n team
13:23:40 <ianychoi> #link https://review.openstack.org/#/c/483452/
13:24:09 <jftalta> btw, there is a new translator in the french team since last tuesday. Seems to be a cool and keen guy :)
13:24:22 <ianychoi> jftalta, great!
13:24:29 <ianychoi> Hope that it will be merged soon
13:25:24 <ianychoi> In the review, I communicated with fungi and found that having openstackid does not guarantee that the guy is a Foundation member
13:25:43 <tono> am I in the extra ATC ?
13:25:50 <ianychoi> For extra ATCs, being Foundation member is important
13:25:57 <ianychoi> tono, hi:) Suhartono?
13:26:14 <tono> Yap, I am
13:26:23 <fungi> right, anyone can have an openstackid for purposes of logging into things like the speaker support system or external resources like translate.o.o
13:26:39 <ianychoi> tono, sure - please find your name in https://review.openstack.org/#/c/483452/2/reference/projects.yaml :)
13:26:48 <fungi> but to be able to vote you also have to join the foundation as an individual member
13:26:52 <tono> Thank you
13:27:22 <ianychoi> Yep :) Fortunately, openstackid resources API helped me to see whether the member is Foundation member or not
13:27:35 <fungi> (and make sure the email address in your extra-atc record is added to at least one of the email address fields in your foundation member profile on www.openstack.org)
13:27:51 <jftalta> fungi, actually. Have a look at this paper written by Jeremy Stanley
13:27:56 <ianychoi> fungi, thanks a lot for kind explanation!
13:28:03 <jftalta> Better with the link : http://lists.openstack.org/pipermail/openstack-dev/2017-July/119786.html
13:28:10 <ianychoi> jftalta, fungi == Jeremy :)
13:28:16 <jftalta> :(
13:28:21 <fungi> jftalta: i wrote it, but that doesn't mean i won't benefit from rereading it ;)
13:28:32 <jftalta> ha ha
13:28:35 <ianychoi> haha
13:28:42 <ianychoi> #link https://wiki.openstack.org/wiki/I18nTeam/ATC_statistics#Pike_cycle_.282017-01-06_to_2017-06-30.29
13:29:22 <ianychoi> I will revise the script http://git.openstack.org/cgit/openstack/i18n/tree/tools/zanata/zanata_stats.py to also check Foundation member status later
13:29:38 <ianychoi> And two additional things are needed
13:30:16 <ianychoi> 1) Language coordinators need to acknowledge that being Foundation member is important and it needs to be more advertised to translators
13:30:37 <fungi> ianychoi: i think your patch to add the extra-atcs for this cycle is due to merge today, if ttx gets time to hit the button
13:31:16 <ianychoi> 2) If users change their e-mail addresses in www.openstack.org, then the change is not reflected to translate.o.o => This might have problems, fungi: would it be solution for this problem?
13:31:58 <fungi> ianychoi: yes, just like if contributors change their e-mail address in gerrit and forget to update their foundation member profile
13:32:52 <fungi> also, if you fail to vote in at least one of two consecutive elections for the foundation board of directors, your foundation membership lapses and you need to re-join
13:33:09 <ianychoi> fungi, then changing e-mail address in translate.o.o is also needed. Hmm, now I can do now is that updating e-mail address in translate.o.o is also needed in I18n contributur guide
13:33:45 <ianychoi> (I meant documentation)
13:34:35 <ianychoi> fungi, yep - thanks for the important info also :)
13:36:14 <fungi> my pleasure
13:36:40 <ianychoi> fungi, and a little bit sorry for not accomplishing auto syncing ATC status for I18n team. AFAIK newer version of Zanata can retrieve translator lists but unfortunately I18n relys on crawling approach on translate.o.o web site: http://git.openstack.org/cgit/openstack/i18n/tree/tools/zanata/zanata_users.py
13:37:27 <ianychoi> fungi, I think such crawling method is not appropriate to use auto sync of I18n ATC status. I would like to postpone with Zanata upgrade consideration
13:38:06 <fungi> ianychoi: that sounds fine. there's no rush, but once we get on that version of zanata with proper lookup capabilities it shouldn't be too hard
13:38:27 <ianychoi> fungi, yep :) Thanks a lot!
13:38:46 <fungi> you're welcome, as always
13:38:50 <ianychoi> :)
13:39:08 <ianychoi> #action ianychoi will more document Foundation member status information with changing e-mail address in Zanata in I18n contributor guide
13:39:29 <tono> +1
13:39:51 <ianychoi> tono, thank u :)
13:39:54 <ianychoi> #topic PTL nomination & election
13:40:14 <ianychoi> #link https://governance.openstack.org/election/
13:40:40 <ianychoi> Queens PTL nomination is from Jul 31, 2017 23:59 UTC to Aug 09, 2017 23:45 UTC
13:41:25 <ianychoi> If there is no PTL nomination from I18n team, then TC (Technical Committee) will consider what TC can do
13:41:41 <jftalta> it's a topic with a big "T"...
13:42:51 <jftalta> How much time does it remain to find candidates ?
13:43:23 <eumel8> at least one week, I guess
13:43:46 <ianychoi> jftalta, ? Jul 31, 2017 23:59 UTC to Aug 09, 2017 23:45 UTC is PTL election nomination - candidates need to submit candidacy to openstack/election repository
13:44:54 <jftalta> ok, 2 weeks
13:45:42 <fungi> yes, we appoint a willing ptl after the nomination period if we can (assuming one appears after the nomination period, which sometimes happens) or we look into ways to reorganize by either folding the leaderless team into another team willing to provide leadership, converting it into a workgroup/sig, or remove its official team status (which doesn't prevent the team from still doing their work
13:45:44 <fungi> unofficially if they want)
13:46:47 <ianychoi> Yep :) http://lists.openstack.org/pipermail/openstack-dev/2017-January/109622.html would be one example
13:46:57 <fungi> but it's a far better situation if someone volunteers before the tc needs to step in and take one of those actions
13:48:13 <ianychoi> I sent an e-mail titled "Asking opinions with team direction" to I18n current cores and sent a reminder e-mail about a week ago
13:48:30 <jftalta> it would be too bad to watch the team disappearing cause the lack of ptl :(
13:48:41 <eumel8> I answered the email already, ianychoi :)
13:48:59 <ianychoi> eumel8, yep :) Thanks again!
13:49:20 <eumel8> thx for the options, fungi. I think we will found a solution.
13:50:45 <ianychoi> eumel8, yep writing what I18n PTL did at least would be helpful to all :)
13:51:16 <jftalta> ianychoi, yes it would !
13:51:43 <ianychoi> It is high priority in my to-do list but unfortunately there are too much in my to-do list with higher priorities :(
13:52:10 <eumel8> ianychoi: send me the time and I will set my alarm clock for a meeting :)
13:52:35 <jftalta> Just add an eighteenth day to your weeks ;)
13:52:42 <ianychoi> eumel8, yep or having another discussion time with u might be so helpful to me
13:53:18 <ianychoi> #topic Open discussion
13:53:26 <eumel8> We can also continue as a working group but this needs also a leadership in the future (from my experience in other OpenStack working groups)
13:53:28 <jftalta> sorry, I meant an eighth ;)
13:53:52 <genek> Am I too late to the meeting? Just missed my alarm
13:54:13 <ianychoi> jftalta, :) eumel8, I am not too much familiar with working groups but yep.. I agree with u
13:54:16 <ianychoi> genek, hi!
13:54:28 <eumel8> hi genek
13:54:29 <jftalta> genek, hi
13:54:42 <genek> Hi all, sorry for being late
13:54:51 <ianychoi> eumel8, I think translation checksite needs to be more discussed with infra teams.
13:55:10 <fungi> i was hoping we'd see more replies on that thread
13:55:25 <ianychoi> eumel8, maybe we can attend to infra team IRC meeting and share the details - which things are needed from infra team
13:55:50 <genek> ianychoi, that will be a great idea
13:55:51 <eumel8> ianychoi: true. Didn't understood Andy's last message about zuul configuration
13:56:00 <fungi> i'm trying not to always be the volunteer of last resort on the infra team, but we're stretched pretty thin so apologies if we seem to not reply to messages like that quickly
13:56:53 <ianychoi> eumel8, lots of translate checksite was under public but it is so nice idea to discuss in mailing lists
13:56:59 <fungi> glad to see the ansible team stepping in and giving suggestions though
13:57:00 <genek> yeah, just heard this week at OpenStack Day Taiwan that the infra team is lacking new contributors
13:57:44 <ianychoi> fungi, I totally understand infra team situation and I am always thankful to infra team - very supportive and kind replies and suggestions :)
13:58:34 <fungi> i just wish we had more bandwidth to tackle stuff in a timely fashion, but it is what it is
13:59:07 <ianychoi> genek, IMHO participating in infra team needs lots of background and knowledge but I suggest people to stay in #openstack-infra IRC channel and try to follow what people are discussing
13:59:10 <fungi> we rely on people figuring things out for themselves as much as possible
13:59:26 <eumel8> fungi: We are all overclocked. Let me know if you need some kind of support.
13:59:48 <ianychoi> Time is up
13:59:56 <fungi> eumel8: thanks, will do
13:59:59 <ianychoi> If you have more discussions, please come to #openstack-i18n channel
14:00:18 <ianychoi> Thanks a lot for today IRC meeting - eumel8 jftalta tono fungi asettle and genek !
14:00:20 <eumel8> ianychoi: I will contact Andy again and ask for his opinions.
14:00:24 <ianychoi> #endmeeting