07:04:24 <ianychoi> #startmeeting OpenStack I18n Meeting
07:04:25 <openstack> Meeting started Thu Jul 27 07:04:24 2017 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:04:28 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:04:51 <ianychoi> #link https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting#Agenda_for_next_meeting Meeting topic today
07:05:01 <ianychoi> #topic Open reviews
07:05:14 <ianychoi> #link https://review.openstack.org/#/q/project:openstack/i18n+status:open
07:05:19 <ianychoi> Those are open reviews currently
07:05:43 <ianychoi> eumel8, would you review https://review.openstack.org/#/c/487206/ , https://review.openstack.org/#/c/486458/ , and https://review.openstack.org/#/c/484111/ ?
07:05:44 <patchbot> patch 487206 - i18n - Add Zanata id to French team member list
07:05:45 <patchbot> patch 486458 - i18n - Rename glossary files to more meaningful names
07:05:46 <patchbot> patch 484111 - i18n - Add information on translation of the i18n guide
07:06:34 <eumel8> thx, for the links. I will do this
07:07:03 <ianychoi> Thank you. Those reviews need one more +2 for approval
07:07:12 <eumel8> ok
07:08:37 <eumel8> other reviews are for Korea only :)
07:09:16 <ianychoi> There is one more: https://review.openstack.org/#/c/486961/ which needs to investigate in more. Generally it looks fine
07:09:16 <patchbot> patch 486961 - i18n - Update URL home-page in documents according to doc...
07:09:54 <ianychoi> But I am not sure whether the URL should be "https://docs.openstack.org/i18n/latest/" or "https://docs.openstack.org/i18n/"
07:11:09 <eumel8> are there more then latest?
07:11:44 <ianychoi> Nope
07:12:09 <ianychoi> But yes - for example https://docs.openstack.org/i18n/latest/ko_KR/ :)
07:12:39 <ianychoi> "/latest", "/ocata" parts are just for suffixes as defined in Docs team
07:13:01 <ianychoi> This is why I am not currently sure whether such prefix needs to be described in setup.cfg or not
07:13:21 <ianychoi> https://docs.openstack.org/i18n/ is redirected to https://docs.openstack.org/i18n/latest
07:13:29 <eumel8> so there are also /newton, /pike, /ocata ... ?
07:13:44 <ianychoi> For other Docs such install-guides, yes
07:14:03 <eumel8> then it makes sense with /latest
07:14:08 <ianychoi> However, for I18n doc, since the doc is contributor guide, the doc will not be branched to latest
07:14:25 <ianychoi> eumel8, what I tell now is then.. how about install-guide in openstack-manuals?
07:15:03 <ianychoi> setup.cfg then can be different with different branches? (e.g., in stable/ocata, the url is /ocata, and in master, the url is .../draft)
07:16:28 <ianychoi> Note that my current review is just for consistency with other setup.cfg files in different repositories
07:16:35 <ianychoi> Except this, I am fine :)
07:16:50 <eumel8> mhm, but there is only I18n guide and there is already latest version
07:17:17 <eumel8> ok, will take a look in 486961
07:18:53 <ianychoi> Thank u - this is the result from http://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html#proposed-change
07:19:02 <ianychoi> "docs.openstack.org/$project-name/latest – build from master"
07:20:50 <ianychoi> Hmm, my review perspective might include general Docs team migration guide
07:21:15 <eumel8> mhm, at the moment I wouldn't approve that change. committer needs to explain as you already mentioned
07:21:42 <ianychoi> eumel8, I see. Let's wait for the reply :)
07:21:52 <eumel8> yes
07:22:22 <ianychoi> #topic Preparing for Queens PTG and Sydney Summit
07:22:46 <ianychoi> There will be PTG in September at Denver
07:23:22 <eumel8> I heart from
07:23:32 <ianychoi> I originally really wanted to go to next PTG but now I think I might be unable to attend to the next PTG
07:24:02 <ianychoi> PTG would be so great :)
07:24:13 <ianychoi> For me, the first PTG was very nice
07:24:36 <eumel8> really?
07:24:55 <ianychoi> Yep :)
07:25:33 <eumel8> similar to design summit or more?
07:25:55 <ianychoi> Something more
07:26:13 <eumel8> mhmm, interesting
07:26:21 <ianychoi> For example, During Boston Summit, we met Horizon team PTL and OpenStackAnsible PTL
07:27:20 <eumel8> thats true and it was very helpfull
07:27:21 <ianychoi> On February, there were several cross project meetings proposed by me: I18n-Docs, I18n-Horizon-ReleaseMgmt with Horizon plugin development teams, I18n-Infra, and I18n-Infra-OpenStackAnsible
07:28:46 <eumel8> we have some new I18n topics to discuss in PTG?
07:28:51 <ianychoi> It was very great to discuss in detail with more time
07:29:05 <ianychoi> We can propose :)
07:29:14 <ianychoi> For example, more on translation checksite
07:29:38 <ianychoi> How to automate ATC status without proposing extra-ATC with infra team
07:29:59 <ianychoi> One more Zanata upgrade before there is new Wildfly
07:30:11 <ianychoi> Horizon translation ratio calculation
07:32:22 <eumel8> ok, there are really topics. But we have also I18n people there? Or people from zanata?
07:32:52 <ianychoi> Nope we need to figure out who will attend to go to PTG from I18n and Zanata dev. team
07:33:25 <ianychoi> And.. for presentation,
07:33:27 <ianychoi> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers
07:33:33 <ianychoi> (Sydney Summit)
07:33:56 <ianychoi> I searched using "I18n" keyword, and now there are three presentations
07:33:58 <ianychoi> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19239
07:34:03 <ianychoi> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/20007
07:34:15 <ianychoi> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/20010
07:35:25 <ianychoi> The first one looks interesting :) It would be much nice if the proposal is accepted and we meet them
07:36:24 <ianychoi> And since Zanata dev. team lives in Austraila (Brisbane, not Sydney but very near), I really hope that Zanata team's presentation is accepted :)
07:36:59 <eumel8> that must be needed :)
07:37:19 <eumel8> you know the guys from the first one?
07:37:27 <ianychoi> Nope
07:38:12 <eumel8> hehe, somebody is doing I18n ;)
07:38:27 <ianychoi> :)
07:38:37 <ianychoi> #topic String Freeze periods are really coming
07:38:46 <ianychoi> It is really coming :)
07:39:38 <ianychoi> I will not run for next PTL and I am now busy, but I would like to announce it through i18n mailing list and language coordinators
07:39:50 <ianychoi> #topic Progress on translate checksite
07:40:13 <ianychoi> Thanks a lot for attending last infra team meeting, eumel8 !
07:40:51 <eumel8> yes, string freeze - the last magic on the universe and what I have to do as PTL. Maybe we can discuss this later.
07:41:28 <ianychoi> eumel8, +10000 :)
07:41:43 <eumel8> infra team meeting was very helpful. I think I have now a plan, a volunteer and a proposal change today.
07:41:56 <ianychoi> Aha, okay!
07:42:21 <eumel8> but I'm not 100% sure and there is only a chance that the site is online in 2 weeks
07:42:36 <ianychoi> eumel8, we can do it on the next cycle :)
07:43:25 <eumel8> but we're really at the end of the street and I want to push this forward.
07:43:59 <ianychoi> eumel8, I think there are two possible ways: 1) Asking Andy and Rob for helping prepare translate checksite on some infra and 2) Using DevStack for this cycle
07:44:34 <eumel8> no, I've setup the new interim page with OSA on #link https://i18n.external.otc.telekomcloud.com/
07:44:36 <ianychoi> 1) includes to find and call for volunteers
07:44:57 <ianychoi> Oh then 2) would be "Using OSA for this cycle"
07:45:20 <eumel8> I can share crendentials on the mailing list
07:46:33 <ianychoi> eumel8, great and it would be also nice if you upload https://review.openstack.org/#/q/project:openstack-infra/puppet-translation_checksite
07:46:52 <eumel8> And I want to write the proposal for the infra team. site name is still translate-checksite.openstack.org?
07:46:52 <ianychoi> I think it would make more people forward :)
07:47:27 <eumel8> ok
07:47:40 <ianychoi> eumel8, It was not mentioned I think. i18n-horizon-checksite.openstack.org might be also a good candidate?
07:48:12 <eumel8> too long for me. I'm over 40
07:48:34 <ianychoi> Haha
07:48:50 <ianychoi> Then i18n-checksite.o.o ?
07:49:06 <eumel8> ok, much better
07:49:35 <eumel8> then I skip #link https://review.openstack.org/#/c/276466/
07:49:36 <patchbot> patch 276466 - openstack-infra/system-config - Manifest for configuration translation checksite
07:49:41 <ianychoi> If we have time, we can do polls through openstack-i18n mailing list with Horizon and OpenStackAnsible team
07:50:07 <ianychoi> Okay. You can abandon it :)
07:50:44 <ianychoi> #topic I18n guide translation support is ready! The only thing remained is for documentation :)
07:50:51 <eumel8> I wouldn't wait for discussion on mailing list . People can poll in Gerrit :)
07:51:02 <ianychoi> eumel8, okay :)
07:51:04 <ianychoi> #link https://docs.openstack.org/i18n/latest/
07:51:21 <ianychoi> I18n contributor guide now supports translation!
07:51:32 <ianychoi> Currently there are Korean and Japanese
07:51:49 <eumel8> no German version, wtf
07:52:13 <ianychoi> eumel8, plz translate in https://translate.openstack.org/iteration/view/i18n/master
07:52:44 <ianychoi> >=75% (per messages) will automatically show by Gerrit interaction
07:53:11 <ianychoi> Oh German is currently 51.67% (per words)! Great!
07:53:14 <eumel8> I have translated over 40% but there was no time the last days. Maybe at the weekend
07:53:25 <eumel8> yes, still 11 pages left
07:53:26 <eumel8> or 9
07:53:47 <ianychoi> eumel8, great - thanks a lot for your translation contribution
07:53:58 <eumel8> you're welcome
07:54:09 <ianychoi> The only remaining thing for such support is Documentation: https://review.openstack.org/#/c/484111/
07:54:09 <patchbot> patch 484111 - i18n - Add information on translation of the i18n guide
07:54:24 <ianychoi> eumel8, would you review it? Then I would like to close a blueprint: https://blueprints.launchpad.net/openstack-i18n/+spec/i18n-guide-translation
07:54:40 <eumel8> ok, I have it on my list
07:55:01 <ianychoi> #topic Open discussions
07:55:28 <ianychoi> And.. for PTL section in I18n contributor's guide
07:55:50 <ianychoi> Would you make some time?
07:56:14 <eumel8> sure
07:56:36 <ianychoi> How about tomorrow?
07:57:13 <ianychoi> I would be fine on 14:00 UTC tomorrow
07:57:36 <eumel8> if you vote for https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19034 ;)
07:57:52 <eumel8> that makes me able to travel to Sydney
07:58:02 <ianychoi> Oh great - I will do it :) Sure!
07:58:11 <ianychoi> with basic description :) haha
07:58:22 <eumel8> company would support the journey
07:58:31 <ianychoi> Great :)
07:58:53 <eumel8> Friday 14:00 UTC is fine for me. On #openstack-i18n?
07:59:08 <ianychoi> Yep :)
07:59:13 <eumel8> great
07:59:28 <ianychoi> Thanks a lot today meeting
07:59:32 <ianychoi> See u tomorrow, eumel8 !
07:59:40 <eumel8> thx ianychoi
08:00:09 <ianychoi> #action ianychoi and eumel8 will discuss on "PTL section" in I18n contributor guide at 14:00 UTC on on July 28
08:00:12 <ianychoi> #endmeeting