07:00:25 <eumel8> #startmeeting OpenStack I18n Meeting
07:00:25 <openstack> Meeting started Thu Nov  2 07:00:25 2017 UTC and is due to finish in 60 minutes.  The chair is eumel8. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:28 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:01:15 <ianychoi> hi
07:01:36 <eumel8> Good morning!
07:01:46 <eumel8> Hopefully the right timezone ;)
07:01:46 <ianychoi> Good morning
07:01:59 <eumel8> Welcome to the I18n team meeting
07:01:59 <ianychoi> yep right 8am here
07:02:59 <eumel8> we have this "funny" thing with summertime and wintertime and this changed last weekend
07:03:41 <eumel8> #topic Open Discussion
07:03:49 <ianychoi> yep I slept 1 hour more on the last Sunday
07:04:49 <eumel8> no special topics today. We had have also some public holidays this week so the time to work was very short.
07:05:28 <ianychoi> Aha.. some holidays in Germany?
07:06:02 <chason> o/
07:06:40 <eumel8> 500 years Martin Luther Reformation Day
07:06:59 <eumel8> so we have this holiday every 500 years ;)
07:07:06 <eumel8> hi chason
07:07:16 <ianychoi> Good holiday :) Hello chason !
07:07:18 <amotoki> hi
07:07:34 <chason> :p
07:07:38 <ianychoi> Hi amotoki :)
07:07:53 <amotoki> i have been very busy since the beginning of Oct
07:08:17 <chason> I guess this is my first time appears here.
07:08:22 <ianychoi> amotoki, oh.. with too much work?
07:08:38 <eumel8> hi amotoki
07:08:43 <amotoki> ianychoi: yeah + private one too
07:08:47 <amotoki> ianychoi: do you have any information from alex or others about Sydney presentations?
07:09:42 <ianychoi> amotoki, yep - they are still waiting for your feedback :)
07:10:29 <amotoki> i think i have some time on Sat before the flight + during the flight
07:10:55 <ianychoi> Oh.. I see
07:12:34 <amotoki> i am really sorry for the inconvenience. will try my best
07:13:30 <ianychoi> I am now in Oslo Norway from last Saturday to next Tuesday morning. Still I am suffered from jat lag but hopefully I can input more on my idea as much as possible
07:14:01 <ianychoi> amotoki, that's fine - plz greet Alex and Patrick during Sydney Summit :)
07:14:28 <eumel8> ianychoi: hahaha, jet lag will take maximal a week ;)
07:14:55 <ianychoi> Infra team PTL - Clark said that he might be so busy during Summit but he can discuss Zanata & Infra with Zanata developemt team during lunch time
07:15:25 <eumel8> amotoki: good luck and greetings to Alex and Patrick also. Will look on Youtube for the video :)
07:15:47 <ianychoi> eumel8, I don't want to but in reality jet lag is not so good..
07:17:48 <eumel8> ianychoi: my feeling is not the best regarding zanata upgrade. I will try to push the necessary merges this week
07:18:51 <ianychoi> eumel8, good! Thanks a lot :)
07:20:33 <eumel8> ianychoi: maybe I need a second period as PTL to reach the goal :)
07:22:51 <eumel8> The Doc/I18n Onboarding Session is managed by pkovar and I think we are well prepared
07:23:01 <ianychoi> eumel8, I will also support u :)
07:23:45 <eumel8> ianychoi: yeah! One thing we want to start project doc translation
07:24:22 <eumel8> I'm not sure which changes we need to put a project doc in Zanata.
07:24:30 <ianychoi> eumel8, yep
07:24:56 <ianychoi> For this, maybe it would be so nice if one I18n member is so familiar with unified zuulv3 jobs
07:25:25 <amotoki> sorry, seems disconnected...
07:25:32 <ianychoi> Like unified doc jobs, project doc translation stuff needs to be included in unified jobs
07:25:59 <eumel8> ianychoi: I have learnt a lot but I wouldn't say I'm familar with this stuff
07:26:28 <amotoki> is it clear what we need to do if we do it manually?
07:26:45 <ianychoi> eumel8, for me, sorry but I have hadn't enough time to be familiar with zuulv3 jobs
07:26:58 <eumel8> my candidate for testing is the osa project. They have the best progress in all parts of documentation
07:28:35 <eumel8> amotoki: I think it's nearly there: https://github.com/openstack/openstack-manuals/blob/master/.zuul.yaml
07:29:38 <chason> eumel8  If you pleased, we can work together for zuulv3 jobs.
07:29:39 <chason> en
07:29:50 <amotoki> eumel8: how about the way to upload and download translation from/to zanata?
07:30:33 <amotoki> we also need to consider what kind of documents we would like to see in Zanata (install guide, user guide or something)
07:30:36 <chason> eumel8 But I am also not familar
07:31:17 <amotoki> i think we need to split docs into meaningful pieces
07:32:14 <ianychoi> Although I am not still familiar with zuulv3, at least, training-guides would be a best reference to support project documentation translation - http://git.openstack.org/cgit/openstack/training-guides/tree/tools/generatepot-training.sh & http://git.openstack.org/cgit/openstack-infra/project-config/tree/jenkins/scripts/common_translation_update.sh#n228
07:32:46 <eumel8> there is a given structure https://github.com/openstack/openstack-ansible/tree/master/doc/source and https://github.com/openstack/openstack-ansible/tree/master/deploy-guide/source
07:33:01 <eumel8> don't know why the deploy-guide is so very special
07:34:30 <ianychoi> eumel8, so.. then for ansible repository, "doc" & "deploy-guide" documents in Zanata for "openstack-ansible" project should be fine?
07:35:18 <ianychoi> eumel8, I think amotoki's saying would be related.. for example: http://git.openstack.org/cgit/openstack/neutron/tree/doc/source -> admin, cli, contributor, and install are mixed in one documentation
07:35:43 <ianychoi> (what I meant - one documentation is one conf.py)
07:37:06 <eumel8> is it really mixed? there is one in each directory
07:37:47 <ianychoi> eumel8, one conf.py and build but different output folder e.g., /install, /admin, /cli, and /contributor
07:38:27 <ianychoi> eumel8, however, when we extract translation po from Sphinx, just one file might be generated as far as I know. amotoki: thoughts?
07:44:30 <amotoki> ianychoi: right. At now, sphinx generates POT files per RST file and
07:44:42 <amotoki> the infra script merges all of them into one file
07:45:21 <amotoki> I think one large file for all docs is too large to translate. that is my point
07:45:40 <eumel8> ianychoi: mhmm, I think we have to try this for one project
07:46:11 <amotoki> this is what I thought around PTG but i failed to find time to write a draft idea :(
07:46:14 <eumel8> amotoki: that's true. also bad to prioritize
07:47:07 <amotoki> doc-migration completely broke the existing approach and a new approach needs to be explored
07:47:39 <amotoki> btw, how many translators are interested in translating documentation?
07:48:14 <amotoki> before moving this forward, we'd like to know whether this is worth trying
07:48:31 <eumel8> I think a lot (including me)
07:48:44 <ianychoi> eumel8, would u kindly create one survey and share through I18n mailing list?
07:48:58 <chason> amotoki me too. :)
07:49:01 <ianychoi> to find out whether translators are interested in document translation or not?
07:49:02 <eumel8> amotoki: indian team and turkish team have completed docs translation
07:49:21 <amotoki> sounds good :)
07:49:50 <amotoki> japanese team has lost most translators working on docs (while GUI translation is active)
07:50:21 <eumel8> #action Create a survey to find out interests of project doc translation (eumel8)
07:51:26 <ianychoi> Thanks a lot, eumel8!
07:51:34 <eumel8> okay, I will investigate how the translation jobs will work for project docs
07:51:54 <chason> What about chinese team?
07:52:58 <eumel8> chason: what do you mean?
07:53:56 <chason> eumel8 I mean how much Chinese translators we have. :)
07:55:02 <eumel8> chason: I think more then enough ;) they are still very active.
07:57:00 <chason> eumel8 Aha, it is a good news.
07:57:05 <eumel8> :)
07:58:13 <eumel8> so, we have the hour. thanks to all. have a save trip if you go to Sydney and see you next week :)
07:58:46 <chason> Thx eumel8
07:58:55 <ianychoi> Thx eumel8 chason and amotoki
07:59:01 <amotoki> thanks!
07:59:07 <eumel8> #endmeeting