13:01:18 <eumel8> #startmeeting OpenStack I18n Meeting
13:01:19 <openstack> Meeting started Thu Nov 23 13:01:18 2017 UTC and is due to finish in 60 minutes.  The chair is eumel8. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:22 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:01:36 <eumel8> who else is there for I18n team meeting?
13:02:33 <eumel8> maybe we wait some few minutes
13:02:38 <genek> OK
13:07:20 <eumel8> ok
13:07:28 <eumel8> then we start
13:07:47 <eumel8> #topic Status Zanata Upgrade
13:08:00 <eumel8> #link https://review.openstack.org/#/c/506795/
13:08:22 <eumel8> I tried to push the zanata upgrade this week
13:08:25 <ianychoi> eumel8, hihi
13:08:32 <eumel8> hi ianychoi!
13:08:33 <genek> hi ianychoi :)
13:08:35 <eumel8> great
13:08:38 <ianychoi> genek, hi!
13:08:46 <eumel8> so, we've just started ;)
13:09:04 <ianychoi> I have been explaining DevStack & docs to Korean user group members - just finished :)
13:09:14 <eumel8> ++
13:09:38 <genek> That's cool
13:09:49 <ianychoi> Thanks and sorry for interrupting
13:09:54 <eumel8> np
13:10:01 <ianychoi> Yep there have been some replies on a review
13:10:14 <ianychoi> #link https://review.openstack.org/#/c/506795/
13:10:29 <eumel8> yes, there are some new comments
13:10:59 <ianychoi> I asked some opinions to Zanata members (unfortunately timezone between Australia and EU are too different) and they kindly added some opinions.
13:11:00 <eumel8> so I'll rework the patch
13:11:07 <ianychoi> eumel8, great!
13:11:08 <ianychoi> Thanks :)
13:11:37 <ianychoi> eumel8, what I can tell now is that let's make the patch stronger :)
13:11:37 <eumel8> my first idea was the first try and clean up old stuff later, but this full patch is also possible
13:13:39 <jpich> (Hi!)
13:13:45 <eumel8> hi jpich!
13:13:52 <ianychoi> jpich, hello!
13:14:00 <jpich> Sorry I'm late :)
13:14:00 <genek> hi jpich
13:14:41 <eumel8> the problem is there are only 3 core-revievers in puppet-infra so it was not possible to merge this proposal
13:15:05 <ianychoi> eumel8, infra-core (clarkb, fungi, and others) can help it
13:15:44 <ianychoi> eumel8, for example, https://review.openstack.org/#/c/422373/ => That patch was helped from infra-cores
13:16:06 <eumel8> ianychoi: I tried this but puppet stuff is special, so infra-core != infra-puppet-core
13:17:04 <ianychoi> hmm
13:17:30 <eumel8> so my idea is to send a proposal to add zanata guys as core for this repo (puppet-zanata)
13:17:31 <ianychoi> From my understand, puppet-cores would deal the review first but infra-cores also can help on it
13:18:11 <ianychoi> s/understand/understanding
13:18:18 <eumel8> or I send an email to infra-ml and ask for merge
13:18:27 <ianychoi> Yep... :) good idea
13:18:42 <eumel8> ok, then I will do that
13:19:09 <eumel8> #action eumel8 inform infra-team about outstanding proposals and ask for help
13:19:18 <ianychoi> But it seems that infra team is so busy dealing with so many things.. :)
13:19:44 <genek> So infra team is now mainly using ansible?
13:20:04 <ianychoi> puppet as far as I know but also some part of ansible
13:20:10 <eumel8> ianychoi: I know, but I told you we have also important things :)
13:20:52 <eumel8> genek: yes
13:21:23 <ianychoi> For core-ships, since we are not currently cores on puppet-zanata repository, we would respect current cores for that repo
13:21:40 <genek> eumel8: Is there any plan to switch to ansible in the future as infra team use them more?
13:22:21 <ianychoi> genek, that would be another idea from eumel8 - sorry eumel8 I read your e-mail but did not have enough time to reply to u
13:22:59 <genek> ianychoi: I can help writing ansible scripts, but I'm not so familiar with puppet
13:23:17 <genek> If there's a plan to move to it
13:23:21 <eumel8> genek: interesting :)
13:23:37 <eumel8> I thing move to ansible would be a good idea
13:23:53 <ianychoi> genek, oh so great! then would you help on https://review.openstack.org/#/c/487936/ ?
13:24:41 <eumel8> ianychoi: this thing is done. We wait for bootstrapping and Andy would help
13:25:29 <ianychoi> eumel8, agreed I just thought that reading the review would be much helpful for genek for better understanding of current translate checksite status I thought
13:25:42 <eumel8> ok, got it
13:25:51 <genek> ianychoi: I'll check on it later
13:25:58 <eumel8> next topic
13:26:15 <eumel8> #topic Project Doc Translation Feedback
13:27:38 <eumel8> #link https://etherpad.openstack.org/p/i18n_project_doc_survey
13:28:21 <eumel8> the results from our survey about Project Doc Translation
13:28:44 <genek> seems that more people would like to see translations on installation projects docs
13:29:19 <eumel8> not so much feedback but I think enough to start with this topic
13:30:41 <fungi> ianychoi: infra-puppet-core includes the infra-core group _plus_ several additional individuals
13:31:28 <ianychoi> fungi, thanks a lot for confirmation - I told it to eumel8 :)
13:31:52 <genek> thanks fungi
13:33:39 <eumel8> fungi: from my point of view to bring in the Zanata guys into puppet-zanata would be a good idea.
13:34:04 <fungi> seems like a fine idea to me
13:34:17 <fungi> bring it up with the ptl (clarkb)
13:34:19 <eumel8> k
13:35:27 <ianychoi> eumel8, when I saw https://review.openstack.org/#/c/509297/ yesterday, my understanding is that such support is also related with https://governance.openstack.org/tc/reference/project-testing-interface.html
13:36:05 <ianychoi> project doc translation
13:36:53 <eumel8> ah, back to the topic
13:36:55 <eumel8> thx ;)
13:37:44 <ianychoi> you're welcome :)
13:38:12 <eumel8> ianychoi: activating translation in project repo should be similar to existing repos like i18n or openstack-manuals
13:39:19 <eumel8> AJaeger mentioned some pitfalls  so we have to try this and see how it will work
13:39:37 <ianychoi> eumel8, generally yes but I18n team cannot deal with all project doc repositories - more volunteers might be needed
13:40:02 <ianychoi> PTI applies to all the repo, so supporting in that would be better
13:41:26 <eumel8> ianychoi: true and there are some supporter on the horizon
13:41:46 <ianychoi> Note that such support needs approvals from TC
13:42:09 <eumel8> ok, thx
13:42:19 <ianychoi> eumel8, would u let me know some examples on such supporter in Horizon?
13:43:10 <eumel8> ianychoi: I mean not the dashboard project  ;)
13:43:36 <ianychoi> eumel8, yep horizon doc - translation is already supported?
13:44:23 <eumel8> I mean there are lot's of native speaker in project teams to support translation in other languages
13:44:39 <ianychoi> Aha.. demands
13:44:40 <ianychoi> okay
13:44:54 <eumel8> but I can contact TC
13:45:01 <ianychoi> I understood that horizon doc translation was already supported
13:45:21 <ianychoi> Let's think more...
13:45:30 <eumel8> #action eumel8 contact TC for Project Doc Translation
13:45:39 <ianychoi> openstack/governance repo
13:45:53 <eumel8> I know, thx
13:46:16 <eumel8> I would use the Office Hours for a chat
13:46:30 <ianychoi> OR some yep office hours great :)
13:46:40 <eumel8> *g*
13:46:57 <eumel8> next topic
13:47:06 <ianychoi> +1
13:47:12 <eumel8> #topic Update Docs Landing Pages
13:47:17 <eumel8> #link https://review.openstack.org/#/c/520997/
13:47:58 <ianychoi> Japanese team seems busy
13:48:19 <ianychoi> Can I exclude Japanese landing page now?
13:48:30 <eumel8> okay, that would be my question if we're ready
13:48:52 <ianychoi> PTL agreed :) I will do that !
13:49:39 <eumel8> just wondering that there no answer from amotoki
13:49:52 <ianychoi> eumel8, and plz approve my proposal for draft translated pages in landing oages
13:49:56 <ianychoi> pages
13:50:02 <eumel8> but okay, you need still a rebase
13:50:13 <amotoki> I have no time to propose an alternative Japanese strings
13:50:16 <ianychoi> eumel8, yep I will do it
13:50:25 <amotoki> but I don't think it is a good reason to exclude Japanese drafts.
13:50:41 <amotoki> what is the minimum check expected?
13:51:37 <ianychoi> amotoki, other language coordinators anticipate new landing pages. Would you then help on translating some English strings in Japanese landing page on that review?
13:52:01 <amotoki> is a landing page with English strings not okay?
13:52:27 <ianychoi> amotoki, alternative - good idea!
13:53:19 <ianychoi> My general idea is that changing language landing page needs approvals from language coordinators
13:53:58 <amotoki> As my hat of Japanese lang coordinator, we lost most of active document translators so far (including me), so I am not confident we need to it
13:53:58 <eumel8> ianychoi: okay, then please rebase and then we will aprove
13:54:08 <ianychoi> If there is no opinion from language coordinators then I think changing from other language background would bot be good
13:54:20 <ianychoi> Or active translators
13:54:22 <eumel8> yeah
13:54:38 <amotoki> but it still has several number of translated documents, so it might be worth having them in a landing page
13:54:50 <amotoki> so I will check links are okay or not after the meeting
13:55:10 <eumel8> thx amotoki
13:55:27 <ianychoi> amotoki, I appreciate your saying :) Note that such idea is related with more participation from language teams
13:55:42 <ianychoi> I18n team cannot go with language translators
13:56:00 <eumel8> we have 5 minutes left
13:56:09 <amotoki> Japanese is feeling difficulties in finding next lang coordinators
13:56:32 <ianychoi> amotoki, hmm.. that's so sad story..
13:56:32 <eumel8> ok
13:56:35 <amotoki> katomo and I are trying to drop from the coordinators due to timei limitation
13:57:20 <amotoki> it is not easy to communicate with the whole members of a language team
13:58:17 <amotoki> coordinators have no contact list to all members, so it is difficult to call for volunteers
13:58:25 <ianychoi> amotoki, so sad and thank u for detail story - hopefully we think some solutions on that
13:59:40 <amotoki> I can still help the effort though
13:59:42 <genek> ianychoi: do we have emails of team members in Zanata?
13:59:55 <amotoki> genek: i think only zanata admin can do it
14:00:09 <ianychoi> eumel8, let's continue in i18n channel if others are also okay
14:00:13 <genek> amotoki: got that
14:00:31 <genek> ianychoi: sure
14:00:47 <eumel8> sorry  we're running out of time
14:01:03 <eumel8> #endmeeting