13:03:15 <eumel8> #startmeeting OpenStack I18n Meeting
13:03:16 <openstack> Meeting started Thu Dec 21 13:03:15 2017 UTC and is due to finish in 60 minutes.  The chair is eumel8. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:16 <ianychoi_phone> Haha yep - ready for Christmas all? :)
13:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:20 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:03:42 <eumel8> yes, just back from shopping
13:04:04 <eumel8> but the christmas tree is prepared ... more or less
13:04:26 <ianychoi_phone> :)
13:04:55 <eumel8> we had also long time no irc meeting
13:05:00 <eumel8> let me check the agenda
13:05:16 <eumel8> #topic Action items from last meeting
13:06:39 <eumel8> eumel8 inform infra-team about outstanding proposals and ask for help
13:07:20 <jftalta> any response from the team ?
13:07:33 <eumel8> we had a very good progress in the last weeks and the infra team was very helpful
13:07:54 <jftalta> nice news
13:08:08 <ianychoi_phone> +1
13:08:37 <eumel8> nevertheless the proposal for the translation checksite isn't merged yet. There are some merge conflicts and I have to rebase it ... the second time
13:09:27 <ianychoi_phone> eumel8: just registering your ssh key seperately would be fine from my seeing :)
13:10:28 <eumel8> I know but the proposal is so old and it could be an option to merge this in one proposal
13:10:44 <eumel8> but maybe I want to split them, indeed
13:11:01 <ianychoi_phone> eumel8: aha.. which proposal? Hmm maybe I lost some pointer on that
13:11:49 <eumel8> #link https://review.openstack.org/#/c/487936/
13:11:50 <patchbot> patch 487936 - openstack-infra/system-config - Installation of i18n-checksite.openstack.org
13:12:03 <eumel8> it's old but not historical ;)
13:13:26 <eumel8> ianychoi_phone: btw, it would be nice if you are able to merge the I18n PTL guide #link https://review.openstack.org/#/c/525051/
13:13:27 <patchbot> patch 525051 - i18n - Add I18n PTL guide
13:13:37 <ianychoi_phone> Thanks
13:13:47 <eumel8> so the next PTL is well prepared :-))
13:14:15 <eumel8> #action eumel8 contact TC for Project Doc Translation
13:14:20 <ianychoi_phone> Okay I will do the review soon - maybe today or tomorrow
13:14:59 <eumel8> this task is still open because I missed the office hours of the TC. It's maybe also a topic for the PTG in Dublin.
13:15:11 <eumel8> ianychoi_phone: thanks!
13:15:37 <ianychoi_phone> np :)
13:15:53 <eumel8> #topic Zanata update translation server
13:16:36 <eumel8> as you know we're now running version 4 of zanata release on the translate-dev.o.o
13:17:10 <eumel8> one issue was the error 404 redirect after openid login
13:17:24 <eumel8> zanata guys prepared a fix very fast
13:17:31 <ianychoi_phone> Yep!
13:17:33 <eumel8> #link https://github.com/zanata/zanata-platform/releases
13:17:48 <eumel8> #link http://docs.zanata.org/en/release/release-notes/#433
13:19:19 <eumel8> my first impression was, the problem is fixed, but after some more tests I experienced a redirect to a "no error" page instead the dashboard after login.
13:19:48 <eumel8> my first tests was on the 4.4 branch and with this version it worked correctly
13:19:49 <ianychoi_phone> Hmm
13:20:19 <eumel8> I hadn't also so much time for tests in the last days
13:20:54 <jftalta> I just logged in and I landed on a Zanata Sign Up new user page...
13:21:45 <eumel8> it's on openid-dev server connected. this is still the next problem with some wrong entries in the database
13:22:01 <jftalta> ok
13:22:30 <eumel8> I don't know how to fix it and how should I anyone explain how it fix it for us :)
13:23:18 <eumel8> maybe a new database would be the easiest way
13:23:21 <ianychoi_phone> I all shared it with Etherpad but more conversation is needed
13:25:51 <ianychoi_phone> Good idea
13:26:06 <eumel8> #link https://etherpad.openstack.org/p/translate-dev-openstackid-issues
13:27:16 <ianychoi_phone> Update: jamesmcarther commented
13:27:35 <jftalta> it means that we will have to create new accounts, right ?
13:28:10 <ianychoi_phone> Some issues on openstackid-dev need to be resolved..
13:28:54 <eumel8> jftalta: on the dev server, yes
13:29:12 <jftalta> of course
13:29:37 <eumel8> ianychoi_phone: I'm not sure if I understand the comment right. There are no password syncs between zanata and openstackid server
13:30:11 <ianychoi_phone> eumel8: between openstackid-dev and openstackid?
13:31:43 <eumel8> ianychoi_phone: I don't know. I tried to register a new account and I'm redirected to a server with htaccess protection
13:32:41 <ianychoi_phone> eumel8: it seems that openstackid developers prevented general users from registering through openstackid-dev
13:33:08 <eumel8> ianychoi_phone: but you tested it in the past sucessful?
13:34:17 <ianychoi_phone> eumel8: yes because at that time translate-dev used openstackid not openstackid-dev. Now translate-dev uses openstackid-dev
13:34:28 <eumel8> ah!
13:35:31 <eumel8> ianychoi_phone: we want to use openstackid or openstackid-dev?
13:36:02 <eumel8> jftalta: could you follow the registration process on the dev server?
13:36:16 <jftalta> sure
13:37:09 <ianychoi_phone> I will ask the help to clarkb or fungi for changing the database table data to all use openstackid-dev, assuming that openstackid developers help openstackid-dev issues well. Currently, I am still not sure of such help.
13:37:42 <eumel8> I'm on https://devbranch.openstack.org/join/register and there is the password protection
13:37:47 <jftalta> I get : username (jftalta) already taken, email (jftalta@gmail.com) already taken
13:38:56 <eumel8> ianychoi_phone: "Find duplicated users on translate-dev.o.o using some database queries". I think this is not possible. On my test server I've created multiple accounts with my email address and who will puzzle the different accounts from the same person.
13:39:33 <eumel8> and there are contraints to other tables, so it's not too easy to manipulate the database
13:40:07 <ianychoi_phone> eumel8: multiple accounts with the same email address? In translate-dev that would be impossible
13:40:19 <ianychoi_phone> unless changing openid
13:40:28 <ianychoi_phone> Hmm...
13:41:07 <ianychoi_phone> eumel8: do u configute openid for your test server?
13:41:19 <ianychoi_phone> s/configute/configure
13:41:42 <eumel8> sure
13:41:46 <eumel8> http://paste.openstack.org/show/sOaylEV4lKvO2jAuciA6/
13:42:24 <eumel8> I tested both openid server
13:42:53 <ianychoi_phone> I thing using sql "group by" query should find such duplicated user id
13:43:03 <ianychoi_phone> s/thing/think
13:44:47 <ianychoi_phone> eumel8: now I am inclined to erase and re-initialize the translate-dev database
13:45:50 <eumel8> ianychoi_phone: yes, because you didn't lost really data
13:47:15 <ianychoi_phone> eumel8: +1 then would u request such thing to infra team?
13:47:16 <eumel8> ianychoi_phone: and question again: we want to use openstackid or openstackid-dev? If the registration process will not work, then it makes no sense to use the openstackid-dev server
13:47:44 <eumel8> ianychoi_phone: together with the next release installation
13:48:35 <eumel8> or is there a sync between both server? I don't unterstand the architecture behind that ;)
13:48:49 <ianychoi_phone> eumel8: openstackid-dev assuming that openstackid developers kindly help I18n team well
13:50:14 <ianychoi_phone> eumel8: ideal sync would be impossible but imo I18n team and openstackid developers can share some timing on such requests and if we request sync than they sync.
13:50:34 <eumel8> ianychoi_phone: I only need username and password of the htaccess page ;)
13:50:49 <ianychoi_phone> Too frequent change between openstackid and openstackid-dev is so stressful..
13:51:26 <eumel8> ianychoi_phone: if we sync then we don't need the openstackid-dev server. We use the live server and we're happy.
13:52:04 <ianychoi_phone> eumel8: but openstackid developers need test
13:52:36 <ianychoi_phone> eumel8: another idea would be to create one more server: like translate-beta
13:53:24 <ianychoi_phone> translate-dev for openstackid-dev and translate-beta for openstackid for the same new test version
13:54:25 <eumel8> ianychoi_phone: yes, it's easy to install. I'm as a translator want only test translation and not openstackid processes.
13:54:27 <eumel8> But install a new server is horrible. It takes months ;)
13:54:35 <eumel8> let's move on the agenda...
13:55:02 <eumel8> #topic Restore Mitaka Documentation.
13:55:24 <eumel8> Restore of language pages like #link https://docs.openstack.org/mitaka/de/
13:56:11 <eumel8> documentation of previous releases were restored. If you want to create a landing page for your language, feel free.
13:56:52 <eumel8> it must be a new index.html file in the directory with the release and the language name
13:57:11 <jftalta> Sounds good. Mitaka is still widely used in production
13:57:46 <jftalta> This is the case at the french Home Ministry, for example
13:57:53 <eumel8> jftalta: this includes also releases after that
13:57:56 <ianychoi_phone> Good
13:58:12 <eumel8> great, support the French Home Ministry ;)
13:58:16 <eumel8> #topic PTG brainstorming
13:58:28 <eumel8> #link https://etherpad.openstack.org/p/dublin-i18n-PTG
13:58:53 <eumel8> if you like to join the PTG in Dublin there is still room for proposals
13:59:08 <eumel8> ans we are together with the docs team, of course
13:59:31 <eumel8> #topic Open Discussion
13:59:43 <ianychoi_phone> I am far from Dublin but it would be nice if more European members like jftalta join in Dublin ptg
14:00:02 <eumel8> sorry for the fast forward, but we are in the last minute
14:00:09 <ianychoi_phone> Time is up
14:00:20 <ianychoi_phone> Thank u all and merry xmas!
14:00:24 <eumel8> have a nice christmas and a happy new year.
14:00:31 <eumel8> next week will be no meeting
14:00:37 <jftalta> merry xmas to !
14:00:41 <ianychoi_phone> Happy new year jftalta and eumel8 !
14:00:45 <eumel8> #endmeeting