07:09:48 <ianychoi> #startmeeting openstack_i18n_meeting
07:09:49 <openstack> Meeting started Thu May 30 07:09:48 2019 UTC and is due to finish in 60 minutes.  The chair is ianychoi. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:09:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:09:52 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:09:58 <ianychoi> I have finally found it :)
07:10:26 <ianychoi> #topic open discussion
07:10:40 <ianychoi> plutoinmii, so are u in Beijing? :)
07:11:05 <plutoinmii> ianychoi: I am in Shanghai.
07:11:08 <plutoinmii> :-)
07:11:13 <ianychoi> Aha I see :)
07:11:53 <ianychoi> Although it is so near from Korea, I have never been to China unfortunately.
07:12:18 <plutoinmii> come to Shanghai this Nov!!
07:12:18 <plutoinmii> w
07:12:43 <ianychoi> Sure - I have strong willingness to go there :)
07:12:45 <plutoinmii> hope there is an i18n meeting on PTG this time as well.
07:12:45 <plutoinmii> w
07:12:53 <ianychoi> For I18n team, Daisy previously initiated translation team in OpenStack world
07:13:29 <plutoinmii> told by the previous China interface a little bit. I got chance to have a call with Daisy several months ago.
07:13:52 <ianychoi> Wow :) How is she?
07:13:58 <ianychoi> I joined in the translation team from 2014 - at that time I think we all translation team have communicated well.
07:14:30 <plutoinmii> She is good, still in IBM. I was told her new focus is about containers, and she is more focused in K8S recently.
07:14:46 <ianychoi> And time goes... now I feel that I18n core governance and the governance in language teams have some distance.
07:15:11 <ianychoi> Good I so miss her... :)
07:15:25 <plutoinmii> wasn't got the chance to experience the golden era of i18n team, but would like to learn a bit and support to  revive it.
07:15:48 <ianychoi> So, this release cycle, as PTL, I would like to have more communication with active translators how the team needs to continue.
07:16:02 <plutoinmii> currently Chinese translators are not very active, I saw 1-2 are still responding.
07:16:19 <ianychoi> Thanks a lot for kind words :)
07:16:23 <plutoinmii> and also I am not sure the priority of the translation tasks and what the roadmap is.
07:17:06 <plutoinmii> ianychoi: sure, agree to comminucate more.
07:17:28 <ianychoi> When I experienced some previous release cycles - Mitaka, Newton, Ocata, Pike, Queens, and so on, there were some attendees on PTGs or Design Summits, so we had conversation for translation priorities.
07:18:00 <ianychoi> Unfortunately, this PTG, I couldn't go there - Frank were there but we have not discussed a lot on translation priority
07:18:24 <plutoinmii> do we generally translate the release note of each cycle? or what documentations we put on the list?
07:18:38 <ianychoi> For translation priority, generally, I18n team update on https://translate.openstack.org/
07:18:50 <plutoinmii> got it. i will take a look.
07:19:36 <ianychoi> For plans, it can be different by different categories.
07:19:52 <plutoinmii> Train Dashboard translation
07:19:53 <plutoinmii> Documentation translation Dashboard
07:19:53 <plutoinmii> I18n contributor guide translation
07:20:00 <plutoinmii> these are the three, right?
07:20:08 <ianychoi> For dashboards, since dashboards are in development during release cycle, some strings can be changed a lot.
07:20:36 <plutoinmii> i see.
07:20:48 <ianychoi> So, generally, translators are more engaged on especially around Soft StringFreeze: https://releases.openstack.org/train/schedule.html
07:21:18 <ianychoi> Soft StringFreeze means that development projects try to freeze strings as much as possible for documentation and translation.
07:21:37 <plutoinmii> these are useful info. thanks a lot!
07:22:53 <ianychoi> And Hard StringFreeze means that strings will not changed without proper exception - if there are still more activities on translations, I can ask for projects e.g., please release RC2, RC3, and so on with more translation resources..
07:23:04 <plutoinmii> i would like to summarize these basic info in Chinese and share in wechat group, so that others could understand basic working flow.
07:23:34 <ianychoi> So for dashboard translation, the best period would be from around Soft StringFreeze to one week / a few days before Hard StringFreeze
07:24:09 <ianychoi> Thanks a lot :) If it is fine, please share via any blog (in Chinese should be fine) and share a link with I18n team :)
07:24:13 <plutoinmii> does it matter is translation falls into after Hard StringFreeze?
07:24:54 <ianychoi> Around Hard StringFreeze, project teams package software as a package (e.g., v12.0.0)
07:25:41 <plutoinmii> so translations will be packed in the package as well, and it would be not possible to change it afterwards?
07:25:45 <ianychoi> If translation lands after such package release, then I need to ask to project teams: e.g., please create a new branch (e.g., v12.0.1) including up to date translation
07:25:55 <plutoinmii> got it..
07:25:56 <plutoinmii> w
07:26:45 <ianychoi> Ideally projects can handle but in reality, for example, the branch sources will be shared with Red Hat, Canonical, and so on.
07:27:02 <ianychoi> The vendor's update will be slower
07:27:28 <ianychoi> (Not ideal explanation.. but I think it would be easy to understand to you, hopefully)
07:28:14 <plutoinmii> it does.
07:28:19 <ianychoi> And.. for releasenotes, since versions are just increased, we only translate in master branch
07:28:30 <ianychoi> So anytime you can translate releasenotes
07:28:59 <ianychoi> But.. projects which have >=75% translations run sync jobs between Zanata and project repos
07:29:35 <plutoinmii> okay
07:30:15 <ianychoi> And I need to sync with Foundation but I will share when user-survey needs to be translated :)
07:30:28 <ianychoi> #action ianychoi will ask Foundation for user-survey translation
07:31:14 <ianychoi> How many members are in Chinese wechat group?
07:34:14 <plutoinmii> 94
07:34:42 <plutoinmii> but not many of them are responding.
07:35:03 <ianychoi> Aha I see
07:35:31 <plutoinmii> i am seeing any chance if a solid plan or detailed task was set up so as to communicate in the group.
07:35:53 <plutoinmii> I feel they are not responding because they don't know how to start with, like me.
07:36:10 <plutoinmii> if more guidance or info could be shared, it might be helpful.
07:36:51 <ianychoi> Aha... thanks a lot - if it is possible, would you see https://docs.openstack.org/i18n/latest/zh_CN/index.html and share your feedback?
07:37:11 <ianychoi> For example, which is useful / not useful, which things need to be more described, and so on
07:37:38 <plutoinmii> this is good. I involved in part of the translation to this guide, I think.
07:37:54 <plutoinmii> I will take a look and share feedback.
07:38:23 <plutoinmii> should I create an "action" as well? :-)
07:40:04 <ianychoi> Not should but it would be so nice :)
07:40:52 <plutoinmii> #action plutoinmii share feedback after reviewing zh_CN translation guide
07:42:19 <ianychoi> Thank you :)
07:42:55 <plutoinmii> no problem.
07:43:30 <ianychoi> And for official team -> working group, do you have any question?
07:44:27 <plutoinmii> what would be the difference between current team and working group.
07:45:24 <ianychoi> #link https://docs.openstack.org/contributors/common/governance.html
07:45:44 <ianychoi> I think this link explain better than my previous explanation through e-mail
07:46:35 <plutoinmii> WG = SIG?
07:46:39 <ianychoi> yep
07:47:01 <plutoinmii> SIG will not get space on PTG?
07:47:53 <ianychoi> Some active SIGs can get a space - I am not sure the detail logistics but we can say that "Every official projects should get space, and SIGs might have space"
07:48:50 <ianychoi> Honestly, there might have little difference on detail activities I believe.
07:49:07 <plutoinmii> yes, noticed there is a list of activity guarantees as a project team instead of working group.
07:49:17 <ianychoi> But, we might have weaker relationship with Technical Committee
07:49:31 <plutoinmii> i am okay with it and have no question to operate as a working group.
07:50:19 <ianychoi> And.. my worry is related with some change on a statement "Translation >=300 words would get ATC"
07:50:28 <ianychoi> This might be removed
07:51:29 <ianychoi> And.. one more imagination might be there might have no PTL election activities :(
07:51:48 <plutoinmii> right...these are all projects team guaranteed.
07:52:10 <plutoinmii> how many translators in total around i18n team?
07:52:13 <plutoinmii> globally.
07:53:20 <ianychoi> I don't have up-to-date statistics but https://docs.openstack.org/i18n/latest/atc-stats.html#train-cycle might be helpful :)
07:54:34 <plutoinmii> this is helpful. I see more zh_CN translators than I've thought.
07:54:35 <plutoinmii> w
07:55:49 <ianychoi> :)
07:56:12 <ianychoi> But as you see, translation ratio is getting decreased unfortunately
07:57:53 <ianychoi> plutoinmii, it is really great to see you!
07:58:15 <plutoinmii> same here! ianychoi
07:58:46 <plutoinmii> thanks for sharing these guidance and info with me, it is a good start for me.
07:58:56 <ianychoi> I18n team has IRC meetings weekly but alternating time - next week it will start from midnight (your timezone) but two weeks later it will start the same as today
07:59:12 <plutoinmii> okay.
07:59:23 <plutoinmii> i will see which timeslot best works for me.
07:59:34 <ianychoi> plutoinmii, by the way, I am not sure but would it be fine if I nominate you as a language coordinator in Chinese team in Zanata?
07:59:54 <plutoinmii> yes, that is for sure.
08:00:00 <ianychoi> (Or already language coordinator? not sure)
08:00:27 <plutoinmii> vuuv asked if I could become the coordinator as he recently got working position change.
08:00:35 <ianychoi> Thanks a lot for today meeting! I would like to close this meeting if there are not no more issues
08:00:39 <ianychoi> Aha.. vuuv.. I see
08:00:44 <plutoinmii> i said yes, but not sure how to operate it or announce it.
08:00:48 <ianychoi> I thought you were mentioning zzxwill
08:01:00 <plutoinmii> but would like to help on coordinating the translation effort.
08:01:25 <ianychoi> Yep fine - a existing coordinator asks to you and you share your willingness here :)
08:01:48 <ianychoi> I will share also via I18n mailing list - would it be okay?
08:03:02 <ianychoi> (closing for future possible meetings)
08:03:04 <ianychoi> #endmeeting