13:30:09 <ianychoi[m]> #startmeeting openstack_i18n_meeting
13:30:09 <opendevmeet> Meeting started Wed Jan 17 13:30:09 2024 UTC and is due to finish in 60 minutes.  The chair is ianychoi[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:30:09 <opendevmeet> The meeting name has been set to 'openstack_i18n_meeting'
13:30:24 <ianychoi[m]> #topic Greetings
13:30:46 <ianychoi[m]> LoL I18n meeting has come back!!
13:30:55 <seongsoocho> Yay~~!!
13:31:08 <seongsoocho> Thanks for hosting this meeting ianychoi[m]
13:31:23 <ianychoi[m]> Thank you seongsoocho to help recover the cadence!
13:32:29 <ianychoi[m]> Not too much sure how many would come for the first meeting in 2024 - let's wait for about a few minutes
13:32:39 <seongsoocho> okay
13:33:10 <ianychoi[m]> I think seongsoocho can have also authority to lead as a co-meeting chair.
13:33:49 <seongsoocho> Hi Kuenjong and nayeon
13:33:56 <ianychoi[m]> Previous history can be found via https://wiki.openstack.org/wiki/Meetings/I18nTeamMeeting and some directory names containing i18n on https://meetings.opendev.org/meetings/
13:34:00 <ianychoi[m]> or translation
13:34:30 <ianychoi[m]> Long time ago before I joined in I18n team, the meeting name was called as translation team meeting AFAIK
13:34:41 <nayeonkim> Hello!
13:35:06 <ianychoi[m]> Around June 2015, translation team has an official name called "Internationalization" team
13:35:08 <ianychoi[m]> Hi nayeonkim
13:35:19 <seongsoocho> nayeonkim: Hi o/
13:36:08 <ianychoi[m]> And.. in 2018, the previous PTL and me had an experiment to change I18n meeting as official hour format
13:36:53 <ianychoi[m]> Finally so glad to restart I18n meeting cadence with colleagues! Thank you all again
13:37:44 <seongsoocho> Let's start i18n again!
13:38:17 <ianychoi[m]> Note that there are two different time zone meetings - this meeting slot will come back in 2 weeks.
13:38:58 <ianychoi[m]> Next week, another meeting time slot which is America + Asia time zone friendly will start
13:39:56 <seongsoocho> wednesday 1330 and 2315
13:40:01 <seongsoocho> utc
13:40:16 <ianychoi[m]> For this time zone, it might be too early for rosmaita and too late for tonyb - hopefully we can see on the next week
13:40:26 <ianychoi[m]> Thank you seongsoocho to share the exact time slot!
13:41:04 <rosmaita> this time is OK for me, I am just running late today
13:41:05 <ianychoi[m]> (Meanwhile, thinking which topic would be great to be discussed first)
13:41:17 <ianychoi[m]> Oh hi rosmaita !!
13:41:25 <rosmaita> hello!
13:42:45 <ianychoi[m]> Thank you for joining today meeting :)
13:42:59 <rosmaita> happy to be here (sorry I'm late, though)
13:43:20 <ianychoi[m]> No worries so glad to see you :)
13:43:41 <seongsoocho> I have a 2 topic for today's meeting.
13:44:17 <ianychoi[m]> seongsoocho: would you share the 2 topics?
13:44:20 <ianychoi[m]> Great!
13:44:37 <seongsoocho> #topic weblate tool
13:45:32 <seongsoocho> I reviewed a patch from last year' contribution mentoring program
13:45:43 <seongsoocho> and merged 2 patches
13:46:07 <rosmaita> \o/
13:46:10 <seongsoocho> #link https://review.opendev.org/c/openstack/i18n/+/893361
13:46:30 <nayeonkim> 👏🏻👏🏻
13:46:39 <seongsoocho> #link https://review.opendev.org/c/openstack/i18n/+/895763
13:47:03 <seongsoocho> thanks nayeon and guemjong
13:47:27 <seongsoocho> and this patch need more review.
13:47:32 <ianychoi[m]> Congratulation nayeonkim and Kuemjong_Jeong
13:47:35 <seongsoocho> I will review this patch asap
13:47:43 <seongsoocho> #link https://review.opendev.org/c/openstack/i18n/+/896306
13:48:19 <Kuemjong_Jeong> 🙌
13:48:36 <ianychoi[m]> For that patch, we might need to investigate how "approved" field is working in Weblate
13:49:08 <nayeonkim> Thanks Seongsoo, Ian and  Akihiro for taking time to review :)
13:49:36 <seongsoocho> after merge all patches for tools, the next step is support stackanalytics metrics based on weblate
13:49:42 <ianychoi[m]> Zanata and Transifex (old translation platform) categories roles as translators and reviewers. If Weblate does not support reviewers role, I am okay not to consider such role.
13:50:18 <seongsoocho> yes.
13:50:27 <ianychoi[m]> nayeonkim: Without your passion and contribution, the patch wouldn't be started thank you again!!
13:51:47 <ianychoi[m]> #info 2 patches have been merged and 1 patch is waiting with reviewers role clarification on openstack/i18n repo
13:51:59 <seongsoocho> so, I want to ask to nayeon and geumjong to contribute for  more weblate tools.
13:52:33 <ianychoi[m]> #action seongsoocho and ianychoi will help clarify reviewers role for https://review.opendev.org/c/openstack/i18n/+/896306 patch
13:52:39 <seongsoocho> I will list up first, what kinds of tools we need .
13:52:52 <Kuemjong_Jeong> Yes, but I would like to proceed with additional work after this change is merged first.
13:52:53 <Kuemjong_Jeong> https://review.opendev.org/c/openstack/i18n/+/896306
13:53:03 <seongsoocho> ok
13:53:50 <ianychoi[m]> #action Kuemjong_Jeong will work more on https://review.opendev.org/c/openstack/i18n/+/896306 patch
13:54:05 <seongsoocho> next topic
13:54:23 <nayeonkim> I think the role definition and how it should be migrated to Weblate needs to be documented and shared within this weekly/bi-weekly meetings. Maybe it can be merged after the clear definition of roadmap for that agenda? I will help Kuemjong as fast as I can.
13:54:28 <ianychoi[m]> How about nayeonkim? Would you help contribute for more weblate tools as seongsoocho mentioned? If then, which tools you are interested now?
13:55:50 <nayeonkim> @ian, as I mentioned I will work on the patch that we mentioned in #1 agenda. Maybe can work on parallel for the new weblate tools.
13:55:53 <ianychoi[m]> Agree then may be an additional separated meeting would be helpful?
13:56:43 <ianychoi[m]> Cool
13:56:55 <seongsoocho> 👍
13:56:59 <ianychoi[m]> #action nayeonkim will also help the patch
13:57:27 <ianychoi[m]> For detailed clarification, since the meeting is short, let's move the next topic first
13:57:36 <seongsoocho> okay
13:57:44 <ianychoi[m]> I also need to spend 5 minutes for today meeting once seongsoocho shares the next topic
13:57:59 <seongsoocho> #topic Migrate to weblate
13:58:42 <seongsoocho> I started making zuul job for weblate. the first step is add a weblate credential in project-config
13:58:52 <seongsoocho> https://review.opendev.org/c/openstack/project-config/+/905701
13:59:03 <seongsoocho> #link https://review.opendev.org/c/openstack/project-config/+/905701
13:59:37 <ianychoi[m]> seongsoocho: great!!
13:59:41 <nayeonkim> 👍🏻👍🏻
14:00:06 <seongsoocho> for now, the credential is mine, but I will ask an infra user account for openstack account and replace the credential to infra user's
14:00:47 <seongsoocho> I can't add user without openinfra account in weblate for now..:-(
14:01:47 <seongsoocho> This is very beginning of automation to support translation for weblate.
14:01:52 <ianychoi[m]> For admin role grant, seongsoocho can do it, right?
14:01:57 <seongsoocho> Yes
14:02:31 <seongsoocho> Currently, weblate can only register openinfra accounts, so it is not possible to add arbitrary accounts.
14:02:49 <ianychoi[m]> On translate.openstack.org, infra username is registered with zanata@openstack.org e-mail address.
14:03:56 <seongsoocho> I need to check if there an account for that email in openinfra account system.
14:04:05 <ianychoi[m]> I believe it might need some help for infra team, while I also would like to see how seongsoocho plans all steps for migration
14:05:14 <ianychoi[m]> Anyway I believe it can be achieveable.
14:05:22 <seongsoocho> ( I'm on my way to go home, so I will update it later.
14:05:36 <ianychoi[m]> Sure
14:05:53 <ianychoi[m]> #action seongsoocho will update migration plans & steps
14:06:06 <seongsoocho> That's all from my side.
14:06:44 <ianychoi[m]> Thank you just now I think that seongsoocho: would you share this to #opendev IRC channel?
14:07:15 <seongsoocho> okay
14:07:17 <ianychoi[m]> Infra meeting happened about 19 hours ago so it would be faster now
14:08:06 <ianychoi[m]> Or rosmaita would have idea hopefully or can help who we can reach :)
14:09:01 <ianychoi[m]> #topic Some sharing for translation before the next release
14:09:22 <rosmaita> i think tony breeds (tonyb) in your time zone, probably jeremy stanley (fungi) right now
14:09:42 <ianychoi[m]> Thank you rosmaita !
14:10:13 <seongsoocho> I left a message at #opendev
14:10:17 <ianychoi[m]> According to Caracal release schedule, Soft StringFreeze starts around the final week of Feb
14:10:39 <ianychoi[m]> Ideally it would be best if translators can test Weblate during the Soft StringFreeze period
14:11:20 <ianychoi[m]> So let's review & figure out the plan whether ^ is possible or not
14:11:25 <fungi> yeah, i can help with some stuff, though the rest of my week is pretty full already with paperwork and prep for tomorrow's openinfra.live episode
14:11:56 <ianychoi[m]> Thank you so much fungi for the comment!!
14:12:54 <ianychoi[m]> And I need to calculate statistics for next Extra AC collection.. and think to choose 1-2 project candidates with many translation ratio
14:13:09 <ianychoi[m]> #topic open discussions
14:13:16 <ianychoi[m]> That's all for my sharing :)
14:13:57 <ianychoi[m]> Any final comments from today participants?
14:14:48 <ianychoi[m]> If no, let me close today meeting. Thank you so much seongsoocho nayeonkim Kuemjong_Jeong and rosmaita today!!
14:15:09 <nayeonkim> Thank you! 😄
14:15:10 <rosmaita> thanks, ianychoi[m] ! have a good remainder of your day
14:15:11 <seongsoocho> \o/
14:15:18 <Kuemjong_Jeong> thank you for everyone!
14:15:21 <ianychoi[m]> #endmeeting