15:59:49 <jasondotstar> #startmeeting openstack-salt
15:59:50 <openstack> Meeting started Tue Jan 26 15:59:49 2016 UTC and is due to finish in 60 minutes. The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:54 <openstack> The meeting name has been set to 'openstack_salt'
15:59:57 <jasondotstar> #topic roll call
16:00:06 <jasondotstar> o/
16:00:17 <evolucion> o/
16:00:26 <jpavlik> o/
16:00:57 <cznewt> o/
16:01:02 <maxstack> o/
16:01:21 <kukacz> o/
16:01:40 <jasondotstar> #topic Introduction
16:02:06 <jasondotstar> this is our first meeting for the 'official' openstack salt team
16:02:15 <evolucion> woohoo!
16:02:21 <jasondotstar> \o/
16:02:32 <jasondotstar> for everyone in attendance, if you're interested in contributing to the discussion, please join #openstack-salt
16:02:50 <jasondotstar> meetings will be here on Tuesdays weekly
16:03:00 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:03:00 <gerhardq1x> o/
16:03:06 <jasondotstar> welcome gerhardq1x
16:03:21 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:03:29 <jasondotstar> for meeting agenda, notes, etc.
16:04:05 <jasondotstar> let me also say here that it's awesome that we've got folks ready to roll with this
16:04:13 <jasondotstar> good to know. :-)
16:04:18 <evolucion> +1
16:04:22 <jasondotstar> anything from anyone else?
16:04:27 <evolucion> thanks for organizing!
16:04:38 <evolucion> excited to get some traction
16:04:48 <gerhardq1x> yes, good initiative
16:04:52 <cznewt> yes, this is great to start officialy under Openstack
16:05:17 <jasondotstar> great minds think alike :-)
16:05:26 <jasondotstar> let's get to it, shall we?
16:05:35 <jpavlik> yes
16:05:35 <cznewt> yes
16:05:37 <evolucion> please
16:05:38 <gerhardq1x> yes
16:05:40 <genunix> yeees
16:05:43 <kukacz> sure
16:05:45 <jasondotstar> #topic items
16:05:46 <bujoon> yes
16:05:53 <cznewt> so the agenda for today is at https://etherpad.openstack.org/p/openstack-salt-weekly-meeting-20160126
16:06:18 <jasondotstar> so, i started the meeting, the channel, and the git project
16:06:37 <jpavlik> maybe I would like to explain this two fractions
16:06:38 <jasondotstar> b/c at the time I was unaware that there was as much going on around creating salt formulas for OpenStack
16:06:46 <jasondotstar> jpavlik: sure.
16:07:16 <jpavlik> there was created two official openstack salt initiatives and we did not know each other.
16:07:20 <jasondotstar> after starting the channel, and the meeting...folks began to trickle into the channel and pledge there interest.
16:07:30 <jasondotstar> one sec jpavlik
16:07:40 <jpavlik> ok
16:07:58 <jasondotstar> as jpavlik said.... 2 openstack salt initiatives have been created, each unaware of the other
16:08:08 <jasondotstar> but I think we have an opportunity to collaborate
16:08:31 <jasondotstar> with that, let's hear from jpavlik who can tell us where things are with the effort they've had going
16:08:37 <jasondotstar> jpavlik: ok.... go for it :-)
16:08:45 <jpavlik> sure. thanks :) ...
16:08:56 <jasondotstar> np.
16:09:42 <jpavlik> so we have worked on salt formulas for more than 3 years and we actually put this approach for at least 10 companies in production. At last summit we decided to get it official and worked on cleanup and standards, CI, etc.
16:10:10 <jpavlik> now we would like to proceed this as https://review.openstack.org/#/c/272469/ first stuff.
16:10:18 <jpavlik> and discuss how we can colaborate
16:10:28 <jpavlik> to get there hybrid environmets
16:10:38 <jpavlik> like redhat and single node deployments devstack, etc.
16:11:12 <jpavlik> I bring some other guys from community like evolucion bujoon kukacz maxstack
16:11:23 <jpavlik> who actualy uses this framework in production
16:11:31 <evolucion> I'm a user/contributor to the tcpcloud salt-formulas. I'm running these in production enterprise
16:12:04 <jpavlik> we would like to bring jasondotstar and other your friends to this platform and extended to your approach
16:12:40 <evolucion> sounds good. I get behind that
16:12:40 <jpavlik> cznewt: is Ales Komarek leader of tehcnology salt and father of the idea
16:12:46 <jasondotstar> +1
16:12:57 <cznewt> to add to this, the effort to go under openstack big tent started some months ago, a lot of work was done on integrating salt testing
16:13:35 <cznewt> so now we are ready to move forward set the current status, priories for next development
16:13:44 <jpavlik> jasondotstar: is there anybody from your side too?
16:14:00 <evolucion> I would love to see it under one effort/direction
16:14:03 <jasondotstar> jpavlik: no. lone wolf.
16:14:11 <jasondotstar> since you guys have a lot of traction already
16:14:24 <jasondotstar> i think it's best that we combine the effort
16:14:28 <jpavlik> I would like to discuss strategy and then organize technical hangout between jasondotstar and cznewt
16:14:30 <evolucion> yeah
16:14:36 <jasondotstar> all of the git repos
16:14:44 <evolucion> agree. Lets get it under one roof and move forward
16:14:44 <jasondotstar> that are mentioned in the review
16:14:45 <bujoon> hi, we as a telco provider we are in process of salt formulas implementation with tcp cloud
16:14:51 <jasondotstar> we should just go with that
16:15:02 <jasondotstar> if you guys dont mind having me on board
16:15:03 <kukacz> and to disclose myself - I'm here for a corp building openstack cloud offering based on tcpcloud salt formulas, soon into the production
16:15:07 <cznewt> yes, get synchronised, combine what we have and head the same way
16:15:23 <jasondotstar> to help with the code (of course), meetings, and etc.
16:15:30 <cznewt> yes
16:15:32 <jasondotstar> I'm willing to help in that regard.
16:15:47 <evolucion> Me too
16:15:57 <jasondotstar> you guys have a lot of work done already. makes no sense for me to try and start again from ground zero.
16:16:22 <evolucion> okay so we've agreed on that
16:16:25 <jpavlik> jasondotstar: great!
16:16:27 <evolucion> what are the next steps here
16:16:34 <cznewt> super, we need to get the revew accepted and get the repositories in openstack namespace
16:16:35 <evolucion> divide and conquer
16:16:39 <jasondotstar> #agreed makes sense to combine the dual efforts
16:16:47 <genunix> can we first talk about what we have and then proceed to next steps?
16:16:54 <jasondotstar> cznewt: +1
16:16:55 <evolucion> sure
16:16:59 <jasondotstar> sure
16:17:47 <jpavlik> jasondotstar: can you put comment on https://review.openstack.org/#/c/272469/ that we agreed? and then we would like to start with first wave of formulas. Maybe Ales can explain better cznewt
16:18:37 <jasondotstar> jpavlik: +1
16:19:09 <jasondotstar> let's continue
16:19:33 <genunix> We have created project base at launchpad here: https://launchpad.net/openstack-salt with wiki home (https://wiki.openstack.org/wiki/OpenStackSalt). Formulas are currently living in https://github.com/tcpcloud git repos.
16:19:34 <jasondotstar> ok can you talk about that first bullet item? Formulas sources available
16:19:37 <jasondotstar> there we go.
16:19:48 <cznewt> ok
16:20:32 <cznewt> the github/tcpcloud is now the general source of repos, as genunix said it is already available at launchpad as packages
16:20:51 <genunix> We build debian packages from all formulas in our CI (but this should be also done in Openstack one), they are living here if someone is interested: https://launchpad.net/~tcpcloud/+archive/ubuntu/salt-formulas
16:21:18 <jasondotstar> how environment specific are these packages
16:21:20 <cznewt> the formulas are primarily targetted to install ha openstack (juno/kilo/liberty)
16:21:37 <jasondotstar> ack.
16:21:44 <cznewt> jamespage: environment = os?
16:21:57 <genunix> and we just finished unified way of testing for all openstack formulas (https://github.com/tcpcloud/salt-formula-linux/tree/master/tests)
16:22:12 <jasondotstar> well, jpavlik mentioned that some of the work was specific to customer build outs
16:22:42 <jasondotstar> im working if there is an opportunity to generalize the formulas, making them less customer centric
16:22:43 <cznewt> it is just backends for cinder
16:22:53 <jasondotstar> s/working/wondering
16:23:02 <jpavlik> jasondotstar: yes, thats excactly what is interesting for me
16:23:18 <cznewt> yes, the idea is to have the system modular as possible, covering all possible scenarios
16:23:28 <jasondotstar> +1
16:23:39 <jasondotstar> I'd have to take a deeper dive into what's there
16:23:51 <cznewt> yes there's a documentation ready
16:23:52 <jasondotstar> but I agree on that.
16:24:05 <cznewt> https://github.com/tcpcloud/openstack-salt
16:24:39 <jasondotstar> cool.
16:24:41 <cznewt> you can build it locally for now, it covers a lot of topics
16:24:51 <jasondotstar> that was going to be my next qn
16:24:55 <jasondotstar> local dev environment
16:25:01 <jasondotstar> cool, I'll have to try that out.
16:25:20 <cznewt> you want to know, about the services composition, metadata, and the deployment
16:25:51 <jasondotstar> so, what has been the development approach? one openstack module at a time? how'd you decide which one(s) to start with?
16:26:18 <genunix> jasondotstar: ad. dev environment, there are heat templates which deploy Salt master + Openstack cluster using these formulas (https://github.com/tcpcloud/heat-templates). Which is basically what we mostly use for development and testing.
16:26:25 <cznewt> I'll polish the chapters about vagrant installation :) this is what you prefer for local dev?
16:26:46 <jasondotstar> yes
16:26:48 <jasondotstar> vagrant.
16:27:21 <cznewt> Ok, i'll fix the chapter
16:27:48 <cznewt> the approach of adpoting one service at a time, how flexible is openstack ci for that?
16:27:56 <jasondotstar> #action cznewt to finish out the chapter on local dev environment (i.e vagrant)
16:29:15 <cznewt> to add all formulas at a time [core ones] and then the support ones, or all of these at once to serve as an inspiration for further contributors
16:29:51 <cznewt> i'd like to summarise our goal in a manifesto: https://etherpad.openstack.org/p/openstack-salt-manifesto
16:30:09 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-salt-manifesto
16:30:37 <cznewt> jasondotstar: can we go through this and agree upon this till next meeting
16:30:46 <cznewt> to all of us
16:30:49 <jasondotstar> cznewt: sure
16:31:45 <jasondotstar> #topic OpenStack Salt Manifesto
16:32:03 <jasondotstar> so this is sort of a lead up to creating specs, yes?
16:32:13 <cznewt> yes
16:32:19 <jasondotstar> cool.
16:32:52 <cznewt> this the main motivation and response to the openstack/salt integration, while keeping the solution as general as possible
16:33:00 <jasondotstar> +1
16:33:39 <jasondotstar> we all agree on the problem statements mentioned in the manifesto, yes?
16:33:47 <genunix> yes
16:34:09 <Tux__> sure
16:34:24 <gerhardq1x> agreed
16:34:49 <jasondotstar> #agreed problem statements in the manifesto are satisfactory
16:35:18 <cznewt> I'd start with getting the core and support formulas under openstack [these are the essential to install whole system]
16:35:35 <jasondotstar> +1
16:35:43 <jasondotstar> how about this statement:
16:35:44 <jasondotstar> This project will be an all batteries included project. Which means anyone can expect that deploying should end up with an OpenStack cloud built for production which will be available after the successful completion of the deployment process.
16:36:01 <jasondotstar> should we spell out which components
16:36:08 <jasondotstar> aka core?
16:36:40 <cznewt> this means you get production ready cloud is the main point here, not just development version
16:37:22 <cznewt> components: keystone, glance, horizon, nova, neutron, heat, ceilometer, cinder, Linux, OpenSSH, Salt, NTP, MySQL, RabbitMQ, Memcached, Mongodb
16:37:57 <jasondotstar> cznewt: understood. i think that spelling out the components prevents confusion
16:38:10 <cznewt> these are the core openstack and infrastructure services needed
16:38:12 <jasondotstar> there shouldn't be any, but just in case ppl think that you're going to get monasca
16:39:23 <gerhardq1x> HA?
16:39:54 <cznewt> Meaning does this support High Availability?
16:40:01 <jasondotstar> high availability
16:40:12 <gerhardq1x> yes, in the statement?
16:40:37 <gerhardq1x> do we intent to include it
16:40:43 <cznewt> yes the main deployment is in HA mode
16:41:02 <cznewt> all control services on multiple nodes in active-active mode
16:41:32 <kukacz> +1 for HA
16:41:51 <cznewt> services can be split to multiple nodes one by one to provide even mode scalability options.
16:42:09 <jasondotstar> #agreed the team should focus on getting the openstack salt formulas for the core components, then focus on the supporting modules
16:42:20 <jasondotstar> +1 re: AH
16:42:25 <jasondotstar> +1 re: HA*
16:42:45 <cznewt> the usual case is to split ceilometer with mongodb aside from the rest of the control plane
16:43:11 <jasondotstar> ok couple other topics
16:43:22 <jasondotstar> we've got about 15 min left here
16:43:33 <cznewt> #link https://github.com/tcpcloud/openstack-salt/blob/master/doc/source/install/figures/server_topology.jpg
16:43:59 <jasondotstar> #topic official repos for OpenStack salt
16:44:15 <jasondotstar> core, support, and monitor
16:44:27 <cznewt> #link https://github.com/tcpcloud/openstack-salt/blob/master/doc/source/install/figures/openstack_system.png this one is better
16:44:36 <jasondotstar> core => keystone, glance, horizon, nova, neutron, heat, ceilometer, cinder
16:44:56 <jasondotstar> support => Linux, OpenSSH, Salt, NTP, MySQL, RabbitMQ, Memcached, Mongodb
16:45:14 <cznewt> get the core ready till the next week
16:45:15 <jasondotstar> monitor => Collectd, Sensu, Graphite, Heka, ElasticSearch
16:45:32 <jasondotstar> how ready is the core set of formulas?
16:46:06 <cznewt> it is ready for juno/kilo/libery on ubuntu, for rhel it needs some polishing
16:46:14 <jasondotstar> ack.
16:46:24 <jasondotstar> and you're targeting next week to be completely rdy?
16:46:53 <cznewt> i think from the functional point of view it's ok, we have just finished the automated test
16:47:31 <cznewt> it's ready already. we need to cover the supported backends
16:47:55 <jasondotstar> +1
16:48:45 <cznewt> the only think that needs to be fixed is support for vanilla neutron setup
16:49:16 <cznewt> this is something that needs to be available for dev single node setup
16:49:16 <jasondotstar> cznewt: want to take an action item to report on the status next week?
16:50:02 <cznewt> yes
16:50:29 <jasondotstar> #action cznewt to report on the completion of the core set of salt formulas
16:50:52 <jasondotstar> #topic salt platform agnostic approach
16:51:10 <jasondotstar> so when jpavlik and i were talking in chan
16:51:23 <cznewt> and i'll walk you through the local dev setup before the next meeting
16:51:39 <jasondotstar> cznewt: sounds good. +1
16:52:16 <cznewt> the ubuntu/cloudarchive is ready, the rhel/rdo needs cleaning up
16:52:26 <jasondotstar> we wanted to make sure that there is a clear distinction between formulas that can adapt to platform
16:52:41 <jasondotstar> are these all part of the same codebase
16:52:48 <jasondotstar> or are we talking two different ones?
16:53:07 <cznewt> everything is part of same codebase
16:53:11 <jasondotstar> cool.
16:53:16 <jasondotstar> sounds like that's covered as well.
16:53:31 <cznewt> it just needs testing and 'polishing'
16:53:39 <jasondotstar> yes, I'll have to take a look at what you've got. sounds very comprehensive
16:53:43 <cznewt> the RDO
16:53:45 <jasondotstar> cool
16:54:01 <cznewt> we worked with that havana/icehouse
16:54:10 <jasondotstar> ok
16:54:20 <cznewt> and it's outdated
16:54:33 <jasondotstar> so the rhel work needs to come up to speed
16:54:37 <cznewt> the only thing that needs our attention is vanilla neutron
16:54:41 <cznewt> yes
16:54:49 <jasondotstar> gotcha.
16:55:00 <jasondotstar> last couple items here
16:55:18 <jasondotstar> #topic integration testing and metadata sources
16:55:18 <cznewt> and we should provide way for other network/storage solutions to integrate into this
16:55:45 <jasondotstar> cznewt: +1. that plays into the agnostic approach
16:55:46 <cznewt> all formulas include basic set of tests
16:56:25 <jasondotstar> is the testing automated through the CI
16:56:26 <cznewt> which can be run upon code changes to check whether they work
16:56:35 <jasondotstar> gating, etc. ?
16:57:00 <cznewt> no, at our ci, just test results
16:57:41 <cznewt> i mean it just runs, no gating, sorry :)
16:57:48 <jasondotstar> so perhaps we need to look into gating
16:58:22 <cznewt> yes
16:58:26 <jasondotstar> and what's needed there
16:58:32 <jasondotstar> ok
16:58:38 <jasondotstar> 2 mins left
16:58:44 <jasondotstar> #topic open discussion
16:59:00 <jasondotstar> so sounds like there's been a TON of work completed
16:59:34 <jasondotstar> interesting that I was unaware
16:59:48 <jasondotstar> so I'm glad we found each other to talk through what's been in the works
17:00:05 <jasondotstar> anything else?
17:00:17 <jasondotstar> of not we can close
17:00:18 <cznewt> yes, I'm glad to be part of this effort :)
17:00:24 <jasondotstar> cznewt: +1
17:00:28 <gerhardq1x> yes, I'm very excited
17:00:36 <cznewt> we will show the puppeteers :D
17:00:44 <jasondotstar> thanks all. until next week. otherwise let's chan in channel. :-)
17:00:47 <cznewt> how its' donw
17:00:47 <jasondotstar> cznewt: lol
17:00:50 <cznewt> yes
17:00:52 <jasondotstar> #endmeeting