16:02:12 <jasondotstar> #startmeeting openstack_salt
16:02:13 <openstack> Meeting started Tue Feb  9 16:02:12 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:16 <openstack> The meeting name has been set to 'openstack_salt'
16:02:23 <jasondotstar> #topic roll call
16:02:26 <jasondotstar> o/
16:02:29 <cznewt> o/
16:03:00 <jasondotstar> hi cznewt
16:03:18 <cznewt> hello jasondotstar
16:03:26 <jasondotstar> #topic Introduction
16:03:48 <jasondotstar> this is the meeting for the openstack-salt team
16:03:56 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
16:04:09 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:04:12 <genunix> o/
16:04:22 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:04:27 <cznewt> hello geneneric unix unit
16:04:33 <jasondotstar> hi genunix
16:04:38 <genunix> :-) Hello
16:04:46 <jasondotstar> #topic Review past action items
16:05:11 <jasondotstar> genunix to research how to openstack packaging works
16:05:18 <jasondotstar> any status?
16:07:02 <genunix> jasondotstar: not much. I have read some docs but didn't find much useful things, it's not much unified.
16:07:15 <jasondotstar> very well, we're carry it over
16:07:23 <genunix> So current conclusion is - try to contact some openstack package maintainer
16:07:34 <genunix> and ask about how to get our formulas to Debian
16:07:50 <jasondotstar> #action genunix to continue openstack packaging research
16:08:06 <jasondotstar> next: jasondotstar to look at the integration of launchpad with our repos
16:08:23 <jasondotstar> not much movement here either. I'll need to move this one fwd :-(
16:08:37 <cznewt> yes integration with launchpad bugs is iportant to set
16:08:49 <cznewt> so we can keep track of upcoming development
16:09:04 <jasondotstar> #action jasondotstar to look at the integration of launchpad with our repos (bug triage, tracking, etc.) *important*
16:09:05 <cznewt> as there are already some areas to tackle [vanilla neutron]
16:09:14 <cznewt> +1
16:09:17 <jasondotstar> +1
16:09:35 <jasondotstar> ok next one:
16:09:46 <jasondotstar> jasondotstar to look into dev environment sponsorship
16:09:54 <jasondotstar> so we were just talking about this
16:09:57 <jasondotstar> from my understanding
16:10:08 <jasondotstar> this request is to have a cloud-based dev environment
16:10:26 <jasondotstar> for functionally testing the services that our salt formulas will deploy
16:10:27 <cznewt> yes, the heat-based both single / cluster deployments
16:10:42 <jasondotstar> +1
16:10:45 <cznewt> of openstack control clusters + few computes to test
16:10:53 <jasondotstar> this is beyond the local dev environment
16:11:01 <jasondotstar> i posed a question to the -infra team
16:11:07 <jasondotstar> and they made a couple suggestions
16:11:11 <jasondotstar> 1- use trystack
16:11:32 <jasondotstar> the only problem with trystack is the resources terminate after 24 hours
16:12:17 <cznewt> We can setup more permament labs at tcpcloud
16:12:21 <jasondotstar> i don't know if we can rely on an environment like that in sustenance
16:12:32 <jasondotstar> +1
16:12:38 <cznewt> it's possible to run up to 10 labs at once
16:12:51 <jasondotstar> the other option is to use an employer based environment
16:13:03 <jasondotstar> so yes, we may have to rely on tcpcloud
16:13:22 <jasondotstar> the other thing we need to eventually thing about is gating
16:13:30 <cznewt> there can be more lab environments to test
16:13:34 <jasondotstar> beyond linting
16:14:20 <jasondotstar> example: puppet uses the beaker gate, to functionally test the service deployed with puppet by launching a couple VMs (one debian based, one rpm based)
16:14:22 <cznewt> yes I'd like that as well
16:14:24 <jasondotstar> to ensure the service works
16:14:45 <cznewt> yes exactly system testing is missing in out setup now
16:14:52 <cznewt> to automate this is +2 for me
16:14:55 <jasondotstar> right
16:15:19 <jasondotstar> #agreed functional testing like beaker is required to achieve gating beyond linting
16:15:32 <cznewt> I can look at beaker gates and how to get it into salt world
16:16:11 <jasondotstar> #action cznewt to look at beaker gates and how to fold into the salt workflow
16:16:45 <jasondotstar> #action cznewt to look at beaker gates and how to fold a similar process into the salt workflow
16:17:02 <jasondotstar> any other thoughts on this
16:17:03 <jasondotstar> ?
16:17:17 <cznewt> not to this topis
16:17:19 <jasondotstar> ok
16:17:21 <cznewt> *topic
16:17:23 <cznewt> another issue is the documentation, it is not
16:17:47 <cznewt> building for some time, but we are working on fixing it
16:18:01 <cznewt> as it moved to the openstack namespace
16:18:30 <cznewt> question off topic: if you abandon change in gerrit, can you revert this?
16:19:05 <clarkb> yes
16:19:07 <jasondotstar> yes
16:19:23 <cznewt> I have much to learn :)
16:20:19 <jasondotstar> newt test the aio/ha openstack-salt heat setup
16:20:19 <cznewt> the other issue is to try access to development environemnts from various platforms [ie mac]
16:20:53 <jasondotstar> 'access to dev environments' <- what do you mean?
16:21:05 <cznewt> the heat clients, the vagrant installs
16:21:29 <cznewt> it is working on linux
16:21:53 <cznewt> but we need to test it works on win/mac as well
16:21:57 <jasondotstar> ah
16:22:06 <cznewt> it should :)
16:22:11 <jasondotstar> windows I can see us working on - mac i'm not sure
16:22:24 <cznewt> you have mac, right?
16:22:33 <jasondotstar> are we talking local dev
16:22:47 <jasondotstar> or a managed cloud enviroment (i.e. lab)
16:22:48 <jasondotstar> ?
16:22:59 <cznewt> local for vagrant, remote for heat, but you still have your laptop as heat client
16:23:10 <jasondotstar> oh i c.
16:23:41 <cznewt> i'd prefer we can support both cases, but i'd primarily focus on cloud based deploys
16:23:52 <cznewt> jasondotstar: what do you think?
16:24:23 <cznewt> as the vagrant is limited by local resources
16:24:48 <jasondotstar> perhaps we can take a look at having mac-based heat clients, but i think it's more important to concentrate on fully standing up the services on linux #1, windows #2
16:25:35 <cznewt> +1
16:26:30 <cznewt> I can test the linux client side, do you have anyone around with M$ win who is willing to test?
16:27:11 <jasondotstar> not right off
16:27:15 <jasondotstar> something to think about
16:27:25 <cznewt> well we need some viretual windows then :)
16:27:43 <cznewt> and that's somethin we have in saltstack-training lab :)
16:27:51 <jasondotstar> #action consider testing deployments to windows-based clients
16:29:27 <jasondotstar> ok
16:29:33 <cznewt> #action cznewt get the first cloud based labs for openstack-salt testing fully operational
16:29:45 <jasondotstar> i think we can move on, we can chat more about this in chan.
16:30:00 <jasondotstar> #topic Today's Agenda
16:30:21 <cznewt> yes, the salt community
16:30:29 <jasondotstar> Salt community involve, no response: https://groups.google.com/forum/#!topic/salt-users/v3PQDfRgtmk
16:30:47 <jasondotstar> cznewt: yes, thanks for engaging the salt community on this topic
16:31:30 <jasondotstar> do we anticipate a response soon?
16:31:59 <cznewt> I have contant to Nitin Madhok who is saltstack merger
16:32:35 <cznewt> we met in Tokio and discussed for a while, I'll let him know of our endeavour and ask him for participation as well
16:33:08 <cznewt> he can probably help us to the right path
16:33:15 <jasondotstar> cznewt: interesting. i did the same :-)
16:33:21 <jasondotstar> cznewt: a few weeks ago
16:33:32 <jasondotstar> but that was before we combined our efforts
16:33:54 <jasondotstar> cool. we'll see if he can help
16:33:55 <cznewt> well I typed him in December and did not get any reply
16:34:08 <jasondotstar> cznewt: same here. I've yet to hear back from him
16:34:08 <cznewt> but it is different topics now
16:34:12 <jasondotstar> right
16:35:23 <jasondotstar> #action continue to engage the salt community regarding our standardizing dependencies, packaging, versioning, and testing
16:35:54 <jasondotstar> i've yet to finish my dev environment setup :-(
16:36:00 <jasondotstar> I'm going to clear my plate today
16:36:03 <jasondotstar> and work on this.
16:36:25 <cznewt> yes, I'd love that and to assist
16:36:37 <jasondotstar> #action jasondotstar to complete local dev testing setup
16:36:47 <jasondotstar> cznewt: +1
16:37:00 <cznewt> whatever issues comes, exept weird ruby/vagrant errors
16:37:16 <cznewt> that were tricky :)
16:37:18 <jasondotstar> hehehe
16:37:20 <jasondotstar> yeah
16:37:27 <jasondotstar> i got a couple weird ones
16:37:44 <jasondotstar> but I'll keep pushing on it.
16:37:48 <jasondotstar> ok, any other pressing topics?
16:38:04 <jasondotstar> if not, i wanted to bring up the question that's being asked right now in -infra
16:38:05 <cznewt> I think we went over all pressing topics for now
16:38:18 <jasondotstar> cool.
16:38:25 <jasondotstar> so did you see the qn in -infra
16:38:37 <jasondotstar> regarding the stackforge/salt projects?
16:40:39 <jasondotstar> basically the issue is we have the new projects
16:40:49 <jasondotstar> that are under the openstack/ namespace
16:40:56 <jasondotstar> and there are existing salt projects
16:41:03 <jasondotstar> under the stackforge/ namespace
16:41:07 <cznewt> I looked these
16:41:14 <jasondotstar> i.e, we have stackforge/nova-salt-formula and openstack/salt-formula-nova
16:41:29 <jasondotstar> cznewt: what did you make if these? I've not looked at them
16:41:35 <jasondotstar> *of
16:41:40 <cznewt> and they don't look good at all
16:41:48 <cznewt> more like empty shells
16:41:50 <jasondotstar> ok
16:42:04 <jasondotstar> so the stackforge/ ones are outated
16:42:04 <cznewt> for example look at this https://github.com/stackforge/neutron-salt-formula/commits/master
16:42:20 <jasondotstar> right nothing there.
16:42:26 <jasondotstar> so we need to prune these
16:42:29 <cznewt> and they have 'We are retired' in the README
16:42:40 <jasondotstar> +1
16:42:41 <cznewt> yes, obsolete stugg
16:42:42 <jasondotstar> i see that
16:42:44 <cznewt> yes, obsolete stuff
16:42:55 <jasondotstar> ok so, I can work on pruning these
16:43:16 <jasondotstar> #action jasondotstar to work on pruning the salt formula projects underneath the stackforge/ namespace
16:43:56 <jasondotstar> i told them that the ones we're migrating from the tcpcloud github repo(s) are house the updated code.
16:44:05 <jasondotstar> s/are//
16:45:12 <cznewt> yes, thanks, the more interesting will be merging with official salt formulas, as the metadata approach varies a little
16:47:54 <jasondotstar> +1
16:48:02 <jasondotstar> ok any other items
16:48:03 <jasondotstar> ?
16:48:12 <jasondotstar> we'll topic switch
16:48:18 <jasondotstar> #topic Open Discussion
16:50:37 <cznewt> I needed some time to reply to the infra guys
16:50:43 <jasondotstar> cznewt: yeah
16:51:39 <jasondotstar> i think we'll end up getting rid of those repos, but we'll see.
16:52:04 <jasondotstar> ok if nothing else we can give the chan 10 mins back
16:52:10 <jasondotstar> anything else?
16:52:31 <jasondotstar> if not, thanks again team. we'll talk in channel.
16:52:38 <jasondotstar> cznewt: thx
16:52:54 <jasondotstar> genunix: thx
16:52:58 <jasondotstar> clarkb: thx
16:53:03 <jasondotstar> #endmeeting