16:00:40 <jasondotstar> #startmeeting openstack-salt
16:00:41 <openstack> Meeting started Tue Mar  1 16:00:40 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:44 <openstack> The meeting name has been set to 'openstack_salt'
16:00:47 <jasondotstar> let's try this again :-)
16:00:52 <jasondotstar> #topic roll call
16:00:53 <jasondotstar> o/
16:00:59 <arif-ali> hi
16:01:02 <cznewt> hi
16:01:26 <jasondotstar> hi cznewt, arif-ali
16:01:37 <jasondotstar> another minute and we'll get going....
16:02:05 <genunix> o/
16:02:12 <jasondotstar> hi genunix
16:02:19 <genunix> Hello :-)
16:02:35 <kevinbenton> Hi
16:02:51 <jasondotstar> hi kevinbenton
16:03:03 <jasondotstar> #topic Introduction
16:03:14 <jasondotstar> This meeting for the openstack-salt team
16:03:24 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
16:03:42 <jasondotstar> Meetings are Weekly on Tuesdays at 1600UTC
16:03:49 <liqw> hello ;)
16:03:51 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:04:00 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:04:10 <jasondotstar> ok....
16:04:22 <jasondotstar> #topic Review past action items
16:04:31 <jasondotstar> we didn't have a meeting last week
16:05:00 <jasondotstar> so everything we had on the board was carried over. with that let's see where we are
16:05:10 <jasondotstar> genunix to continue openstack packaging research
16:05:17 <jasondotstar> any updates?
16:05:49 <genunix> jasondotstar: nope :-X
16:06:06 <genunix> jasondotstar: too busy with contrail packaging for ARM
16:06:12 <jasondotstar> no worries
16:06:16 <jasondotstar> let's move it up
16:06:21 <arif-ali> this also ties in what I am doing, how are you proposing of hosting the formulas?
16:06:45 <arif-ali> and then to build? tarballs.openstack.org?
16:06:54 <jasondotstar> #action genunix tlo continue researching openstack packaging
16:07:10 <carl_baldwin> xiaohhui: ping
16:08:08 <carl_baldwin> jasondotstar: sorry wrong room
16:08:11 <genunix> arif-ali: I don't know tarballs.openstack.org, what did you find regarding RPM packaging of formulas?
16:08:21 <jasondotstar> carl_baldwin: no worries
16:08:55 <arif-ali> well, all the projects in RDO, assume that the tarball of the project is hosted at tarball.openstack.org, (I think that is the URL)
16:08:56 <cznewt> the formula packages are now hosted at tcpcloud repo for debain, we can look how we could use the tarballs.os.org
16:09:22 <genunix> our repo (apt.tcpcloud.eu) + Launchpad PPA (launchpad.org/~tcpcloud)
16:09:23 <arif-ali> and then they use that on their build server and spec files
16:09:42 <jasondotstar> just so that I understand....
16:09:47 <jasondotstar> as an example
16:09:58 <jasondotstar> the salt-formula-ceilometer project
16:10:06 <jasondotstar> what will be in the pkg?
16:10:19 <jasondotstar> what's the RPM or DEB comprised of?
16:10:52 <arif-ali> they are comprised of the actual formulas for the projects, I presume
16:11:42 <cznewt> yes the content of service dir
16:12:03 <jasondotstar> so we're simply packaging up the salt formulas we develop
16:12:06 <cznewt> the install is simple copying over to proper place
16:12:12 <cznewt> yes
16:12:16 <jasondotstar> +1
16:12:43 <arif-ali> I have an example of the RPMs in http://yum.ocf.co.uk/rh7/noarch/ for RPM packages
16:12:44 <jasondotstar> #agreed the packages we build will be comprised of the actual salt formulas for each project
16:12:53 <jasondotstar> #link http://yum.ocf.co.uk/rh7/noarch/
16:12:54 <cznewt> the ci is setup for building apt packages, not for rpm now
16:13:27 <jasondotstar> cznewt: is that what you're working on figuring out?
16:13:45 <cznewt> we can look into building rpms using openstack ci
16:14:01 <jasondotstar> yeah, we'll need someone to take a look at that
16:14:06 <jasondotstar> any takers?
16:14:06 <cznewt> and switching the apt building as well
16:14:26 <arif-ali> ok, I have spec files available, that's listed in the etherpad
16:15:18 <jasondotstar> ok
16:15:38 <jasondotstar> #action Research building RPMs using the openstack-ci
16:15:55 <jasondotstar> ok let's keep moving
16:16:03 <jasondotstar> jasondotstar to begin working on the launchpad integration (enlisting help from cznewt)
16:16:46 <jasondotstar> so
16:16:58 <jasondotstar> i've created all the launchpad projects
16:17:06 <jasondotstar> for each of the salt projects we've got
16:17:22 <jasondotstar> from a discussion that I had with -infra
16:17:37 <jasondotstar> since we've got the LP projects named the same as the git.o.o projects
16:17:51 <jasondotstar> we should be able to simply reference bug-IDs
16:17:56 <jasondotstar> in our commit msgs
16:18:10 <jasondotstar> so that they close bugs that are filed in LaunchPad
16:18:45 <jasondotstar> in a nutshell, LP is simply used for bug tracking, and blueprint documentation
16:19:17 <jasondotstar> all of our code and the review process is hosted on reviews.o.o
16:19:51 <jasondotstar> that's about where that tasks sits atm
16:19:53 <jasondotstar> questions?
16:19:54 <genunix> good, so LP is ready now?
16:19:57 <jasondotstar> yes
16:19:58 <jasondotstar> it is ready
16:20:12 <jasondotstar> each of our core team members should be members of the LP groups
16:20:28 <jasondotstar> for bug tracking 'OpenStack Salt Bugs Team' is the group you should join.
16:20:29 <cznewt> for the tasks, I'd use LP
16:20:39 <jasondotstar> cznewt: true
16:20:47 <jasondotstar> tasks should go there as well.
16:20:58 <arif-ali> +1
16:21:05 <jasondotstar> Blueprints are feature docs
16:21:19 <jasondotstar> like the RPM and DEB packaging
16:21:27 <jasondotstar> im wondering if we should create a blueprint doc for that
16:21:44 <jasondotstar> is that a feature? or just part of the business?
16:21:46 <genunix> and in which project then?
16:21:50 <cznewt> The first task https://bugs.launchpad.net/openstack-salt/+bug/1551817
16:21:50 <openstack> Launchpad bug 1551817 in openstack-salt "Testing of lab environments [vagrant, heat] results" [Undecided,New]
16:22:15 <jasondotstar> each project has its own bug tracker
16:22:25 <jasondotstar> for a common task
16:22:37 <jasondotstar> we'd have that task replicated across each LP bug site
16:23:02 <genunix> so for RPM packaging you need to create one task for every formula?
16:23:03 <cznewt> or use openstack-salt project?
16:23:21 <cznewt> for extra formula tasks
16:23:22 <genunix> yes I would also preffer using openstack-salt for common formula-independent tasks
16:23:30 <jasondotstar> hmmmm
16:23:40 <jasondotstar> i guess we could
16:23:54 <jasondotstar> is that the general consensus here?
16:24:09 <jasondotstar> any -infra team ppl listening in care to advise?
16:25:09 <jasondotstar> ok for now, i'm good with that idea
16:25:17 <egon> seems reasonable.
16:25:44 <jasondotstar> #agreed For common forumula-independent tasks, those will be filed under the openstack-salt LP project
16:26:32 <jasondotstar> #agreed For more specific tasks, those will be filed under its associated salt-formula-* LP project
16:26:56 <jasondotstar> ok next:
16:27:02 <jasondotstar> cznewt to look at beaker gates and how to fold in a similar process into the openstack-salt workflow
16:27:47 <cznewt> I've looked up a few solustions, I don't know which is best
16:28:27 <cznewt> we'd use jenkins and heat to automate lab tests
16:28:56 <jasondotstar> +1
16:28:57 <cznewt> does anyone have experience with beaver?
16:29:26 <jasondotstar> beaver or beaker?
16:29:53 <cznewt> beaker of course :)
16:29:55 <genunix> sidenote: if we want to do lab tests, we should move all required formulas under openstack big tent (nginx/apache and so)
16:30:13 <jasondotstar> +1
16:30:39 <cznewt> yes it on the roadmap
16:30:47 <jasondotstar> I've tried out beaker for puppet stuff in the past, but I probably need to play with it more :-/
16:30:56 <genunix> I would create an action to make a list of these formulas and proceed with it
16:31:22 <jasondotstar> genunix: proceed with implementing beaker tests with each formula?
16:31:35 <cznewt> Yes, but there's discussion whether to host generic formulas in salt ecosystem rather that openstack
16:31:50 <jasondotstar> +1
16:32:30 <jasondotstar> i think the openstack specific ones should be under big tent, and any supporting formulas should be under salt
16:33:20 <genunix> But there are not any common salt formulas or sort-of salt big tent or anything. We would need to create such "tent" first :-)
16:33:22 <cznewt> the formulas we have are generally more functional than official ones, but the metadata definition is very much different for some seamless integration with official salt formulas
16:34:16 <jasondotstar> i c
16:34:31 <cznewt> But preferably i'd have all essential formulas for openstack-salt managed from one place
16:34:34 <genunix> ..also try to standarize some things in community (btw still no response to my mailing list post)
16:34:56 <arif-ali> I agree, that have everything the openstack-salt depends on, should be under one place
16:35:19 <jasondotstar> one place = one project?
16:35:34 <genunix> one place = openstack big tent?
16:35:43 <jasondotstar> or one place = projects hosted in one place (big tent)
16:36:07 <cznewt> yes this is big tent question :)
16:37:06 <cznewt> I prefer separation of formulas as it help integration with custom formulas and better reusability
16:37:28 <jasondotstar> cznewt: agreed. each service should have it's own formula project
16:37:38 <jasondotstar> then we can figure out which ones belong under big tent
16:37:45 <jasondotstar> and which ones don't.
16:37:59 <cznewt> it is not the simplest way, but given the complexity and growing number of services to manage
16:38:40 <jasondotstar> right. plus it's nice to have the ability to have self contained services
16:38:52 <jasondotstar> as much as we can 'box' them
16:39:01 <cznewt> well some of the essential formulas are listed for the regular discussion, and will remain still, but at the end we should end up having formula for each openstack service
16:39:14 <jasondotstar> +1
16:39:47 <arif-ali> +1
16:39:50 <cznewt> now it's like 10 formulas, with core it's like 20-25, and with extra openstack services we can go up to 50
16:40:12 <cznewt> and that is for start
16:40:23 <jasondotstar> #action Research big tent.  Determine which of our salt-formula-* projects should fall under the big tent umbrella, and which of the more host-generic formulas should be pushed up to the salt community
16:40:47 <jasondotstar> ok let's keep moving:
16:40:52 <jasondotstar> cznewt to work on getting the cloud-based labs for openstack-salt testing fully operational
16:40:53 <cznewt> and from this some 10 formulas are supplemetal not strictly openstack and the growing number will be openstack ones
16:41:25 <cznewt> #link http://openstack-salt.tcpcloud.eu/develop/quickstart-heat.html
16:41:50 <cznewt> The documentation for running the heat and vagrant based has been updated
16:41:58 <jasondotstar> \o/
16:42:05 <jasondotstar> nice
16:42:06 <cznewt> the updates are tested, on linux for no
16:42:12 <cznewt> now
16:42:35 <jasondotstar> cool.
16:42:45 <jasondotstar> ok next:
16:42:49 <jasondotstar> UNASSIGNED => continue monitoring the salt mailing list for a response
16:42:59 <jasondotstar> think we just heard that we've still had no response on this
16:43:08 <cznewt> yes
16:43:17 <jasondotstar> ok
16:43:25 <jasondotstar> next: jasondotstar to write a blog post that illustrates how to setup the openstack-salt local dev environment
16:43:40 <jasondotstar> I've yet to write this. :-X
16:43:52 <cznewt> I can help with this
16:43:53 <jasondotstar> so, I'll move this one up
16:43:56 <jasondotstar> cznewt: ok cool.
16:44:01 <jasondotstar> I'll get with you on it
16:44:10 <cznewt> Yes
16:44:16 <jasondotstar> basically it's rewriting the steps you've got
16:44:32 <jasondotstar> but I want to add a short terminal vid too.
16:44:47 <cznewt> Yes, cool I liked that
16:44:49 <jasondotstar> anyway, we'll work on this this week
16:45:05 <jasondotstar> next:  jasondotstar to coordinate 'sunsetting' of the salt formula repos under the stackforge/ namespace
16:45:07 <cznewt> and a little copy-pasting for steps
16:45:18 <jasondotstar> cznewt: right :-)
16:45:26 <jasondotstar> ok this one is COMPLETE
16:46:04 <jasondotstar> all of the old stackforge repos have been marked as RETIRED via the process laid out by -infra
16:46:19 <jasondotstar> and they are marked as RO
16:46:35 <jasondotstar> so we shouldn't have dual salt efforts
16:46:49 <jasondotstar> with what we have under the openstack/ namespace and the stackforge/ namespace
16:47:07 <jasondotstar> any questions on this?
16:47:33 <jasondotstar> ok next: arif-ali to confirm where the tarballed pkgs for the openstack salt formulas should be hosted
16:47:37 <cznewt> yes, I've audited the formulas and found no additional functionality
16:47:59 <jasondotstar> most of those old ones didn't have much in them at all.
16:48:17 <arif-ali> so, this, I think we have already discussed, and maybe there is another route we need to create the RPMs, i.e. via openstack-ci
16:48:47 <arif-ali> So, I need to understand how to do it via that, and can move the spec files into the relevant places to get them built
16:49:05 <cznewt> +1
16:49:57 <jasondotstar> yep, i think we covered this - we just need to know how to use the openstack ci
16:50:10 <arif-ali> does anyone here know?
16:50:39 <cznewt> not for building tarballs, we'll have to go to -infra guys
16:51:14 <jasondotstar> true
16:51:34 <jasondotstar> #action talk to the  -infra team about using the openstack ci pipeline for building RPMs
16:51:54 <jasondotstar> ok running short on time
16:52:09 <jasondotstar> we've had quite a bit of discussion for topics from last meeting
16:52:31 <jasondotstar> anything else before we give the last 8 mins over to today's agenda?
16:52:42 <cznewt> let's go
16:53:05 <cznewt> #topic Today's Agenda
16:53:26 <cznewt> Openstack-salt RedHat test stacks
16:53:43 <jasondotstar> #topic todays agenda
16:53:46 <jasondotstar> go for it
16:54:09 <cznewt> what is the centos version required for testing redhat stack?
16:54:27 <jasondotstar> 7 at this point i think
16:54:59 <arif-ali> I am using centos 7.2 in most of my installations, so makes sense to 7
16:55:06 <jasondotstar> we can target 7 and if we find out otherwise
16:55:08 <jasondotstar> we can add 6
16:55:10 <cznewt> we have the stack for single and cluster, the question is, do we make config node (salt-master) run centos for the begging as well
16:55:40 <cznewt> or do we wait until the packages are ready, or work with git based salt master?
16:56:11 <arif-ali> there is already salt-master for el7
16:56:15 <arif-ali> from epel
16:56:18 <jasondotstar> +1
16:56:27 <jasondotstar> we can use that
16:56:38 <arif-ali> that's what I am using in my test environments
16:57:39 <jasondotstar> #action more discussion neede on testing the RH stack
16:57:45 <cznewt> yes, delivering the formulas i was thinking
16:57:48 <jasondotstar> #action more discussion needed on testing the RH stack
16:58:03 <jasondotstar> how about this one? Testing lab: Schedule testing, prepare rules
16:58:11 <cznewt> Now access to the testing lab
16:58:22 <cznewt> let us know at #openstack-salt channel
16:58:27 <jasondotstar> +1
16:58:53 <jasondotstar> Discuss the Beaker-gate implementation possibilities, real experience
16:58:53 <jasondotstar> Discussion about adding new formulas under openstack: Swift, Linux, OpenSSH, Salt, Reclass, Rabbit, Galera
16:58:53 <cznewt> we'll have to figure rotating passwords and distributing them among team members
16:59:05 <jasondotstar> let's move these two to the #openstack-salt channel
16:59:15 <cznewt> yes this was tackled at tha beginning
16:59:28 <cznewt> ok
16:59:32 <jasondotstar> right, we can continue there
16:59:54 <jasondotstar> finally we've got to reviews that need to be addressed
17:00:02 <jasondotstar> #link https://review.openstack.org/#/c/276353/
17:00:13 <jasondotstar> #link https://review.openstack.org/#/c/276228/
17:00:18 <jasondotstar> let's look at these as well
17:00:25 <jasondotstar> ok... times up :-/
17:00:32 <jasondotstar> anything else?
17:01:01 <jasondotstar> ok.... lost track of time, but good discussion
17:01:08 <jasondotstar> let's continue in channel
17:01:10 <jasondotstar> thanks team
17:01:13 <jasondotstar> #endmeeting