16:00:04 <jasondotstar> #startmeeting openstack-salt
16:00:07 <openstack> Meeting started Tue Mar 15 16:00:04 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'openstack_salt'
16:00:13 <jasondotstar> #topic roll call
16:00:16 <jasondotstar> o/
16:00:23 <cznewt> \o
16:00:38 <jasondotstar> hi cznewt
16:00:47 <liqw> o/
16:01:01 <jasondotstar> hi liqw
16:01:07 <cznewt> hello, last time I tried to chair, was fun, made a few errors though :o :)
16:01:30 <cznewt> like wrong start command, luckily did not get recorded :D
16:01:33 <jasondotstar> you did a fine job, cznewt - thanks for stepping in! \o/
16:02:02 <jasondotstar> #topic Introduction
16:02:07 <jasondotstar> This meeting for the openstack-salt team
16:02:15 <jasondotstar> if you're interested in contributing to the discussion, please join #openstack-salt
16:02:34 <jasondotstar> meetings are here, Weekly on Tuesdays at 1600UTC
16:02:44 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:02:52 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:02:58 <jasondotstar> #topic Review past action items
16:03:21 <jasondotstar> ok, let's see... i took a look at last week's meeting notes
16:03:34 <jasondotstar> here's what we've got - 1) genunix to continue researching openstack packaging
16:03:54 <genunix> o/
16:04:13 <jasondotstar> hi genunix
16:04:25 <jasondotstar> any status on this item?
16:05:05 <genunix> no update
16:05:33 <jasondotstar> np, let's move it up - if you need someone to take a look at it in parallel, I can possibly help out
16:05:45 <genunix> busy with building Debian images+packages for Raspberry :-)
16:06:20 <jasondotstar> #action genunix to continue researching openstack packaging (with help from jasondotstar)
16:06:24 <jasondotstar> ok no worries
16:06:38 <jasondotstar> this next one dovetails on it:
16:06:50 <jasondotstar> continue to research building RPMs using the openstack-ci (unassigned)
16:07:04 <jasondotstar> anyone want to take a look at this one?
16:07:32 <jasondotstar> if not, I'll help out with this one as well.
16:07:51 <jasondotstar> #action jasondotstar to research building RPMs using the openstack-ci
16:08:01 <jasondotstar> ok next one:
16:08:08 <jasondotstar> iceyao to test the centos aio deployment
16:08:28 <jasondotstar> don't see iceyao in chan
16:09:26 <jasondotstar> perhaps iceyao is offline now. one of the reasons we might need to reschedule this meeting to accommodate our far east team members
16:10:09 <jasondotstar> #action iceyao to continue testing the centos aio deployment
16:10:19 <jasondotstar> next:
16:10:22 <cznewt> yes unfortunately lot of redhat guys is offline
16:10:32 <jasondotstar> is iceyao from RH?
16:11:02 <jasondotstar> cznewt: ^
16:11:11 <cznewt> meaning redhat salt deploying, not exactly from redhat
16:11:29 <jasondotstar> oh i gotcha - I'm an RH alum :-)
16:11:41 <cznewt> for redhat testing we have done a testing lab
16:12:02 <cznewt> and most of the issues come from not-openstack related formulas - galera, gluster etc
16:12:09 <jasondotstar> i c
16:12:23 <cznewt> but we're getting through
16:12:30 <jasondotstar> yep, looks like it
16:12:37 <jasondotstar> I'll have to get with you guys on it
16:12:58 <jasondotstar> there's a special place in my 'heart' for how things work from a RH perspective :->
16:13:13 <cznewt> :D
16:13:16 <jasondotstar> so this next one is => prepare the repositories for redhat deployments
16:13:27 <jasondotstar> again, along the same lines
16:13:43 <cznewt> genunix is doing preliminary preparations
16:13:47 <cznewt> for rh repos
16:13:47 <jasondotstar> ok
16:14:06 <jasondotstar> genunix: do you mind if i put your name on this one?
16:14:32 <genunix> I think this was up to ali
16:14:48 <jasondotstar> ok
16:14:49 <genunix> we currently have RPM repo but only for taking third parties as is, etc.
16:14:56 <genunix> no own CI yet
16:15:07 <cznewt> yes to clear matter up, we are reusing 3rd parties packages [rdo and contrail]
16:15:35 <jasondotstar> +1
16:15:52 <cznewt> and for the test lab we'll get these setup properly, I think we have ended up at contrail's gates
16:16:04 <jasondotstar> #agreed we are currently reusing third party packages [rdo, contrail]
16:16:30 <cznewt> that except gluster,contrail everything looks fine
16:17:04 <jasondotstar> #action arif-ali to continue the preparation of the RH repos
16:17:36 <jasondotstar> ok
16:17:37 <cznewt> +1
16:17:58 <jasondotstar> another UNASSIGNED one => look at getting OVS networking working
16:18:03 <jasondotstar> any takers?
16:18:18 <cznewt> this goes the our chinese friend from past meeting
16:18:26 <jasondotstar> +1
16:18:57 <cznewt> we don't have capacity to get this working in near future, so anyone's help would be appreciated
16:18:58 <jasondotstar> #action iceyao to look into getting OVS networking operational
16:19:07 <cznewt> yes, +1
16:19:25 <cznewt> the same goes for the next issue
16:19:47 <jasondotstar> agreed
16:19:48 <cznewt> I think we can merge these 2, as they deal with the same issue
16:20:05 <jasondotstar> #action iceyao to  get the neutron formula with OVS support ready
16:20:10 <jasondotstar> ok
16:20:37 <jasondotstar> any other items to discuss on the action items from last meeting?
16:21:06 <cznewt> I think that's it, all important issues are in today's agenda
16:21:12 <jasondotstar> ok
16:21:15 <jasondotstar> let's move on then
16:21:25 <jasondotstar> #topic Today's Agenda
16:21:46 <jasondotstar> so i guess we didn't have quorum last meeting
16:21:54 <jasondotstar> to discuss: OpenStack summit at Austin develop session (there was no one to discuss this with during last week's meeting)
16:22:29 <jasondotstar> is everyone attending the Austin Summit in April?
16:22:36 <cznewt> yes for me
16:22:41 <genunix> me and cznewt
16:22:43 <jasondotstar> my travel is currently pending approval
16:23:02 <cznewt> I hope it will pass :)
16:23:13 <cznewt> you don't have it that far
16:23:13 <jasondotstar> I am scheduled (booked) to go but we'll see if it is approved
16:23:43 <cznewt> fingers crossed :)
16:23:47 <jasondotstar> yeah... the company has an approval process that takes some time so... we'll see
16:23:57 <jasondotstar> I was in Tokyo... that got approved
16:24:06 <jasondotstar> but we'll have to see about TX
16:24:11 <cznewt> and how is the procedure to get the devel meetup
16:24:22 <cznewt> texas is like 1/10th of the distance :)
16:24:27 <cznewt> comparing to japan
16:24:35 <jasondotstar> i know
16:24:39 <jasondotstar> :-)
16:24:54 <jasondotstar> so are we thinking of doing a design summit session?
16:24:59 <cznewt> yes
16:25:01 <jasondotstar> is that what you mean by devel meetup?
16:25:01 <genunix> for sure
16:25:19 <jasondotstar> well, we can try to get a room for us
16:25:21 <cznewt> yes design session
16:25:28 <jasondotstar> but I'm not exactly sure how that works
16:25:42 <jasondotstar> i think there's a sign-up etherpad somewhere (or something)
16:25:55 <jasondotstar> I hope the window hasn't closed for us though...
16:26:09 <jasondotstar> anyone in channel know what the procedure is?
16:26:34 <cznewt> well, my colleague tells me, that we cannot get design session before we get oficially under openstack
16:26:39 <jasondotstar> ah
16:26:41 <jasondotstar> i c
16:26:59 <jasondotstar> have to be a big tent project first (i guess)
16:27:33 <jasondotstar> in that case
16:27:45 <jasondotstar> I did see in Tokyo that there were informal meetings
16:28:07 <jasondotstar> that were being held in hotel lobbies, and etc.
16:28:52 <cznewt> but we have propsed a "Bird of feather" session in which we want to describe real world usage of openstack-salt
16:29:03 <jasondotstar> we can look to see if there are any accommodations for that
16:29:21 <jasondotstar> I know of another effort to put together a BoF
16:29:37 <jasondotstar> wait, you're saying you've already proposed one
16:29:40 <jasondotstar> cool
16:29:50 <jasondotstar> how much time is it? 45min?
16:30:03 <cznewt> this is Lithium/tcp cloud's usage of openstack-salt
16:30:10 <cznewt> yes, I think so
16:30:22 <cznewt> We can look at the informal meetings
16:30:31 <jasondotstar> right ok
16:30:46 <cznewt> What BoF you were thinking of?
16:30:46 <jasondotstar> #action Look into scheduling an informal openstack-salt session for our team
16:30:53 <jasondotstar> cznewt: App Ecosystem WG
16:31:14 <jasondotstar> they are putting together a BoF as well - I assist with that team (now) as well.
16:31:34 <cznewt> WG stands for?
16:31:41 <jasondotstar> Working Group
16:31:44 <genunix> "Working Girl; a call girl or a prostitue."
16:31:52 <jasondotstar> noooooooooooooo
16:31:56 <cznewt> :D not exactly
16:31:59 <jasondotstar> not that.
16:32:15 <jasondotstar> careful, sensitive ears here. :-)
16:32:59 <jasondotstar> but yes, the AppEcoWG is doing a BoF
16:33:33 <cznewt> for the usage of openstack-salt?
16:33:44 <jasondotstar> I think our best bet is to try and see if there's a place where we can meet informally
16:33:54 <jasondotstar> no not for salt, for their group/team
16:35:56 <jasondotstar> ok
16:36:09 <jasondotstar> any other discussion on this topic?
16:36:11 <cznewt> I know the floorplans of the summit building, so it won't be problem to find a suitable place :)
16:36:30 <jasondotstar> nice!!!
16:36:37 <cznewt> we will be placing some environmental sensors there
16:36:49 <jasondotstar> hehehe... cool
16:37:02 <cznewt> iqrf mesh network :) yes a side project
16:37:11 <cznewt> with positive implications :)
16:37:25 <jasondotstar> hehehehhe
16:37:34 <cznewt> but i think this topic is done
16:37:38 <jasondotstar> ok
16:37:40 <cznewt> for today
16:37:40 <jasondotstar> next one:
16:37:46 <jasondotstar> Meeting time change to 14:00 gmt
16:38:05 <jasondotstar> good thing is, we're expanding our team
16:38:22 <jasondotstar> glad to have more ppl helping out with this effort
16:38:31 <cznewt> but it is harder to get 1 time to fit all
16:38:33 <jasondotstar> perhaps we need to move the meeting time up
16:38:40 <jasondotstar> cznewt: yep, that's true
16:38:51 <jasondotstar> a couple other teams alternate meeting times
16:38:54 <jasondotstar> which is an option
16:39:23 <jasondotstar> but we have to take into consideration what meeting times are available here in the meeting channel(s)
16:40:04 <cznewt> yes, we could do alternate times, how does it work? 2 meetings/week different times
16:40:06 <jasondotstar> is everyone ok with the 1400UTC time slot?
16:40:15 <jasondotstar> one meeting a week
16:40:20 <jasondotstar> alternating the times each week
16:40:40 <cznewt> Europeans are fine, what about you? :)
16:41:03 <jasondotstar> it's a only a couple hours earlier
16:41:06 <jasondotstar> should be fine
16:41:38 <jasondotstar> #action jasondotstar to check the irc meeting channels for an available meeting slot at 1400UTC
16:41:45 <jasondotstar> we may have to change the channel we're in
16:41:47 <cznewt> it is fine with us, if there is free slot
16:41:56 <jasondotstar> if not, I'll let you guys know what is avail.
16:42:21 <jasondotstar> ok next:
16:42:24 <jasondotstar> Continuing to push the SaltStack on formula integration resolution, e-mailed David Boucha directly for some kind of official reply (http://openstack-salt.tcpcloud.eu/develop/extending-ecosystem.html)
16:42:38 <jasondotstar> #link http://openstack-salt.tcpcloud.eu/develop/extending-ecosystem.html)
16:42:42 <jasondotstar> #link http://openstack-salt.tcpcloud.eu/develop/extending-ecosystem.html
16:43:23 <cznewt> we are in touch with saltstack (as a company to company) so I've used this channel to address salt internal staff
16:43:58 <jasondotstar> so we are looking to get these formulas added to the official list of saltstack formulas
16:44:00 <jasondotstar> is that correct?
16:44:07 <jasondotstar> much like PuppetForge
16:44:23 <cznewt> yes, more precisely the way to integrate it
16:44:28 <jasondotstar> gotcha
16:44:47 <jasondotstar> can you keep us updated on the latest on this?
16:44:51 <cznewt> I've sent something like this: "We are currently setting up the salt based deployment of openstack, however there are many more formulas outside of scope of openstack, which we would like to integrate/merge with official salt formulas. The complete formula ecosystem is summarized here: http://openstack-salt.tcpcloud.eu/develop/extending-ecosystem.html and it consists of about 50 formulas all sharing the same metadata layout. However the integration wi
16:44:59 <cznewt> yes I will
16:45:35 <jasondotstar> sounds good1
16:45:43 <cznewt> this is rather difficult matter for both sides
16:45:50 <jasondotstar> I'm sure
16:45:57 <jasondotstar> let us know what you need from the team
16:46:22 <cznewt> yes, exactly
16:46:30 <cznewt> hoping to get progress on this
16:46:36 <jasondotstar> #action cznewt to update the team on the integration process of our salt formulas with saltstack
16:47:01 <jasondotstar> ok last topic:
16:47:09 <jasondotstar> status of the CentOS based labs
16:47:37 <jasondotstar> does this fall in iceyao's territory ?
16:47:59 <cznewt> this is something we have beeen progressing, from point of setting up metadata and testing if formulas work in general
16:48:20 <jasondotstar> ok
16:48:23 <cznewt> this will help iceyao to test his work
16:48:38 <jasondotstar> gotcha
16:49:00 <cznewt> can you place this action to 'Tux' user
16:49:12 <jasondotstar> hehehe
16:49:15 <cznewt> as he does all the stack adjustments :)
16:49:54 <cznewt> he could not attend today's meeting, but has the job almost complete
16:50:01 <jasondotstar> #action continue to report the status of the CentOS-based labs
16:50:17 <cznewt> except the contrail repo and gluster service
16:50:18 <jasondotstar> cznewt: sounds good. anyone who can report on this feel free to do so
16:50:35 <cznewt> jasondotstar: perfect :)
16:50:45 <jasondotstar> ok
16:50:47 <jasondotstar> final 10 mins
16:50:55 <jasondotstar> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
16:51:59 <jasondotstar> do I need to list all of the commits that are currently up for review?
16:52:43 <cznewt> we have some reviews stuck
16:53:04 <cznewt> and we have encoutered some issues with new base image
16:53:14 <jasondotstar> which reviews are held up?
16:53:42 <cznewt> https://review.openstack.org/#/c/276228/
16:53:54 <cznewt> this i cannot abandon at all
16:54:08 <cznewt> it is completely off as it points to wrong branch
16:54:20 <cznewt> i suppose
16:54:53 <jasondotstar> hmm
16:55:54 <jasondotstar> we'll have to look at it
16:56:50 <jasondotstar> ok any others to bring up here?
16:56:55 <cznewt> and this one
16:56:56 <cznewt> https://review.openstack.org/#/c/276353/
16:57:14 <cznewt> this does not go thru even though it has many +1s
16:57:27 <jasondotstar> hmmm
16:57:30 <cznewt> and I dont see reason why
16:57:51 <cznewt> should we ty to push it by new path set?
16:58:50 <jasondotstar> well, i'd like to figure out why it didn't get merged
16:58:58 <jasondotstar> I +2 merged it
16:59:03 <jasondotstar> but it's not moving
16:59:19 <jasondotstar> yeah, I don't see why either
16:59:28 <cznewt> weird, it's minor fix
16:59:33 <jasondotstar> true
16:59:40 <jasondotstar> ok, we'll look into it...
16:59:53 <jasondotstar> alright, times up everyone
16:59:57 <jasondotstar> thanks for joining
17:00:01 <jasondotstar> see you guys in channel
17:00:11 <jasondotstar> #endmeeting