13:02:09 <jasondotstar> #startmeeting openstack-salt
13:02:10 <openstack> Meeting started Tue Apr 5 13:02:09 2016 UTC and is due to finish in 60 minutes. The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:14 <openstack> The meeting name has been set to 'openstack_salt'
13:02:21 <jasondotstar> #topic roll call
13:02:23 <jasondotstar> o/
13:02:27 <cznewt> o/
13:02:29 <cznewt> hello
13:02:34 <jasondotstar> hi cznewt
13:03:14 <jasondotstar> what's new? :-)
13:03:30 <cznewt> we have good news :)
13:03:38 <jasondotstar> oh nice
13:03:50 <cznewt> dvr support in review process
13:03:56 <jasondotstar> \o/
13:04:15 <jasondotstar> who else we got?
13:04:21 <cznewt> and bird of feather has been accepted
13:04:26 <jasondotstar> niiiiiice
13:05:06 <cznewt> yes :)
13:05:32 <jasondotstar> ok I just pinged the rest of the team, hopefully they will show
13:06:05 <jasondotstar> #topic Introduction
13:06:14 <jasondotstar> this meeting is for the openstack-salt team
13:06:25 <jasondotstar> if you're interested in contributing to the discussion, please join #openstack-salt
13:06:39 <jasondotstar> meetings are Weekly on Tuesdays at 1300UTC
13:06:46 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:06:53 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:07:13 <jasondotstar> #topic Review past action items
13:07:30 <jasondotstar> is genunix around today?
13:07:36 <liqw> o/
13:08:04 <jasondotstar> ohai liqw
13:09:33 <cznewt> so let's move to agenda from past?
13:09:44 <jasondotstar> we don't have genunix yet, but is there anyone who can speak to this:
13:09:45 <jasondotstar> genunix to start the RPM packaging spec
13:09:51 <jasondotstar> if not, we'll move on
13:10:00 <jasondotstar> jasondotstar to reach out to dirk (RPM-packaging team) to discuss RPM packaging
13:10:01 <cznewt> he's away today
13:10:06 <jasondotstar> cznewt: ack.
13:10:37 <jasondotstar> so I reached out to dirk and Igor from the RPM-packaging team
13:11:06 <jasondotstar> we are going to have a short meeting today to discuss RPM packaging. this should give us the info we need to write up a spec
13:24:43 <jasondotstar> well, let's step back a sec
13:24:43 <jasondotstar> i think you're saying that we need to use salt to stand up multiple interconnected services
13:24:49 <jasondotstar> and do end-to-end tests
13:24:54 <cznewt> yes
13:24:58 <jasondotstar> to ensure that all our formulas work in concert, right?
13:25:11 <cznewt> yes, pretty much
13:25:14 <jasondotstar> right, ok
13:25:45 <jasondotstar> so I think there's a facility for that where nodepool is involved
13:25:50 <cznewt> basically we have salt orchestration which shlould bring the services up in right order
13:25:58 <jasondotstar> right
13:26:13 <jasondotstar> i can follow up on this
13:26:39 <cznewt> but the actual scenario testing and result evaluation is not clear on how to do
13:26:54 <cznewt> basically we need more than "services are running"
13:27:05 <jasondotstar> cznewt: agreed
13:27:06 <cznewt> but to be able to create net/server/volume
13:27:12 <jasondotstar> spawn infra
13:27:23 <cznewt> and if this work, we can mark it success
13:27:34 <jasondotstar> spawn resources i should say
13:27:36 <jasondotstar> I gotcha
13:28:22 <jasondotstar> #action jasondotstar to follow up on how we run integration/functional tests that incorporate multi-node services
13:28:33 <cznewt> +1
13:28:51 <jasondotstar> ok let's move on
13:29:09 <jasondotstar> cznewt to follow up on DVR networking and the neutron salt formula with OVS support
13:29:38 <cznewt> yes this has been contributed by wondra
13:29:46 <jasondotstar> excellent!
13:30:07 <cznewt> wondra: can you tell some more things about the implementation?
13:30:34 <wondra> Frankly? The base is probably yours from Icehouse time.
13:30:46 <wondra> I just updated it, tested, added DVR parameters.
13:31:37 <wondra> There are a few bugfixes and I renamed bridge and switch to compute and network, because it was highly confising.
13:32:17 <cznewt> yes, I'm thinking on how to create new test-lab with this network setup
13:32:30 <wondra> About the reviews.. I don't really know what the package fuel-utils does. I just copied it. I actually think it is obsolete.
13:33:05 <jasondotstar> is there a review to look at on this?
13:33:22 <wondra> And about the testing. How exactly does the test infrastructure work now? I read in the docs that it spins up some VM, but what does it do then?
13:33:27 <wondra> https://review.openstack.org/#/c/300725/2
13:33:43 <cznewt> this package is not required
13:33:52 <wondra> OK, will delete.
13:33:58 <cznewt> and generally no packages in formulas
13:34:36 <jasondotstar> #link https://review.openstack.org/#/c/300725/2
13:35:11 <cznewt> we can d
13:35:30 <cznewt> o review comments at the end of session
13:35:44 <cznewt> there are 2 points I'd like to go over first
13:36:09 <cznewt> regarding the summit and propagation of our effort
13:36:14 <jasondotstar> ok
13:38:21 <cznewt> 1. bird of feather talk https://www.openstack.org/summit/austin-2016/summit-schedule/events/9449?goback=1
13:39:12 <cznewt> it will be about real life experience, but i'd like to empasise on how to join us
13:39:37 <cznewt> the benefits of our solution over the competition etc :)
13:40:07 <cznewt> I'd make the presentation shareable to the rest of the team
13:40:16 <jasondotstar> yes
13:40:19 <jasondotstar> that's awesome
13:40:21 <jasondotstar> +1
13:40:30 <jasondotstar> #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/9449?goback=1
13:41:28 <jasondotstar> we certainly want to bring up what makes us different
13:42:20 <cznewt> Ok can you give me action to prepare the presentation doc
13:42:47 <jasondotstar> sure thing
13:43:05 <jasondotstar> #action cznewt to prepare the BoF session presentation slide for review with the team
13:43:25 <jasondotstar> #action cznewt to prepare the BoF session presentation slides for review with the team
13:44:27 <jasondotstar> cznewt: there was a second item?
13:45:35 <cznewt> yes it's the vendor involvement
13:45:54 <cznewt> if to gather them to BoF presentation
13:46:05 <cznewt> to give them some reason to come/contribute
13:46:15 <cznewt> to this presentation
13:46:50 <jasondotstar> are there specific vendors you want to target?
13:48:03 <cznewt> sdn/disk
13:48:24 <cznewt> vendors, to integrate their backends
13:48:57 <cznewt> if they were to be summoned to BoF talk, there should be part in how to integrate new things
13:49:15 <jasondotstar> +1
13:49:28 <cznewt> this is the main question whether to direct them to BoF or make some informal meeting on integration
13:49:41 <cznewt> or make the integration part of BoF
13:49:51 <jasondotstar> the BoF is like a kickoff
13:52:46 <jasondotstar> i'd think
13:52:49 <jasondotstar> we invite them there
13:53:01 <jasondotstar> and have them hear what we have to offer
13:53:26 <jasondotstar> but an informal meeting might work too.... something to think about
13:53:57 <jasondotstar> something we can talk about more in chan
13:54:03 <cznewt> ok, agreed, we can tell them more at end BoF and if there's demand we'll make informal meeting
13:54:12 <jasondotstar> +1
13:54:18 <jasondotstar> ok final 5 minutes
13:54:24 <jasondotstar> #topic Open Discussion
13:54:29 <cznewt> now to the dvr stuff
13:54:31 <jasondotstar> any other items to bring up
13:54:37 <jasondotstar> yes, let's finish up with that
13:54:39 <cznewt> yes and the test labs
13:54:47 <jasondotstar> go for it
13:54:57 <cznewt> we have ubu/rh dvr/contrail single/cluster
13:55:07 <cznewt> this is 2x2x2 - 8 possible solutions
13:55:10 <cznewt> setups
13:55:31 <cznewt> how to manage this
13:55:51 <cznewt> if we add any more it goes to 16...32 :)
13:55:56 <cznewt> possible setups
13:56:12 <cznewt> how to choose what setups to support
13:57:01 <jasondotstar> hmmmmmmmm
13:57:06 <jasondotstar> good point
13:57:58 <wondra> Crazy idea - do it in serial on a btrfs filesystem with snapshots. In testing the setups, you always change 1 option, so the snapshots will form a binary tree :-)
13:58:13 <cznewt> :)
13:58:15 <jasondotstar> :-)
13:59:54 <cznewt> time is running up, we can discuss in our channel this, I'd like to get to some resolution as I want to setup at least the dvr/ubuntu single/cluster for start
13:59:57 <jasondotstar> something for us to think about
14:00:01 <jasondotstar> +1
14:00:06 <jasondotstar> thanks guys
14:00:08 <jasondotstar> #endmeeting