13:00:50 <jasondotstar> #startmeeting openstack-salt
13:00:51 <openstack> Meeting started Tue Apr 12 13:00:50 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:55 <openstack> The meeting name has been set to 'openstack_salt'
13:00:58 <jasondotstar> #topic roll call
13:01:01 <jasondotstar> o/
13:01:11 <cznewt> hello \o
13:01:23 <jasondotstar> GM cznewt
13:06:11 <jasondotstar> anyone else?
13:06:17 <jasondotstar> otherwise let's move on
13:06:27 <jasondotstar> #topic Introduction
13:06:33 <jasondotstar> This meeting is for the openstack-salt team
13:06:41 <jasondotstar> if you're interested in contributing to the discussion, please join #openstack-salt
13:06:54 <jasondotstar> meetings are Weekly on Tuesdays at 1300UTC
13:07:10 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:07:19 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:07:40 <jasondotstar> #topic Review past action items
13:07:57 <jasondotstar> meeting etherpad: https://etherpad.openstack.org/p/openstack-salt-weekly-meeting-20160412
13:08:00 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-salt-weekly-meeting-20160412
13:08:08 <jasondotstar> genunix to start the RPM packaging spec
13:08:21 <genunix> o/
13:08:28 <jasondotstar> hi genunix
13:08:32 <jasondotstar> any updates here?
13:08:38 <genunix> just a little
13:09:09 <genunix> I am investigating debian packaging for openstack and trying to reach debian-openstack team and ask them for some guidance
13:09:25 <cznewt> and there's the salt packaging business
13:09:43 <genunix> (OFTC/#debian-openstack)
13:10:40 <jasondotstar> genunix: +1. I'm doing the same on the RPM side.
13:10:44 <genunix> I have some idea on how to do it but we still need some Debian mentor
13:10:48 <jasondotstar> +1
13:11:15 <genunix> I also hope we can talk with people around packaging on Openstack summit.
13:12:03 <cznewt> +1 this is one of the priorities
13:12:14 <jasondotstar> indeed
13:12:29 <jasondotstar> this sort of dovetails on mine agenda item:
13:12:29 <jasondotstar> jasondotstar to reach out to dirk (RPM-packaging team) to discuss RPM packaging
13:12:39 <jasondotstar> I have reached out to the RPM-packaging team
13:13:47 <jasondotstar> they will be assisting us in a couple different things
13:13:57 <jasondotstar> 1- using their RPM spec templates
13:14:20 <jasondotstar> to create RPMs for RPM distros we are targeting
13:14:58 <jasondotstar> SUSE, CentOS, Fedora
13:15:04 <jasondotstar> all have small differences
13:15:19 <jasondotstar> that need to be addressed in the spec files
13:15:27 <jasondotstar> so there's that
13:17:40 <jasondotstar> 2) we have to decide where the 'source' is going to be hosted
13:17:51 <jasondotstar> in other words
13:18:22 <jasondotstar> we may have to leverage a 3rd party CI
13:18:30 <jasondotstar> for build/test
13:19:00 <jasondotstar> so having the source (perhaps) HTTP accessible to the 3rd party CI would be important
13:19:18 <jasondotstar> the RPM packaging team uses the SUSE CI pipeline for building RPMs atm.
13:19:32 <jasondotstar> they are willing help us leverage this same CI.
13:19:42 <jasondotstar> questions, comments?
13:22:56 <jasondotstar> ok moving on
13:23:05 <jasondotstar> jasondotstar to follow up on how we run integration/functional tests that incorporate multi-node services
13:23:10 <jasondotstar> no updates on this one yet.
13:23:17 <jasondotstar> #action jasondotstar to follow up on how we run integration/functional tests that incorporate multi-node services
13:23:25 <jasondotstar> last one:
13:23:26 <jasondotstar> cznewt to prepare the BoF session presentation slides for review with the team
13:25:11 <jasondotstar> cznewt: any status here?
13:25:58 <jasondotstar> if not, we'll move on to today's agenda
13:26:19 <jasondotstar> #topic Today's Agenda
13:26:45 <jasondotstar> 3rd Party Vendor Support
13:26:52 <jasondotstar> so I've got a question here
13:27:21 <cznewt> I don't have pprogess on that one
13:27:23 <jasondotstar> what's the team's take on how we are going to support 3rd party vendors
13:27:27 <jasondotstar> cznewt: no worries
13:27:33 <cznewt> I 'm preparing another presentation
13:28:54 <jasondotstar> no prob, we can move it up
13:29:12 <jasondotstar> if we can get a look at it prior to summit, that'd be a win
13:29:34 <jasondotstar> #action cznewt to continue prepping the BoF presentation slides for summit
13:30:14 <cznewt> yes I'll get it ready till the next week
13:30:23 <jasondotstar> so the reason why I'm asking about third party vendor support in our salt formulas is b/c F5 Networks
13:30:31 <jasondotstar> has reached out to me directly
13:30:36 <jasondotstar> about this.
13:31:49 <jasondotstar> this is the first group that has reached out to us
13:32:12 <jasondotstar> specifically about salt formulas for integrating BIG-IP devices
13:32:25 <jasondotstar> with OpenStack
13:32:36 <jasondotstar> i'd like to hear the team's thoughts on this....
13:34:16 <jasondotstar> cznewt, genunix ^^
13:34:20 <jasondotstar> any thoughts around this?
13:35:11 <genunix> hmm, not much. What's the difference in 3rd party vendors and other contributors?
13:35:35 <jasondotstar> well, F5 is willing to support us
13:35:47 <jasondotstar> give us licenses and dev/test VMs
13:35:55 <genunix> Ah, didn't know
13:36:05 <jasondotstar> so that we can do the work that's needed
13:36:39 <jasondotstar> i think saying that you can use our salt formulas to integrate F5 devices into your OpenStack deployments is a win for us
13:36:46 <jasondotstar> i guess it
13:37:03 <jasondotstar> would be like Cisco and Juniper integration with neutron
13:37:12 <cznewt> yes indeed, I've seen already some salt f5 integrations somewhere
13:37:27 <jasondotstar> right, they have begun to open source their stuff
13:37:51 <cznewt> https://docs.saltstack.com/en/latest/ref/states/all/salt.states.bigip.html
13:38:14 <cznewt> we could just whap this in formula with proper metadata
13:38:22 <jasondotstar> http://github.com/f5networks
13:38:28 <jasondotstar> cznewt: +1
13:38:37 <jasondotstar> they know have a Python SDK
13:38:44 <jasondotstar> *now
13:39:06 <jasondotstar> as well
13:39:18 <jasondotstar> anyway, this is something that can work directly with them on.
13:39:27 <jasondotstar> they are offering support to us for it.
13:40:09 <jasondotstar> ok we can talk more about this in chan.
13:40:35 <jasondotstar> we can figure out how to move forward if we think this is a worthy cause
13:40:42 <jasondotstar> here's another topic:
13:40:43 <jasondotstar> Yash's blueprint (support the salt formula for "Keystone" till Liberty release)
13:40:54 <jasondotstar> #link https://blueprints.launchpad.net/salt-formula-keystone/+spec/yash-agarwal
13:41:42 <jasondotstar> any background info on this one?
13:42:45 <genunix> nothing unfortunately
13:42:55 <genunix> Hoped that anyone here will have more info :-)
13:44:08 <genunix> I think it's somehow connected with keystonev3 support
13:44:37 <genunix> and Yash's refactor to use python-openstack instead of python-keystone
13:45:26 <genunix> He posted url with his changes some time ago in #openstack-salt
13:45:33 <jasondotstar> genunix: +1
13:46:10 <jasondotstar> honestly, i'd have to take a look to see what this is..... i have no idea :-/
13:46:25 <jasondotstar> but I'll take your word for it :-)
13:49:07 <jasondotstar> ok
13:49:25 <jasondotstar> we've got a couple reviews up:
13:50:02 <jasondotstar> #link https://review.openstack.org/304436 - config files to support lvm driver
13:50:27 <cznewt> I'm looking over that one
13:50:38 <jasondotstar> #link https://review.openstack.org/304472 - parameterized mq
13:50:43 <jasondotstar> cznewt: +1
13:51:08 <cznewt> yes, I'm handling these, but they're stuck in my internal queue :D
13:51:23 <jasondotstar> cznewt: cool.
13:51:28 <cznewt> but I'll process them 2day
13:51:32 <jasondotstar> #topic Open Discussion
13:51:44 <cznewt> at the end we'll have full Mitaka support
13:51:52 <jasondotstar> cznewt: \o/
13:52:12 <jasondotstar> ok any last thoughts before we close?
13:53:23 <cznewt> about the f5, how we can start the cooperation process?
13:54:04 <cznewt> can we setup
13:54:09 <jasondotstar> I've got a direct contact
13:54:17 <jasondotstar> with one of their solution architects
13:54:42 <cznewt> yes, I'm wandering on how to fit this into the deployment scenarios
13:54:49 <jasondotstar> we can meet with him directly
13:55:10 <cznewt> yes, when/where summit?
13:55:20 <jasondotstar> he will be at summit
13:55:29 <jasondotstar> I'll introduce you two :-)
13:56:03 <jasondotstar> we can also have a call w/ them as well.
13:57:09 <cznewt> y this would be perfect
13:57:55 <jasondotstar> :-)
13:57:56 <jasondotstar> cool
13:58:11 <jasondotstar> ok any last thoughts?
13:59:30 <cznewt> not for me, I'll send link to presentation to our channel
13:59:46 <jasondotstar> +1
13:59:48 <jasondotstar> thanks all
14:00:00 <jasondotstar> #endmeeting