13:02:16 <jasondotstar> #startmeeting openstack-salt
13:02:17 <openstack> Meeting started Tue Apr 19 13:02:16 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:20 <openstack> The meeting name has been set to 'openstack_salt'
13:02:25 <jasondotstar> #topic roll call
13:02:28 <jasondotstar> o.
13:03:25 <cznewt> hello
13:03:31 <wondra_> Hi
13:03:47 <jasondotstar> i there
13:03:51 <jasondotstar> *hi there
13:04:00 <jasondotstar> #topic introduction
13:04:29 <cznewt> This meeting for the openstack-salt team
13:04:41 <cznewt> if you're interested in contributing to the discussion, please join #openstack-salt
13:05:01 <cznewt> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:05:26 <cznewt> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:05:27 <jasondotstar> cznewt: +1
13:05:33 <genunix> o/
13:05:53 <jasondotstar> #topic  Review past action items
13:06:13 <jasondotstar> busy week last week for me- so all of my stuff is still in progress :-/
13:06:33 <jasondotstar> feel free to continue talking about the other items.
13:08:14 <genunix> ok, there's no past action item on packaging but I did a huge step forward in getting salt formulas to debian
13:09:13 <genunix> salt-formula-ceilometer was uploaded to Debian unstable today as the first one and the others are ready to go :-)
13:09:29 <cznewt> genunix: +5
13:09:32 <genunix> @link https://tracker.debian.org/news/762883
13:09:35 <genunix> #link https://tracker.debian.org/news/762883
13:09:45 <cznewt> this is a huge leap :)
13:10:19 <cznewt> the past items review:
13:10:21 <cznewt> jasondotstar to follow up on how we run integration/functional tests that incorporate multi-node services
13:10:41 <jasondotstar> #action jasondotstar to follow up on how we run integration/functional tests that incorporate multi-node services
13:10:50 <cznewt> yes till the next time
13:10:50 <jasondotstar> genunix: +100
13:11:22 <cznewt> the next topic is:
13:11:25 <cznewt> cznewt to continue prepping the BoF presentation slides for summit
13:12:23 <cznewt> #link https://docs.google.com/presentation/d/1ytVCUPGfo7lbMLqQwr8gE4Tfu77_apQOG7_u2_2HLQ8/edit?ts=570e52e1#slide=id.p4
13:13:41 <cznewt> sorry the working link
13:13:44 <cznewt> #link https://docs.google.com/presentation/d/1ytVCUPGfo7lbMLqQwr8gE4Tfu77_apQOG7_u2_2HLQ8/edit?usp=sharing
13:15:00 <cznewt> it's just a rough skeleton, please feel free to comment it
13:15:07 <cznewt> we have a week to proceed
13:18:21 <cznewt> You can comment now as well
13:21:51 <cznewt> #topic Today's Agenda
13:22:44 <cznewt> there's no point listed at todays's agenda so we will skip to
13:22:48 <cznewt> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
13:23:13 <cznewt> wondra_: I'd like to talk about https://review.openstack.org/#/c/300725/
13:24:06 <cznewt> can you please fix the tests metadata for checks to pass?
13:24:19 <jasondotstar> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
13:24:44 <wondra_> That's the DVR one.. What should I do?
13:25:24 <cznewt> there's a contrail referenced, it should be opencontrail
13:26:18 <wondra_> I really don't know how the test setup works.
13:28:19 <cznewt> you provide test metadata and the test tries to compile the catalog
13:28:49 <cznewt> in your case, you're referencing contrail, which is not defined, you need to reference opencontrail
13:29:14 <wondra_> I'm not referencing anything. I provided some test pillar files.
13:30:18 <wondra_> Where is the metadata supposed to be and how should it look like?
13:32:01 <genunix> wondra_: also please don't use lines longer than 80 characters in commit message
13:32:20 <wondra_> That I could fix.
13:32:41 <cznewt> I'll give you more thorough answer afterwards in czech
13:33:14 <cznewt> I't one of the issues to test this setup in heat lab
13:33:35 <cznewt> #action cznewt prepare testbed environment for DVR neutron setup
13:37:39 <cznewt> I've reviewed the metadata issue https://review.openstack.org/#/c/300726/
13:38:05 <cznewt> It looks ok, but I've notices that you update file which is not present in our setup
13:38:44 <cznewt> the neutron.conf.Debian does not exist
13:39:13 <cznewt> in our current setup, what was your starting position for that change?
13:39:21 <wondra_> Because you use mostly neutron.conf.contrail.Debian or somesuch.
13:40:23 <wondra_> Will the quotas work the same with Contrail backend?
13:41:09 <cznewt> it's another config file
13:42:13 <wondra_> Yes, the template for vanilla Neutron is separate from Contrail.
13:43:26 <wondra_> And then I have temples for network node and compute node, which are not needed in Contrail.
13:44:29 <wondra_> (Well, at least for compute, which is not expected to be co-located with network.)
13:46:03 <cznewt> we'll test it this week to get it integrated, I'll send you credentials to join that stack
13:46:49 <wondra_> OK, thanks.
13:53:39 <cznewt> wondra_: I'll have to go now, do you have some IM to get in touch on the testing?
14:00:35 <jasondotstar> i think we're all done
14:00:38 <jasondotstar> #endmeeting