13:00:13 <jasondotstar> #startmeeting openstack-salt
13:00:14 <openstack> Meeting started Tue May  3 13:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:17 <openstack> The meeting name has been set to 'openstack_salt'
13:00:20 <jasondotstar> #topic roll call
13:00:22 <jasondotstar> o/
13:04:41 <nmadhok> what time is the openstack-salt meeting?
13:04:53 <jasondotstar> it's going on right now
13:04:57 <cznewt> hello
13:04:58 <jasondotstar> :-)
13:05:00 <jasondotstar> so wellcome
13:05:06 <jasondotstar> #topic Introduction
13:05:13 <nmadhok> did it just start?
13:05:22 <nmadhok> hope I didn't miss anything
13:05:32 <cznewt> yes, I got here right now
13:06:05 <jasondotstar> yes it *just* started
13:06:14 <cznewt> still catching up the local time after the 2 day trip home
13:06:14 <jasondotstar> This meeting is for the openstack-salt team
13:06:20 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
13:06:25 <jasondotstar> Meetings are Weekly on Tuesdays at 1300UTC
13:06:41 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:06:52 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:07:09 <jasondotstar> #topic Review past action items
13:07:19 <jasondotstar> so because of summit
13:07:29 <jasondotstar> we didn't have a meeting last week
13:07:45 <jasondotstar> perhaps cznewt can talk to us
13:07:50 <jasondotstar> about what took place
13:07:54 <jasondotstar> oh
13:08:01 <cznewt> yes, last week was a summit
13:08:08 <jasondotstar> we also have nmadhok who's joined us.  thanks for attending
13:08:35 <nmadhok> Yes I'm a new addition to the team. I'm Nitin Madhok working for Clemson University
13:08:37 <jasondotstar> nmadhok was a presenter in Tokyo that originally gave me the idea to create this team so thanks for attending.
13:09:08 <cznewt> yes we have met with nmadhok and have similar feelings
13:09:15 <cznewt> in Tokio
13:09:17 <nmadhok> @jasondotstar you're welcome!
13:09:38 <nmadhok> Thanks to you guys for starting the project
13:09:58 <jasondotstar> the TCP Cloud guys have come in, and have *really* helped with our codebase
13:10:27 <jasondotstar> so I'm glad we've all had a chance to 'meet'
13:10:28 <jasondotstar> :-)
13:10:36 <nmadhok> So where are we today with the project and where are we headed?
13:10:56 <jasondotstar> cznewt feel free to chime in here....
13:11:01 <nmadhok> If I had known, we couldn't have met in austin and held a design session or something
13:11:05 <nmadhok> *could
13:11:15 <jasondotstar> nmadhok: +1
13:11:24 <cznewt> well i tried to reach you a fwe times by mail :)
13:11:34 <jasondotstar> hehehehe me too :-)
13:11:41 <jasondotstar> busy guy!
13:11:51 <nmadhok> I've been really busy preparing for various conferences
13:12:01 <cznewt> well we have covered the juno, kilo, liberty, the mitaka is getting ready
13:12:06 <nmadhok> Just got back home last night after three weeks of travel
13:12:14 <jasondotstar> wow
13:12:15 <nmadhok> SaltConf, OpenStack Summit
13:12:30 <cznewt> we have covered and tested multiple cinder/keystone/glance/nova backends
13:13:03 <cznewt> well more like months following the tokio than months preceeding austin
13:13:05 <nmadhok> I'll be speaking at openSUSE conference in Germany next in June. One of the sessions that got accepted is deploying OpenStack in 10 minutes
13:13:17 <nmadhok> Would be nice to have you all join me in presenting
13:13:31 <cznewt> I could, I'm very nearby
13:13:52 <cznewt> the main focus is to deploy HA/cluster setup suitable for production
13:14:08 <nmadhok> where are you all from? Introductions would be good too.
13:14:16 <nmadhok> I'm from South Carolina, USA
13:14:25 <cznewt> now we are polishing the orchestration goes green 1st time
13:14:31 <cznewt> I'm Czech Republic
13:14:38 <jasondotstar> North Carolina, USA
13:14:38 <cznewt> Europe
13:14:57 <nmadhok> I'll be visiting Prague around that time.
13:15:11 <cznewt> There will be a Openstackday prague
13:15:21 <nmadhok> either before/after the conference. You all should definitely join me in presenting together
13:15:23 <cznewt> If you want to attend, mmnt i'll find a link
13:15:51 <nmadhok> I'll need to understand how the project currently is designed and how it works
13:15:52 <cznewt> I'll have presentation in Prague as well, so we can share each other's slot
13:16:16 <cznewt> #link http://openstack-salt.tcpcloud.eu/ the projects documentation and scope
13:16:32 <nmadhok> (talking about the current openstack-salt project instead of saltopenstack project)
13:17:11 <cznewt> so am I, I hope I follow
13:17:27 <nmadhok> Perfect. I went through the documentation a little. Noticed everything was being done using pillars. Correct?
13:17:28 <cznewt> #link http://openstackdayprague.eu/ is the event in Prague, june 8th
13:18:23 <cznewt> yes, that is correct in most places
13:18:26 <nmadhok> I'll get together with you @cznewt about the sessions and details. Do you have my email/LinkedIn?
13:18:45 <cznewt> nmadhok: do you have some link to German event
13:19:19 <jasondotstar> cool
13:19:23 <cznewt> yes
13:19:46 <cznewt> I see, u have accepted me on linkedin yesterday
13:20:00 <nmadhok> https://events.opensuse.org/conference/oSC16
13:20:11 <jasondotstar> #action nmadhok to connect with cznewt on the openSUSE conf
13:20:42 <nmadhok> @jasondotstar Will you be joining us for presentation at the conference?
13:20:51 <jasondotstar> maybe
13:21:00 <jasondotstar> I'd have to see if I can get travel approval for it...
13:21:04 <nmadhok> It'll be great for us to get together and present. Would be nice PR for the project
13:21:12 <jasondotstar> nmadhok: +100
13:21:14 <cznewt> that would be very appreciated, you already have 1 absence :)
13:21:21 <nmadhok> Let me know over email or IRC
13:21:22 <jasondotstar> cznewt: I know
13:21:28 * jasondotstar slaps his own hand
13:21:43 <jasondotstar> speaking of which
13:21:49 <jasondotstar> how did things go at summit?
13:22:30 <nmadhok> Here's the the two talks that got accepted for the conference in Germany:
13:22:40 <nmadhok> https://events.opensuse.org/conference/oSC16/program/proposal/792 (VMware salt-cloud)
13:22:47 <cznewt> we had a Bird of feather presentation, it was at 9 am, enve though attendance rathed good (50+), we went through the motivation, and got the good response
13:22:57 <nmadhok> https://events.opensuse.org/conference/oSC16/program/proposal/794 (saltopenstack)
13:23:13 <nmadhok> Good to know that
13:23:26 <cznewt> some team from germany wants to do salt-based deploy and got some stuff ready for mitaka and were glad to find us
13:23:36 <jasondotstar> cznewt: nice
13:23:57 <cznewt> yes, I've contact, but I'm officially dead till tomorrow
13:24:05 <jasondotstar> sure thing
13:24:11 <jasondotstar> jet lagged im sure.
13:24:28 <cznewt> look at my twitter to get the idea :)
13:24:37 <jasondotstar> will do.
13:24:42 <cznewt> 24hrs dealy
13:24:50 <cznewt> like 100%, ouch
13:25:16 <nmadhok> Yes talked to Jakub yesterday. He told me about the delay in SFO
13:25:49 <cznewt> then I spoke with Thierry, the tech comittee lead about the offical state of the project
13:26:26 <jasondotstar> cznewt: how'd that go?
13:26:35 <nmadhok> so the project was created 3-4 months ago is that correct?
13:26:44 <cznewt> and we are good to go official, as other (ansible, puppet) thrive
13:26:54 <nmadhok> nice
13:27:08 <jasondotstar> cznewt: what's the process like?
13:27:26 <jasondotstar> nmadhok: about that
13:27:27 <cznewt> we made a strong impression with our other activities on summit - had a best keynote :)
13:27:43 <jasondotstar> cznewt: yes, the keynote was great
13:27:54 <cznewt> yes, I goes through the governance repo
13:28:03 <nmadhok> Agree that keynote was very good
13:28:06 <cznewt> and I needs to be accepted and merged
13:28:18 <cznewt> so you liked my dashboard :D
13:28:41 <nmadhok> @cznewt yeah
13:28:44 <cznewt> d3 over svg overlays :D
13:29:11 <cznewt> then it met it's purpose 100%
13:29:46 <jasondotstar> good deal
13:29:57 <cznewt> nmadhok: jakub told me about your concerns about not using the oficial formulas, is that right?
13:29:59 <jasondotstar> cznewt: do you have a link to the governamce repo?
13:30:25 <nmadhok> @cznewt yes that's right.
13:30:31 <cznewt> jasondotstar: wait a sec, must dig for it
13:30:38 <jasondotstar> cznewt: +1
13:31:19 <nmadhok> would be good to have the needed formulas to be merged under the official saltstack-formulas on GitHub
13:31:24 <cznewt> nmadhok: we have been trying to reach salt about this / david boucha even promised to reply / but no reply yet
13:31:32 <nmadhok> I'll merge them
13:31:54 <nmadhok> Need to get together sometime and see what needs to be merged
13:32:18 <cznewt> yes, this thing is complex and it will be a lot of work
13:32:35 <cznewt> as there is like 50 formulas taking place on our side
13:33:00 <nmadhok> Can we setup a Adobe Connect/WebEx/Hangout sometime this week where you can demo how the project works currently, bring me up to speed, and we can work on merging stuff under the official Salt repositories?
13:33:12 <cznewt> we have standard metadata model used to generate various auxiliary services
13:33:33 <cznewt> nmadhok: this is the right way to go, I think
13:33:33 <cznewt> yes
13:33:43 <nmadhok> Yes that's what official formulas are being converted to. Salt Package Manager (SPM) used the metadata
13:33:47 <nmadhok> *uses
13:34:11 <nmadhok> formulas might need to be rewritten on tcpcloud's side to also be able to use the full power of SPM
13:34:20 <jasondotstar> +1
13:34:55 <cznewt> +1
13:35:40 <nmadhok> There are some concerns I have with pillars
13:36:07 <nmadhok> Using pillars entirely. Did some research, ran into problems. Will be happy to share my experiences with you
13:36:15 <cznewt> yes, can we setup the meeting?
13:36:24 <nmadhok> and learn your experiences with it
13:36:25 <cznewt> for the thursday let's say
13:36:42 <nmadhok> I can do Thursday or Friday.
13:36:52 <cznewt> as this sounds like a aches I'm having lately
13:37:08 <cznewt> thursday this time, or 1 hour later
13:37:17 <cznewt> would be good for me
13:37:42 <nmadhok> Yes I saw a lot of work was done using pillars and had some concerns with it. Didn't want everybody to spend to much time and learn about the idiosyncrasies
13:38:19 <nmadhok> hursday at 14:00 UTC work for everybody?
13:38:22 <nmadhok> *Thursday
13:38:44 <cznewt> yes, for my side, an some hangout will be fine?
13:39:01 <jasondotstar> a hangout works
13:40:10 <nmadhok> I'll schedule either a hangout or Adobe connect session at connect.clemson.edu
13:40:27 <jasondotstar> sounds good
13:40:30 <nmadhok> ping me with your emails
13:40:49 <nmadhok> I think I have your email @jasondotstar
13:41:34 <nmadhok> @cznewt need to get together with you about the presentation at Prague
13:41:48 <nmadhok> I'll need to make travel arrangements accordingly
13:42:14 <cznewt> jasondotstar: I cannot find it at the moment, this is where i started last time https://governance.openstack.org/, will send it in a few hours, when I get back home
13:42:22 <jasondotstar> no worries
13:42:36 <cznewt> nmadhok: is the thursday soon enough?
13:42:47 <cznewt> when is the suse thing?
13:43:05 <nmadhok> openSUSE is June 22-26
13:43:32 <nmadhok> but for Prague i'll have to travel earlier so will need to make the arrangements accordingly
13:44:21 <jasondotstar> #action nmadhok to schedule a hangout or Adobe connect session with the team to discuss current salt team progress
13:44:22 <nmadhok> let's take that conversation offline over emails
13:44:45 <cznewt> OK
13:44:46 <jasondotstar> that's fine.
13:45:06 <nmadhok> to be able to schedule a hangout/adobe connect session, i need everybody's email who would be joining
13:45:25 <nmadhok> email me at nmadhok@clemson.edu
13:45:29 <jasondotstar> there we go
13:45:43 <jasondotstar> email nmadhok if you're planning to attend.
13:45:44 <cznewt> #action newt to get the project governance status moved to official level
13:46:02 <jasondotstar> #action newt to get the project governance status moved to official level
13:47:03 <cznewt> I'll send details for all of the discussed matters
13:47:28 <cznewt> I think this is the best way to connect salt and openstack worlds on official levels
13:48:15 <nmadhok> @cznewt +1
13:48:22 <cznewt> I've been toying with cloudify-salt to get the TOSCA based deploys a possibility
13:49:38 <cznewt> and having the formulas official will make it a very interesting choice for a lot of people/companies
13:50:08 <nmadhok> Yes that's why I had concern about not using them
13:50:33 <nmadhok> since people might think it's not officially supported by SaltStack
13:50:41 <jasondotstar> +1
13:51:02 <jasondotstar> a path to making our salt formulas officially supported by saltstack is the way to go.
13:51:39 <cznewt> yes, there are strong reasons for
13:52:03 <nmadhok> There are some already out there like https://github.com/saltstack-formulas/keystone-formula
13:52:11 <nmadhok> We just need to rewrite these
13:52:18 <nmadhok> and make them work with the openstack-salt project
13:52:38 <jasondotstar> +1
13:52:46 <cznewt> I'm glad that we are having this kick off meeting
13:52:48 <cznewt> +1
13:53:33 <nmadhok> Some formulas will need to be deprecated
13:53:36 <nmadhok> like: https://github.com/saltstack-formulas/openstack-standalone-formula
13:53:48 <nmadhok> In favor of the official openstack-salt project
13:53:50 <cznewt> yes, the openstack formulas do not pose much of a problem, but there's more going on http://openstack-salt.tcpcloud.eu/develop/extending-ecosystem.html
13:54:14 <nmadhok> Yeah
13:54:55 <cznewt> yes, but my biggest concern is the metadata model, whis is very strictly consistent in openstack-salt
13:55:33 <cznewt> has some semantics, it't not juct a config values
13:56:07 <nmadhok> Check this: https://github.com/saltstack-formulas/apache-formula/blob/master/FORMULA
13:56:22 <nmadhok> Some formulas are already being converted to use Metadata
13:56:30 <cznewt> and 1 thing I'd like to mention, the containers
13:56:35 <nmadhok> This will make them easy to install using SPM
13:56:57 <nmadhok> SPM works similar to the way yum works
13:56:58 <cznewt> to have a way to deploy service to host, or to create a container out of the same sls
13:57:06 <nmadhok> so you could do spm install apache-formula
13:57:38 <nmadhok> it will use the metadata information to determine if it can be installed on the OS or not
13:57:59 <nmadhok> or if the formula needs to be updated or not
13:58:01 <cznewt> I've looked at spm already, I'll have to look deeper to see the advantage over os packages, we use neo
13:58:04 <cznewt> now
13:58:47 <cznewt> generally I dont like reinventing the wheel (as spm looks to me now)
13:58:54 <nmadhok> if we need to add some functionality into core Salt to make it work with openstack-salt, we can do that
13:59:13 <jasondotstar> we had a thread opened in the salt community as well
13:59:23 <jasondotstar> regarding standards,
13:59:29 <jasondotstar> but we can chat about that in channel.
13:59:38 <nmadhok> yeah. we just need to be careful about following project standards
13:59:46 <nmadhok> both openstack and salt
13:59:50 <cznewt> yes, time's running up
13:59:52 <cznewt> +2
14:00:02 <jasondotstar> ok guys
14:00:05 <cznewt> I'm offline today
14:00:07 <jasondotstar> good meeting
14:00:09 <cznewt> will mail you
14:00:13 <jasondotstar> until next week
14:00:14 <cznewt> yes!
14:00:18 <jasondotstar> #endmeeting