13:03:55 <jasondotstar> #startmeeting openstack-salt
13:03:56 <openstack> Meeting started Tue May 17 13:03:55 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:59 <openstack> The meeting name has been set to 'openstack_salt'
13:04:00 <jasondotstar> #topic roll call
13:04:02 <jasondotstar> o/
13:04:12 <nmadhok> here
13:04:17 <jasondotstar> hi nmadhok
13:04:25 <jasondotstar> ne1 else around?
13:04:30 <nmadhok> Don't think so
13:04:48 <nmadhok> Just the two of us until now
13:05:02 <nmadhok> Good morning jasondotstar
13:05:12 <jasondotstar> good morning
13:05:14 <jasondotstar> :-)
13:05:27 <nmadhok> Link to agenda for today
13:05:28 <jasondotstar> i'm going to ping around and see if we've got anyone else who will join...
13:05:28 <nmadhok> ?
13:05:35 <nmadhok> ok
13:05:45 <jasondotstar> im running behind a bit....
13:05:49 <jasondotstar> apologies
13:07:24 <genunix> o/
13:07:41 <cznewt> hello
13:07:47 <jasondotstar> hi there
13:07:50 <jasondotstar> #topic
13:07:53 <jasondotstar> #topic introduction
13:07:58 <cznewt> Sorry for the late arrival, I got stucked at a meeting
13:08:01 <jasondotstar> This meeting is for the openstack-salt team
13:08:03 <nmadhok> hello genunix and cznewt
13:08:08 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
13:08:16 <jasondotstar> Meetings are Weekly on Tuesdays at 1300UTC
13:08:24 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:08:32 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:08:39 <jasondotstar> #topic #topic Review past action items
13:08:46 <jasondotstar> #topic Review past action items
13:08:54 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-salt-weekly-meeting-20160517
13:09:06 <jasondotstar> late with the meeting etherpad too :-(
13:09:10 <jasondotstar> sorry abt that
13:09:26 <jasondotstar> if there's stuff you want to talk about, after we go through the last meeting items
13:09:32 <jasondotstar> feel free to add them there.
13:10:44 <jasondotstar> ok so i think much of what we discussed last week was around the openSUSE conf
13:11:07 <jasondotstar> and the idea that we need to somehow align the openstack-salt and the salt community efforts
13:11:39 <jasondotstar> everyone who joined the hangout session yesterday.... thanks. i think we had a spirited discussion around how we move forward
13:11:50 <cznewt> yes, I got an idea to introduce not conflicting formulas to salt-formulas namespace on github
13:12:33 <nmadhok> what do you mean by non conflicting?
13:13:28 <jasondotstar> one sec guys
13:13:42 <jasondotstar> let's see if we have any topics to discuss regarding last week
13:13:55 <nmadhok> sure
13:14:21 <jasondotstar> so, are we good with what is going to presented at the conf?
13:14:25 <jasondotstar> is there an update on that?
13:15:06 <nmadhok> I don't see any option to add a speaker. Still need to decide. The proposal I submitted that got accepted is around saltopenstack project
13:15:31 <nmadhok> Ales said he was going to register and see if he see's an option
13:15:35 <jasondotstar> that's your personal salt openstack project on github, yes?
13:16:01 <nmadhok> Sent a link last time to him. Not my personal but yeah supported by Salt community
13:16:05 <jpavlik> saltopenstack project under official?
13:16:09 <nmadhok> I worked on it pretty much
13:16:09 <jpavlik> what is the purpose?
13:16:14 <jpavlik> it is old
13:16:47 <nmadhok> Yeah there's some new stuff on it that I worked upon that's in a private repository
13:17:02 <nmadhok> This was before I came across openstack-salt project
13:17:24 <jpavlik> I think that we should get there salt-formula-swift and other stuff which is on roadmap
13:17:30 <jpavlik> what we are waiting for some time
13:17:46 <nmadhok> Let's discuss that today on what projects are needed
13:17:47 <jasondotstar> can you re src the link here?
13:17:53 <nmadhok> and what work needs to be done
13:18:01 <nmadhok> link to register you mean?
13:18:09 <jpavlik> both
13:18:13 <jpavlik> repo and registre
13:18:18 <jasondotstar> guys....
13:18:23 <jasondotstar> we've got an agenda
13:18:35 <jasondotstar> im just trying to go through it.
13:18:35 <nmadhok> #link https://events.opensuse.org/conference/oSC16
13:18:44 <jasondotstar> is this a link to the presentation?
13:18:47 <jasondotstar> or the conference
13:18:55 <jasondotstar> ?
13:18:59 <nmadhok> Sending link to presentation
13:19:02 <jpavlik> it is about conference
13:19:07 <jasondotstar> let's have a look at it
13:19:12 <jpavlik> not about accepting saltopenstack under official openstack-salt?
13:19:18 <nmadhok> #link https://events.opensuse.org/conference/oSC16/program/proposal/794
13:19:42 <nmadhok> Link above is the link to the proposal that was accepted
13:19:52 <jpavlik> OK, sorry. I was confused.
13:19:52 <jasondotstar> cool.
13:19:57 <nmadhok> I have another proposal but that's related to the VMware cloud driver for Salt that I created
13:19:57 <jpavlik> presentation is fine :)
13:20:42 <jasondotstar> cznewt: how's the governance stuff looking?
13:20:52 <nmadhok> saltopenstack is official from Salt's perspective but not OpenStack's perspective
13:21:06 <nmadhok> openstack-salt is official from OpenStack's perspective but not Salt's perspective
13:21:18 <jpavlik> nmadhok: yes that is correct.
13:21:20 <jasondotstar> we have to merge these two efforts
13:21:45 <jasondotstar> we can't have two parallel efforts in my opinion
13:21:45 <nmadhok> #agreed
13:22:04 <nmadhok> it's too much work maintaining two projects.
13:22:18 <nmadhok> But both projects support different OS distro
13:22:21 <nmadhok> I think?
13:22:22 <jasondotstar> if we can't come together on it, that's going to be a problem
13:22:25 <jpavlik> different os distro?
13:22:35 <jpavlik> openstack-salt support RHEL and DEBIAN
13:22:44 <nmadhok> saltopenstack tested on RHEL/Oracle Linux
13:22:47 <jasondotstar> it's obvious that we're done with last week's agenda
13:22:55 <nmadhok> The new version also tested on openSUSE and Debian
13:22:56 <jasondotstar> so let's just move to open discussion
13:23:01 <jasondotstar> #topic Open Discussion
13:23:05 <jpavlik> we can merge effort. nmadhokcan start contribute
13:23:09 <nmadhok> Yeah
13:23:17 <nmadhok> that's why I asked what needs to be done
13:23:23 <jasondotstar> my fault for not having an agenda
13:23:43 <nmadhok> and mentioned yesterday about having flexibility in the project
13:23:48 <jpavlik> nmadhok: saltopenstack is useless. It is another devstack. Can nmadhok take something what we need to solve
13:24:12 <jpavlik> like neutron compatability
13:24:29 <jasondotstar> nmadhok: do you want to work on this?
13:24:39 <nmadhok> I wouldn't call any project useless. Spent a lot of hours on it and made deployment easy for a lot of universities/people
13:25:04 <nmadhok> It's got it's own use case
13:25:14 <jpavlik> OK, but is developed by only one. Please continue in your usecase
13:25:27 <jpavlik> this is community who voted and get these formulas
13:25:42 <jpavlik> please join or continue in your way of implementation.
13:25:43 <nmadhok> Yeah that's true it's only developed by one
13:25:50 <nmadhok> didn't have anybody in community that time
13:26:04 <nmadhok> to work on the project with me
13:26:26 <cznewt> jasondotstar: governance is going super, got workflow + from thierry
13:26:48 <nmadhok> Not going to argue here and start yesterday's discussion all over again
13:26:55 <jasondotstar> no we don't need to.
13:26:57 <nmadhok> let's talk about what needs to be done and needs to be implemented
13:27:25 <nmadhok> it's not about joining or continuing "my" way of implementation
13:27:28 <jpavlik> can we vote? on next irc meeting
13:27:31 <jpavlik> to stop this discussion
13:27:41 <jasondotstar> what would you like to vote on?
13:27:43 <nmadhok> it's really for the community and not for "me" or "you"
13:27:58 <jpavlik> about use or stop saltopenstack repo
13:28:00 <nmadhok> so whatever's best for the community, I'm all in for that
13:28:42 <jasondotstar> what we have now is considered the official openstack salt formulas, yes?
13:28:55 <jasondotstar> would nmadhok, jpavlik, and cznewt agree?
13:29:01 <jpavlik> I need to solve real issues and vision of openstack-salt instead of dealing with someone personal repo
13:29:02 <cznewt> well, I'm not conviced that saltopenstack meets the criteria, give me evolution steps
13:29:37 <jasondotstar> again....what we have now is considered the official openstack salt formulas, yes?
13:29:52 <jasondotstar> we we have in the openstack-salt projects....
13:29:54 <cznewt> yes the openstack-salt is official openstack
13:29:57 <jasondotstar> who agrees?
13:30:06 <jpavlik> +1
13:30:13 <genunix> +1
13:30:14 <cznewt> the formulas for setting opestack services
13:30:18 <nmadhok> has anybody from SaltStack looked into the project yet?
13:30:29 <jasondotstar> nmadhok: not the question yet
13:30:37 <cznewt> +1
13:30:41 <jpavlik> +1
13:30:43 <jasondotstar> do you agree or disagree with the question
13:30:46 <nmadhok> Yeah I meant to pose that as the next question
13:30:47 <nmadhok> +1
13:31:09 <jasondotstar> ok so what we have now are the official openstack salt formulas
13:31:22 <jasondotstar> we already know the answer to your question
13:31:29 <jasondotstar> but let's ask
13:31:42 <nmadhok> I don't know the answer myself
13:31:51 <nmadhok> If someone from Saltstack looked into it yet
13:32:01 <jpavlik> Is it important?
13:32:04 <jasondotstar> who would agree that no one from the SaltStack community has looked at what we have?
13:32:08 <cznewt> well David Boucha
13:32:19 <jasondotstar> ok
13:32:25 <nmadhok> not Salt community, SaltStack as a company themselves
13:32:29 <nmadhok> I don't work for the company
13:32:35 <cznewt> saying something about it "being great" but not hearing eversince
13:32:47 <nmadhok> that's awesome
13:32:49 <jasondotstar> so 1 from the broader salt community
13:33:05 <jasondotstar> anyone else?
13:33:11 <cznewt> david is the top tech guy at salt company
13:33:15 <nmadhok> David works for Salt
13:33:24 <jasondotstar> anyone else???
13:33:31 <jasondotstar> we're at 1
13:33:37 <cznewt> we tried to push it to the salt community, but no response
13:33:46 * jasondotstar that point was coming
13:33:47 <nmadhok> Who did you contact?
13:33:55 <jasondotstar> hang on ppl
13:33:58 <jpavlik> What is the point? Can we create widely used solution for life cycle in OpenStack or invite people who wrote salt?
13:34:03 <jasondotstar> are we in agreement
13:34:12 <nmadhok> The idea is to get both communities together
13:34:13 <jasondotstar> that only one person has looked?
13:34:23 <cznewt> push the unconflicting formulas + linux to salt-formulas namespace and get the response from the community
13:34:29 <nmadhok> I don't care whose project it is (mine or yours). At the end of the day it's the community's project
13:34:30 <jpavlik> Idea is to be successful for openstack
13:34:43 <cznewt> jasondotstar: that is the only confirmed one
13:34:53 <jasondotstar> cznewt: THANK YOU
13:34:57 <nmadhok> jpavlik: correct
13:35:06 <nmadhok> but also for Salt
13:35:11 <jasondotstar> ok so we agree that the openstack-salt repos are the official ones
13:35:19 <jpavlik> +1
13:35:26 <nmadhok> If you're using Salt and don't have agreement of Salt community then it's not worth it
13:35:27 <jasondotstar> but, we've only had 1 person from the salt community take a look at what we have
13:35:27 <jasondotstar> ?
13:35:48 <jasondotstar> we all agree on these two points, yes?
13:35:57 <nmadhok> Correct
13:36:02 <jpavlik> I agree that 1 person took look
13:36:04 <cznewt> yes
13:36:22 <jasondotstar> ok.... cznewt as PTL, would you agree that for the benefit of OpenStack
13:36:30 <nmadhok> I can represent the Salt community but not SaltStack as a company
13:36:36 <jasondotstar> it's important that we consider what the greater salt community has to say
13:36:39 <nmadhok> so definitely you need someone from the company to agree as well
13:36:39 <jasondotstar> about what we've done?
13:37:10 <jpavlik> None from salt community was interested until now, when it starting to be offficial
13:37:13 <cznewt> but, I've pinponted points to be solved from the salt community formula side
13:37:25 <jasondotstar> #agreed the openstack-salt repos are the official repos for the Salt efforts within the OpenStack community
13:37:38 <jasondotstar> cznewt: did you see my question?
13:37:56 <nmadhok> Was anyone from Salt community (not the company) contacted about the effort?
13:38:07 <jpavlik> yes, you did not respond my team
13:38:08 <cznewt> yes, this goes both ways, we have a lot to say to community as well
13:38:18 <nmadhok> I only came to know about the project when I was going through my emails and saw Jason's email from January
13:38:42 <jasondotstar> you guys are bickering again.
13:38:51 <cznewt> as the guidelines for formulas structures are followed not well
13:39:06 <nmadhok> I'm pretty much open. I already said there are things that will need to be changed on the Salt Formula's side
13:39:18 <jasondotstar> cznewt: +1, we value salt's opinion, and salt should value ours
13:39:19 <jasondotstar> yes?
13:39:20 <nmadhok> But need everyone here to respect each other's work
13:39:21 <jpavlik> nmadhok: can you stop talking and create blueprint?
13:39:24 <jpavlik> as we aggreed?
13:39:25 <cznewt> yes
13:39:31 <nmadhok> I'm not building anything for my company
13:39:34 <nmadhok> or to make money
13:39:40 <jasondotstar> ok the best way for the salt guys
13:39:41 <nmadhok> I spent time doing things for the community
13:39:45 <nmadhok> So respect that
13:40:01 <cznewt> well we're desinging battle hardened solutions
13:40:04 <jpavlik> nmadhok: so respect rules. Create blueprint with suggestions
13:40:09 <nmadhok> Neither am I paid for it neither do I use the stuff I've worked on to make money
13:40:14 <jasondotstar> to give us their opinion as I mentioned before is to create a blueprint.
13:40:36 <nmadhok> And I agreed with that
13:40:39 <jpavlik> Can nmadhok stop talking until first blueprint appeared?
13:40:51 <cznewt> still there needs to be a quick research what effort is duped
13:40:51 <nmadhok> Any change that will need to be made, will require a blueprint
13:41:05 <nmadhok> Did I say I didn't agree with that?
13:41:33 <jasondotstar> yes.
13:41:38 <jasondotstar> in the meantime....
13:41:45 <nmadhok> I started today's conversation with what needs to be done for the openstack-salt project
13:41:57 <jpavlik> nmadhok: you cannot know that
13:42:02 <nmadhok> I can start looking into what features need to be added
13:42:08 <jpavlik> because you saw this yeasterday for firstime
13:42:11 <nmadhok> or what projects/formulas need to be worked upon
13:42:37 <nmadhok> I installed this yesterday for the first time. Looked at it sometime last to last week
13:42:52 <jpavlik> you are not managing this project. Can you let jasondotstar and cznewt manage this irc as ussually
13:42:55 <nmadhok> But can get upto speed
13:43:09 <nmadhok> Did I say I'm managing this project?
13:43:24 <nmadhok> I'm asking what needs to be done as a community user of the OpenStack community
13:43:32 <jpavlik> nmadhok: please create neutron ovs
13:43:37 <cznewt> well let's talk to topic
13:43:42 <jpavlik> this is wish of community
13:43:59 <cznewt> i'll look into the differences of opesntack-salt / community till next time
13:44:17 <jpavlik> we have a lot of work that needs to be done on functionality side
13:44:26 <jpavlik> nice salty leave for blueprint
13:44:27 <cznewt> then I have a testing deployments progress
13:44:45 <jpavlik> genunix: works on CI/CD with better testing now
13:44:55 <cznewt> with orchestration updates to test the gerrit review changes
13:45:59 <cznewt> jasondotstar: can you ples add me the action for the diff chcek
13:46:30 <jasondotstar> #action cznewt to investigate the differences between the openstack-salt project and the salt community project
13:47:09 <cznewt> as much as I like salt, the formulas part has been left free to play with vague rules to follow [and evolving through history]
13:47:14 <jasondotstar> are we going to be able to collaborate with each other?
13:47:20 <jasondotstar> this is getting ridiculous.
13:47:28 <cznewt> I'd like to see if we put some of our formulas how the community will react
13:47:40 <jasondotstar> cznewt: +1
13:47:51 <jpavlik> +1
13:48:17 <cznewt> nmadhok: what do you think?
13:48:37 <nmadhok> I'd like to see that too. But just getting rid of old formulas we have is not possible
13:48:54 <nmadhok> We need a deprecation workflow and slowly need to accommodate changes
13:49:21 <nmadhok> We have a large community that relies on the currently Salt formulas
13:49:25 <jasondotstar> neither one of these projects
13:49:25 <nmadhok> *current
13:49:49 <jasondotstar> belong to any one company or entity
13:50:02 <nmadhok> and most of the projects were started by the community, for the community and not by any company
13:50:34 <nmadhok> I just try to review and merge and fill the gaps
13:51:13 <jasondotstar> how are the puppet guys working together?
13:51:36 <jasondotstar> somehow, there is a workflow that allows the openstack puppet team to push their modules upstream
13:51:54 <nmadhok> OpenStack and Pupet work together
13:51:55 <jpavlik> we are openstack-salt community. We started and it is more than 15 people
13:51:58 <jasondotstar> right
13:52:07 <nmadhok> just like OpenStack community and Ansible community work together
13:52:09 <jasondotstar> i understand
13:52:20 <jasondotstar> but how do we take what we consider to be the official salt formulas
13:52:25 <jasondotstar> and push them upstream?
13:52:41 <cznewt> and the only problem is that community formulas do not comply with requirements we have, I'm figuring way to make it work
13:52:56 <jasondotstar> cznewt: we => 'OpenStack' ?
13:53:09 <cznewt> but this is the most shitty complex problem that I faced
13:53:12 <nmadhok> you need agreement of SaltStack employees and community for it to be considered official
13:53:17 <jpavlik> Can salt formulas look in same way? nmadhok start there
13:53:19 <jpavlik> then please come here
13:53:27 <cznewt> we as the openstack-salt team
13:53:34 <jpavlik> we are openstack-salt
13:53:39 <jpavlik> we have everything in same way
13:53:39 <jasondotstar> we are our requirements ?
13:53:50 <jpavlik> saltstack-formulas are differnet between themself
13:53:58 <jpavlik> nobody was able to start this project
13:53:58 <cznewt> nmadhok: i tried, I mailed you, I mailed salt guys
13:54:06 <jasondotstar> specifically what are the requirements that we have the differ from the salt community?
13:54:08 <jpavlik> we spent more than 6 month
13:54:16 <jpavlik> and now nmadhok come here start talking this?
13:54:17 <cznewt> and the response was not at all
13:54:19 <nmadhok> cznewt: I responded to your email but didn't get a response back
13:54:23 <jasondotstar> that's true we did reach out
13:54:31 <nmadhok> I don't represent Saltstack as a company but can definitely talk to them
13:54:34 <jasondotstar> and we've reached out on the forums too.
13:54:35 <jpavlik> please think about yourself
13:54:56 <jasondotstar> we need another person from the salt community
13:54:56 <jpavlik> I do not know any community where someone came and start put critism
13:55:16 <jpavlik> until any our added value
13:55:24 <jpavlik> I suggest to continue in our work
13:55:32 <nmadhok> Not putting any criticism here. But for something to be considered official between both communities, it has to be vetted by both communities
13:55:47 <jpavlik> nmadhok: SaltStack was not interested
13:55:55 <jpavlik> please do not waste our time
13:56:01 <jpavlik> we have to work on mitaka release
13:56:03 <nmadhok> Maybe there was a reason they were not interested?
13:56:10 <jpavlik> yes
13:56:13 <jpavlik> they do not have time
13:56:18 <jpavlik> and community is not one
13:56:25 <jpavlik> everyone does it in different way
13:56:31 <jpavlik> we do not want to be like salt formulas
13:56:35 <jpavlik> every is different
13:56:40 <jpavlik> so please fix your side
13:56:46 <jpavlik> then suggest something here
13:56:49 <jpavlik> who are you?
13:56:56 <nmadhok> OpenStack community user
13:57:08 <jpavlik> you did not know yesterday how to push review
13:57:13 <jpavlik> and now you are community user
13:57:18 <jasondotstar> ok, I can't continue. I think we're done.
13:57:19 <jpavlik> Please use stanard cannal
13:57:21 <jasondotstar> #endmeeting