13:01:25 <cznewt> #startmeeting openstack-salt
13:01:26 <openstack> Meeting started Tue May 31 13:01:25 2016 UTC and is due to finish in 60 minutes.  The chair is cznewt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:30 <openstack> The meeting name has been set to 'openstack_salt'
13:01:55 <cznewt> #topic roll call
13:02:07 <cznewt> o/
13:02:58 <genunix> o/
13:03:36 <cznewt> hello genunix :)
13:03:49 <cznewt> welcome from cold toscany
13:04:37 <genunix> Hello from Czech :-)
13:05:16 <cznewt> well, today it seems the attendance is small, so we'll make it quick
13:05:22 <cznewt> #topic introduction
13:05:34 <cznewt> This meeting is for the openstack-salt team
13:05:45 <cznewt> If you're interested in contributing to the discussion, please join #openstack-salt
13:05:50 <cznewt> Meetings are Weekly on Tuesdays at 1300UTC
13:05:55 <cznewt> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:06:01 <cznewt> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:06:21 <cznewt> #topic Review past action items
13:08:09 <cznewt> last time, the meeting was cancelled, but the issue discussed was alignment our work with salt stack community
13:08:55 <cznewt> if I may quote Thomas Hatch here: I don't think that we should look into merging these with our openstack states, yours are much more thought out and have had more time dedicated to being a unified design, so I would say to not try to merge. Your model looks very nice and is made in a highly reusable way, so I am all on board with saying that we over at Saltstack should look into updating how we push out openst
13:09:21 <jpavlik> hello all
13:09:28 <cznewt> hello latecommer :)
13:10:11 <cznewt> I just posted thomas reply to the integration of formula ecosystem of openstack-salt
13:11:15 <cznewt> the resolution is: we will make the formulas compatible with the latest standards
13:11:29 <cznewt> to comply with SPM, it is matter of one file
13:12:08 <cznewt> and then we will propose a standard interoperability guidelines for advanced formula metadata
13:12:29 <cznewt> #action newt: make sure formulas are SPM compliant and registered
13:12:53 <cznewt> #action cznewt make sure formulas are SPM compliant and registered
13:13:37 <cznewt> #topic Today's Agenda
13:14:09 <cznewt> the saltstack based docker image creation
13:14:22 <cznewt> can genunix or jpavlik tell us more?
13:15:27 <genunix> it's almost done :-)
13:15:43 <genunix> #link https://github.com/tcpcloud/docker-salt
13:16:22 <genunix> We've got images, jpavlik is now preparing docker-compose for simple dev setup and marco is working on Kubernetes setup.
13:16:42 <jpavlik> yes, we are almost done. This approach can be used for CI as well.
13:17:38 <cznewt> will we keep the dockerfiles in separate repository?
13:17:58 <cznewt> or include it within the formulas?
13:18:50 <genunix> I would keep it separate
13:19:21 <genunix> actually dockerfile is still the same, just the service name differs, so I would maybe simply generate it.
13:19:40 <jpavlik> docker compose is for docker-salt repository testing
13:19:41 <cznewt> yes, that is the most prefferable way
13:19:50 <jpavlik> nothing more
13:20:21 <jpavlik> docker-salt repo builds your containers by salt formulas and then you can launch them through one compose.yml
13:20:24 <jpavlik> for testing
13:20:46 <cznewt> regardung this: are there any services to add to openstack repos?
13:20:46 <jpavlik> target platform is still kubernetes
13:21:32 <jpavlik> https://review.openstack.org/#/c/322000/
13:21:37 <jpavlik> every service has this
13:22:04 <cznewt> shall we place the kubernetes and swift repos under the openstack CI?
13:22:20 <cznewt> do we agree that we should?
13:22:26 <jpavlik> yes
13:22:29 <jpavlik> definatelly
13:22:34 <jpavlik> kubernetes formula must out
13:22:37 <jpavlik> as well as swift
13:23:11 <cznewt> #action cznewt add kubernetes and switf repos to opesntack-salt project repos
13:23:40 <jpavlik> and what about docker-salt?
13:23:41 <cznewt> now the issue of salt documentation under docs.openstack.org
13:23:53 <jpavlik> do you think that it can be usefull?
13:23:58 <jpavlik> to put under openstak as well?
13:24:27 <cznewt> docker salt ... I'd put the scripts to openstack-salt repo and generate the dockerfiles
13:24:46 <cznewt> what does genunix think?
13:26:30 <cznewt> and there's one more repo that may be added under openstack and it is the metadata model containing repo with all possible deployment combinations
13:27:25 <cznewt> to test reviews for example, test all possible combinations of operating sysstem, openstack versions and networking and virtualization, etc ...
13:28:06 <genunix> dunno
13:28:10 <cznewt> But I'm not sure, but it can stay on github
13:28:25 <genunix> don't have an opinion yet :)
13:28:27 <cznewt> genunix: the last message goes to my previous messages
13:28:45 <cznewt> genunix: there are already several scripts
13:28:48 <genunix> it could go to openstack-salt when finished
13:29:03 <cznewt> yes, I think it will be the best spot
13:29:06 <genunix> I would wait before we are done
13:29:27 <cznewt> #agreed
13:29:29 <majklk> from my point of view, it doesn't matter where the scripts lives now when is under heavy development
13:29:48 <majklk> since stable release we can move it to the final location
13:29:50 <cznewt> yes, I see your point
13:30:01 <cznewt> hello majklk
13:30:10 <majklk> hi bro
13:30:13 <cznewt> nice to see you
13:31:13 <majklk> yes, miss you here
13:31:25 <cznewt> the docs.openstack.org, the documentation moving there, does anyone have time to look at it? I've made some progress but I'm stuck
13:31:58 <cznewt> if not, I'll have to push it
13:32:02 <jpavlik> push it
13:32:08 <jpavlik> it must be there
13:32:18 <cznewt> #action cznewt deploy the documentation to proper place
13:32:40 <cznewt> #action genunix finish the docker deployment scripts
13:33:02 <jpavlik> I need to leave now
13:33:05 <jpavlik> so thanks guys
13:33:45 <cznewt> bye jakob
13:35:26 <cznewt> we have made progress with deployments by heat and vagrant
13:35:59 <cznewt> it is under heavy finalisation
13:36:02 <cznewt> #link https://review.openstack.org/#/c/321260/
13:36:41 <genunix> good
13:37:22 <cznewt> it provides a way to test openstack-salt in any form, we need to get it documented thoroughly and prepare basic set of valid parameter combinations
13:37:56 <cznewt> we need to get it out for the community to test the review options
13:38:35 <cznewt> #action cznewt to document the changes to development deployments
13:39:10 <cznewt> this all from todays agenda
13:39:11 <cznewt> #topic Open Discussion
13:39:32 <cznewt> well we have 20 minutes to go
13:39:51 <cznewt> do you have anything more to discuss?
13:41:58 <cznewt> does anyone has anything else to say? [sounds like killbill quote :)]
13:45:23 <cznewt> well, I'll end the meeting then a little earlier, as I have a pressing issue to attend
13:45:37 <cznewt> thanks all
13:45:46 <cznewt> #endmeeting