13:01:16 <newt_> #startmeeting openstack-salt
13:01:17 <openstack> Meeting started Tue Jun 14 13:01:16 2016 UTC and is due to finish in 60 minutes.  The chair is newt_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:21 <openstack> The meeting name has been set to 'openstack_salt'
13:01:26 <newt_> #topic roll call
13:02:04 <majklk_> o/
13:03:37 <newt_> anyone else today?
13:03:43 <newt_> and hello majkl
13:04:19 <marco__> o/
13:04:22 <genunix> o/
13:05:01 <Guest56804> o/
13:05:30 <newt_> hello all
13:05:36 <newt_> #topic Introduction
13:05:43 <newt_> This meeting for the openstack-salt team
13:05:50 <newt_> if you're interested in contributing to the discussion, please join #openstack-salt
13:05:57 <newt_> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:06:03 <newt_> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:06:12 <newt_> #topic Review past action items
13:06:50 <newt_> the last meeting was cancelled due to the openstack-day preparations
13:07:20 <newt_> so we have issues from the previous event
13:07:48 <newt_> the SPM support for the formulas
13:09:08 <newt_> it is just an addition of meta descriptor file, Tux has updates on this issue
13:09:54 <newt_> To add support for the spm and register the formulas to appropriate repos
13:10:28 <newt_> the another issue is "document the changes to development deployments"
13:11:13 <newt_> we have finished the scripts to deploy various deployment options, we'll make proof of concept on neutron dvr setup
13:11:16 <epcim> hi there..
13:11:54 <epcim> newt_:  what is the agenda
13:14:16 <newt_> epcim: the isses from the past meeting now
13:14:27 <newt_> #link http://eavesdrop.openstack.org/meetings/openstack_salt/2016/openstack_salt.2016-05-31-13.01.html
13:16:00 <newt_> we need to test the orchestration platform it has multiple options to setup salt version, openstack version, networking, operating system, et
13:16:16 <newt_> it can even reference particular core review
13:17:09 <newt_> #action newt_ to test the new heat/vagrant provisioning
13:17:24 <newt_> the we have the "genunix finish the docker deployment scripts"
13:17:31 <newt_> can you tell us more?
13:18:08 <genunix> yes, it's done
13:18:20 <genunix> and available in tcpcloud/docker-salt repo
13:18:28 <newt_> on github?
13:18:32 <genunix> nightly images are built using our CI and published on docker hub
13:19:07 <genunix> yep
13:19:12 <newt_> how do you bootstrap the dockerfile, by flying cloud or generating dockerfile?
13:20:40 <genunix> #link https://github.com/tcpcloud/docker-salt
13:21:57 <newt_> yes, perfect, this is cool, not toying with bash scripts but alleviating the power of salt, great job!
13:22:39 <newt_> the last past issue is "cznewt add kubernetes and switf repos to opesntack-salt project repos"
13:23:27 <newt_> well i did not move one with this one yet as I put most effort to the testing suite and boostraping.
13:23:51 <newt_> ok now the recent issues
13:24:05 <newt_> #topic Today's Agenda
13:24:44 <newt_> does anyone have anything to share?
13:26:23 <genunix> Don't think so :)
13:26:29 <marco__> i started to work on midonet formula
13:26:51 <genunix> also note that we are working on xenial support in our formulas
13:27:35 <marco__> and also expanding neutron formula to support other networking plugins
13:27:38 <genunix> so we have salt formulas packages for xenial available from now on :-)
13:28:03 <newt_> yet another os/version option to handle :D
13:28:28 <marco__> is it possible to automatically test different versions of midonet with different versions of openstack?
13:28:50 <epcim> newt_:  how we will handle new interface names in new ubuntu 16.04 LTS. example: eth0 became ens3 (etc...) similary it must be already solved for rhel systems...
13:29:17 <newt_> this is to be solved by map.jinja
13:29:38 <newt_> basically there's a param default_interface
13:30:13 <newt_> I think genunix has also created a custom grain to get the default routed network's IP
13:31:04 <newt_> we can probably define the default_interface all the time [to be it eth0/dhcp] for most of cases and the eth0 to be set according to os_family/version
13:31:07 <epcim> however we want to name default / private / public /mgmt etc.. right?
13:31:35 <newt_> the nets do not have any trivial naming, just the device based
13:31:46 <newt_> interfaces
13:32:28 <epcim> newt_: btw isn't map.jinja going to be replaced by yamls?
13:32:37 <newt_> marco__: yes the openstack-salt now supports running multiple scenarios of various openstack version so you can test your stack with kilo, liberty or mitaka for example
13:33:25 <newt_> epcim: not that i know of, the jinja blocks in map.jinja may get replaced by yaml blocks but it will remain the same
13:34:17 <epcim> newt_: but since centos 7 interfaces has names based on the bus position instead of order of definition, thus if you will replace physical card in server to the NEW slot,  interface on that given server will has new name. Thus probably not a good idea to share it cross enironment
13:34:25 <newt_> marco__: we can discuss this in the channel I can walk you through the basic setup of the environment to test all the service combinations you want to test
13:35:50 <newt_> epcim: ok, can you look at how things are implemented in rh7 and propose changes if we get uncompatible?
13:36:04 <marco__> newt_: it would be great!
13:38:30 <newt_> marco__: I'll reach during this week
13:39:10 <newt_> I think Tux is trying to  make the orchestrations and bootstrap working
13:40:04 <Tux_> Yeah Im working on heat stacks and automatic tests of various combinations of operating systems, OpenStack versions and networking solutions
13:40:37 <marco__> great, I need this
13:40:47 <newt_> Tux_: can you provide support for testing the midonet formula and integration?
13:41:02 <newt_> setup the metadata and stacks
13:41:15 <newt_> marco__: do you test single or cluster deployments
13:41:16 <newt_> ?
13:41:42 <newt_> can the midonet be run from the same node as openstack-control services?
13:42:03 <Tux_> Ill look into it, is midonet formula available somewhere? Gerrit review maybe?
13:42:26 <marco__> newt_: I have currently cluster, but I am going to do single as well.
13:42:37 <newt_> it is not part of openstack-salt yet, so github
13:43:45 <epcim> newt_: ok will bring some approach to next meeting
13:43:50 <newt_> #action marco to provide support for testing midonet setup on heat stack
13:44:00 <marco__> I have midonet formula private for now, it is going out soon
13:44:44 <newt_> #action epcim to find out if our networking approach is rh7 compatible and suitable
13:45:14 <Tux_> marco_: OK, let us know when the repository gets public
13:45:35 <newt_> marco__: If you can put it on github it would help the process a bit :)
13:47:29 <newt_> Tux_: I review your orchestrating changes, please look at https://review.openstack.org/#/c/310945/2
13:47:47 <marco__> newt_: i will do that
13:47:59 <marco__> i have to g
13:48:05 <marco__> i will stay i touch
13:48:41 <Tux_> newt_: OK, Ill take a look at your proposed changes
13:48:47 <newt_> Tux_: and change the orchestration script accordingly, I'll help you if u get stuck in jinja hell
13:49:37 <newt_> ok we have last 10 minutes so we can now go wild
13:49:54 <newt_> #topic Open Discussion
13:52:17 <newt_> have anyone tried boron already?
13:53:13 <Tux_> Im going to fiddle with it today, I hope to see new changes in orchestration at work in stable version
13:54:05 <newt_> what version of salt do you try?
13:54:08 <Tux_> Btw did you talk about SPM today? I was bit late today. We could possibly use it as an option for OS Salt formulas, there are just deb packages at the moment, right?
13:55:00 <epcim> does anyone tested formulas on 16.04 LTS + liberty?
13:55:04 <newt_> the spm is sure way to go, we should add the support for spm formulas to all of our formulas and the salt formula as well
13:55:12 <newt_> what do you think?
13:55:37 <epcim> newt_: can you pleas point link to salt formula (portal, finder) where the SPM should be registered?
13:55:40 <Tux_> epcim: not yet
13:55:53 <genunix> epcim: it can't work very well
13:56:05 <genunix> epcim: there's mitaka in xenial
13:56:19 <genunix> epcim: to have liberty, you would need to pin packages.
13:56:34 <newt_> yes it's guite a 2 different worlds of packages
13:56:41 <genunix> epcim: which is like caress pet against fur.. :-)
13:56:48 <epcim> geniux how you pin packages today?
13:57:18 <newt_> genunix: We shall rename our team to dead poet's society :)
13:57:25 <daneel> +1
13:57:41 <genunix> indeed, +1 :-)
13:57:50 <Tux_> +1
13:58:21 <epcim> geniux how you pin packages today? | grep salt-formula- to file, and than reuse it to in apt-get install PKG =<version>
13:58:27 <epcim> +1
13:58:27 <silentpj> +1
13:59:00 <newt_> well I hope it's go ahead to make the spm working
13:59:09 <genunix> epcim: we do not use package pinning
13:59:30 <epcim> geniux: could we?
13:59:35 <newt_> #action Tux to add the SPM support to formulas and register to inverntory if there's any
13:59:51 <newt_> epcim: yes we can
14:00:07 <newt_> epcim: but it is difficult to maintain
14:00:15 <genunix> but we don't want, pets don't like it :-)
14:00:29 <newt_> epcim: but the nightly/test/stable works for pet's cattle alike
14:00:34 <newt_> well time's up
14:00:43 <newt_> we can continue in the channel
14:00:53 <newt_> thanks all
14:00:57 <newt_> #endmeeting