13:03:55 <newt_> #startmeeting openstack-salt
13:03:57 <openstack> Meeting started Tue Jun 28 13:03:55 2016 UTC and is due to finish in 60 minutes.  The chair is newt_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:00 <openstack> The meeting name has been set to 'openstack_salt'
13:04:24 <newt_> #topic roll call
13:04:32 <newt_> Hello everyone
13:04:35 <newt_> o/
13:06:00 <lelouch_> o/
13:06:02 <ovobora> \o/
13:06:05 <Tux_> o/
13:06:11 <osm> o/
13:06:18 <marco_> o/
13:06:30 <newt_> hello gentlemen
13:06:40 <epcim> welcome 3:-o
13:06:54 <ovobora> Greetings..
13:06:56 <newt_> epcim: hello  :)
13:07:15 <newt_> #topic Introduction
13:07:31 <newt_> This meeting for the openstack-salt team
13:07:41 <newt_> hif you're interested in contributing to the discussion, please join #openstack-salt
13:07:54 <newt_> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:08:09 <newt_> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:08:22 <newt_> #topic Review past action items
13:08:56 <newt_> At last, let's review, sorry for the slow pace, I'm testing a pointer instead of mouse
13:09:09 <ovobora> Umm, your mouse ran away, or?
13:09:23 * newt_ newt add midonet to openstack-salt formulas
13:09:53 <newt_> This is in review, both midonet and swift formulas
13:10:06 <newt_> will be up within the week
13:10:17 <newt_> next one
13:10:18 * newt_ Tux to add the SPM support to formulas and register to inverntory if there's any
13:10:30 <newt_> we have the SPM support ready
13:10:37 <newt_> how about the inventory
13:10:43 <newt_> have you found any?
13:12:41 <Tux_> newt_: I don't believe there is official SPM repository at the moment, but there may be in near future, here is discussion about this topic: https://github.com/saltstack/salt/issues/32253
13:13:02 <Tux_> #link https://github.com/saltstack/salt/issues/32253
13:13:33 <newt_> yes, can we help with this/is it worh it?
13:14:12 <Tux_> I don't know if this is necessary for OpenStack Salt project specifically, but it is sure valuable thing to do for Salt community in general
13:15:07 <newt_> Ok, let's postpone the decision SMP, as we do not use it as our delivery channel
13:15:29 * newt_ newt_ to test the new heat/vagrant provisioning
13:15:49 <Tux_> newt_: I have implementation of SPM source for formulas for our Salt formula in TODO list, but its not ready yet
13:16:15 <newt_> The automated orchestration, what is the status, did we get the basic scenarios running?
13:17:35 <Tux_> Salt Orchestrate solution itself is ready, but I had to use 2016.3 version of Salt, because of new features that heavily improves stability of the solution and I need to do some more debugging of this Salt version, as it is bit unstable atm
13:18:23 <newt_> This is critical for our mission
13:18:46 <newt_> Until the orchestration is up and running 100%
13:19:07 <newt_> we cannot guarantee the fully automated tests, right?
13:19:24 <newt_> what parts are the most problematic?
13:19:29 <Tux_> Well, it takes considerable amount of time to debug, fix and contribute to upstream, not to mention waiting for next packaged release to use in production environment later, so this will take some more time, but we are on good progress
13:20:48 <Tux_> Also complex testing is time consuming, because I have to run tens of states every time
13:20:57 <newt_> and what's failing?
13:21:10 <newt_> what formulas/setups?
13:22:37 <Tux_> After I resolved some RabbitMQ and GlusterFS issues, I'm facing issues with Galera formula, which is bit unstable by itself, so it needs complete overhaul I believe, I need to run full set of tests again to see if the rest is working already
13:23:11 <newt_> ok, sounds like cluster setup isseus
13:23:33 <Tux_> Galera failures are critical though, because almost all the following orchestration steps depends on database
13:23:46 <Tux_> Yeah, single setup should work correctly
13:23:47 <newt_> yes, we could use some extra hand with this
13:24:01 <newt_> to test the other setups
13:24:21 <newt_> anyone has spare time/want to try something new?
13:24:31 <ovobora> Sure :p
13:25:08 <epcim> \/o\
13:26:00 <newt_> ovobora: What setup can you test: vagrant/heat/docker?
13:26:20 <newt_> epcim: The same question, which setup would you like to test
13:26:27 <epcim> I was about to review vagrant deployment and update the docs with procedures to bootstrap the stack
13:26:28 <ovobora> Heat.
13:27:06 <epcim> I am working on adding CI (based on kitchen) to core components.
13:27:28 <newt_> ovobora: I'll give you credentials to our testing cloud
13:27:54 <newt_> epcim: kitchenci?
13:28:06 <epcim> newt_: I will test vagrant. May have a look on docker.
13:28:22 <newt_> yes this brings us to curent agenda
13:28:30 <newt_> #topic Today's Agenda
13:28:53 <newt_> we need to document the usage of docker-salt to deploy the openstack
13:29:07 <epcim> newt_: generally I am about to bring a documentation for easy bootstrap of the stack from the repos (not just into vagrant)
13:30:25 <newt_> I was thinking on expanding the documentation and add it aside the vagrant, heat
13:31:50 <epcim> sounds good, will take it
13:32:18 <newt_> #action epcim to document the docker deployment in openstack-salt documentatino
13:32:55 <newt_> and this brings us to another issue that is documentation build
13:33:59 <newt_> this is something I didn't do
13:34:17 <newt_> and I should have done
13:34:36 <newt_> #action newt_ to setup the pipeline to build the docs
13:35:06 <newt_> There are a few more blueprints
13:35:09 <newt_> undecided
13:35:19 <newt_> #link https://blueprints.launchpad.net/openstack-salt
13:35:31 <newt_> the support for ubuntu 16.04
13:36:16 <newt_> shall we proceed with support for 16.04
13:36:22 <newt_> and for what versions of openstack
13:37:16 <Tux_> We should support 16.04 and it should be for Mitaka release +
13:37:37 <epcim> agree, starting with mitaka ?
13:37:58 <newt_> +1
13:38:03 <lelouch_> +1
13:38:15 <epcim> +1
13:38:15 <ovobora> +1
13:38:16 <osm> +1
13:38:36 <newt_> Yes I'll update the blueprint
13:39:05 <newt_> and shall we support mitaka with 14.04 as well as 16.04?
13:40:09 <newt_> I'm not sure how it plays with 14.04
13:40:15 <epcim> ok
13:40:47 <marco_> mitaka is working with 14.04
13:41:16 <epcim> however who will use 14.04  in 6 months?
13:42:37 <epcim> rather keep up it with latest LTS, there is no reason to support latest OS for previosu LTS versions of system
13:43:16 <jpavlik> can we get salt-formula-kubernetes and docker-salt under official openstack repo? to be open
13:43:27 <jpavlik> this is only way how to bring attention of community
13:44:18 <newt_> hello jakob, nice seeing you
13:45:03 <newt_> we have agreed to add the docker-salt into the openstack-salt docs
13:45:16 <newt_> along the vagrant/heat deployments
13:46:09 <newt_> with the salt-formula-kubernetes, as it is becoming the integral part of our solution we should include it as well
13:46:22 <jpavlik> great
13:46:24 <jpavlik> this is the future
13:46:28 <newt_> last time we didn't make a clear decision
13:47:10 <newt_> and I was hesitant, but I think we should add it in openstack formulas
13:47:17 <newt_> what do you think?
13:47:19 <newt_> +1
13:47:28 <ovobora> +1
13:47:30 <jpavlik> +1
13:47:39 <marco_> +1
13:47:41 <Tux_> +1
13:47:43 <epcim> -1
13:47:46 <osm> +1
13:48:06 <jpavlik> amazing
13:48:31 <newt_> epcim: why do you disagree?
13:49:49 <epcim> ok why not, majority wins
13:50:16 <newt_> ok
13:50:34 <newt_> #action newt to add the salt-formula-kubernetes
13:51:03 <newt_> this is all from today's agenda
13:51:08 <newt_> now
13:51:24 <newt_> #topic Open Discussion
13:51:39 <newt_> please feel free
13:51:45 <newt_> to say anything
13:51:54 * liqw says hello ;)
13:52:01 <newt_> hello :)
13:52:11 <newt_> you have not voted :)
13:52:11 <jpavlik> hello
13:52:17 <Tux_> Hi
13:52:28 <liqw> i'm just read-only here
13:52:57 <newt_> we shall enroll you to to the team, if your bosses let you :)
13:53:23 <newt_> there was a nice progress with containers lately
13:54:43 <liqw> i'm quite not happy with containers +extra crap layer.. but .. yeah it's hype and i guess it helps some1
13:55:41 <newt_> we'll that is progress or how they call it :)
13:56:20 <newt_> so a quick recap, tune up the orchestration, update the docs with docker and get it published
13:56:41 <newt_> add the kube formula and test deployments
13:56:56 <newt_> anything else?
13:58:11 <newt_> well, nice meeting you guys, see you on channel
13:58:16 <newt_> #endmeeting