13:09:39 <cznewt> #startmeeting openstack-salt
13:09:40 <openstack> Meeting started Tue Jul 19 13:09:39 2016 UTC and is due to finish in 60 minutes.  The chair is cznewt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:09:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:09:43 <openstack> The meeting name has been set to 'openstack_salt'
13:09:52 <cznewt> hello everyone
13:10:15 <cznewt> sorry for the past meeting, I was sick and did not pass the chairmanship
13:10:25 <cznewt> who is present?
13:10:27 <cznewt> o/
13:10:43 <majklk> \o/
13:12:26 <lelouch_> O/
13:13:22 <cznewt> #topic roll call
13:13:27 <cznewt> hello everyone
13:13:44 <epcim> hi
13:13:46 <cznewt> #topic Introduction
13:13:52 <cznewt> This meeting is for the openstack-salt team
13:13:58 <cznewt> if you're interested in contributing to the discussion, please join #openstack-salt
13:14:01 <Tux_> o/
13:14:16 <cznewt> meetings are Weekly on Tuesdays at 1300UTC
13:14:24 <cznewt> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:14:29 <cznewt> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:14:39 <cznewt> Tux_: hello
13:14:47 <cznewt> epcim: hello
13:14:55 <Tux_> Hi
13:15:12 <cznewt> we have met in great numbers :)
13:15:17 <cznewt> #topic Review past action items
13:15:52 * cznewt newt_ to setup the pipeline to build the docs
13:15:57 <liqw> hi
13:16:00 <cznewt> this issue is done :)
13:16:04 <cznewt> liqw: hello
13:16:22 <cznewt> the documentation is now available at http://docs.openstack.org/developer/openstack-salt/
13:16:25 <cznewt> #link http://docs.openstack.org/developer/openstack-salt/
13:16:41 <cznewt> so please change the links at any references you see
13:17:15 <cznewt> I've fixed the wiki and formulas
13:17:33 <cznewt> the next is
13:17:34 * cznewt epcim to document the docker deployment in openstack-salt documentatin
13:17:43 <cznewt> how is progress on this one?
13:18:04 <epcim> I am doing a review of openstack-salt docs. vagrant deployment etc..
13:18:14 <epcim> docker is on list as well
13:18:32 <epcim> will have to fix docs to reffer new bootstrap scripts.
13:18:50 <cznewt> yes this is right
13:18:53 <epcim> and update bootstrap script to be capable of multiple consequence runs..
13:19:26 <Tux_> Yes I can do this
13:19:47 <cznewt> cool, when you will time?
13:20:30 <epcim> Week or two (depends on when we give a birth ;)
13:20:32 <Tux_> I will look at it tonight, its on my wishlist for the past few weeks now
13:21:24 <cznewt> Tux_: great I'll send you a link to blueprint on this issue
13:21:28 <epcim> I do have kitchenCI init script to , auto-generate, introduce this kind of platform reharsal for openstack salt formulas.
13:22:03 <cznewt> #action tux to update the documentation on bootstrap for vagrant and docker
13:22:18 <cznewt> epcim: let's go over past issues first
13:22:29 <cznewt> we'll get to your point in a minute
13:22:42 <cznewt> the last past action is ACTION: newt to add the salt-formula-kubernetes
13:22:50 <epcim> As of now, it;'s passing tests for nova, neutron. Working on Swift and cinder. Expecting in a week I push it for review. Discussion expected..
13:22:53 <cznewt> i've not yet started the process
13:23:12 <cznewt> but i will this week
13:23:19 <cznewt> #action newt to add the salt-formula-kubernetes
13:23:45 <cznewt> #topic Today's Agenda
13:24:29 <cznewt> epcim: do you have some results to look at? can we setup blueprint to give it more contrete use-cases?
13:25:14 <epcim> as of now, there is cookiecutter internal template and script, but as we have /tests/pillars - now the init script use these to define/generate test suites
13:26:01 <epcim> individual formula run a salt-call, but as we have CI in docker, the services are not started (dependency related constrains)...
13:26:54 <cznewt> this is something we can see further to test the individual services as well as complete systems
13:27:07 <cznewt> both in virtual-machine and container way
13:27:23 <epcim> .. not an trivial way to provision "component" dependencies without proper metadata.. It's expected to test n-tier infrastructures (or rather say n-applicaton composition) for the whole openstack stack
13:28:44 <cznewt> the openstack-salt project has the multi-openstack deployment metadata ready for use to solve this kind of test requirements
13:29:18 <cznewt> by actually deploying the control plane on virtuals or to containers
13:30:21 <cznewt> there are setups for local deployments by vagrant or cloud by heat and the docker which should be local and cloud/heat as well
13:30:38 <apuimedo> cznewt: what's the status of salt-formula-kubernetes?
13:31:47 <cznewt> apuimedo: the formula is being tested and can automate provisioning of kubernetes clusters and containers [services] running on top
13:32:21 <cznewt> it is not yet production ready, needs some polishing, but it is getting there rather quickly
13:33:05 <cznewt> this is something that needs much better documentation for start
13:33:25 <epcim> cznewt: surely - we expect to use heat templates to provision infrastructure and that use custom bootstrap scripts (that download/setup formula dependencies) and later use scripts or later salt orchestrate to spin up the whole thing..
13:35:16 <cznewt> yes this is exactly what we provision for vms now [bootstrap, orchestrate], the local docker/cloud kubernetes deploy is under way, it is testable but not yet integrated with heat setups
13:37:41 <apuimedo> cool
13:37:44 <apuimedo> thanks cznewt
13:38:05 <apuimedo> I'd love to see the documentation
13:39:14 <cznewt> apuimedo: you can start at the https://github.com/tcpcloud/docker-salt
13:39:55 <apuimedo> cznewt: děkuju :-)
13:40:29 <cznewt> and we'll setup a heat stack that installs the kubernetes cluster with openstack control plane
13:40:41 <cznewt> apuimedo: kdo tam? :)
13:42:12 <cznewt> action create deployments for docker and kubernetes and synchronise with Tux on docs
13:42:17 <cznewt> #action create deployments for docker and kubernetes and synchronise with Tux on docs
13:43:06 <cznewt> we'll do we have any more issues?
13:43:08 <apuimedo> cznewt: kuryr devel
13:43:52 <apuimedo> I'm just checking deployment options for kuryr-kubernetes
13:45:12 <cznewt> kuryr-kubernetes works with what neutron backends?
13:45:18 <epcim> leaving.. too busy ... see u.
13:45:32 <apuimedo> cznewt: so far we've prototyped with midonet
13:45:44 <apuimedo> but should work at least with ovs ref impl
13:45:44 <cznewt> do you look for a way to setup complex testing environment?
13:46:11 <apuimedo> we have ad-hoc containers now using https://github.com/midonet/midonet-sandbox
13:46:32 <apuimedo> but as we upstream the prototype, using some existing openstack project for the CI would be good
13:46:46 <apuimedo> so either kolla, openstack salt, etc
13:47:21 <cznewt> we deal a lot with contrail setups
13:47:30 <cznewt> have you seen our midonet formula?
13:48:02 <apuimedo> I did, mceloud did it, IIRC
13:48:22 <cznewt> yes we can setup more complex environment using midonet network neutron backend
13:48:24 <apuimedo> but I've not tried it yet
13:49:19 <jpavlik> hello all
13:49:21 <cznewt> I have to check that we have the proper metadata for the midonet networking
13:49:34 <cznewt> so we can launch it as any other stack
13:49:35 <jpavlik> I developed midonet formula with marco
13:49:43 <apuimedo> cool!
13:49:46 <apuimedo> thanks for that
13:50:19 <jpavlik> readme provides sample pillars
13:50:35 <cznewt> apuimedo: if you are interested we can work to gether to get the kuryr salted
13:50:51 <apuimedo> jpavlik: did you try it together with the kubernetes formula? (I guess not, since the k8s - midonet integration is a prototype)
13:51:02 <jpavlik> not yeat
13:51:03 <apuimedo> cznewt: that sounds interesting
13:51:18 <jpavlik> we have calico, flannel contrail
13:51:26 <apuimedo> jpavlik: for k8s?
13:51:33 <jpavlik> yes
13:51:38 <apuimedo> cool
13:51:38 <cznewt> so you can setup it as integral part of the deployment process and have openstack+mido and kube along with networking managed by the kuryr
13:51:38 <jpavlik> we can add midonet as well
13:51:55 <apuimedo> cznewt: right
13:51:57 <cznewt> if I get it right, I'm not too much a network guy :)
13:52:03 <jpavlik> we tested midonet with openstack only
13:52:15 <apuimedo> we have midonet getting providing the networking for both OSt and k8s pods and services
13:52:25 <jpavlik> I know that there is some beta
13:52:27 <cznewt> jpavlik: and this is the openstack+midonet - kubernetes binding
13:52:37 <apuimedo> s/getting//
13:52:44 <jpavlik> have you tested kuryr with k8s and openstack on midonet?
13:52:52 <cznewt> it should pass well as we can provide more neutron backend setups to test the kuryr against
13:52:56 <apuimedo> jpavlik: yes, doing it all the time
13:53:14 <apuimedo> but with haproxy as the lbaas driver
13:53:24 <jpavlik> this is interesting
13:53:27 <apuimedo> do you have neutron lbaasv1 in the salt formulas?
13:53:43 <jpavlik> so you have single network spread between kubernetes and openstack
13:53:50 <apuimedo> jpavlik: right
13:53:57 <apuimedo> that's the kuryr vision
13:54:09 <apuimedo> swarm + k8s + ost all backed by the same net
13:54:37 <jpavlik> interesting
13:54:44 <apuimedo> I hope so :-)
13:54:53 <jpavlik> so we can tested this
13:55:00 <apuimedo> cool
13:55:08 <jpavlik> last time midonet guys told us that this should be in the end of year
13:55:29 <apuimedo> jpavlik: I'm talking about a prototype, it didn't hit kuryr-kubernetes upstream repo yet
13:55:40 <jpavlik> OK
13:55:47 <jpavlik> where I can contact you?
13:55:53 <apuimedo> for the upstreaming work I want to have a good deployment tool for the CI
13:56:02 <apuimedo> jpavlik: I'll query you
13:56:16 <jpavlik> OK thanks
13:56:18 <jpavlik> let me know
13:56:53 <cznewt> apuimedo: cool, I'd like to discuss the kuryr formula
13:57:03 <apuimedo> cznewt: thanks
13:57:08 <apuimedo> cznewt: do you have a channel?
13:57:18 <cznewt> and how it could fit, #openstack-salt
13:57:42 <jpavlik> great
13:57:49 <apuimedo> thanks cznewt, joining
13:57:49 <jpavlik> kuryr formula would be awesome
13:57:55 <cznewt> apuimedo: you are welcome, this is what the openstack-salt is for :)
13:58:12 <apuimedo> :-)
13:58:18 <cznewt> well time is running low
13:58:47 <cznewt> #action apuimedo to contact jpavlik about the kuryr integration
13:58:56 <cznewt> #topic Open Discussion
13:59:19 <cznewt> we have free discussion now
13:59:37 <cznewt> any more thoughts to share?
14:00:11 <cznewt> ok, it's all for today
14:00:18 <cznewt> thank you gentlemen
14:00:21 <cznewt> #endmeeting