15:01:26 <TravT> #startmeeting openstack search
15:01:27 <openstack> Meeting started Thu May 28 15:01:26 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:31 <openstack> The meeting name has been set to 'openstack_search'
15:01:39 <ativelkov> o/ :)
15:01:44 <sigmavirus24> o/
15:01:46 <kragniz> o/
15:01:51 <TravT> o/ :)
15:01:52 <david-lyle_> o/
15:01:53 <smc7> morning!
15:01:53 <nikhil_k> o/
15:02:01 <rosmaita> o/
15:02:06 <nikhil_k> Exciting day!
15:02:11 <sigmavirus24> "OpenStack Search: The Search for a working OpenStack installation" ;)
15:02:20 <david-lyle_> lol
15:02:28 <krykowski> o/
15:02:34 <TravT> sigmavirus24, let's not get too crazy here
15:02:36 <sigmavirus24> That'll be airing weekly on Fox after American Idol I think
15:02:38 <jokke_> o/
15:03:03 <TravT> allirght, well looks like we have a good crowd!
15:03:08 <kragniz> sigmavirus24: lol
15:03:24 <TravT> here's the agenda I proposed: https://etherpad.openstack.org/p/search-team-meeting-agenda
15:03:46 <TravT> we officially got this added to the meeting list last night.
15:04:09 <nikhil_k> \o/
15:04:17 <TravT> just under the generic name "search"
15:04:28 <TravT> so, naming will be an important topic.
15:04:48 <TravT> #topic Summit Review
15:05:04 <TravT> we had two sessions on this at the summit.
15:05:14 <TravT> one in the Glance fishbowl and one in the horizon fishbowl
15:05:34 <nikhil_k> Does anyone have links handy?
15:05:57 * nikhil_k scutters
15:06:20 <TravT> david-lyle: do you have that link for horizon/
15:06:21 <TravT> ?
15:06:31 <david-lyle_> I'll find it, wrong laptop
15:06:35 <kragniz> this one? https://etherpad.openstack.org/p/YVR-horizon-performance
15:06:40 <rosmaita> waiting for etherpad to respond so i can see if i have the correct link
15:06:43 <nikhil_k> https://etherpad.openstack.org/p/catalog-index-service-liberty
15:06:48 <TravT> that looks right
15:07:10 <TravT> not much was captured on the etherpad I think.
15:07:20 <david-lyle_> #link https://etherpad.openstack.org/p/YVR-horizon-performance
15:07:26 <david-lyle_> oops
15:07:32 <david-lyle_> thanks kragniz
15:07:44 <TravT> But overall, my impression was that we had very positive feedback in both sessions.
15:07:54 <rosmaita> that was my impression as well
15:08:18 <mclaren> agreed
15:08:19 <ativelkov> "Shut up and take my money" comment was awesome :)
15:08:39 <TravT> ativelkov: :)
15:08:47 <sigmavirus24> thirded
15:08:53 <smc7> :)
15:09:15 <TravT> a number of us had side conversations as well
15:09:35 <TravT> kragniz: mclaren: want to share anything about the conversation with the swift guys?
15:10:00 <mclaren> um, sure
15:10:17 <mclaren> there's been some prior discussion on search for swift, eg see https://etherpad.openstack.org/p/liberty-swift-metadata-search
15:10:21 <sigmavirus24> Was it "Swift is fast and this will slow us down so, no"?
15:10:54 <mclaren> to quote rosmaita 'swift was built for comfort not for speed' :-)
15:11:02 <rosmaita> mclaren: +1
15:11:28 <mclaren> but anyway, John Dickenson (swift PTL) actually brought the topic up (rather than other way around)
15:11:51 <mclaren> so, I'm not sure how high it is on their list of priorities, but they do seem interested
15:12:14 <TravT> yeah, it was interesting.  they tried to track us down for that session the next day.
15:12:15 <mclaren> Just need to find out more about that existing spec, and the degree to which they'd be willing to work with us
15:12:32 <smc7> that they're adding notifications is a good first step
15:13:13 <nikhil_k> afaik, swift uses lightweigth DBs like sqllite. Wondering what their intent to restructure the scheme here is?
15:13:26 <TravT> Yes, so i think that'll be an area to explore in the coming the weeks.
15:13:30 <nikhil_k> Also, these DBs are distributed
15:13:56 <nikhil_k> Looks like an interesting topic
15:14:11 <TravT> i also attended the big tent meeting and spoke with a number of TC / board members
15:14:45 <TravT> it seems that we just need to get a few ducks in a row and then can propose the project to go under openstack governance
15:14:59 <TravT> which leads to the next topic
15:15:00 <kragniz> TravT: did that show some light on going into stackforge vs straight into openstack?
15:15:18 <TravT> straight into openstack
15:15:22 <kragniz> cool
15:15:32 <mclaren> fwiw my understanding is the swift dbs are just sqlite dbs which are kept in sync by replication
15:15:40 <nikhil_k> kragniz: straight into openstack has some nice process. That can be found in the governance repo
15:15:58 <TravT> so we might as well jump to that topic.
15:16:06 <TravT> #topic openstack governance
15:16:21 <TravT> #link: http://governance.openstack.org/reference/new-projects-requirements.html
15:16:50 <nikhil_k> mclaren: yep, though these are file like entities and indexing can be tricky unless we have good connectors to the indexer from file. Update model via notification would help here.
15:17:21 <TravT> there are a number of requirements to be considered.
15:17:27 <TravT> chief among them is openness
15:18:06 <TravT> and from my conversations with people like monty and jay pipes, since we developed this all to date under Glance, we already meet those criteria
15:18:20 <nikhil_k> I think your proposal covers most if not all of these, TravT
15:19:11 <TravT> however there are a few things to take care of.
15:19:26 <TravT> which i've started to capture on this etherpad
15:19:27 * nikhil_k is staring at Keystone support
15:19:35 <TravT> #link https://etherpad.openstack.org/p/liberty-searchlight
15:19:51 <TravT> and thank to everybody for starting to jump in on it
15:20:20 <nikhil_k> ++
15:21:01 <TravT> we proposed the name searchlight initially
15:21:37 <TravT> but as you all probably know, we need to consider trademark
15:22:09 <david-lyle_> namechanges aren't the end of the world, maybe go with searchlight until there is a problem?
15:22:10 <TravT> So, on that etherpad, you can put some alternate ideas up
15:22:25 <nikhil_k> :)
15:22:53 <TravT> david-lyle_: probably not a bad idea.
15:22:58 <david-lyle_> because without vetting the list, we won't know if an obscure name is ok either
15:23:13 <nikhil_k> david-lyle_: I think that makes sense. There is that small risk of losing some emails on ML until people change their filters but then we all are available on IRC :-)
15:23:17 <smc7> let's try and get through to the openstack lawyers but if we've not heard by tomorrow just go with searchlight?
15:23:29 <mclaren> TravT: any idea of lawyer turnaround time on searchlight?
15:23:38 <david-lyle_> good to have alternatives that could potentially go through review at the same time, so we have a fallback
15:24:00 <TravT> yeah, so we contacted HP's attorney and it kind of is a black hole.  not sure where it is
15:24:05 <nikhil_k> Can we tag [all] in the emails for now?
15:24:17 <TravT> david-lyle_: suggested contacting jonathan bryce directly
15:24:24 <mclaren> TravT: ok (not hugely surprised)
15:24:34 <david-lyle_> TravT, any success?
15:24:40 <TravT> i sent private message to him yesterday, but just got an "away from keyboard message"
15:24:42 <nikhil_k> I doubt if anyone else is looking for this name in stackforge/openstack-big-tent but good to check there too
15:24:51 <TravT> i will try again after this meeting
15:25:19 <nikhil_k> TravT: I know someone who can get us there. So, if no luck we can try that route.
15:25:29 <david-lyle_> TravT, or go through another foundation employee
15:25:33 <sigmavirus24> yeah
15:25:50 <sigmavirus24> VanL is a Foundation person iirc and can probably help research this too
15:26:06 <rosmaita> sigmavirus24: and he is a lawyer
15:26:07 <nikhil_k> and he has Law degree too
15:26:26 <sigmavirus24> I was hoping "can probably help research this too" would imply that ;)
15:26:30 <david-lyle_> it's only been a day with jbryce, we can probably give it a little more time
15:27:11 <TravT> so do you guys know VanL?
15:27:33 <sigmavirus24> TravT: sort of? He works for Rackspace
15:27:50 <rosmaita> we are all friends & family
15:27:50 <sigmavirus24> Oh, maybe he's just a defcore person and not a foundation person
15:28:42 <TravT> okay, how about I reach out the jbryce again right after this meeting, but it couldn't hurt for you guys to check in with VanL as well.
15:28:44 <david-lyle_> we should move on, there's many ways to move contacting jbryce forward
15:29:25 <TravT> And then how about if we don't have explicit "no" that we go with searchlight for a name and go ahead and create base wiki's and irc room with it?
15:29:32 <mclaren> so we wait a period of time 'x' and then just start with searchlight?
15:29:33 <TravT> by end of Friday
15:29:38 <TravT> ?
15:29:47 <david-lyle_> +1
15:29:51 <smc7> +1
15:29:54 <mclaren> sure
15:29:57 <sigmavirus24> +1
15:30:03 <nikhil_k> TravT: I recommend giving people the weekend to catch up on email
15:30:15 <nikhil_k> may be Monday morning ?
15:30:23 <TravT> that seems reasonable
15:31:18 <TravT> so there are a few other items to do before submission
15:31:29 <TravT> #topic new repo for CIS code
15:31:41 <TravT> smc7 and lakshmiS have been working on this
15:31:47 <TravT> smc7 can you give an update?
15:31:51 <smc7> sure
15:31:51 <kragniz> I had a look through uk trademarks - https://www.ipo.gov.uk/tmcase/Results/4/EU009148404
15:32:17 <smc7> like i said in the email, the intent's to get to functional parity with the code in glance, but with references to glance removed
15:32:32 <sigmavirus24> kragniz: close but no cigar
15:32:46 <smc7> the code in github now indexes glance images with tests and pep8 compliance. i intend to add metadef support today or tomorrow but then i don't intend to do any changes until we're in gerrit
15:33:00 <TravT> smc7, can you give a link?
15:33:13 <smc7> https://github.com/lakshmisampath/searchlight
15:33:33 <smc7> so what we'll (hopefully) import into openstack will very closely match what's in glance
15:33:41 <sigmavirus24> smc7: makes sense
15:33:56 <smc7> i'd really like to wait til we're in gerrit to comply with the openness model, but people can feel free to start filing bugs etc
15:34:04 <TravT> yeah, we don't want to do any new work outside of gerrit worfklow.
15:34:06 <smc7> they just might not get acted on for a bit
15:34:13 <david-lyle_> keystone support is a requirement
15:34:15 <kragniz> smc7: wouldn't it be nice to maintain the current git history?
15:34:23 <nikhil_k> == david-lyle_
15:34:27 <nikhil_k> I was surprised
15:34:31 <smc7> kargniz - it's mostly just one big commit in glance
15:34:37 <smc7> we do support keystone
15:34:46 <david-lyle_> have yet to look through the repo
15:34:50 <david-lyle_> smc7, ok
15:35:00 <nikhil_k> smc7: for all APIs? including indexing?
15:35:05 <TravT> so, remember, we aren't separating metadefs from glance.
15:35:11 <kragniz> smc7: okay, I was eyeing up that "Change README to RST format" commit
15:35:15 <david-lyle_> ah, because it was a separate service before
15:35:35 <smc7> err.. yes, on all three counts
15:35:36 <sigmavirus24> TravT: right
15:35:54 <nikhil_k> very important point TravT !
15:36:24 <mclaren> is there currently keystone support for the api requests to the CIS port?
15:36:24 <smc7> yes - but we'll still be indexing metadefs
15:36:40 <smc7> from e.g. horizon, mclaren? yes
15:36:48 <smc7> it's very similar to any other openstack API
15:36:59 <mclaren> ok, so keystone support = check
15:37:38 <smc7> yep
15:37:51 <TravT> so, i'm not entirely clear how it goes from this github repo to an openstack one.
15:37:56 <TravT> even though i asked about a dozen people
15:38:13 <TravT> the impression i was given is that they can just import it
15:38:27 <TravT> dhellman offerred to help
15:38:28 <kragniz> TravT: there's some import thing where you tell infra where to clone from
15:38:31 <smc7> ativelkov - do you know the process murano went through?
15:38:38 <david-lyle_> #link http://docs.openstack.org/infra/manual/creators.html
15:39:01 <TravT> i think ativelkov dropped, unfortunately
15:39:03 <smc7> ah, even better
15:39:44 <TravT> ok, we'll need to study that.
15:40:03 <david-lyle_> but it doesn't explicitly say how to seed the repo
15:40:07 <kragniz> david-lyle_: that's some good documentation!
15:40:17 <smc7> "If you have an existing repository that you want to import"
15:40:19 <david-lyle_> infra means business
15:40:28 <TravT> we had several people tell us as long as it is in a repo, infra can import.
15:40:34 <smc7> http://docs.openstack.org/infra/manual/creators.html#adding-the-repository-to-the-ci-system
15:40:38 <kragniz> `upstream: git://github.com/awesumsauce/<repositoryname>.git`
15:40:39 <kragniz> in gerrit/projects.yaml
15:40:40 <TravT> monty said to not first go into stackforge.
15:40:49 <mclaren> kragniz: +1
15:40:54 <smc7> yeah, looks like it doesn't matter where it originates
15:40:56 <david-lyle_> kragniz, right
15:42:04 <sigmavirus24> TravT: I agree with monty
15:42:15 <TravT> hmm... so i wonder if we do that before submitting the governance projects yaml patch.
15:42:27 <sigmavirus24> TravT: same time maybe?
15:42:56 <TravT> sigmavirus24: that would make some sense.
15:43:01 <kragniz> TravT: after the governance projects is merged, I think
15:43:02 <nikhil_k> I think infra might stick on goverance first (that's a hunch though) they are very particular
15:43:26 <TravT> ok, then we should talk about that
15:43:34 <TravT> #topic governance repo
15:43:44 <TravT> on this same page
15:43:45 <TravT> https://etherpad.openstack.org/p/liberty-searchlight
15:43:52 <david-lyle_> you need approval for using the namespace before adding to it
15:44:05 <TravT> i put a possible draft for what to submit to the projects yaml
15:45:00 <TravT> I kept the first pass at mission statement very simple.  Most other projects are pretty simple
15:45:27 <TravT> looks like nikhil_k suggested adding index to it
15:45:36 <TravT> what do you all think?
15:45:47 <nikhil_k> Yeah, it used to be CIS (C "Index" S) :-)
15:46:48 <smc7> i'm in favor of adding that
15:46:54 <TravT> Current: To provide advanced and scalable search across multi-tenant cloud resources.
15:47:02 <TravT> Possible: To provide advanced and scalable indexing and search across multi-tenant cloud resources.
15:47:11 <david-lyle_> does the implementation detail matter in the mission statement?
15:47:12 <mclaren> simple is good.
15:47:20 <nikhil_k> Can we quickly discuss pros and cons?
15:47:30 <TravT> please
15:47:46 <nikhil_k> david-lyle_: I think sorta yes
15:48:18 <TravT> david-lyle_: you can also look through the other projects mission statements here  https://github.com/openstack/governance/blob/master/reference/projects.yaml
15:48:20 <nikhil_k> The reason being, it defined the scope and direction. I was happy to see TravT pointing out in the summit that we are going with ES based search in the presentation.
15:48:30 <nikhil_k> defines**
15:49:00 <mclaren> we're just indexing and searching openstack service metadata rather than of the documents themselves? (AWS has a search service for searching inside documents like pdf etc)
15:49:09 <rosmaita> i think a key aspect of the project is the plugins or whatever that will allow indexing of other projects
15:49:21 <nikhil_k> A few comments that we received in Glance in Kilo were that it was a simple ES proxy, thought that might be a good thing. However, as a separate program we need to be clear and loud about it.
15:49:47 <david-lyle_> nikhil_k, I agree that ES is the base technology, whether it's important to call that out (shrug)
15:50:07 <sigmavirus24> mclaren: I believe so
15:50:08 <nikhil_k> The API would get defined by it, I think
15:50:16 <david-lyle_> but adding indexing isn't bad, and mission statements can be altered in time if necessary
15:50:44 <rosmaita> +1 adding indexing
15:50:52 <nikhil_k> That makes me wonder if we should consult API-WG for some API guideline while that happens. I can volunteer to go for that discussion.
15:50:57 <TravT> regarding ES.  i definitely don't want us to be inventing a new lowest common denominator language.
15:51:31 <TravT> however, at best we could support the plugins declaring a type of backend syntax they'll accept
15:51:36 <TravT> initially only elastic search
15:51:52 <rosmaita> TravT: yes, the potential consumers i have spoken with definitely want ES, not some kind of openstack query language
15:51:52 <sigmavirus24> I think perhaps we shouldn't plan for that
15:52:03 <sigmavirus24> We should try to build what we can for a liberty release
15:52:03 <smc7> yes, far distant future
15:52:13 <TravT> sigmavirus24: i like that line of thinking
15:52:14 <sigmavirus24> And in a distant future support other providers than elasticsearch
15:52:17 <nikhil_k> TravT: That being the main reason ,for me being pro indexing in mission stmt. We do not want people prosing sessions in summit that have dozens of people who can to reinvent stuff. You can never be sure what the other side of the worlds is thinking
15:53:16 <nikhil_k> proposing**
15:53:18 <TravT> ok, i like adding indexing to it.
15:53:21 <TravT> is this enough?
15:53:23 <TravT> To provide advanced and scalable indexing and search across multi-tenant cloud resources.
15:53:26 <TravT> or more specific?
15:53:42 <sigmavirus24> I'm okay with just that
15:53:44 <kragniz> TravT: that sounds pretty good
15:53:51 <TravT> seems we should do a formal vote here to record it.
15:53:53 <david-lyle_> works for me
15:53:57 <smc7> yep, good with me
15:54:00 <nikhil_k> (That was a very ill formed suggestion from me)
15:54:00 <TravT> anybody know how to make that work?
15:54:01 <sigmavirus24> TravT: beware, #startvote is the worst
15:54:04 <nikhil_k> TravT: lgtm
15:54:19 <nikhil_k> (+1)
15:54:21 <kragniz> TravT: don't, the voting is broken last I saw
15:54:32 <sigmavirus24> TravT: #startvote (Question)? Response1, Response2, etc.
15:54:35 <sigmavirus24> Or something like that
15:54:37 <rosmaita> i think #startvote doesn't work, but we should get all the votes in one place, so go ahead and do it
15:54:55 <sigmavirus24> rosmaita: I think OpenStack's fork requires options for it to work
15:55:01 <sigmavirus24> #help
15:55:27 <mclaren> +1 (obviously others can comment on the patch when it goes up)
15:55:33 <TravT> #startvote (ratify mission statement  To provide advanced and scalable indexing and search across multi-tenant cloud resources.) ? yes, no
15:55:34 <openstack> Begin voting on: (ratify mission statement  To provide advanced and scalable indexing and search across multi-tenant cloud resources.) ? Valid vote options are yes, no.
15:55:35 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:55:45 <sigmavirus24> #vote yes
15:55:45 <smc7> #vote yes
15:55:46 <nikhil_k> #vote yes
15:55:47 <TravT> #vote yes
15:55:47 <rosmaita> #vote yes
15:55:48 <krykowski> #vote yes
15:55:49 <kragniz> #vote yes
15:55:52 <mclaren> #vote yes
15:56:07 <sigmavirus24> Is that everyone?
15:56:08 <david-lyle_> #vote: yes
15:56:09 <openstack> david-lyle_: : yes is not a valid option. Valid options are yes, no.
15:56:17 <david-lyle_> #vote yes
15:56:24 <TravT> anybody outstanding?
15:56:37 * david-lyle_ thinks of himself that way
15:56:40 <david-lyle_> :D
15:56:43 <TravT> #endvote
15:56:44 <openstack> Voted on "(ratify mission statement  To provide advanced and scalable indexing and search across multi-tenant cloud resources.) ?" Results are
15:56:45 <openstack> yes (9): david-lyle_, mclaren, smc7, sigmavirus24, nikhil_k, TravT, krykowski, kragniz, rosmaita
15:56:45 <nikhil_k> :)
15:56:54 <rosmaita> hey, it worked!
15:56:55 <kragniz> wow, it worked
15:57:02 <TravT> Sweet!  we can accomplish great things!  thanks sigmavirus24
15:57:17 <sigmavirus24> Yw
15:57:22 <sigmavirus24> kragniz: explicit options
15:57:24 <sigmavirus24> that's the key
15:57:26 <TravT> ok, so we are about out of time.
15:57:28 <nikhil_k> sigmavirus24: ++
15:57:41 <TravT> do you guys want to startup an IRC room #openstack-searchlight until monday?
15:57:50 <mclaren> #help
15:57:53 <TravT> or communicate in glance until then?
15:57:55 <sigmavirus24> mclaren: doesn't work
15:57:59 <kragniz> sigmavirus24 for votebot liaison
15:58:01 <sigmavirus24> TravT: up to y'all
15:58:05 <mclaren> heh
15:58:09 <nikhil_k> TravT: glance works until monday
15:58:10 <sigmavirus24> kragniz: I once read votebot's source.
15:58:14 <TravT> ok, let's do that.
15:58:23 <TravT> so #action-item TravT follow up with jbryce
15:58:30 <TravT> maybe that isn't format?
15:58:38 <sigmavirus24> TravT: just "#action ..."
15:58:43 <nikhil_k> #action TravT follow up with jbryce
15:58:44 <david-lyle_> TravT: #action
15:58:49 <nikhil_k> Hoped that worked :D
15:58:51 <sigmavirus24> like nikhil_k
15:58:51 <TravT> thanks nikhil_k
15:58:52 <david-lyle_> what nikhil_k said
15:59:03 <TravT> #action TravT follow up with jbryce
15:59:17 <TravT> #action smc7 finish direct port of code to repo
15:59:23 <nikhil_k> From Glance's side
15:59:27 <TravT> who else wants actions?
15:59:30 <nikhil_k> let's please discuss the split out
15:59:49 <nikhil_k> SO, that people (devs, deployers, OpenStack) are aware
15:59:54 <nikhil_k> gah
15:59:57 <nikhil_k> so that*
15:59:57 <TravT> yeah.
16:00:09 <TravT> i'm not sure if we'll get kicked out of here
16:00:11 <kragniz> we're out of time in here, anyway
16:00:32 * nikhil_k needs a long break
16:00:42 <TravT> can we have a follow on discussion Monday?
16:00:44 * nikhil_k will catch up with everyone soon :-)
16:00:47 <TravT> informally
16:00:50 <nikhil_k> ++
16:00:57 <kragniz> TravT: go for it
16:00:59 <david-lyle_> sure
16:01:00 <TravT> ok.  thanks everybody!
16:01:05 <smc7> later
16:01:07 <nikhil_k> TravT: please do incl. [all] tag in ML
16:01:10 <TravT> ok
16:01:19 <nikhil_k> \o/
16:01:20 <TravT> really excited about this effort and this team!
16:01:25 <nikhil_k> ++
16:01:27 <kragniz> #openstack-searchlight is lonely, everyone!
16:01:33 <nikhil_k> lol
16:01:37 <TravT> #endmeeting