15:01:21 <TravT> #startmeeting openstack search
15:01:22 <openstack> Meeting started Thu Jun  4 15:01:21 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:26 <openstack> The meeting name has been set to 'openstack_search'
15:01:33 <nikhil_k> O/
15:01:40 <ativelkov> o/
15:01:43 <kragniz> o/
15:01:43 <lakshmiS> o/
15:01:46 <rosmaita> o/
15:01:48 <TravT> long time no see :)
15:01:54 <nikhil_k> :)
15:01:55 <david-lyle> o/
15:02:00 <sigmavirus24> o/
15:02:21 <TravT> ok, so our agenda is here: #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:02:29 <TravT> please add to it as you see fit...
15:02:45 <TravT> i seem to be having some issues with staying connected to etherpad today
15:03:10 <nikhil_k> I do sometimes on chrome/chromium/yandex. Firefox works better
15:03:18 <sigmavirus24> TravT: blame infra ;)
15:03:33 <TravT> sounds like a good plan. ;)
15:03:41 <TravT> #topic governance repo submission
15:04:04 <TravT> as we discussed last week and as you saw, i put up the patch
15:04:08 <TravT> #link https://review.openstack.org/#/c/188014/
15:04:20 <TravT> also sent out a short ML announcement.
15:04:33 <mclaren> o/
15:04:41 <TravT> so far it has been all positive!
15:05:04 <TravT> i think need to add a few other TC members as reviewers to try to get their votes.
15:05:36 <mclaren> any idea is there a particular number of TC votes required?
15:05:43 <mclaren> (just curious)
15:05:45 <david-lyle> TravT: what day did you post?
15:05:45 <TravT> based on history, it looks like Thierry waits for most the members to weigh in and then he'll do a final approval.
15:05:51 <mclaren> k
15:05:55 <TravT> just yesterday morning.
15:05:59 <TravT> so, hasn't been there long.
15:06:02 <sigmavirus24> mclaren: we must be mentally linked, I was thinking the same
15:06:02 <david-lyle> 8 days before TC meeting to vote
15:06:18 <david-lyle> wait that may be the old rules
15:06:41 <TravT> ttx maybe can answer that if he's around?
15:06:51 <nikhil_k> #link http://comments.gmane.org/gmane.comp.cloud.openstack.devel/55196
15:06:52 <TravT> i see him in the room list
15:07:08 <ttx> TravT: In that case it needs to be discussed in a TC meeting
15:07:23 <ttx> then we collect TC members votes and I approve when more than half members agree
15:07:37 <ttx> that would be 7
15:08:00 <TravT> ok.  so, is there a meeting every week or every other week?
15:08:04 <ttx> then we have more rules for corner cases -- see http://governance.openstack.org/reference/charter.html
15:08:08 <ttx> every week
15:08:19 <ttx> It's likely that we would try to cover it next week
15:08:34 <TravT> would you mind adding to the agenda or do I need to do that?
15:08:48 <ttx> I'll pick it up tomorrow morning as I build the final agenda
15:08:57 <TravT> great, thanks!
15:09:22 <TravT> do you have a link for the meeting, so everybody here knows when it is?
15:09:52 <nikhil_k> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
15:10:19 <TravT> thanks nikhil_k:
15:11:14 <TravT> ok, so we'll try to get a few more votes and attend that meeting.
15:11:33 <TravT> anything else on this, or can we move on?
15:12:13 <TravT> #topic Glance code breakout update (Steve, lakshmi)
15:12:26 <TravT> sjmc7 sent me a message a bit ago that he's in transit
15:12:47 <TravT> he said he's got the metadef plugin pull request up, but needs a tiny bit of tweaking.
15:13:06 <TravT> dhellmann also said he'd help us out with repo.
15:13:17 <nikhil_k> \o/
15:13:25 <kragniz> TravT: with what part of the repo?
15:13:27 <kragniz> importing it?
15:13:41 <nikhil_k> packaging in general I think
15:13:42 <TravT> i think so, need to follow up with him (unless he's on here)?
15:13:51 <lakshmiS> i dont know if dhellmann knows that we already extracted the code from glance
15:14:02 <TravT> yeah, wanted to cover that with him.
15:14:10 <nikhil_k> we need to be mindful about the requirements, release style and sync on global etc
15:14:23 <TravT> but we will need help going from our glance extract to an openstack governed repo.
15:14:40 <TravT> nikhil_k, anything there to share?
15:15:10 <nikhil_k> It would be nice to get some glance cores (may 2) to review the removal so that we do not leave a trail behind
15:15:19 <nikhil_k> I can be one of those
15:15:25 <lakshmiS> +1
15:15:32 * TravT looking at nikhil_k, sigmavirus24, mclaren, kragniz
15:15:34 <mclaren> me too
15:15:49 <TravT> great!
15:15:50 <kragniz> when do we plan on doing the removal?
15:16:07 <kragniz> before l1, or sooner?
15:16:11 <wko> Do I need to remove glance-search from devstack?
15:16:19 <nikhil_k> next week of so should be great
15:16:35 <nikhil_k> depending on when the review is approved
15:16:37 <TravT> nikhil_k, should wait until this new project is actually accepted?
15:16:44 <nikhil_k> :)
15:16:53 <lakshmiS> yes :)
15:16:57 <sigmavirus24> I'm in
15:17:24 <TravT> if for some odd reason the project gets rejected, i'd rather not get stranded. :)
15:17:28 <nikhil_k> TravT: yes, sorry I meant the project acceptance by review
15:17:46 <TravT> :)
15:17:54 <TravT> wko: re: devstack, probably same thing.
15:18:01 <nikhil_k> basically, we should try to switch the repos is what I was getting at
15:18:11 <nikhil_k> vs. keeping it in two places near L1
15:18:18 <wko> TravT: ok will wait
15:18:23 <TravT> but that said, did you get a chance to talk with sdague at the summit?
15:19:00 <TravT> he is working on (maybe landed now) a new way for projects to deliver their code via plugins to devstack
15:19:19 <kragniz> TravT: devstack plugins
15:19:26 <kragniz> they're pretty cool
15:19:29 <TravT> basically, it is a new task in the devstack scripts that allows you to do something like enable foo foo-url
15:19:41 <kragniz> and let us keep most of the devstack code in our tree
15:19:46 <wko> TravT: no didn't talk to  him. Will ping him on how to deliver searchlight when available...
15:19:56 <TravT> it will then reach out to foo-url and executes a script that has known lifecycle points
15:20:25 <wko> ok...that sounds pretty cool.
15:20:36 <TravT> so, project can much more easily install into devstack by keeping in their tree (like kragniz said)
15:20:59 <kragniz> TravT: it's the maintaining that gets easier
15:21:07 <wko> was there a session on it at vancouver?
15:21:16 <kragniz> so we don't need to wait for devstack people to approve our changes
15:21:27 <TravT> no, i just talked with him for awhile after the session on the Bit Tent model.
15:21:37 <TravT> s/Bit/Big
15:21:52 <wko> TravT: ok
15:22:03 * sigmavirus24 likes bit tent better
15:22:09 <TravT> lol
15:22:11 <nikhil_k> == singleth_
15:22:15 <nikhil_k> :)
15:22:31 <kragniz> TravT: have a look at how zaqar does it
15:22:33 <kragniz> https://github.com/openstack/zaqar/tree/master/devstack
15:22:37 <nikhil_k> sigmavirus24: I was thinking the same. We shall have a bit tent and then a byte tent :P
15:22:53 <TravT> and the release is called the megabyte
15:22:53 <sigmavirus24> bit tent will be each repo and byte tent will be openstack/
15:22:54 <sigmavirus24> ;)
15:23:01 <sigmavirus24> TravT: skipping one sir
15:23:04 <sigmavirus24> kilobyte ;)
15:23:13 <nikhil_k> lol
15:23:14 <sigmavirus24> okay
15:23:18 <sigmavirus24> we're getting wayyyy off topic
15:23:21 <kragniz> then libertybyte?
15:23:22 * sigmavirus24 apologizes
15:23:28 <TravT> lol
15:23:30 <nikhil_k> I was thiking byte tent == program. bit tent == repo/sub team
15:23:37 <wko> kragniz: Thx!
15:23:39 <sigmavirus24> nikhil_k: ah
15:23:47 <TravT> #action mclaren review extract
15:23:57 <TravT> #action nikhil_k review extract
15:24:04 <TravT> so next up:
15:24:11 <mclaren> TravT: send on the link in case I miss it
15:24:21 <TravT> #topic Brainstorming session
15:24:46 <nikhil_k> lakshmiS: please ping me near your extraction plan (that sounds a bit fishy/james bond like)
15:25:06 <TravT> Basically, i'd like to have a session where we can all do some brainstorming on where we go with this project.
15:25:06 <lakshmiS> :) sure
15:25:20 <nikhil_k> +1 TravT
15:25:29 <david-lyle> +1
15:25:29 <TravT> i've started on etherpad (will share in a second).
15:25:46 * nikhil_k looks for like button. forgets irc and fb are different
15:26:08 <TravT> The idea is to talk about what we need to do.
15:26:10 <TravT> what we should do
15:26:15 <TravT> what we want to do
15:26:21 <TravT> and what we DON'T want to do.
15:26:46 <TravT> And the bubble that up into some plans for what we WILL do in the liberty time frame
15:27:16 <TravT> On the initial etherpad, people can just freeform add to those topics
15:27:36 <TravT> but then I think we need to have some discussion in a rich environment.
15:27:48 <nikhil_k> ++
15:27:53 <TravT> so was hoping we could do a video conference (or two) next week.
15:27:53 <lakshmiS> also discuss on the scope of what areas searchlight can be used in openstack
15:27:53 <sigmavirus24> I think what we want to do is focus on the defcore projects for liberty and ignore the others unless someone else adds it
15:28:23 <nikhil_k> lakshmiS: exactly what I was thinking too.
15:28:27 <sigmavirus24> by focusing on defcore and indexing defcore projects (or the ones that make sense) I think we'll have a bit more legitimacy on top of what we already have for being so freaking awesome
15:28:52 <TravT> sigmavirus24: that's generally my thoughts too
15:29:06 <nikhil_k> sigmavirus24: good point. Do we know the new DefCore plan yet or they are going with same old same old?
15:29:07 <TravT> i'm not sharing the link just yet
15:29:34 <TravT> so please have some open discussion here
15:30:02 <nikhil_k> I have heard that HEAT might benefit from this a bit besides other discussions people have had
15:30:31 <nikhil_k> It seems a good fit for autoscale that needs to be extra aware of resource contraints/updates
15:30:43 <TravT> interesting.
15:30:47 <mclaren> obviously getting it done for nova would win mindshare amount the community
15:30:49 <lakshmiS> app catalog can use some searching from searchlight
15:30:51 <mclaren> *amoung
15:31:36 <TravT> ok, i'll go ahead and drop the etherpad link.
15:31:37 <rosmaita> +1 for defcore projects first, beginning with nova
15:31:42 <nikhil_k> lakshmiS: app catalog == https://github.com/stackforge/apps-catalog ?
15:31:46 <TravT> #https://etherpad.openstack.org/p/liberty-searchlight-brainstorming
15:31:50 <TravT> #link https://etherpad.openstack.org/p/liberty-searchlight-brainstorming
15:31:53 <sjmc7> hi all
15:32:08 <nikhil_k> hi!
15:32:12 <lakshmiS> nikhil_k: yes
15:32:13 <sigmavirus24> TravT: we can start with the existing defcore projects and expand as necessary
15:32:18 <sjmc7> on the subject of other projects, designate bug me regularly about getting a plugin
15:32:21 <sigmavirus24> at the very least we'll be one cycle behind to start with
15:32:32 <david-lyle> defcore includes keystone
15:32:34 <sigmavirus24> sjmc7: if they want to write it ;)
15:32:35 <nikhil_k> sjmc7: lakshmiS and you are going to work on extraction plan ;) is what I heard
15:32:37 <david-lyle> what's the plan around keystone
15:32:42 <david-lyle> ?
15:33:02 <TravT> david-lyle: we don't have one.  do you want to own coming up one?
15:33:11 <david-lyle> index identity constructs as well? or just use keystone for authZ
15:33:48 <lakshmiS> nikhil_k: https://github.com/lakshmisampath/searchlight has the extracted code which is getting fine tuned
15:33:51 <TravT> i was wondering about how keystone would work for when keystone is hooked up to ldap... keystone doesn't pass notification everytime an ldap user is added, right?
15:33:51 <david-lyle> it get messy once you're trying to index keystone, I would put that part on hold for now, but I will think about it more
15:33:51 <nikhil_k> this coule potentially replace keystone-middleware calls that don't work well
15:34:08 <nikhil_k> lakshmiS: thanks
15:34:50 <nikhil_k> Also, they have support for nosql DB now is what we heard
15:34:58 <david-lyle> TravT: I believe that is correct
15:35:13 <nikhil_k> so may not benefit as much as other projects would
15:35:57 <nikhil_k> I would like to focus on Nova myself as I know rackspace heat can use this better
15:36:10 <nikhil_k> (not air conditioning)
15:36:25 <mclaren> I'd be interested in swift (if I get permission from the powers that be)
15:36:32 <TravT> yeah you and rosmaita probably would be good on nova
15:37:38 <TravT> so, my suggestion is to start adding things to the etherpad and putting your name by it if you want to be the primary person on it.
15:37:57 <TravT> but, on the etherpad, i'd like us to also think about other conceps as well.
15:38:13 <TravT> such as technology decisions and direction.
15:38:55 <TravT> for example sigmavirus24 was mentioning twisted the other day
15:38:58 <mclaren> nailing down some pluses and minuses of different approaches sounds like a good idea
15:39:19 <TravT> +1 mclaren
15:40:05 <TravT> also, if people are able to go off and look at what it would mean to index different services, we could come back together and compare notes to help drive framework decisions
15:40:43 <sigmavirus24> twisted is just really good for async work and has great methods of testing interleaved tasks
15:41:00 <sigmavirus24> (just my quick 2 cents)
15:41:18 <kragniz> sigmavirus24: do any other openstack services use it currently?
15:41:23 <sigmavirus24> no =(
15:41:36 <TravT> so, we are running low on time...
15:41:38 <sigmavirus24> no other openstack services use elasticsearch either though =P
15:41:57 * sigmavirus24 shuts up
15:42:10 <wko> sigmavirus24: ceilometer?
15:42:12 * TravT trying to remember how to setup vote
15:42:24 <sigmavirus24> \#vote question options
15:42:34 <sigmavirus24> e.g. #vote Do you think this shed should be red? yes, no
15:43:01 <TravT> #startvote (are we okay with doing a video conference vs IRC for a brainstorming session) ? yes, no
15:43:03 <openstack> Begin voting on: (are we okay with doing a video conference vs IRC for a brainstorming session) ? Valid vote options are yes, no.
15:43:05 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:43:12 <sigmavirus24> #vote yes
15:43:16 <nikhil_k> I like that however I feel like we can do that first up for M-1. For L if we can get it working along lines of codes and designs other projects like nova, glance use then it would be decently stable. We can get more feedback too at the summit.
15:43:32 <TravT> #vote yes
15:43:38 <nikhil_k> #vote yes
15:43:55 <lakshmiS> #vote yes
15:44:08 <mclaren> #vote yes
15:44:11 <david-lyle> #vote yes
15:44:12 <wko> #vote yes
15:44:22 <TravT> smc7?
15:44:24 <kragniz> #vote yes
15:44:35 <TravT> rosmaita?
15:44:37 <sjmc7> #vote yes
15:44:50 <TravT> #endvote
15:44:50 <openstack> Voted on "(are we okay with doing a video conference vs IRC for a brainstorming session) ?" Results are
15:44:51 <openstack> yes (9): wko, lakshmiS, mclaren, sjmc7, sigmavirus24, nikhil_k, TravT, david-lyle, kragniz
15:45:09 <TravT> ok, so then we basically have vidyo (rackspace) or hangouts
15:45:15 <rosmaita> sorry, saw something shiny ... yes!
15:45:30 <david-lyle> so many shiny things
15:45:33 <TravT> i think vidyo works a little bit better, so could one of your rackers set one up?
15:45:53 <mclaren> hangout is better from behind firewall?
15:45:54 <nikhil_k> sure, I can take that
15:46:15 <TravT> oh right, i did have some vidyo problems when in office.
15:46:27 <kragniz> I'd rather have hangouts, unless we have too many people for that
15:46:34 <nikhil_k> as long as we have <10 people joining
15:46:37 <sigmavirus24> ^
15:47:09 <TravT> ok, we could start with a hangouts and go to vidyo as backup?
15:47:21 <kragniz> TravT: that sounds reasonable
15:47:28 <TravT> So on days...
15:48:05 <TravT> would either Tuesday or Wednesday next week at 14:00 UTC for 2 hours work for you?
15:48:09 <nikhil_k> Sometime after TC meeting?
15:48:18 <nikhil_k> that is on Tuesdays
15:48:34 <david-lyle> not Tuesday pleas
15:48:35 <david-lyle> e
15:49:15 <nikhil_k> +1 on Wednesdays (in general)
15:49:41 <rosmaita> wednesday is better, but i may have to disappear for 1/2 hour in the middle
15:50:08 <TravT> lakshmiS, i know this is late for you.  How late are you able to attend?
15:50:15 <nikhil_k> I may disaapear for 10-15 mins
15:50:25 <lakshmiS> 9:00 PM IST
15:50:48 <nikhil_k> that's 15.30UTC
15:51:32 <TravT> okay #startvote will this time work for everybody to do a video meetup http://everytimezone.com/#2015-6-10,150,cn3 ? yes, no
15:51:42 <TravT> hmm,, didn't like that
15:51:53 <nikhil_k> # needs to be first for this command
15:51:53 <sigmavirus24> TravT: leave off the "okay"
15:52:02 <TravT> #startvote (will this time work for everybody to do a video meetup http://everytimezone.com/#2015-6-10,150,cn3) ? yes, no
15:52:02 <openstack> Begin voting on: (will this time work for everybody to do a video meetup http://everytimezone.com/#2015-6-10,150,cn3) ? Valid vote options are yes, no.
15:52:03 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:52:15 <sjmc7> #vote yes
15:52:21 <sigmavirus24> #vote yes
15:52:27 <david-lyle> #vote yes
15:52:28 <sigmavirus24> but I'll probably bail early
15:52:48 <TravT> sigmavirus24, we could start 30 min earlier
15:52:54 <nikhil_k> TravT: for 2 hours from then?
15:53:09 <TravT> yes
15:53:12 <kragniz> #vote yes
15:53:14 <sigmavirus24> TravT: the start time doesn't matter =P
15:53:15 <lakshmiS> TravT: is it just for next week?
15:53:18 <nikhil_k> ok
15:53:21 <TravT> just next week
15:53:23 <nikhil_k> #vote yes
15:53:26 <rosmaita> #vote yes
15:53:28 <nikhil_k> I may leave early too
15:53:31 <lakshmiS> #vote yes
15:53:31 <TravT> i'm trying to help get things kicked off
15:53:41 <wko> #vote yes
15:53:56 <TravT> #endvote
15:53:57 <openstack> Voted on "(will this time work for everybody to do a video meetup http://everytimezone.com/#2015-6-10,150,cn3) ?" Results are
15:53:58 <openstack> yes (8): wko, lakshmiS, sjmc7, sigmavirus24, nikhil_k, david-lyle, kragniz, rosmaita
15:54:05 <TravT> okay, we'll go with that time
15:54:36 <TravT> so please add ideas to etherpad and be prepared to discuss them
15:54:54 <TravT> thank you!
15:54:55 <lakshmiS> TravT: whats the etherpad link?
15:55:04 <nikhil_k> yeah, I think I missed it
15:55:05 <nikhil_k> too
15:55:07 <TravT> #link https://etherpad.openstack.org/p/liberty-searchlight-brainstorming
15:55:23 <lakshmiS> thx
15:55:35 <TravT> #topic mid cycle meetup
15:55:45 <TravT> i think everybody has already heard about it in glance or horizon meetings.
15:56:14 <TravT> but please add your availability to the voting section on the bottom of this page
15:56:17 <TravT> #https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0
15:56:21 <TravT> #link https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0
15:56:34 <david-lyle> I seem to be the only one not in the know, what is meant by "No preference"
15:56:39 <TravT> we have crossover between projects, so trying to get them colocated if possible.
15:56:45 <ekarlso> ello guys :)
15:56:48 <david-lyle> don't care?
15:56:49 <TravT> nikhil_k: ^ "no preference"
15:56:52 <TravT> hi ekarlso
15:56:56 <rosmaita> david-lyle: i interpreted it as "don't care either way"
15:57:13 <TravT> i'd kinda lika "not preferred, but will do it"
15:57:33 <nikhil_k> got disconnected sorry
15:57:44 <lakshmiS> hmm. i thought it meant "didnt care"
15:57:50 <TravT> nikhil_k: david-lyle wants a definition for no preference
15:58:12 <nikhil_k> david-lyle: no is strong no, no preference is okay but not preffered kinda ono
15:58:28 <TravT> ok.
15:58:33 <david-lyle> ok, just wasn't clear, thanks!
15:58:44 <TravT> i'm going to skip the launchpad topic... we'll come back to that after brainstorming
15:58:46 <nikhil_k> I will update legend
15:59:12 <TravT> kragniz, should we push the searchlightclient to next week / brainstorming?
15:59:15 <kragniz> let's skip client stuff, too
15:59:20 <TravT> ok.
15:59:21 <kragniz> yeah, we're too short on tome
15:59:24 <kragniz> time
15:59:33 <TravT> Well thanks, everybody!
15:59:39 <kragniz> thanks!
16:00:01 <nikhil_k> Thanks
16:00:03 <TravT> I think we are just about ready to really start running!
16:00:04 <ekarlso> hey guys
16:00:06 <rosmaita> bye!
16:00:24 * nikhil_k finds his running shoes :)
16:00:24 <TravT> out of time for now.  try to jump in on #openstack-searchlight
16:00:29 <TravT> #endmeeting