15:04:06 <nikhil_k> #startmeeting openstack search
15:04:07 <openstack> Meeting started Thu Jun 11 15:04:06 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:10 <openstack> The meeting name has been set to 'openstack_search'
15:04:11 <nikhil_k> #chair TravT_
15:04:12 <openstack> Current chairs: TravT_ nikhil_k
15:04:19 <nikhil_k> #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:04:24 <rosmaita> o/ (again)
15:04:27 <nikhil_k> o/
15:04:31 <TravT_> i guess we can see what happened in the logs.
15:04:34 <TravT_> fun test
15:04:42 <TravT_> good morning, anyway
15:04:56 <sjmc7> morning!
15:05:20 <nikhil_k> It went fine
15:05:34 <nikhil_k> logs still there http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-06-11-15.00.html
15:05:48 <TravT_> ok, cool.
15:05:58 <sigmavirus24> either one works
15:06:03 <sigmavirus24> logs are live updating here too: http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-06-11-15.04.log.txt
15:06:06 <sigmavirus24> =P
15:06:11 <nikhil_k> Latest ones (this mtg logs) http://eavesdrop.openstack.org/meetings/openstack_search/2015/openstack_search.2015-06-11-15.04.log.txt
15:06:16 <sigmavirus24> nikhil_k: ^5
15:06:16 <TravT_> cool
15:06:39 <TravT_> #topic We have a project!
15:06:45 <sjmc7> yay!
15:06:45 <TravT_> https://review.openstack.org/#/c/188014/
15:07:01 <nikhil_k> \o\ \o/ /o/
15:07:16 <TravT_> So, virtual cheers to everybody!
15:07:35 <nikhil_k> (with a bit of drama of course)
15:07:45 <TravT_> you mean the gate failing....
15:07:47 <TravT_> :)
15:08:01 <nikhil_k> yeah
15:08:13 <sigmavirus24> lol
15:08:17 <sigmavirus24> that was lifeless' fault
15:08:26 <sigmavirus24> He's always trying to cause drama =P
15:08:33 <sigmavirus24> Breaking gates and whatnot
15:08:48 <TravT_> lol
15:09:37 <TravT_> #topic OpenStack repo import status (kragniz)
15:09:39 <nikhil_k> I remember the dialogue from Batman Begins .. why do we fall Mr. Bruce?
15:09:48 <TravT_> kragniz are you around today?
15:09:51 <kragniz> hey
15:10:01 <kragniz> ready to go (almost)
15:10:06 <kragniz> https://review.openstack.org/#/c/190278/4
15:10:12 <sigmavirus24> do or do not, there is no almost
15:10:22 <sigmavirus24> =P
15:10:49 <TravT_> looks like just waiting for checks to pass?
15:11:00 <kragniz> and some +2s from people
15:11:45 <sigmavirus24> so
15:11:55 <sigmavirus24> do we want python3.4 to be a non-voting job for searchlight?
15:12:07 <sjmc7> yeah, let's do it from the start
15:12:08 * sigmavirus24 is just asking since it was mentioned yesterday
15:12:18 <TravT_> sigmavirus24: i think we do.
15:12:20 * sigmavirus24 is not trying to make Louis' job harder
15:12:23 <sjmc7> we'll have to do it sometime and i don't want to have to go and fix a bunch of stuff later
15:12:24 <kragniz> sjmc7: do you know if the py34 job currently runs?
15:12:25 <sigmavirus24> s/not//g
15:12:32 <sigmavirus24> kragniz: does not
15:12:37 <sigmavirus24> -python-jobs is only python2
15:12:54 <nikhil_k> and we just need 27
15:12:56 <nikhil_k> ?
15:13:00 <TravT_> in the cross project meeting, there was a lot of discussion on moving to py 34.
15:13:04 <kragniz> sigmavirus24: I mean if you do to -e py34, does it do horrible things
15:13:05 <sigmavirus24> you have to add check:\n  - gate-searchlight--python34
15:13:08 <kragniz> tox -e
15:13:09 <sigmavirus24> kragniz: oh yeah
15:13:10 <sigmavirus24> no clue
15:13:14 <sjmc7> there ARE non-voting python 3 jobs though
15:13:19 <sigmavirus24> right
15:13:30 <sigmavirus24> if we have an express goal of being able to run on 3.4 then we should add it
15:13:31 <kragniz> we can add it when we have something that runs (okayishly)
15:13:39 <nikhil_k> sigmavirus24: experimental: ,I think vs. check:
15:13:40 <sigmavirus24> if it's just going to be a "nice to have" for liberty, then I say no
15:13:53 <kragniz> I think we should have it from the start
15:14:00 <sjmc7> i do too
15:14:05 <sigmavirus24> nikhil_k: the way I did it for bandit was adding it to check and defining it as non-voting
15:14:06 <sjmc7> while the test suite is relatively small
15:14:14 <sigmavirus24> yeah the codebase is also small
15:14:16 <sjmc7> make it non voting until it passes
15:14:18 <sigmavirus24> so it should be easy to work on
15:14:25 <sigmavirus24> then make it voting to annoy people
15:14:25 <sigmavirus24> ;)
15:14:27 <TravT_> +1 ^
15:14:27 <kragniz> we're going to have to port anyway, so we should keep the amount of legacy stuff small from the start
15:14:47 <sjmc7> yeah... i've been on projects that have ported to 3, it's a real pain once you have significant code
15:14:55 <kragniz> yup
15:15:13 <TravT_> anybody have that link handy that I shared in the room yesterday?
15:15:16 <nikhil_k> given 34 is a real thing now
15:15:18 <kragniz> I think we should aim for a voting job in liberty, anyway
15:15:21 <nikhil_k> unless 33 last year
15:15:21 <TravT_> just wanted to link it from here
15:15:25 <nikhil_k> unlike*
15:15:36 <kragniz> but that can come later, with a non-voting job first
15:15:36 <nikhil_k> please no
15:15:45 <nikhil_k> who deploys 34!?
15:16:11 <sigmavirus24> nikhil_k: I will if I have to
15:16:12 <nikhil_k> +1 on non-voting but voting should be only in-use production ready
15:16:38 <sigmavirus24> nikhil_k: I think you overestimate how hard it is to get a code-base to be production ready on Python 3
15:16:38 <nikhil_k> otherwise patches will have tendency to get stuck that may break stuff in real world
15:16:50 <sigmavirus24> ^ can you expound on this?
15:17:04 <nikhil_k> sigmavirus24: I am just saying..
15:17:22 <nikhil_k> if no one is using py34 in real world, it does not make sense to mark the job voting
15:17:54 <kragniz> nikhil_k: but who deploys searchlight?
15:17:55 <nikhil_k> we can continue to monitor it as responsible developers
15:18:04 <kragniz> we're a new project, so we can be more cutting-edge
15:18:10 <nikhil_k> I hope that was a joke
15:18:17 <kragniz> anyway, we can talk about this later in the cycle
15:18:29 <TravT_> FYI on some discussion on py 3 yesterday: #link http://eavesdrop.openstack.org/meetings/crossproject/2015/crossproject.2015-06-09-21.01.log.html#l-123
15:18:49 <sigmavirus24> nikhil_k: IMO, if we don't gate on Python 3, no one will fix their broken patches unless we block them until they do
15:18:58 <sigmavirus24> That shouldn't be the reviewer's job, that should be the gate's job
15:19:18 <sigmavirus24> And for all the gloom and doom that everyone predicts about Python 3, I can speak from years of experience, that it isn't that bad
15:19:23 <sigmavirus24> And it's constantly getting a lot better
15:19:57 <sigmavirus24> Many of the biggest libraries in use are production ready for Python 3
15:20:03 <nikhil_k> It's just about porting your N K servers to use py34 after you've just spent months porting from py26->py27
15:20:25 <sigmavirus24> That will only happen when openstack drops 2.7
15:20:25 <nikhil_k> But I don't want to hold back the meeting
15:20:32 * nikhil_k shuts up
15:20:34 <sigmavirus24> And in many cases, if they're using debian or ubuntu, they wont' have a choice
15:20:42 <sigmavirus24> Python 3 is becoming the default real soon
15:20:58 <sigmavirus24> Red Hat will be left supporting 2.x customers and that's what they're good at
15:20:59 * sigmavirus24 shuts up
15:21:05 <TravT_> i think this is a good discussion.  My vote is that we enable it as a non-voting job.
15:21:23 <TravT_> and revisit making it voting
15:21:30 <kragniz> it should certainly be a non-voting job at first
15:21:32 <kragniz> TravT_: +1
15:21:38 <sjmc7> aye
15:21:47 <david-lyle> +1
15:21:58 <TravT_> so kragniz, i guess you should go ahead and add it to the patch.
15:22:44 * sigmavirus24 is always happy to discuss Python 3 outside of meetings
15:22:45 <sigmavirus24> =P
15:22:54 <kragniz> yeah, I guess so
15:23:09 <TravT_> next up
15:23:13 <TravT_> #topic Brainstorming Session
15:23:31 <TravT_> #link https://etherpad.openstack.org/p/liberty-searchlight-brainstorming
15:23:47 <TravT_> thank you everybody that attended
15:23:59 <TravT_> i thought it was a very useful session!
15:24:12 <nikhil_k> +1
15:24:37 <TravT_> there were a few actions out of it.
15:24:58 <TravT_> one was the discussion we just had with kragniz^
15:25:03 <rosmaita> TravT_: an interesting point came up in today's glance meeting, viz., that we could record minutes of the meeting into the logged openstack-serach channel
15:25:24 <rosmaita> TravT_: live, during the meeting, i mean
15:25:56 <TravT_> rosmaita, you mean as a supplement to the etherpad?
15:26:05 <rosmaita> yes
15:26:18 <TravT_> seems like a pretty good idea.
15:26:18 <nikhil_k> yeah, I wanted to get reasoning behind that if we have time
15:26:31 <TravT_> sure, go ahead
15:26:57 <nikhil_k> Any specific reason we prefer openstack logs over etherpad?
15:27:42 <nikhil_k> Or can we just link a etherpad during the meeting? Not sure what helps.. We may need someone dedicated notes taker for irc logs..
15:28:18 <nikhil_k> (seems like folks who want it are not here)
15:28:25 <rosmaita> etherpad is ephemeral by nature
15:28:31 <rosmaita> and not discoverable
15:28:51 <sigmavirus24> ^^
15:28:56 <sigmavirus24> logs are not ephemeral
15:29:02 <sigmavirus24> also, they're immutable
15:29:11 <sigmavirus24> etherpads can supplement the logs, but can't exactly replace them
15:29:22 <nikhil_k> true, otoh more collaboratiev and async (good for offline feedback etc)
15:29:23 <rosmaita> sigmavirus24: ty, that's what i was trying to say
15:29:32 <sigmavirus24> yep
15:29:39 <nikhil_k> gotcha
15:29:41 <nikhil_k> thanks
15:29:44 <sigmavirus24> nikhil_k: I don't think this should be a discussion of 1 or the other
15:29:50 <sigmavirus24> I think having both is really good
15:29:58 <rosmaita> yes, let's use all the tools!
15:30:02 <nikhil_k> ok, as long someone DOES IT
15:30:03 <sigmavirus24> I wouldn't have been able to participate yesterday (in any capacity) without an etherpad
15:30:25 <rosmaita> nikhil_k: i guess i can volunteer as minute-taker
15:30:33 <rosmaita> (it will force me to pay attention)
15:30:40 <nikhil_k> heh, thanks!
15:30:42 <rosmaita> TravT_: what do you think?
15:30:50 <sigmavirus24> rosmaita: thanks for not making me volunteer ;)
15:30:58 * nikhil_k too
15:30:58 <TravT_> i'm happy for you to take notes rosmaita. :P
15:31:27 <rosmaita> ok, put me down as minutes-taker for the out-of-normal-schedule meetings
15:31:39 <TravT_> thanks, rosmaita!
15:31:59 <TravT_> i guess we can ask for volunteers next time we have such a thing
15:32:06 <nikhil_k> +1
15:32:19 <TravT_> so another action from the meeting was getting #openstack-searchlight logged
15:32:29 <TravT_> kragniz, david-lyle, is that done?
15:32:32 <kragniz> TravT_: I think that's done
15:32:40 <david-lyle> I got the channel added this morning
15:32:41 <nikhil_k> I didn't want to put rosmaita in that position either and was just trying to get more feedback and reduce my multi-tasking responsiblity
15:32:43 <kragniz> I think the patch merged
15:32:44 <sigmavirus24> no bots in there
15:32:46 <david-lyle> so the log should start
15:33:04 <TravT_> ok, thanks!
15:33:05 <rosmaita> cool, having the channel logged is a dependency for minutes!
15:33:35 <TravT_> so this means everybody should be on good behavior in there now!
15:33:39 <nikhil_k> not yet on the channel logs
15:33:46 <david-lyle> if a log doesn't appear soon, I'll dig into why
15:33:53 <TravT_> thanks david-lyle
15:34:17 <TravT_> i sent a message back to the attorney re: trademark.
15:34:20 <TravT_> no response
15:34:34 <david-lyle> looks like it's written once a day
15:34:44 * nikhil_k doesn't mind enjoying the name until someone pushes back
15:35:04 <TravT_> yeah, i like it
15:35:05 <kragniz> david-lyle: I think I know why
15:35:09 <sigmavirus24> david-lyle: the logs are live updated =P
15:35:10 <nikhil_k> david-lyle: oh, you mean written to create one?
15:35:11 <kragniz> I'll write a patch
15:35:32 <david-lyle> kragniz: ok thanks
15:36:01 <kragniz> (needs a system-config change)
15:36:22 <TravT_> ok, the next thing is we agreed that people should start opening blueprints for the areas they are working on which brings us to
15:36:27 <TravT_> #topic launchpad
15:36:49 <TravT_> OpenStack release management tracked based on the blueprints closed: http://status.openstack.org/release/
15:36:54 <david-lyle> oh yeah, I always forget about system-config and hard coded lists
15:37:26 <TravT_> in order for us to show up on the release management board, we do need blueprints
15:38:04 <TravT_> in previous discussions, we decided that we will use as lightweight as possible
15:38:10 <david-lyle> eavesdrop.pp
15:38:40 <TravT_> but there is a template that you can look at filling out.  https://blueprints.launchpad.net/searchlight/+spec/searchlight-blueprint-template
15:38:57 <TravT_> mainly, just share some information. if we need more we'll ask for it.
15:38:59 <nikhil_k> pick and choose, I guess
15:39:21 <TravT_> for API discussions and changes, we do want that to be more stringent
15:39:26 <sjmc7> this is one area where a specs repo is nice, it formalizes that "you need to provide more info" aspect
15:39:41 <nikhil_k> +1
15:39:50 <sjmc7> for now though, perhaps we're small enough that we can do it more informally?
15:39:58 <sjmc7> so if my blueprint's too scanty, tell me in IRC and i'll fix it
15:40:04 <nikhil_k> Also, specs.openstack.org links can be a part of the release notes for that cycle
15:40:04 <sigmavirus24> sjmc7: you betcha
15:40:05 <sigmavirus24> =P
15:40:45 <sjmc7> i think this template's good to read while you're writing them though
15:40:46 <nikhil_k> BP can be changed rather easily and thus may contain bad data
15:41:03 <TravT_> what about creating docs in our docs directory?
15:41:22 <TravT_> so, if you are working on nova plugin, you will create a doc on the nova plugin
15:41:22 <sjmc7> so my vote's not to be crazy formal about it, but feel free to demand more information from people if BP's aren't clear enough
15:41:37 <TravT_> it is rst. it can be reviewed for more info.
15:42:01 <sjmc7> that won't work for all BPs
15:42:34 <sjmc7> i guess ultimately i don't really mind as long as it's clear what the intent is
15:42:45 <nikhil_k> +1 on small BPs and good info on API
15:42:53 <TravT_> my belief is this.  we need documentation.
15:43:08 <TravT_> whether it specs or in our docs section of our repo
15:43:15 <sjmc7> since we have to do BPs for project purposes, i'd vote for as much info in there as is useful to implement and then docutmation as part of the implementation
15:43:27 <nikhil_k> +1 docs section
15:43:27 * rosmaita has not talked to docs team yet, is writing email now
15:43:32 <TravT_> blueprints usually don't work so well when it gets complicated, because they don't have proper review tools
15:44:07 <nikhil_k> and history/timelogs isn't preserved :P
15:45:43 <nikhil_k> #action nikhil: write BPs for his assigned tasks
15:45:44 <TravT_> ok, well, for now, please just create your blueprint
15:46:00 <TravT_> so we have something to show...
15:46:17 <TravT_> need to move on.
15:46:23 <TravT_> #topic midcycle meetup
15:46:39 <TravT_> probably nikhil_k already covered this with glance
15:47:00 <nikhil_k> TravT_: yeah, and received some feedback
15:47:04 <sjmc7> i *think* i have clearance to travel
15:47:06 <TravT_> do you want to repeat yourself nikhil_k
15:47:26 <nikhil_k> sure
15:47:31 * nikhil_k will try to be quick
15:48:12 <nikhil_k> People (and a few of those in specific) were a little worried that mid-cycles are harder to schedule and get travel approved
15:48:12 <rosmaita> how about http://eavesdrop.openstack.org/meetings/glance/2015/glance.2015-06-11-14.00.log.html
15:48:24 <nikhil_k> So there were 2 requests
15:49:10 <nikhil_k> 1. Look at the possiblity of preferring the team (so that people from that team can attend) -- that meaning specific dates, venue etc
15:49:45 <nikhil_k> 2. Look at the possiblity of Video conf. only mid-cycle (or ask Foundation to schedule these events)
15:50:00 <nikhil_k> did I get your concern right rosmaita ?
15:50:16 <nikhil_k> Basically, I made no promises to change in schedule
15:50:50 <nikhil_k> however, wanted to consider the possiblity of mid-cycle during Jul 28-30 preferred over Jul 21-23. And many online participants voted yes
15:51:19 <nikhil_k> I also added the column in #link https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0 for respective date range
15:51:20 <rosmaita> my concern is just that these mid-cycle meetings are sufficiently important, and scheduling is so difficult, that the foundation should give administrative assistant support to help scheduling
15:51:43 <rosmaita> the chosen week conflicts with europython conf
15:51:51 <david-lyle> rosmaita: the foundation wants midcycles to go away
15:51:59 <david-lyle> so I doubt support is an option
15:51:59 <nikhil_k> yep
15:52:12 <david-lyle> this is the reason for all the changes to the summit structure
15:52:32 <david-lyle> to attempt to remove the perceived need for more f2f meetings
15:52:36 <TravT_> nikhil_k, it doesn't look like anybody really updated the https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0
15:52:45 <nikhil_k> yeah
15:52:46 <rosmaita> hmmm ... whatever happend to bottom-up governance?
15:52:47 <TravT_> are people supposed to go vote on that other week now?
15:52:59 <david-lyle> companies at the top don't like them
15:53:01 <david-lyle> $$$
15:53:18 <rosmaita> david-lyle: that is a problem
15:53:42 <rosmaita> we just have to stop having summits in exotic locales
15:54:05 <nikhil_k> TravT_: only if we think it's feasible. The only thing I mentioned is if we decide to consider a different date then some others may be online to provide more feedback
15:54:50 <nikhil_k> rosmaita: expensive locale ?
15:55:00 <TravT_> #action everybody here, go ahead and indicate in the spreadsheet if you can attend the 28 - 30th on the spreadsheet
15:55:04 <TravT_> #link https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0
15:55:25 <rosmaita> hong-kong, paris, tokyo ... would be way cheaper in florida during august
15:55:36 <sjmc7> i am NOT going to florida in august
15:55:48 <sjmc7> the horror!
15:55:49 <rosmaita> sjmc7: it would be cheap!
15:55:53 <TravT_> they could probably do two meetups in north dakota for the price of a single paris
15:55:59 <kragniz> sjmc7: +1 to that!
15:56:14 <sjmc7> there's a reaosn it's cheap! i would go to dakota!
15:56:26 <rosmaita> dakota during february
15:56:43 <nikhil_k> Foundation needs adoption across the globe, I think
15:56:56 <TravT_> ok, so for now... the plan is still july 21-23
15:56:58 <nikhil_k> having in ND might not interest many
15:57:00 <TravT_> nikhil?
15:57:20 <rosmaita> nikhil_k: there must be a european equivalent of north dakota
15:57:20 <nikhil_k> TravT_: yes
15:57:32 <TravT_> ok, we're nearly out of time.
15:57:52 <TravT_> so kragniz, i guess we defer on client for another week
15:57:58 <sigmavirus24> rosmaita: that would be cheap for US people
15:58:03 <sigmavirus24> ;)
15:58:08 <TravT_> although there was some discussion yesterday on it.
15:58:11 <sigmavirus24> nikhil_k: I'd go to the dakotas ;)
15:58:25 <nikhil_k> sigmavirus24: if you are there, then so am I :)
15:58:32 * sigmavirus24 likes cold weather
15:58:39 <sigmavirus24> And I have all of last year's vacation time + this year's
15:58:39 <TravT_> want to mention, i'll be out June 16th - 24th
15:58:44 <sigmavirus24> so might as well spend it on midcycles
15:59:05 <sigmavirus24> TravT_: enjoy yourself
15:59:13 <TravT_> #topic open discussion
15:59:16 <TravT_> since we already were
15:59:34 <TravT_> any other vacations in the next week or two we should know about?
15:59:52 <rosmaita> i will be gone june 24-july 8
16:00:12 <sigmavirus24> unlikely I'll be able to take a vacation in the next 3 weeks
16:00:21 <sigmavirus24> if I can find one after that I'll let you all know
16:00:34 * TravT_ pictures sigmavirus24 being chained to desk.
16:00:44 <TravT_> i guess we're out of time.
16:00:46 <sigmavirus24> more or less
16:00:49 <sigmavirus24> =P
16:00:49 <TravT_> thanks everybody
16:00:50 <nikhil_k> Thanks!
16:00:52 <sigmavirus24> htanks travis
16:00:53 <kragniz> TravT_: yeah
16:00:55 <TravT_> #end meeting
16:01:00 <TravT_> #endmeeting