15:00:57 <nikhil_k> #startmeeting openstack search
15:00:58 <openstack> Meeting started Thu Jun 18 15:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:02 <openstack> The meeting name has been set to 'openstack_search'
15:01:08 <nikhil_k> #topic agenda and roll call
15:01:11 <sjmc7> mornin
15:01:14 <kragniz> o/
15:01:16 <david-lyle> o/
15:01:18 <lakshmiS> o/
15:01:25 <nikhil_k> g'morning/afternoon/evening
15:01:40 <rosmaita> o/
15:01:50 <nikhil_k> #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:02:34 <kragniz> so the repo is set up in gerrit now
15:02:42 <nikhil_k> Thanks guys. I wanted to discuss the possibility of mid-cycle meeting co-located with Glance.
15:02:51 <lakshmiS> thats a great way to start!!
15:02:59 <kragniz> we still need to add people to the group so we can approve patches
15:03:02 <nikhil_k> #topic We've operational gerrit workflow
15:03:17 <nikhil_k> kragniz: who's the admin?
15:03:24 <nikhil_k> openstack-ci?
15:03:25 <kragniz> nikhil_k: no one yet
15:03:35 <nikhil_k> huh?
15:03:37 <kragniz> #link https://review.openstack.org/#/admin/groups/964,members
15:03:48 <sjmc7> doh
15:03:57 <nikhil_k> someone must have to be there to create it?
15:04:14 <sjmc7> apparently not
15:04:15 <kragniz> we need to talk to -infra to get someone added, then they add other people
15:04:24 <nikhil_k> kragniz: you wanna own it?
15:04:29 <kragniz> sure
15:04:40 <nikhil_k> #action kragniz : talk to -infra to get someone added to
15:04:47 <sjmc7> there was a list of potential cores somewhere in the post-summit conversation
15:04:47 <nikhil_k> #info Group searchlight-core
15:05:02 <david-lyle> you should make the co-PTLs admins
15:05:14 <david-lyle> as well
15:05:22 <kragniz> yup
15:05:31 <kragniz> there's also searchlight-release
15:05:54 <david-lyle> nevermind, mixing lp and gerit
15:06:08 <nikhil_k> usually, all drivers are admins
15:06:18 <nikhil_k> here cores==drivers
15:06:27 <david-lyle> right, just got my tools crossed
15:06:41 <kragniz> after we have that done, we need to fix the gate, which is currenly failing
15:06:52 <sjmc7> agreed
15:07:19 <sjmc7> unless anyone desperately wants to, i can take a look at that
15:07:20 <kragniz> sjmc7: do you want to look at that?
15:07:22 <kragniz> heh
15:07:39 <sjmc7> i'm hoping it's something simple in our tox file
15:07:42 <nikhil_k> #action sjmc7 , kragniz to look at the failing gate
15:07:52 <kragniz> sjmc7: I think it's the same failure I was seeing on that last patch of yours on github
15:08:18 <sjmc7> looked like it was much earlier in the process when i took a quick look yesterday but i'll dive in later
15:08:46 <nikhil_k> this is the failure
15:08:48 <nikhil_k> #link http://logs.openstack.org/32/192532/1/check/gate-searchlight-python27/1020cb4/testr_results.html.gz
15:09:13 <sjmc7> ok. yeah, will take a look today
15:09:17 <nikhil_k> looks like mismatch , members is missing in actual
15:09:43 <sjmc7> pep8 was failing too i noticed
15:10:00 <nikhil_k> ah, on the newer one
15:10:10 <sjmc7> yep. i'll dig around later today
15:10:27 <nikhil_k> Thanks
15:10:34 <nikhil_k> #topic BP walkthrough
15:10:47 <nikhil_k> #info BPs registered: https://blueprints.launchpad.net/searchlight
15:10:52 <nikhil_k> Thanks everyone for doing that.
15:11:07 <sjmc7> that was the easy part :)
15:11:15 <nikhil_k> #action: nikhil_k to add performance test related BP
15:11:24 <lakshmiS> I guess we can mark this BP as implemented now? https://blueprints.launchpad.net/searchlight/+spec/separate-from-glance
15:11:26 <nikhil_k> Any other missing?
15:11:48 <sjmc7> i think those were all the ones we discussed
15:12:09 <nikhil_k> nice!
15:12:20 <kragniz> lakshmiS: yup, I think so
15:12:22 <nikhil_k> lakshmiS: makes sense. may be the init gerrit link can be posted there?
15:12:27 <nikhil_k> kragniz: ^
15:12:41 <lakshmiS> sure!
15:13:07 <kragniz> #link https://review.openstack.org/#/admin/projects/openstack/searchlight
15:13:24 <kragniz> oops, there not here
15:14:26 <kragniz> done and maked as implemented
15:15:08 <lakshmiS> kragniz: thx
15:15:41 <sjmc7> yay!
15:15:58 <nikhil_k> some more details added
15:16:11 * sigmavirus24 got distracted, sorry
15:16:23 <kragniz> sigmavirus24: you missed all the fun!
15:17:15 <lakshmiS> sigmavirus24: check your inbox for all the blueprints assigned to you ;)
15:17:20 * sigmavirus24 read the scrollback
15:17:22 <sigmavirus24> lakshmiS: lol
15:17:23 <sjmc7> :)
15:17:29 <sigmavirus24> lakshmiS: https://blueprints.launchpad.net/searchlight shows none
15:17:32 <sigmavirus24> so I'm winning
15:17:45 <lakshmiS> wait for it ...
15:17:45 <nikhil_k> all unassigned go to sigmavirus24 :P
15:18:14 * sigmavirus24 is disappointed in launchpad. No way to subscribe to new blueprints it seems
15:18:19 <nikhil_k> kragniz: I guess we can create one in glance for #link https://blueprints.launchpad.net/searchlight/+spec/remove-from-glance
15:18:33 <nikhil_k> Should we mark it as started now?
15:19:01 <sjmc7> has any one volunteered to do it?
15:19:12 <kragniz> can you mark a BP as being for more than one project
15:19:15 <nikhil_k> I see kragniz assigned
15:19:19 <kragniz> sjmc7: I sort of did
15:19:27 <kragniz> not very attached to it, though
15:19:27 <sjmc7> good man!
15:19:56 <lakshmiS> kragniz: thats the point. remove all the attachments from glance
15:19:58 <nikhil_k> kragniz: umm, I can help out the spec+BP
15:20:30 <nikhil_k> #action nikhil_k : create a glance spec and BP for port-out of CIS code
15:20:48 <lakshmiS> kragniz: i can help with it, since i added most of it in glance ;)
15:20:54 <nikhil_k> I will link the spec to this BP too
15:21:11 <kragniz> lakshmiS: great
15:21:42 <sigmavirus24> kragniz: you can't
15:21:50 <nikhil_k> #info https://blueprints.launchpad.net/searchlight/+spec/glance-image-api-plugin
15:21:56 <sigmavirus24> (mark it as affecting more than one project)
15:22:11 <kragniz> sigmavirus24: :(
15:22:29 <nikhil_k> sjmc7: I guess this work would go in Glance mostly
15:22:38 <nikhil_k> ?
15:22:43 <sjmc7> nikhil_k no
15:22:57 <sjmc7> what we proposed for liberty was keeping it all in searchlight
15:23:15 <sjmc7> because otherwise we have precisely the same problems we had for kilo that we have little control over the pace we can make changes
15:23:29 <sjmc7> and because if plugins are spread around everywhere, making changes to the base code is hard
15:23:35 <lakshmiS> nikhil_k: did you mean that this is about glance images or where the code lives?
15:23:35 <nikhil_k> hmm, I thought that was just for tests
15:23:51 <nikhil_k> lakshmiS: I meant the plugin.
15:24:00 <nikhil_k> (code)
15:24:04 <sjmc7> we can discuss it but i think development will be VERY hard if we immediately try to push plugin code out to other projects
15:24:31 <kragniz> yeah, we discussed this a while ago
15:24:36 <lakshmiS> nikhil_k: yeah we need to talk about it.
15:25:37 <nikhil_k> Looks like we should create a breakdown of the implementation of this BP
15:25:50 <sjmc7> the code's already there
15:25:56 <sjmc7> in the searchlight repo
15:25:58 <lakshmiS> nikhil_k: the initial idea is to keep glance and nova plugin in searchlight to start with the initial codebase
15:26:09 <nikhil_k> I think putting this in Glance wouldn't hurt for Liberty and that can be an example for other project in next releases
15:26:27 <sjmc7> it makes deployment, testing etc MUCH harder from the get go
15:26:34 <lakshmiS> nikhil_k: I agree but that should be a seperate BP
15:26:40 <nikhil_k> cool
15:27:08 <nikhil_k> so, this is very searchlight centric for now. We can leave other projects scope out.
15:27:14 <sjmc7> yeah, i'm good with a separate BP. that is the direction we want to take, but i'd like to get those initial plugins done first
15:27:40 <nikhil_k> I think that may slow down adoption but we need to focus on getting it to work intiially.
15:27:49 <lakshmiS> exactly!
15:28:09 * nikhil_k quickly changes his TODOs
15:28:12 <sjmc7> yeah, that's my thought
15:28:31 <sjmc7> but i agree with using glance as the intial example of where we want to go, just not right now
15:29:17 <lakshmiS> but in the long run its easy to maintain the glance plugin code in glance(especially for RBAC changes)
15:29:48 <nikhil_k> yeah
15:30:04 <nikhil_k> I think we may do oslo.versionedobjects this cycle then
15:30:13 <nikhil_k> given there is b/w
15:30:42 <nikhil_k> that complicates stuff a bit for indexing but we will see
15:31:17 <lakshmiS> yeah will have to maintain multiple index mappings
15:31:46 <nikhil_k> agree and think the rythm should work
15:32:08 <nikhil_k> for deployments we need to follow https://blueprints.launchpad.net/searchlight/+spec/devstack-plugin , right? but no one assigned yet
15:32:52 <lakshmiS> i thought eklarso was interested
15:32:56 <sjmc7> someone was keen to do devstack integeration
15:32:58 <nikhil_k> wko: ekarlso seem to be volunteers
15:32:59 <sjmc7> ah, yeah, that's right
15:33:08 <nikhil_k> #link https://etherpad.openstack.org/p/liberty-searchlight-brainstorming
15:33:22 <lakshmiS> wko did the intial devstack patch
15:33:41 <sjmc7> wayne i think?
15:33:43 <sjmc7> yeah
15:34:27 <nikhil_k> can we assign someone to that ?
15:34:34 <lakshmiS> lets assign to wko to start with
15:34:54 <nikhil_k> given it would be great to have it working earlier in the cycle
15:35:06 <nikhil_k> fyi, Liberty-1 is next week
15:35:14 <ekarlso> volunteer for what ? :D
15:35:23 <nikhil_k> ekarlso: https://blueprints.launchpad.net/searchlight/+spec/devstack-plugin
15:36:38 <nikhil_k> lakshmiS: sjmc7  we have to just port the code proposed against glance for this https://blueprints.launchpad.net/searchlight/+spec/set-up-functional-tests ?
15:37:14 <sjmc7> nikhil_k yep
15:37:14 <ekarlso> nikhil_k: oh, who wrote that ?
15:37:17 <sjmc7> i can probably do that
15:37:33 <nikhil_k> #link https://review.openstack.org/#/c/157209/
15:38:03 <ekarlso> sjmc7: I can help you with it if you want me to
15:38:10 <nikhil_k> #action sjmc7 to port out functional tests proposed against glance to propose against searchlight
15:38:15 <sjmc7> we're talking about different things i think
15:38:22 <sjmc7> i'm not doing the devstack stuff :)
15:38:25 <ekarlso> sjmc7: the functional tests part ;)
15:38:30 <lakshmiS> :)
15:38:47 <sjmc7> ok. i'll port the review over; it will likely need some work
15:39:12 <lakshmiS> ekarlso: I can ask wayne to get in touch with you on the devstack patch. Are you interested working on it?
15:39:19 <ekarlso> lakshmiS: ofc
15:39:26 <ekarlso> sjmc7: judging from the looks of it you need to add base scaffolding to get it to work
15:39:31 <sjmc7> aye
15:40:16 <nikhil_k> yeah, glance spins up servers for functional tests
15:40:36 <nikhil_k> I wonder if that's a correct terminology for such tests more so for searchlight
15:40:47 <nikhil_k> any preference to calling them integration tests?
15:40:57 <ekarlso> nikhil_k: uh I think for that you could just cheat and post out notifications to the MQ where the listeners are...
15:41:01 <sjmc7> they are functional, i think, not integration
15:41:05 <sjmc7> integration would be tempest
15:41:24 <ekarlso> or am I talking about smth diff ;P
15:41:34 <ekarlso> ah, probably are ..
15:41:36 <ekarlso> nvm me :)
15:41:46 <sjmc7> the existing tests were primarily to test RBAC, not notification processing
15:41:50 <nikhil_k> tempest tests for integration are being ported out
15:42:16 <nikhil_k> given we would be testing plugins for different projects, I am in more dilemma about the name
15:42:24 <nikhil_k> tests in glance are confusing as they are
15:42:40 <nikhil_k> we were going to port out functional tests to tempest as they are more integration like
15:42:55 <nikhil_k> so that's a bad name currently there
15:43:04 <sjmc7> ah, ok
15:43:13 <sjmc7> ummm.. in that case, i might not be the best person to do it
15:43:23 <kragniz> I thought other projects were moving their functional tests out of tempest now?
15:43:48 <nikhil_k> sjmc7: I or some one would need to follow up on what's the speed of porting out tempest tests under projects
15:44:04 <nikhil_k> in that case we can get rid of functional and just keep integration
15:44:37 <nikhil_k> s/under/to go under projects umbrella/g
15:44:42 <sjmc7> ok.. i'm confused. should i hold off moving that un-merged glance review into searchlight?
15:44:57 <nikhil_k> sjmc7: yeah, may be we can pick it up next week
15:45:02 <ekarlso> kragniz: moving tests out of tempest itself and in project tree under folders aclled "functionaltests" or alike using the tempest-lib
15:45:07 <sjmc7> personally i think it's useful having tests that can be run outside the context of devstack that actually exercise elasticsearch
15:45:16 <ekarlso> kragniz: so each proj has independent functionaltests
15:45:53 <nikhil_k> sjmc7: yeah, it would be a very painful job to maintain them and they are very expensive on the CI/CD
15:46:05 <nikhil_k> yeah ==  I agree
15:46:15 <nikhil_k> but that's the tradeoff
15:46:22 <sjmc7> ok. so - hold off for now?
15:46:28 <nikhil_k> yes, please
15:46:45 <nikhil_k> #action: nikhil_k check tempest-lib adoption speed
15:47:20 <ekarlso> nikhil_k: I'l help you out if you want to ..
15:47:20 <nikhil_k> I just wanted to discuss the preference for the mid-cycle location and dates
15:47:38 <nikhil_k> ekarlso: awesome, that would be super helpful. ping out offline..
15:47:43 <nikhil_k> you*
15:47:49 <nikhil_k> #topic Mid cycle
15:47:57 <nikhil_k> #info Horizon is officially the week of July 21 in Fort Collins
15:48:13 <nikhil_k> We are discussing multiple possiblities for Glance atm
15:48:28 <nikhil_k> but some memebers are suggesting July 28th
15:48:55 <sjmc7> it would be easy for me to go to the horizon one; i can probably get clearance to travel somewhere else but won't be able to do two weeks
15:49:13 <lakshmiS> I am ok with any date. I will attend remote due to travel budget problems
15:49:13 <nikhil_k> ah
15:49:57 <david-lyle> the 21st was the only way Horizon could get critical mass
15:50:31 <nikhil_k> yeah, thanks for helping get feedback and decision david-lyle :-)
15:51:03 <david-lyle> midcycle scheduling is not fun, for the record :)
15:51:09 <sjmc7> :)
15:51:21 <nikhil_k> anyone else?
15:51:41 <sjmc7> is the preference that SL be part of glance's? i guess that makes more sense given the personnel
15:51:52 <nikhil_k> krykowski : would you be joining us?
15:52:39 <nikhil_k> sjmc7: My thought was that Travis et.al would be at the Horizon so, may be we can do discussion there and at Glance's too given people can travel
15:53:15 <david-lyle> I still think a virtual midcycle might make sense for Searchlight
15:53:19 <nikhil_k> If Glance happens in bburg, there would be decent number of people interested in getting involved and providing feedback
15:53:38 <sjmc7> bburg?
15:53:50 <nikhil_k> david-lyle: sure. I was thinking more along the lines of -- a few active folks show up
15:54:01 <nikhil_k> oops, bburg == Blacksburg, VA
15:54:14 <david-lyle> nikhil_k: sure, either way
15:54:15 <nikhil_k> sigmavirus24: do you think if we set location to that you may get to travel?
15:54:24 <sjmc7> my apologies for not recognizing the acronym for that seething metropolis!
15:54:44 <david-lyle> sjmc7: :)
15:54:53 <nikhil_k> david-lyle: but I agree, the entire team would need a virtual mid-cycle
15:55:06 <sigmavirus24> nikhil_k: so tl;dr I'm a secondary caregiver and travel is just not going to work for a while now + the sprint planning shenanigans on my team mean I probably won't be able to even take a vacation until August
15:55:24 <sjmc7> i'm ok planning for a virtual one
15:55:32 <nikhil_k> sjmc7: heh. habit fail :-)
15:55:36 <ekarlso> if virtual then I can attend :P
15:55:46 <sjmc7> and i'm similar - other work commitments are starting to crunch for the next 2 months
15:56:28 <nikhil_k> sigmavirus24: gotcha
15:56:59 <nikhil_k> Thanks for the feedback !
15:57:06 <sjmc7> let's see what glance decides, and then make a decision
15:57:30 <nikhil_k> I guess Glance team just needs to decide how many can show up if non-colocated event happens
15:57:44 <sjmc7> yeah. it sounds like not many here can travel in any case
15:58:01 <nikhil_k> I am a bit worried about people not getting budget approved in that case
15:58:23 <nikhil_k> may be we will cancle and keep things virtual this cycle
15:58:57 <kragniz> I'd be good with that
15:59:00 <lakshmiS> sounds like virtual this time!
15:59:06 <sjmc7> okey dokey
15:59:09 <nikhil_k> distributed team!
15:59:35 <nikhil_k> Thanks all.
15:59:58 <sjmc7> thanks for running it
16:00:07 <nikhil_k> :)
16:00:09 <nikhil_k> #endmeeting