15:02:01 <TravT> #startmeeting openstack search
15:02:01 <openstack> Meeting started Thu Jun 25 15:02:01 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:05 <openstack> The meeting name has been set to 'openstack_search'
15:02:08 <nikhil_k> o/
15:02:14 <TravT> #chair nikhil_k
15:02:15 <openstack> Current chairs: TravT nikhil_k
15:02:28 <TravT> hey nikhil_k
15:02:39 <nikhil_k> hi TravT
15:02:41 <kragniz> o/
15:02:41 <lakshmiS_> o/
15:02:49 <nikhil_k> Hope you had a great trip
15:02:58 <TravT> well, i'm about 20 minutes back into work...
15:03:08 <TravT> always rough to get going again
15:03:09 <david-lyle> o/
15:03:12 <nikhil_k> :)
15:03:18 <sjmc7> o/
15:03:59 <TravT> ok
15:04:34 <TravT> so, looks like the first #topic is mid cycle meetup
15:04:51 <TravT> nikhil_k, any updates on this?
15:05:06 <TravT> #topic mid-cycle meetup
15:05:11 <nikhil_k> #link https://etherpad.openstack.org/p/search-team-meeting-agenda/q
15:05:14 <nikhil_k> o/
15:05:43 <nikhil_k> The Glance mid-cycle is planned to be in BLacksburg, VA July 28-30
15:05:58 <TravT> david-lyle: horizon is finalized for July 21 - 23rd in Fort Collins, right?
15:06:04 <david-lyle> correct
15:06:21 <nikhil_k> There was a lot of demand from US folks who showed interest in attending and in Blakcsburg so we went ahead with that plan
15:06:32 <TravT> so, we won't have the overlap that would have helped with travel planning coordination.
15:07:01 <nikhil_k> I have asked for video conferencing capability and from experience it works very well in Blacksburg
15:07:13 <nikhil_k> +1 TravT
15:07:19 <TravT> kragniz, laskhmiS_: you guys couldn't travel anyway, right?
15:07:26 <lakshmiS_> yes
15:07:41 <kragniz> TravT: likely
15:08:08 <nikhil_k> As a lot of the european folks aren't showing the possiblity of attending during that time frame (for travel and other reasons) we will have it remote heavy
15:08:35 <nikhil_k> But I request everyone to please try and attend personally if possible!
15:09:01 <TravT> so, the question is whether or not we should try to do a one day searchlight meetup at the same time in blacksburg?
15:09:46 <TravT> or if we should do a morning or two of virtual conferences (US morning)
15:10:02 <nikhil_k> That would be fantastic but like GLance we can agree to not make important decisions if people aren't able to attend (Even remotely)
15:10:22 <nikhil_k> Having people personally will help with some face to face time and rapport building
15:10:38 <TravT> sjmc7 how are things looking for you?
15:11:02 <sjmc7> manager's been on vacation til today. i am 100% certain i could get clearance to travel to FC for the horizon one, not sure about VA
15:11:13 <nikhil_k> Also, if someone is planning to fly into CLT we can arrange for ride-sharing (With someone attending the meetup)
15:11:52 <TravT> i think some of the best value we could get is if we do some pair programming.
15:12:47 <TravT> david-lyle: what is your availability?
15:13:21 <david-lyle> I'm not sure I can make it to VA :(
15:13:50 <TravT> ok, so it sounds like we need to all have a discussion with our managers.
15:14:21 <TravT> nikhil_k, is this tied to the interest, time, virtual meetings topic up next?
15:14:27 <TravT> or is that separate?
15:14:56 <nikhil_k> TravT: yes
15:15:06 <nikhil_k> it's the same, just wanted some feedback
15:15:25 <nikhil_k> Basically, the only reason the announcement is not on the ML is to check any red flags
15:15:50 <nikhil_k> The homework to schedule it in Blacksburg has been mostly done
15:16:17 <TravT> ok, well, I can probably get to blacksburg if we can get a few other people there.
15:16:22 <nikhil_k> and I am too tired now to think about rescheduling :)
15:16:33 <TravT> but I think all of this is tied to another topic
15:16:46 <TravT> #topic Liberty 2 Release Plan
15:17:26 <TravT> If we hope to have something usuable in liberty, we need to make some solid progress on implementing some blueprints in Liberty 2
15:18:02 <TravT> I guess first of all, there are 3 blueprints on liberty-1
15:18:06 <TravT> #link https://launchpad.net/searchlight/+milestone/liberty-1
15:18:27 <TravT> lakshmiS, sjmc7, kragniz: are they all implemented?
15:18:36 <TravT> or do we need to move any of them to liberty 2?
15:18:42 <nikhil_k> TravT: I checked with rel-mgrs the other day and they are cool with the team releasing it's own milestone(s) in Liberty timeframe. We dont' have to stick to the common schedule
15:18:52 <sjmc7> 1 and 2 are, TravT
15:19:00 <sjmc7> not sure about whether the code's out of glance yet
15:19:08 <nikhil_k> So, may be we just pick a date and call it Liberty-0.1 or something
15:19:14 <TravT> sjmc7: can you update the status
15:19:23 <nikhil_k> sjmc7: it's not yet. (last time I checked)
15:19:47 <TravT> nikhil_k: what are the pros and cons?
15:20:24 <nikhil_k> pro: we don't have to wait. something is out is good for real world testing and getting interested poeple using it beta
15:20:54 <nikhil_k> cons: we have to keep track of the dates and rel-mgmt ourselves and it doesn't happen in batch mode
15:21:15 <lakshmiS_> but i think it should be an easy task to remove the code
15:21:26 <TravT> hmm... so are you saying maybe we'd do like a 0.1 and then go back to standard milestones?
15:21:27 <lakshmiS_> since its isolated
15:21:30 <nikhil_k> pro: we can work on fixing packaging issues offline and not in the gate (& other rush) during peak rel periods
15:22:02 <TravT> david-lyle: what should we consider from a horizon consumption of searchlight perspective when it comes to releases?
15:22:11 <nikhil_k> cons: we may hav eto resolve packing woes ourselves and get less help from the experts working upstream already
15:22:48 <nikhil_k> TravT: yeah, I think we can go with 0.1 as alpha and may be a 0.2 beta followed with Liberty overall for beta-prod
15:23:03 <david-lyle> Horizon will likely only consume a client if there is one and the version for that can be anything
15:23:27 <david-lyle> if there's not, they dependency wise, I suppose we don't have one
15:23:35 <david-lyle> s/they/then/
15:23:54 <david-lyle> just make the API calls and hope for the best
15:23:59 <nikhil_k> :)
15:24:05 <TravT> david-lyle: we need to talk through the whole client concept and see if we would initially write direct queries from horizon.
15:24:26 <sjmc7> we can make available the code from the summit demo if that'd help discussion
15:24:35 <sjmc7> i think it's on github
15:24:43 <david-lyle> I think initially it's fine to make direct calls
15:24:52 <TravT> sjcm7: yep, i was planning on syncing up with you and kelly on that in the next day or so
15:24:56 <david-lyle> the API shouldn't be overly complex to need a wrapper
15:25:09 <david-lyle> and we can adjust later if necessary
15:25:23 <nikhil_k> ++
15:25:41 <david-lyle> but in that case, if searchlight shows up in the service catalog, we'll expose it in horizon, otherwise no
15:26:04 <sjmc7> again, we had some PoC code to do that that might be good to start conversation
15:26:23 <david-lyle> sjmc7: are you saying it's a mess ;)
15:27:10 <TravT> sjmc7: definitely, i want to start working from some of that code in horizon.  was going to open a proper blueprint on the horizon side.
15:27:21 <sjmc7> it's charming and rough around the edges
15:27:44 <TravT> david-lyle: was thinking of first opening a blueprint to angularize images table.
15:27:49 <TravT> and start working on that
15:28:06 <TravT> and then adding the searchlight integration for images first
15:28:15 <TravT> since it is in theory ready for images
15:28:20 <TravT> and then do instances
15:28:28 <david-lyle> good to use what's there rather than what's not
15:28:33 <david-lyle> ++
15:28:47 <TravT> but hopefully instances BP will be ready soon.
15:29:16 <TravT> so, we can swing back around on this tangent
15:29:49 <TravT> nikhil_k on releases, what all is involved?
15:30:21 <nikhil_k> TravT: if we do it ourselves, getting the script that does the tagging of bugs
15:30:29 <nikhil_k> we will hav eto manually update BPs
15:30:43 <nikhil_k> also, rel notes are written by the PTL so that
15:31:00 <nikhil_k> requirements check
15:31:05 <nikhil_k> stable branch
15:31:24 <nikhil_k> and setting up backports etc tags in BP to help keep track of stuff
15:31:32 <nikhil_k> minor things
15:31:37 <nikhil_k> but many
15:32:26 <nikhil_k> these are two edged swords, it used by openstack rel-mgrs then we would always be in a rush. but if we do it personally then a bit of work
15:32:34 <nikhil_k> s/it/if/g
15:32:55 <david-lyle> release mgmt should still help us even if we pick an open release schedule
15:32:55 <TravT> ok, so, if we wait until liberty 2, they'd take care of a number of the above?
15:33:21 <nikhil_k> david-lyle: I hope so, they said that team should do it on its own schedule for newer projects
15:33:22 <david-lyle> be parting of the integrated 6 month release is no longer a requirement
15:33:41 <david-lyle> can't type
15:33:43 <david-lyle> being part
15:34:20 <TravT> ok, well, it seems like even if we try to line up with liberty 2, that we should start heading in that direction sooner than later.
15:34:21 <david-lyle> incubated projects in the past also set their own milestones
15:34:24 <nikhil_k> TravT: may be. the tone of the response seemed tentative as there is a lot of work as is with so many older projects
15:34:53 <david-lyle> nikhil_k: hedging against overload
15:35:06 <nikhil_k> My feeling was that we have something out soon-ish for people to start consuming it and that might be worth one realse on our own
15:35:23 <nikhil_k> david-lyle: yeah, I understand
15:35:45 <TravT> ok, so we should try to do that.
15:36:03 <TravT> #action nikhil_k, TravT work on release plan
15:36:23 <TravT> So let's talk about important bp
15:36:30 <TravT> #topic Important BPs
15:36:40 <TravT> #link https://blueprints.launchpad.net/searchlight
15:37:03 <nikhil_k> sorry, I forgot to add my name
15:37:26 <TravT> go ahead nikhil_k
15:37:27 <nikhil_k> but feel free to go ahead
15:37:29 <nikhil_k> :)
15:37:52 <nikhil_k> Was curious if we can work on the devstack bit first and setup tests
15:38:08 <nikhil_k> having a good working dev environment doesn't hurt
15:38:15 <TravT> i would definitely like to see us get devstack in right away
15:38:29 <TravT> ekarlso: wko
15:38:43 <TravT> #link: https://review.openstack.org/#/c/194251/
15:38:50 <wko> yes
15:39:05 <TravT> wko, have you had a chance to look over the above?
15:39:32 <wko> only just
15:39:39 <TravT> since you had catalog index service working for glance
15:41:03 <TravT> ok, well, i just saw it right before the meeting.  I will look through it later today.
15:41:15 <TravT> sjmc7, looks like you've already given it a once over
15:41:25 <wko> it looks different to me, but, sorta the same
15:41:45 <TravT> there is some question about whether devstack should be under contrib folder or not
15:41:49 <sjmc7> yeah - i didn't have a chance to run it yet. there were some things i noted in the review but it follows the template of other projects fairly closely
15:42:35 <TravT> i see that karlso might have done that because it provides some symmetry with the vagrant file
15:43:16 <TravT> but, if we could all make it a priority to look over it, run it, review it, that'd be best.
15:43:56 <TravT> nikhil_k, what other items did you have on this topic?
15:44:06 <nikhil_k> I haven't had a chance to look at the possiblity of us using tempest-lib. this would mean we have intergration tests in the repo and not use the functional tests concept in glance (which is flawed anyways as it does a lot of integration testing). I am a bit caught up in nova using glance v2 work and that may take a bit of time in the coming weeks. Should we just play it by ear and go ahead with sjmc7's plan to port functional tests to SL?
15:45:50 <TravT> what this in last week's meeting?
15:45:57 <nikhil_k> yeah
15:46:02 <TravT> i need to catch up on that
15:46:02 <sjmc7> yeah, we didn't make a decision
15:46:53 <nikhil_k> no worries, just throwing it out there
15:47:10 <sjmc7> the tests i had did were mainly to exercise RBAC
15:47:27 <sjmc7> i don't think it had a requirement on keystone or any other services
15:47:42 <nikhil_k> yeah, it uses fake auth
15:47:51 <nikhil_k> which is terrible
15:48:00 <sjmc7> :)
15:48:01 <nikhil_k> but so are other things in glance :)
15:48:11 <sjmc7> it means they run as functional tests, rather than requiring a full stack
15:48:15 * nikhil_k pretends he did not just say that :P
15:48:25 <TravT> so, i thought integration testing was becoming more a responsibility within projects?
15:48:32 <nikhil_k> slowly
15:48:56 <nikhil_k> sjmc7: yeah, but they spin up a server process
15:49:05 <nikhil_k> so it's kinda really in the middle
15:49:21 <nikhil_k> and have it's own config, rbac etc setup
15:49:31 <nikhil_k> within the repo
15:50:09 <TravT> sjmc7 what would be your recommendation here?
15:50:22 <sjmc7> ultimately, we need tempest tests
15:50:49 <sjmc7> we can't do that until we're integrated properly, and until then i think there's value in having tests that run against elasticsearch
15:50:59 <TravT> i agree with that
15:51:13 <sjmc7> whether we invest the time doing it is another question
15:51:38 <sjmc7> versus getting into tempest asap
15:51:46 <TravT> if we don't have tests that run against elastic search, i'm not sure how we'd have any level on confidence
15:52:16 <nikhil_k> sjmc7: I agree with you. if we all can agree to not maintain functional tests in the repo and use tempest later, it would be really nice
15:53:05 <TravT> seems reasonable to me.
15:53:19 <TravT> hate to rush us, but this is still on topic.  nikhil_k where are you in looking at a nova plugin?
15:53:39 <nikhil_k> haven't started yet :(
15:53:47 <TravT> kragniz, lakshmiS, do you have any plugin work started on swift?
15:54:17 <nikhil_k> I can take a look late next week, (after coming abck from travel) but wouldn;t have status in the next meeting.
15:54:23 <lakshmiS_> stuart was asking for info from a spec which has similar requirement
15:54:28 <TravT> nikhil_k, do you want sjmc7 to post his initial nova plugin and then you guys (kragniz, lakshmiS) as well, could collaborate on it from there?
15:54:30 <sjmc7> i couldn't find any evidence swift sends notifications at the moment
15:54:46 <nikhil_k> with the defcore stuff in glance/nova images, I couldnt get a chance to ask John
15:54:57 <lakshmiS_> https://review.openstack.org/#/c/180918 is the spec which will send notications
15:55:02 <nikhil_k> TravT: that would work
15:55:58 <lakshmiS_> hopefully we can get them to use searchlight instead and let them develop the notifications
15:55:58 <sjmc7> TravT, nikhil_k - you want me to push a review up with the nova work from the summit and hand it over?
15:56:23 <TravT> sjmc7, that sounds good.  maybe you guys can co-author on it.  I'm sure lakshmiS can contribute as well.
15:56:42 <TravT> just want to see us start getting other data in from other services.
15:56:58 <TravT> we also, need somebody to start looking at neutron
15:57:09 <nikhil_k> sjmc7: sounds good
15:57:32 <TravT> #topic Adding an entrypoint for the agent process, potentially renaming searchlight-index because it's confusing
15:57:36 <TravT> sjmc7
15:57:37 <sjmc7> this was me!
15:57:39 <TravT> not much time
15:57:43 <sjmc7> i'll be brief
15:57:43 <TravT> sorry
15:57:57 <sjmc7> i think endre had some confusion (understably) about the searchlight-index entrypoint
15:58:05 <sjmc7> which in fact is more akin to glance-manage
15:58:15 <sjmc7> rather than being the notification indexing service
15:58:23 <sjmc7> so we a) need an entry point for agent_notifications
15:58:42 <sjmc7> and b) i suggest renaming searchlight-index to searchlight-manage or something similar
15:59:02 <sjmc7> and using searchlight-monitor or -agent or -listener for the daemon processes
15:59:29 <TravT> no -monitor
15:59:34 <sjmc7> -listener might be best
15:59:36 <TravT> too many impleications
15:59:43 <TravT> -listener sounds pretty good
15:59:48 <nikhil_k> +1 -listener
15:59:59 <nikhil_k> and on searchlight-manage
16:00:07 <TravT> i'm +1 on that as well
16:00:14 <nikhil_k> how about searchlight-ctrl
16:00:15 <sjmc7> i'll file a BP and make the change if nobody objects within a day or so
16:00:24 <TravT> yeah, BP would be best
16:00:28 <TravT> thanks everybody
16:00:30 <sjmc7> nikhil_k - i'll post the BP in a bit
16:00:32 <TravT> we are out of time.
16:00:32 <nikhil_k> thanks!
16:00:33 <sjmc7> make suggestions there
16:00:38 <nikhil_k> sjmc7: sure
16:00:39 <sjmc7> thanks TravtT
16:00:42 <TravT> #endmeeting