15:00:27 <TravT> #startmeeting openstack search
15:00:28 <openstack> Meeting started Thu Jul  2 15:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'openstack_search'
15:00:39 <nikhil_k> o/
15:00:40 <kragniz> o/
15:00:42 <david-lyle> o/
15:01:28 <TravT> hello everybody.
15:01:35 <lakshmiS_> o/
15:01:38 <TravT> give a min to see if other join
15:02:49 <sigmavirus24> o/
15:02:53 <sigmavirus24> sorry
15:03:09 <TravT> let me try to track down sjmc7...
15:03:52 <TravT> so, agenda is here as usual: https://etherpad.openstack.org/p/search-team-meeting-agenda
15:04:18 <TravT> please add anything you'd like to talk about.
15:04:36 <TravT> today, i mainly wanted to walk through bugs / blueprints
15:04:51 <TravT> nikhil_k, anything else you had in mind
15:05:15 <nikhil_k> TravT: nope, I just got back from a long travel
15:05:20 <sigmavirus24> "bugs" there are no bugs, just accidental features
15:05:22 <nikhil_k> so cactchin up :)
15:05:38 <nikhil_k> sigmavirus24: lol
15:05:51 <sigmavirus24> flaper87: ^^
15:06:22 <sjmc7> hey
15:06:27 <TravT> ok, so then
15:06:40 <TravT> #topic bugs https://bugs.launchpad.net/searchlight
15:07:01 * flaper87 reads
15:07:10 <flaper87> sigmavirus24: LOL
15:07:28 <TravT> so i'll start with an easy one to discuss as it leads to another
15:07:43 <TravT> i created a bug (could have been a bp) for setting a dev env
15:07:46 <TravT> https://bugs.launchpad.net/searchlight/+bug/1470194
15:07:46 <openstack> Launchpad bug 1470194 in OpenStack Search (Searchlight) "Missing developer manual install docs" [Undecided,In progress] - Assigned to Travis Tripp (travis-tripp)
15:07:55 <TravT> i think it is done.
15:08:05 <TravT> just addressed some minor comments from krykowski
15:08:51 <TravT> but it the process of that lakshmi and I remembered that we  have  a problem with notification listening
15:09:03 <TravT> https://bugs.launchpad.net/searchlight/+bug/1470627
15:09:03 <openstack> Launchpad bug 1470627 in OpenStack Search (Searchlight) "Searchlight does not receive notification when deployed in same env as Ceilometer" [High,New]
15:09:33 <TravT> sjmc7 originally found this while working on our summit demo
15:10:15 <sigmavirus24> oof
15:10:16 <sjmc7> i never definitely confirmed it
15:10:17 <sigmavirus24> that hurts
15:10:20 <TravT> sjmc7 or lakshmiS can you characterize a bit of what we think the problem is
15:10:28 <TravT> sjmc7, i confirmed it yesterday
15:10:29 <sjmc7> but it would explain some behavior i saw
15:10:31 <sjmc7> ok
15:10:35 <sjmc7> the problem is
15:10:51 <sjmc7> that we're sharing notifications with ceilometer, so to rabbitmq ceilometer and searchlight look like the same consumer
15:11:02 <TravT> when i killed the ceilometer processes, notifications flowed.
15:11:24 <lakshmiS_> ceilometer also listens on the same glance notification info
15:11:54 <lakshmiS_> and searchlight doesnt seem to recieve it when ceilometer is running
15:12:19 <lakshmiS_> i was trying to create a pool name to isolate it but still troubleshooting it
15:13:05 <TravT> ok, so lakshmiS_ does that mean you can take ownership of this bug?
15:13:09 <lakshmiS_> sure
15:13:37 <sjmc7> being able to set up a separate consumer would be a much neater fix than having to have services send requests to multiple topics
15:14:28 <TravT> anybody have any ideas to help lakshmiS_ out?
15:14:39 <lakshmiS_> yeah that the idea behind a pool name as an namespace which oslo messaging should send it multiple consumers but somehow not working
15:16:01 <TravT> ok, i guess we can move on.
15:16:51 <TravT> next bug seems pretty small. not much to say about it.
15:16:52 <TravT> https://bugs.launchpad.net/searchlight/+bug/1469336
15:16:52 <openstack> Launchpad bug 1469336 in OpenStack Search (Searchlight) "Errors are returned as html" [Undecided,New]
15:17:40 <TravT> so moving on #topic blueprints https://blueprints.launchpad.net/searchlight
15:17:47 <TravT> #topic blueprints https://blueprints.launchpad.net/searchlight
15:18:06 <TravT> ekarlso has done some great work on getting a devstack plugin going
15:18:14 <TravT> https://blueprints.launchpad.net/searchlight/+spec/devstack-plugin
15:18:18 <nikhil_k> yay!
15:18:22 <sigmavirus24> TravT: agreed
15:18:28 <TravT> I tested it quite a bit yesterday
15:18:37 <TravT> found a few things and he addressed overnight
15:18:45 <TravT> i just was almost done testing it again this morning
15:18:56 <TravT> hit an odd error, that I think was my fault
15:19:25 <TravT> #link https://review.openstack.org/#/c/194251/
15:19:33 <TravT> but this is a bit tricky to test.
15:19:44 <TravT> I'd like to suggest that we don't all nitpick this patch too much
15:20:03 <TravT> because it enables everybody and is kinda difficult to test in current state
15:20:11 <TravT> because of the way devstack plugins work.
15:20:18 <TravT> you kind of have to install devstack twice
15:20:25 <TravT> i put some notes in a comment yesterday
15:20:31 <TravT> on that.
15:21:03 <TravT> but hopefully we can get it in and then improve from there
15:21:18 <sjmc7> agree about not nitpicking too much,although i would like to get the entrypoints tidied up
15:21:30 <TravT> well, that is a chicken or the egg kind of thing right?
15:22:03 <TravT> you are referring to #link https://review.openstack.org/#/c/196750/
15:22:05 <TravT> ?
15:22:16 <sjmc7> it's an ordering issue, yes
15:22:42 <sjmc7> yeah, i guess it doesn't matter which way round
15:23:05 <TravT> both are marked as essential.
15:23:48 <TravT> so, just walking down through the bp's
15:23:53 <TravT> next is https://blueprints.launchpad.net/searchlight/+spec/glance-metadef-plugin
15:24:50 <TravT> sjmc7 are metadefs basically done?
15:24:54 <TravT> at least for first pass?
15:25:06 <sjmc7> i *think* so, though i'd like someone who understands them to test it
15:25:40 <sjmc7> in particular i think updates may need looking at. the original was very complicated and relied heavily on database access
15:26:05 <TravT> any volunteers to look through that?  lakshmiS_?
15:26:25 <lakshmiS_> i think kamil would be a better person, but i can also check
15:26:59 <TravT> ok, let's ping kamil.  he's been pretty active recently.
15:27:16 <TravT> i will be looking at them from a consumer standpoint shortly.
15:27:42 <TravT> ok, so next is nova.
15:28:07 <TravT> nikhil_k owns it, but i believe sjmc7 you were going to do an initial drop of the summit demo POC code?
15:28:27 <TravT> https://blueprints.launchpad.net/searchlight/+spec/nova-instances-plugin
15:28:28 <sjmc7> yeah, i was. i will try and do it today
15:28:32 <sjmc7> or over the weekend
15:28:44 * nikhil_k needs to consult nova folks about object versioning and indexing
15:28:55 <sjmc7> yeah, i'm not getting involved with that :)
15:29:40 <TravT> ok, well, i guess if you can just update the blueprint with what you know.
15:30:00 <sjmc7> i'll get an initial review up when i can
15:30:03 <nikhil_k> missed my meeting with john this week, I will try to schedule one next and update
15:30:10 <TravT> sjmc7, it is a holiday weekend, so not asking you to work over it!
15:30:29 <sjmc7> that's going to happen anyway unfortunately
15:31:24 <TravT> in my doc patch, i have started a rst for glance plugin as an initial landing place for documenting the plugins
15:31:28 <TravT> https://review.openstack.org/#/c/197232/8/doc/source/plugins/glance.rst
15:31:37 <TravT> we'll want to do the same for other plugins
15:31:53 <TravT> so, maybe what you find out nikhil_k could go in rst file like that
15:31:55 <TravT> in patch
15:32:02 <nikhil_k> TravT: sure
15:32:19 <TravT> thanks
15:32:24 <nikhil_k> #action nikhil_k : add infromation on nova pluging reqs to documentation
15:32:24 <TravT> next up is indexing cli
15:32:44 <TravT> bp is basically blank at this point.
15:32:51 <TravT> https://blueprints.launchpad.net/searchlight/+spec/indexing-cli
15:32:57 * nikhil_k is half asleep/tired
15:32:59 <TravT> i'm wondering how this relates to the entrypoints
15:33:36 <sjmc7> i don't know what this is :)
15:33:52 <TravT> there was some discussion about it in brainstorming session
15:34:07 <TravT> ahh... now i remember
15:34:15 <TravT> this is diff than searchlight-index
15:34:22 <TravT> this is more like the glanceclient has a cli
15:35:17 <TravT> i seem to remember kragniz being opinionated on this, but since the BP is basically blank and I filed it, I'll try to first clarify from old notes
15:35:23 <nikhil_k> wrapper around API? then why just on index?
15:35:48 <TravT> nikhil_k, idk
15:36:12 <nikhil_k> may be we can ask on that BP?
15:36:26 <TravT> yeah, if you can fill in anything on it, please do.
15:36:32 <nikhil_k> and ask for differentiation between searchlight-index ?
15:37:40 <TravT> any other comments on CLI to add here?
15:38:14 <sjmc7> i think this was to aboid having to run the equiv of glance-manage
15:38:27 <sjmc7> something you could use to force indexing from elsewhere
15:39:01 <TravT> i would like to see the index command API make a comeback
15:39:13 <TravT> iirc that got ripped out of what landed in glance
15:39:25 <TravT> i mean, it never made it into glance
15:39:31 <TravT> and so we still don't have it
15:39:46 <sjmc7> i've no objection to doing that. the plumbing is mostly there
15:40:05 <TravT> so, i suppose that means a new BP for the API first
15:40:36 <TravT> Anybody willing to file it?  I think we could copy paste from our original spec in glance.
15:41:15 <sjmc7> if nobody else wants to do it i'll volunteer and hopefully not forget this one too
15:41:22 <TravT> lol
15:41:26 <lakshmiS_> you mean the original spec?
15:41:48 <TravT> we had a whole section in the original spec on an index management API...
15:42:01 <TravT> that's basically the BP i'm talking about filing
15:42:07 <lakshmiS_> yeah i can do that too
15:42:13 <TravT> ok. cool
15:42:23 <TravT> next up functional tests
15:42:30 <TravT> https://blueprints.launchpad.net/searchlight/+spec/set-up-functional-tests
15:42:49 <TravT> anybody willing to take ownership?
15:44:07 <TravT> guess we'll have to come back to that.
15:44:07 <lakshmiS_> i have some of the RBAC sceanarios that brian has given previously which i can add some of them but not all the tests
15:44:19 <nikhil_k> TravT: ++
15:44:25 <sjmc7> we keep getting caught up on what we mean by functional tests
15:44:35 <nikhil_k> lakshmiS_: I can pair with you on adding more covrage
15:44:46 <sjmc7> there's the patch that was never merged into glance that i did, but last week it sounded like that wasn't what people want
15:44:47 <TravT> lakshmiS_, you don't have to own the whole thing.
15:44:54 <lakshmiS_> nikhil_k: sure
15:44:55 <ekarlso> oii guys
15:45:00 <ekarlso> sorry I just got back home ;)
15:45:05 <TravT> o/ ekarlso
15:45:19 <TravT> we praised your devstack work earlier
15:45:32 <TravT> i had hoped to have it re-tested by the start of this meeting
15:45:36 <TravT> but got a weird erro.
15:45:37 <TravT> r
15:45:39 <nikhil_k> sjmc7: I think we agreed to take that route for now (merge that patch) and refactor testing
15:45:46 <TravT> might ping you afterwords
15:46:07 <nikhil_k> refactor testing later (in early M)
15:46:15 <ekarlso> use the project room after then TravT :)
15:46:21 <sjmc7> ok. i've not had time to do that this week
15:46:23 <ekarlso> i'll volunteer partially for testing btw :)
15:46:46 <TravT> :)
15:46:57 <TravT> nikhil_k, that is what I remember as well
15:47:42 <TravT> ok, so if somebody can take it as being assigned to them, it doesn't mean you own everything
15:48:11 <TravT> next up is horizon integration for images
15:48:12 <TravT> https://blueprints.launchpad.net/searchlight/+spec/horizon-integration-images
15:48:19 <TravT> i'm working towards that
15:48:31 <TravT> i've filed a couple blueprints in horizon.
15:48:37 <TravT> we have a chain of things that have to happen
15:48:40 <nikhil_k> lakshmiS_: ekarlso and I can be coassignees (added in the notes)
15:48:51 <lakshmiS_> ok
15:48:57 <TravT> thanks guys!
15:49:22 <TravT> basically in horizon, we are trying to angularize the tables.
15:49:34 <TravT> so, we have to get the images table angularized first.
15:49:53 <TravT> which is also dependent on a bunch of other work going on that david-lyle and i are supporting
15:50:17 <TravT> but, i have a personal goal of getting a first pass at angularizing the images table next week.
15:50:39 * david-lyle 's personal waterloo
15:50:51 <sjmc7> :)
15:51:06 <TravT> and want to have some initial integration attempt with searchlight by the horizon mid-cycle in a 2-ish weeks.
15:51:44 <ekarlso> i'll be pushing designate support also very soon
15:51:55 <TravT> this is intended to serve two purposes.  first is to figure out what more needs to be done in horizon, but second, help drive any improvements to our API.
15:53:25 <TravT> ok. so that's it for high's.
15:53:45 <TravT> kragniz: how is the "remove from glance" going?
15:54:27 * TravT maybe he dropped.
15:54:31 <kragniz> TravT: it's going well
15:54:48 <TravT> anything needed from us?
15:54:59 <kragniz> all tests are passing, appart from a requirements issue that wasn't related
15:55:28 <kragniz> apart from reviews, not much
15:55:36 <kragniz> #link https://review.openstack.org/#/c/197043/
15:55:48 <TravT> we are almost out of time, but i wanted to ask about two other BP's.  swift and neutron.
15:55:56 <nikhil_k> #link https://review.openstack.org/#/c/197043/
15:56:08 <sjmc7> havn't had a chance to look at neutron
15:56:50 <TravT> kragniz, have you, mclaren, lakshmiS_ been able to make progress with the swift team?
15:56:55 <lakshmiS_> yeah i also wanted to know from stuart if he heard any further on the swift?
15:57:07 <kragniz> TravT: not much from us
15:57:19 <kragniz> mclaren's away for a few days
15:57:36 <lakshmiS_> last thing i saw was a note from stuart on a similar spec in swift
15:58:45 <TravT> ok. well, let's talk next week when stuart is back.  just don't want that team to move along without us.
15:59:19 <TravT> ekarlso, from a priority standpoint, we can bump up designate plugin if you are gonna be working on it.
15:59:35 <TravT> and we should talk with david-lyle re: horizon priority
16:00:12 <TravT> I just wanted to thank everybody for the progress we made.
16:00:16 <david-lyle> horizon priority for?
16:00:53 <TravT> i think going from not a project to being a project with a repo and (almost) installable via devstack in one milestone is great progress!
16:01:14 <TravT> david-lyle: time is up. let's chat in the room
16:01:18 <david-lyle> sure
16:01:20 <TravT> thanks everybody!
16:01:23 <TravT> #endmeeting