15:03:37 <nikhil_k> #startmeeting openstack search
15:03:38 <openstack> Meeting started Thu Jul 16 15:03:37 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:41 <openstack> The meeting name has been set to 'openstack_search'
15:03:54 <nikhil_k> #topic roll call and agenda
15:04:15 <lakshmiS> o/
15:04:18 <sjmc7> o/
15:04:25 <kragniz> o/
15:04:27 <rosmaita> o/
15:04:28 <nikhil_k> #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:05:36 <nikhil_k> #topic Updates
15:06:19 <nikhil_k> The webinar video that describes plans for liberty and accomplishments for kilo is out on the openstack foundation you tube channel.
15:06:45 <sjmc7> ah yes, travis mentioned that
15:06:57 <nikhil_k> #info Horizon mid-cycle next week https://wiki.openstack.org/wiki/Sprints
15:07:10 <nikhil_k> #info Nova mid-cycle next week: https://wiki.openstack.org/wiki/Sprints
15:07:17 <sjmc7> i'll be in FC for the horizon one
15:07:49 <sjmc7> one of the agenda items is to add some support for SL to horizon
15:07:51 <nikhil_k> sjmc7: I was earlier planning to travel however, things have not permitted to do so.
15:08:11 <sjmc7> ah, that's a shame
15:08:11 <nikhil_k> Cool
15:08:32 <lakshmiS> sjmc7: would be great to see Horizon use SL
15:08:35 <david-lyle> ./
15:08:48 * david-lyle apparently has long arms today
15:09:09 <nikhil_k> Can we plan to collaborate on video next week partially and depending on the schedule we can keep a brainstorming session on searchlight for glance and nova related things during the glance mid-cycle ?
15:09:22 <sjmc7> yeah
15:09:38 <sjmc7> travis' schedule is the one to workaround since he's heavily involved in horizon too
15:09:57 <sjmc7> but yeah, we can find some time
15:10:01 <nikhil_k> glance one spreads over 3 days and we should have enough time to schedule different events while accomodating timezone
15:10:22 <sjmc7> ok. i'm in FC tuesday through friday
15:11:19 <nikhil_k> david-lyle: I guess we will have to wait on Travis for the remote conn details?
15:11:39 <david-lyle> nikhil_k: they are still in flux
15:11:47 <david-lyle> probably vidyo based
15:12:00 <nikhil_k> sounds good
15:12:02 <lakshmiS> david-lyle: that sounds good
15:12:20 <lakshmiS> david-lyle: is there a link on timings somewhere?
15:12:31 <david-lyle> lakshmiS: yes :)
15:12:34 <david-lyle> let me locate
15:12:48 <david-lyle> #link https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=1788841692
15:12:54 <lakshmiS> thx
15:13:12 <david-lyle> most of the time is meant as more of a sprint, but there are a few topics lined up
15:13:19 <nikhil_k> david-lyle: objects to putting that on the wiki https://wiki.openstack.org/wiki/Sprints ?
15:13:48 <david-lyle> I think it bounces through the etherpad version
15:13:52 <david-lyle> but I can check
15:14:17 <nikhil_k> Possible Short Hike / Dinner sounds interesting
15:14:23 <nikhil_k> I was planning one for Glance too
15:14:25 <sjmc7> we can do that remotely :)
15:14:30 <nikhil_k> ha :)
15:14:33 <david-lyle> I guess I never completed the wiring
15:15:19 <lakshmiS> well travis took us on a supposedly short hike which was enough for us :)
15:15:47 <nikhil_k> :)
15:15:49 <nikhil_k> Also, this basically covers the next topic "Cross Project Updates (nikhil_k, david-lyle?)"
15:16:21 <nikhil_k> #topic Bug review
15:16:30 <nikhil_k> #link https://bugs.launchpad.net/searchlight
15:16:38 <lakshmiS> https://review.openstack.org/#/c/202392
15:16:58 <lakshmiS> I have tested the change in searchlight which works well.
15:17:01 * david-lyle has a working sprint link now
15:17:16 <lakshmiS> and also made changes to ceilometer to introduce a pool name
15:17:19 <sjmc7> lakshmiS - i asked on the review, but what's the effect if ceilometer doesn't also add a pool name?
15:17:24 <nikhil_k> thanks david-lyle !
15:17:47 <nikhil_k> lakshmiS: is the review to ceilometer merged?
15:17:49 <lakshmiS> sjmc7: without a pool name it defaults to some "default" name
15:18:23 <lakshmiS> ceilometer team hasn't responded. there is a weekly IRC meeting going on right now where I will be disussing that topic
15:18:26 <sjmc7> so your proposed change will still work because there'll be two pools? i'm not familiar with oslo.messaging at all
15:18:32 <lakshmiS> on #openstack-meeting
15:18:33 <nikhil_k> I think it would be nice to add a Depends On: <Change Id> tag to commit message
15:18:43 <sjmc7> i can also put you in touch with HP's ceilometer folks if that'd be helpful
15:18:54 <lakshmiS> any help is appreciated
15:19:05 <sjmc7> ok. i'll email you after this
15:19:19 <lakshmiS> i am waiting for the open questions session to discuss it right now on #openstack-meeting
15:20:27 <lakshmiS> will update after this meeting
15:20:45 <nikhil_k> Thanks lakshmiS
15:21:14 <nikhil_k> sjmc7: I think we stalled on the discussion on this bug last week #link https://bugs.launchpad.net/searchlight/+bug/1471878
15:21:14 <openstack> Launchpad bug 1471878 in OpenStack Search (Searchlight) "Service client auth in listener" [Undecided,New] - Assigned to Steve McLellan (sjmc7)
15:21:44 <sjmc7> yeah.. i put a review up to address the problem for now
15:21:45 <nikhil_k> forgot if you had a proposed patch or were we discussing the possible approach
15:21:57 <sjmc7> there's a BP to discuss better long term solutions
15:22:08 <sjmc7> https://blueprints.launchpad.net/searchlight/+spec/openstack-client-usage
15:22:29 <nikhil_k> cool!
15:23:05 <nikhil_k> #topic Blueprint review
15:23:21 <nikhil_k> #link  https://blueprints.launchpad.net/searchlight/+spec/devstack-plugin
15:24:21 <nikhil_k> I guess we are waiting on some updates here #link https://review.openstack.org/#/c/197885/
15:24:49 <sjmc7> the base support is merged; that patch is for keystone v3
15:26:25 <nikhil_k> Does anyone have objections to cut a release without keystone v3 support?
15:26:44 <sjmc7> no, unless we'd be the only ones
15:26:54 <lakshmiS> does glance support it?
15:27:01 <david-lyle> I think that's fine for now
15:27:37 <nikhil_k> I think the patches for keytsone v3 to client are pending review
15:27:43 * nikhil_k needs to check
15:27:54 <sjmc7> well, we don't have a client :)
15:28:10 <sjmc7> i'll try and review the devstack patch today or tomorrow
15:29:22 <nikhil_k> Sorry the comment was about glance client
15:29:50 <nikhil_k> and I am not too familiar with keystone v3 updates to devstack for glance
15:30:14 <nikhil_k> #link https://blueprints.launchpad.net/searchlight/+spec/designate-plugin
15:31:02 <nikhil_k> I think this just needs some review attention
15:31:03 <sjmc7> endre's had a patch up since last week. it looks really close now, although i don't have designate running to test it
15:31:14 <nikhil_k> looks like comments have been addressed
15:31:25 * nikhil_k neither
15:31:44 <david-lyle> what's the access model in that patch? it doesn't seem to be gated on anything
15:32:12 <sjmc7> which one, david-lyle?
15:32:18 <david-lyle> sorry, designate
15:32:48 <david-lyle> just glancing at it
15:32:54 <sjmc7> you mean RBAC?
15:32:58 <david-lyle> is this only population
15:33:08 <david-lyle> yes, I was referring to RBAC
15:33:19 <sjmc7> get_rbac_filter in the XYZIndex classes provides rbac filtering
15:33:38 <sjmc7> we "and" that with whatever the query is
15:33:55 <lakshmiS> Will be reviewing the RBAC stuff tomorrow on that
15:34:08 <david-lyle> wasn't part of the goal, the plugin providing it's own RBAC?
15:34:24 <sjmc7> yeah, the plugin does
15:34:26 <lakshmiS> yes
15:34:34 <lakshmiS> thats how other plugins are too
15:34:51 <lakshmiS> since it specific to each plugin
15:34:52 <sjmc7> i'm confused :)
15:34:53 <david-lyle> ok, I see it now
15:35:04 <david-lyle> my fault, I overlooked the method
15:35:19 <lakshmiS> plugin model only intercepts but takes the rbac queries from plugin
15:35:29 <david-lyle> but it just allows global access
15:35:43 <david-lyle> I'll dig in off line
15:35:50 * david-lyle moves out of the way
15:35:52 <sjmc7> :)
15:35:54 <lakshmiS> it has term filter on "project_id"
15:35:59 <nikhil_k> :)
15:36:07 <sjmc7> ask in the SL channel once you've had a second look. we may well have overlooked something
15:36:17 <nikhil_k> #info https://blueprints.launchpad.net/searchlight/+spec/plugin-config-options
15:36:37 <nikhil_k> I think it makes sense
15:36:38 <sjmc7> i don't think there's been much movement on that one. i'm in favor of it
15:36:54 <sjmc7> if only to allow e.g. notification topic parameters
15:37:14 <sjmc7> ekarlso, did you get anywhere with it?
15:37:17 <nikhil_k> :)
15:38:28 <nikhil_k> He was not around earlier (at least)
15:38:32 <nikhil_k> so, we can chat with him offline
15:38:44 <sjmc7> ok. there are some oddities around the oslo.config/stevedore load order i think
15:39:50 <nikhil_k> sjmc7: for the separate sections of configs?
15:40:03 <sjmc7> yeah. but donwe 't need to discuss it here
15:40:07 <sjmc7> we don't
15:40:21 <nikhil_k> ok, thanks
15:40:24 <nikhil_k> #info https://blueprints.launchpad.net/searchlight/+spec/nova-instances-plugin
15:40:38 <nikhil_k> Thanks for putting that review up sjmc7
15:40:38 <sjmc7> i put a review up that replicates the summit demo functionality
15:40:53 <nikhil_k> I had a interesting discussion with Nova PTL on this yday
15:40:57 <sjmc7> uh oh :)
15:41:10 <lakshmiS> and..
15:41:14 <nikhil_k> well not on the review to say
15:41:32 <nikhil_k> he was suggesting that we should index only via the API
15:41:39 <nikhil_k> and not touch the DB
15:41:45 <nikhil_k> but it really depends on what we want to do
15:41:49 <sjmc7> we are
15:41:52 <sjmc7> only using the API
15:42:58 <nikhil_k> hmm, I missed the review completely :/
15:43:28 <sjmc7> direct database access was something we ruled out for various reasons
15:43:30 <nikhil_k> because I was thinking about other database tables
15:44:24 <nikhil_k> I think we have potentially contradictory cases for metadefs and instances
15:44:32 <sjmc7> ok
15:44:39 <nikhil_k> instances are more dynamic and senstive on the DB front
15:44:49 <sjmc7> that's a shame :)
15:44:50 <nikhil_k> whereas metadefs are potentially static entries
15:45:02 <sjmc7> right
15:45:23 <nikhil_k> so a DB direct index on metadef would be really helpful even for images in some cases while for instances it would hurt more than help
15:45:23 <sjmc7> anything we can't get from the API and/or notifications is going to be tough to work with
15:45:50 <nikhil_k> The pitfall is that notifications and admin api can have more info
15:46:18 <nikhil_k> whereas the tenant specfic api is going to be rather restrictive
15:46:25 <sjmc7> well, SL is an admin
15:46:33 <sjmc7> it's not authing as an ordinary user
15:46:45 <nikhil_k> the query won't be though
15:46:58 <sjmc7> no. so we'll need to restrict fields
15:47:50 <sjmc7> if there are specific examples then note them on the BP or review; i don't know enough to address this
15:49:16 <nikhil_k> thanks, I will try to recollect examples.
15:49:21 <nikhil_k> on another note, I haven't followed up much on metadef indexing but was hoping to have direct db access for that
15:49:35 <nikhil_k> calls to glance api would be pretty expensive for re-indexing
15:49:57 <sjmc7> ok. we need to discuss that. direct DB access is not ideal from a deployment and functionality perspective
15:50:00 <nikhil_k> and it won't need much restrictions on fields
15:50:14 <nikhil_k> (hopefully unless the cloud deployment is supre complicated)
15:51:09 <nikhil_k> Moving on for now
15:51:53 <nikhil_k> Do we want to cover all the specs?
15:52:13 <nikhil_k> oops, I meant BPs
15:52:23 <sjmc7> still want to discuss openstack-client-usage but not necessarily here
15:52:26 <lakshmiS> I added a new BP for named queries
15:52:29 <sjmc7> since there's no decision on it
15:53:11 <nikhil_k> cool, we can discuss some of these on #openstack-searchlight
15:53:40 <nikhil_k> lakshmiS: do you have something on the named queries for today?
15:53:59 <lakshmiS> i have been worknig on the code without a BP :) so added a BP today.
15:54:08 <nikhil_k> :)
15:54:19 <lakshmiS> essentially its meant to save useful queries as named queries.
15:54:44 <lakshmiS> would need help from glance/horizo to know what are usef queries though?
15:55:08 <sjmc7> talk to TravT when he's back since he's doing some horizon integration work
15:55:32 <lakshmiS> sure sjmc7:
15:56:04 <nikhil_k> #info Liberty 2 Release plan
15:56:17 <nikhil_k> I guess we should wait unitl the Nova plugin is merged
15:56:24 <sjmc7> yeah, i think so
15:56:35 <sjmc7> whens the deadline?
15:56:39 <nikhil_k> are there any more blockers people know of?
15:57:19 <sjmc7> no
15:57:19 <nikhil_k> L-2 July 30th
15:57:33 <sjmc7> ok. we can aim for that
15:57:38 <nikhil_k> cool
15:57:47 <nikhil_k> #info Summit speaking proposals - anyone interested in being added as copresenters?
15:57:50 <nikhil_k> was that you sjmc7 ?
15:57:53 <sjmc7> this was me
15:58:10 <sjmc7> travis and i filed a couple of proposals - one similar to what we presented to glance and horizon, at a higher product level
15:58:27 <sjmc7> and one at a more technical level about how data gets in and out of e-s
15:58:29 <sjmc7> for developers
15:58:45 <sjmc7> i don't have links yet but if anyone's interested in being named as a co-speaker let me or travis know
15:59:31 <sjmc7> if we don't get either we'll try and get some working session time, although not sure about travel budgets
16:00:01 <nikhil_k> sounds good
16:00:13 <nikhil_k> #action all: Code reviews, particularly for Endre's designate plugin and Steve's WIP nova support
16:00:19 <sjmc7> yes please!
16:00:42 <nikhil_k> Thanks all for joining, have a nice rest of the day/evening!
16:00:45 <nikhil_k> #endmeeting