15:03:24 <nikhil_k> #startmeeting openstack search
15:03:24 <openstack> Meeting started Thu Jul 23 15:03:24 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:28 <nikhil_k> #chair TravT
15:03:28 <openstack> The meeting name has been set to 'openstack_search'
15:03:29 <openstack> Current chairs: TravT nikhil_k
15:03:34 <TravT> thanks, nikhil_k
15:03:43 <rosmaita> o/
15:03:46 <nikhil_k> #topic agenda and roll call
15:03:47 <kragniz> o/
15:03:48 <nikhil_k> o/
15:03:49 <TravT> o/
15:03:49 <lakshmiS> o/
15:03:54 <nikhil_k> hey TravT
15:03:58 <sjmc7_> o/
15:04:16 <TravT> agenda here: https://etherpad.openstack.org/p/search-team-meeting-agenda
15:04:22 <TravT> add anything to it that you'd like
15:05:04 <TravT> #topic Horizon integration update --> Endpoint in Keystone (include v1 or not?) TravT, sjmc7
15:05:19 <TravT> so, sjmc7 and i are at the horizon mid-cycle
15:05:28 <sigmavirus24> o/
15:05:46 <TravT> my focus has been trying to get images table angularized and getting a widget called magic search on top of it.
15:06:01 <TravT> this lays the groundwork for utilizing searchlight
15:06:20 <TravT> and yesterday sjmc7 started porting over our concept patch that we showed at the summit
15:06:37 <TravT> very early, but we did encounter one question
15:06:43 <TravT> that is the endpoint in keystone
15:07:01 <sjmc7_> currently devstack puts in 'host:9393/'
15:07:09 <sjmc7_> which means the client has to append v1/
15:07:21 <sjmc7_> there seems to be about a 50/50 split with how other services do it
15:07:30 <TravT> in the endpoint list for other services there doesn't seem to be consistency
15:07:53 <TravT> for example, cinder has a totally different service listed
15:07:58 <TravT> for their v2
15:08:16 <nikhil_k> hmm, yeah
15:08:21 <TravT> so, we were wondering if we should keep the endpoint in the service catalog to not have the 'vX' appended
15:08:30 <TravT> and force the user of the service to add that
15:08:39 <TravT> or if we should have the endpoint in the catalog
15:08:48 <sjmc7_> especially since we dpn't have a client to do that auto-versioning thingy the python clients seem to have
15:08:48 <TravT> have the vX on it
15:09:22 <kragniz> we should have it unversioned
15:09:34 <kragniz> that's where other projects are trying to move to
15:09:52 <lakshmiS> seems like cinder is good way to solve it since it also tells clients what versions are supported as endpoints
15:10:12 <sigmavirus24> == kragniz
15:10:24 <sjmc7_> that's 2 - 1. any other takers? :)
15:11:21 <TravT> we could put this out on the mailing list and announce our intention to not have it versioned in the endpoint list
15:11:32 <ekarlso> guys
15:11:35 <ekarlso> hey guys :9
15:11:43 <TravT> howdy ekarlso!
15:12:21 <ekarlso> unversioned with discovery is the typical pattern
15:12:28 <ekarlso> no /vFOO in the endpoints :P
15:12:41 <ekarlso> at least what we did for designate
15:12:45 <TravT> allright, we'll stick with the unversioned for now.  that's what the current horizon patch assumes.
15:12:45 <sjmc7_> we have no client
15:12:50 <sjmc7_> and thus no autodiscovery
15:13:12 <ekarlso> sjmc7_: u can easily do that by using the adapter / session stuffi n ksauth
15:13:30 <TravT> we don't have a discovery api right now (unless I missed something), so do we need to add that?
15:13:54 <ekarlso> TravT: u can pass a endpoint too to ks if you want to with a token
15:14:00 <TravT> typically you put in the requested version and client tries, right?
15:14:27 <sjmc7_> let's put this on the mailing list and get a decision by next week
15:14:28 <ekarlso> TravT: yeah it'll try discovery if you dont pass a explicit endpoint
15:14:51 <TravT> ok, well, let's stick with no version in keystone then.
15:15:04 <TravT> so next topic is bug review
15:15:17 <TravT> #topic     Ceilometer / Notifications: https://review.openstack.org/#/c/202392
15:15:28 <TravT> lakshmiS: any updates here?
15:15:37 <lakshmiS> after several discussions/reviews we have the patch in decent shape now
15:16:22 <lakshmiS> haven't seen any further -1's and works fine with ceilometer running
15:16:46 <TravT> ok. I'm guilty of not doing reviews in about a week, but tomorrow i'm intending to get on that.
15:16:46 <sjmc7_> yeah, i'm good with it too, thanks for addressing my suggestions
15:16:51 <TravT> today is last day of horizon meetup
15:17:49 <TravT> ok, on to next
15:18:01 <TravT> any other bugs anybody needs discussion?
15:18:08 <sjmc7_> https://bugs.launchpad.net/searchlight/+bug/1469336
15:18:10 <openstack> Launchpad bug 1469336 in OpenStack Search (Searchlight) "Errors are returned as html" [Medium,New] - Assigned to Ian Cordasco (icordasc)
15:18:25 <sjmc7_> we hit this doing the horizon integration and it's a pain
15:18:41 <sjmc7_> doesn't need discussion i don't think
15:19:15 <TravT> ok
15:19:31 <TravT> #topic     Blueprint review (Please add any blueprints needing attention below) https://blueprints.launchpad.net/searchlight
15:19:57 <TravT> ekarlso, there were several the last two weeks you had added but i don't think we discussed
15:20:30 <TravT> ekarlso, can you re-share the info for setting up designate in devstack
15:20:31 <TravT> https://blueprints.launchpad.net/searchlight/+spec/designate-plugin
15:20:48 <TravT> i'd like to get that setup so i can properly review and get that patch in
15:21:53 <ekarlso> http://paste.ubuntu.com/11925639/
15:21:57 <lakshmiS> ekarlso: I would like to review that but what setup needs to be done?
15:22:06 <ekarlso> that's the localrc
15:22:19 <TravT> does it setup sample data as well?
15:22:32 <ekarlso> u just clone searchlight to /opt/stack/searchlight, checkout the PS
15:22:40 <ekarlso> ehm
15:22:45 <ekarlso> lemme write up instructions :p
15:23:03 <sjmc7_> well, if there are eisting designate instructions we can follow that
15:23:23 <TravT> i was talking to a guy at time warner about desginate
15:23:34 <TravT> he said he's happy it'll be in searchlight
15:23:50 <TravT> but also asked "will it give me any more data than I get from the CLI"
15:23:54 <sjmc7_> i'll try and test the designate patch tomorrow or monday as well, be great to get that merged
15:24:01 <TravT> i didn't know what to tell him?
15:25:06 <TravT> is there anything else on the designate plugin we should know for reviewing it?
15:25:15 <TravT> if so, just add a comment on the patch i guess.
15:25:21 <TravT> i will get to it tomorrow or monday
15:25:43 <TravT> a big monkey on our back right now are nova instances
15:25:48 <TravT> #topic  https://blueprints.launchpad.net/searchlight/+spec/nova-instances-plugin
15:25:50 <nikhil_k> o/
15:26:00 <sjmc7_> yeah, any reviews on that patch are welcome
15:26:05 <TravT> nikhil_k have you had any chance to look at that one?
15:26:19 <TravT> i also intend to look at it tomorrow or Monday
15:26:37 <nikhil_k> TravT: I did take a look and I think we should be good to go ahead on that based on the initial feedback.
15:26:47 <TravT> it seems if it is a reasonable start and functions that we could get it in and do additional iteration.
15:26:49 <nikhil_k> TravT: but I need to test it functionally :)
15:26:58 <TravT> cool.
15:27:06 <sjmc7_> woo. yes, please test it. let me know if you have questions
15:27:42 <nikhil_k> TravT: btw, if you happen visit last week's meeting and channel logs for thursday, I did some sharing on thoughts on what could be potential enhancements needed
15:27:57 <ekarlso> https://etherpad.openstack.org/p/designate-searchlight
15:28:04 <ekarlso> ^ TravT sjmc7_ lakshmiS
15:28:07 <TravT> ekarlso: thanks!
15:28:15 <sjmc7_> great, thanks
15:28:35 <ekarlso> gtg, house maintenance on the works!
15:28:35 <lakshmiS> ekarlso: will ping you on irc if needed. whats your timezone?
15:28:39 <TravT> nikhil_k, I did read the logs.  I guess anything needed to be kept forever could be added to the BP.
15:28:51 <ekarlso> uhm, Norwegian / GMT+2 I believe :P
15:28:58 <TravT> ekarlso.  thanks!  we'll get your stuff going!
15:29:00 <lakshmiS> ok good for me
15:29:41 <TravT> there are two more BP listed on the meeting agenda
15:29:51 <TravT> BP: https://blueprints.launchpad.net/searchlight/+spec/openstack-client-usage
15:29:58 <TravT> whose is that?
15:30:02 <nikhil_k> TravT: sjmc7_ can we schedule a session during the glance midcycle for some discussion around indexing and nova instances?
15:30:14 <nikhil_k> curious to know what our participation looks like
15:30:20 <sjmc7_> uh.. sure
15:30:27 <TravT> sure, i'll be around all next week
15:30:35 <nikhil_k> cool
15:30:52 <nikhil_k> melissa can possibly join us
15:31:12 <TravT> ok. i had a call with her a couple weeks ago.
15:31:32 <TravT> she seemed very interested in utilizing searchlight
15:31:54 <TravT> i think you and rosmaita will have the most context
15:32:33 <TravT> nobody seems to own the client bp?
15:32:48 <TravT> guess we can move onto the named queries bp
15:32:49 <TravT> https://blueprints.launchpad.net/searchlight/+spec/named-queries
15:32:55 <lakshmiS> i am working on that
15:32:55 <nikhil_k> TravT: we did a intial discussion yday but not so much on instances. I wanted to get some feedback on the use cases to see how we can proceed for long term indexing on that
15:33:22 <TravT> nikhil_k, she has a very strong interest in utilizing searchlight for cross resource searching as well
15:33:40 <nikhil_k> TravT: yeah, that part
15:33:46 <TravT> to help facilitate a concept like amazon resource groups.
15:33:49 <nikhil_k> + cross region
15:34:06 <TravT> yeah, we really could spend some time brainstorming on cross region.
15:34:23 <nikhil_k> turtles all the way down, may be
15:34:44 <TravT> it would be good to have a working vidyo session on some of these topics
15:35:04 <TravT> if we could get a few more of these basic patches in.
15:35:52 <nikhil_k> TravT: so I think my misunderstanding was around the indexing through command line. Does HP use cases never needs direct db indexing?
15:36:20 <sjmc7_> i don't think a use case ever dictates how you index
15:36:49 <TravT> but we're not aware of that right now.
15:36:50 <nikhil_k> TravT: becasue for some API calls like the ones that have potentially large queries -- changes-since can be really expensive indexing operation and in some cases is 413'ed internally
15:37:10 <sjmc7_> we're not habitually doing a changes-since query though
15:37:17 <nikhil_k> pagination would take forever to index it, may be days!
15:37:44 <nikhil_k> sjmc7_: yeah, I meant deleted stuff that can be potentially retrieved using that
15:37:49 <TravT> nikhil_k, what's the likelihood of us getting notification in nova to carry the full data we need?
15:38:03 <nikhil_k> because deleted stuff isn't really exposed via the api
15:38:11 <TravT> is that a BP that we should open on nova?
15:38:16 <TravT> (spec)
15:38:45 <sjmc7_> i don't think i understand what you mean about 'deleted stuff'
15:38:47 <nikhil_k> TravT: I think I would need to discuss the scope of such notifications with you both. we can do that offline
15:39:08 <TravT> yeah, that would be good.
15:39:09 <nikhil_k> sjmc7_: deleted instances, images (for now) (that's soft deleted)
15:39:19 <sjmc7_> maybe we should have a call about nova because i think my understanding is lagging behind yours
15:39:25 <sjmc7_> deleted instances send a notification
15:39:31 <sjmc7_> deleted glance images i don't know about
15:39:40 <sjmc7_> but i thought they did too
15:39:42 <nikhil_k> yeah, but old ones won't. anyways we can chat later :)
15:40:01 <TravT> yes, this would be a good working session / vidyo session
15:40:08 <TravT> let's schedule that
15:40:12 <nikhil_k> cool
15:40:36 <TravT> #action nikhil_k schedule nova design session
15:40:46 <TravT> apparently that isn't how you do actions
15:41:28 <TravT> thanks nikhil_k, i also feel like I'm missing some important information here.
15:41:45 <nikhil_k> TravT: hmm, I thought it was the right way for doing # action
15:41:55 <nikhil_k> https://wiki.debian.org/MeetBot
15:42:05 <TravT> going back on the topic of named queries.
15:42:14 <TravT> lakshmiS, i don't know any exact named queried yet
15:42:18 <nikhil_k> ok, sure TravT
15:42:40 <lakshmiS> TravT: I only have some basic quries for now.
15:42:45 <TravT> i was wondering if for glance if rosmaita, nikhil_k, kragniz might know the most common searches needed or requested
15:42:46 <lakshmiS> currenlty the queries are part of the plugin but once plugin config file patch lands I can move it to the config file
15:43:15 <lakshmiS> putting in config file will easier to add queries later easily
15:43:54 <TravT> lakshmiS, there isn't a plugin specific config patch up yet, is there?
15:44:22 <nikhil_k> 1. /images/details?name=foobar
15:44:52 <lakshmiS> Travt: haven't seen one but heard someone was working on it. ekarlso? or may be no one is working on it
15:44:52 <rosmaita> TravT: name, name wildcard, instance_uuid, base_image_ref
15:44:55 <nikhil_k> 2. /images/details?updated_at=when??
15:45:03 <rosmaita> prob wildcards on all those i guess
15:45:18 <TravT> for updated_at, are time ranges important?
15:45:25 <rosmaita> probably
15:45:28 <TravT> eg between X dates or after X dates
15:45:33 <rosmaita> yes
15:45:46 <rosmaita> forget the wildcards on UUID, don't know what i was thinking there
15:46:01 <sigmavirus24> rosmaita: :D
15:46:11 <rosmaita> probably the operating system
15:46:11 <sjmc7_> let's stick these on the BP or an etherpad
15:46:12 <rosmaita> and version
15:46:59 <TravT> rosmaita, is that just a well known property?  i didn't think that was in the common images properties list
15:47:26 <rosmaita> i am pretty sure those are "common image properties"
15:47:37 <rosmaita> though i don't know that anyone uses them much
15:47:46 * TravT admits it has been a few months since reading those
15:47:47 <rosmaita> but if they are indexed, that will motivate people!
15:47:55 <TravT> they'll all be indexed!
15:47:59 <TravT> everything is indexed
15:48:37 <rosmaita> http://docs.openstack.org/developer/glance/common-image-properties.html
15:48:53 <nikhil_k> I think we may need some on the min disk, min ram too
15:49:13 <TravT> rosmaita: nikhil_k: could you add the notes above to the blueprint?
15:49:16 <TravT> https://blueprints.launchpad.net/searchlight/+spec/named-queries
15:49:39 <rosmaita> ok
15:49:49 <TravT> one thing i want to see about adding to horizon (although i know you public cloud rackspace guys don't care) is a drop down list of common queries
15:49:57 <TravT> and we'd pull that from these named queries
15:50:25 <TravT> thanks guys.
15:50:37 <TravT> #topic liberty 2 release plan
15:50:41 <lakshmiS> i should have the named queries patch up by tomorrow
15:50:52 <TravT> thanks lakshmiS
15:51:04 <TravT> so, we don't have a release plan yet
15:51:23 * TravT slightly embarrassed
15:51:41 <TravT> i think the action is for nikhil_k and I to talk offline about that
15:52:00 <nikhil_k> yes
15:52:21 <TravT> i'm guessing we get questioned on that later today, because we'll be talking about searchlight for a small bit in the horizon meetup this afternoon
15:52:29 <nikhil_k> TravT: sjmc7_ and I agreed last week that it would be good to release after nova instances merges
15:52:35 <TravT> ok.
15:52:58 <TravT> so, let's make it a goal that we have that and designate plugin merged by next meeting.
15:53:14 <TravT> assuming they are ready of course
15:53:31 <TravT> #topic open discussion
15:53:59 <nikhil_k> I added a section for glance+searchlight in the glance's midcycle etherpad #link https://etherpad.openstack.org/p/liberty-glance-mid-cycle-meetup
15:54:23 <nikhil_k> #action all interested: please add name and timezone info so that we can try to schedule it accordingly
15:54:37 <nikhil_k> or if we need to split it
15:54:45 <TravT> Thanks, nikhil, just added me name
15:55:06 <rosmaita> lakshmiS: i put some notes on the "whiteboard" on your BP
15:55:25 <lakshmiS> rosmaita: saw that. thanks
15:55:59 <rosmaita> i have a general discussion question, viz., what are people thinking currently about how to do multi-region searchlight?
15:56:38 <TravT> we briefly spoke at summit, but haven't come up with a concrete plan.
15:56:45 <lakshmiS> i think initial idea was having multiple index one for each region
15:56:50 <rosmaita> we had informally said at some point that we'd keep a searchlight in each region, and then mabye a super-serachlight that would index them all
15:57:02 <TravT> yeah, searchlight of searchlights
15:57:10 <sjmc7_> *shudder*
15:57:16 <rosmaita> searchlight++
15:57:19 <sjmc7_> authentication is a problem
15:57:31 <lakshmiS> authenticate is always pain
15:57:46 <sjmc7_> i *think* tokens are always region scoped
15:57:54 <lakshmiS> specially across resource types
15:58:06 <sjmc7_> that's maybe something we should have a proper discussion about, maybe next week
15:58:20 <sjmc7_> figure out what we want it to look like and then if we can do it
15:58:31 <rosmaita> sounds good
15:58:46 <TravT> agreed... also maybe get a few high level ideas up and get some ML input as well.
15:59:01 <TravT> anything else for today?  2 mins left
15:59:01 <sjmc7_> if we're done with that, we've tried to discuss this a couple of times, but if people could give some thought to the implemenation around authenticating the service clients i would welcome suggestions; i'm not sure the current method is ideal
15:59:36 <sjmc7_> currently SL requires admin creds that it uses to intiailize the various clients, and tries to cache a successful auth when the listener's running
16:00:07 <sjmc7_> it works and it's not insecure but i'd appreciate someone taking a look at it since it was diret from the summit prototype which i didn't put a huge amount of thought or optimization into
16:00:21 <TravT> ok, plz link patch / bp
16:00:26 <TravT> and we'll call it a meeting
16:00:48 <nikhil_k> Thanks
16:01:22 <sjmc7_> https://blueprints.launchpad.net/searchlight/+spec/openstack-client-usage
16:01:24 <TravT> thank everybody.
16:01:28 <TravT> #endmeeting