15:01:02 <TravT> #startmeeting openstack search
15:01:02 <openstack> Meeting started Thu Aug 27 15:01:02 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <openstack> The meeting name has been set to 'openstack_search'
15:01:39 <TravT> we'll  wait a minute or two.
15:01:44 <david-lyle> o/
15:01:55 <lakshmiS> o/
15:02:17 <sjmc7> o/
15:02:25 <TravT> nikhil_k is sigmavirus24 around today?
15:02:34 <TravT> didn't see his name in latter part of glance meeting
15:02:35 <sigmavirus24> yes sorry
15:02:42 <TravT> oh good
15:02:46 <sigmavirus24> $work is keeping me distracted
15:02:56 <TravT> $ugh
15:03:08 <TravT> ok agenda here:
15:03:16 <TravT> #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:03:34 <TravT> #Mitaka Summit Sessions
15:03:40 <TravT> #topic Mitaka Summit Sessions
15:04:02 <TravT> so, first of all, we did get a main conference session accepted
15:04:03 <TravT> https://mitakadesignsummit.sched.org/event/51d3ca10844052e650c130eebe7264f9#.Vd8ji9NVhBd
15:04:37 <TravT> If others are interested in being a part of that, let's talk later.
15:04:49 <rosmaita> o/
15:04:56 <TravT> hi rosmaita
15:05:29 <TravT> so, thierry sent out a meeting saying we have to put in a requests for session by August 31st
15:05:58 <TravT> Requests for fishbowls vs workrooms vs contributors meetups.
15:06:18 <TravT> there are less sessions overall available for vancouver
15:06:18 <rosmaita> we should prob ask for 1 of each?
15:06:23 <TravT> and less fishbowls.
15:06:55 <TravT> yesterday in the horizon meeting, i put up a topic to have a joint horizon / searchlight session
15:07:09 <sjmc7> contributor meetup we can organize elsewhere if we have to. fishbowl would be good in case other people are interested in getting involved
15:07:17 <TravT> david-lyle supported it.  thanks david-lyle
15:07:25 <TravT> other horizoner's seemed good with it.
15:07:30 <rosmaita> sjmc7: +1
15:08:11 <TravT> the fishbowls are advertised.
15:08:14 <sjmc7> right
15:08:26 <TravT> so, it might bring in cores from other projects
15:08:43 <TravT> we'd want them to help review plugins, even if we develop them.
15:09:15 <rosmaita> TravT: +1
15:09:48 <TravT> it also might be 3 of us staring at each other in a big room.
15:09:56 <TravT> :P
15:10:01 <rosmaita> we're not so bad on the eyes
15:10:04 <TravT> lol
15:10:09 <sjmc7> yeah.... i suspect there'll be less people there than vancouver
15:10:12 <rosmaita> Searchlight: the best-looking project
15:10:18 <TravT> sweet!
15:10:47 <lakshmiS> we need to invite one core from each project to write a plugin for us :)
15:10:50 <TravT> if we have a fishbowl, it would need to have a good topic... not just a presentation. that's what our main session presentation will be about.
15:10:57 <ekarlso> oii guys
15:11:03 <TravT> o/ ekarlso
15:11:15 <ekarlso> hmm, I can maybe do a plugin for Cue also
15:11:23 <ekarlso> seeing that i've worked on that
15:11:25 <rosmaita> i like lakshmiS idea: deep dive into Searchlight plugins?
15:11:41 <TravT> that would make sense.
15:11:54 <lakshmiS> at the least be a SME for that project and talk to us
15:12:14 <TravT> and we could send an invite to each project team seeing if 1 person could attend.
15:12:29 <sjmc7> yeah, that's a good idea
15:12:42 <TravT> ok, so here's what I think is current summary:
15:12:46 <TravT> Request:
15:13:02 <TravT> 1 fishbowl: Topic to deep dive into plugins and invite SME from each project
15:13:27 <TravT> 1 Working session for us: (possible ideal topic is multi-region searching)
15:13:39 <TravT> 1 Shared session with horizon
15:14:33 <sjmc7> works for me
15:14:40 <TravT> should we request the contributors meetup slot as well?
15:14:58 <sjmc7> depends how many of us there'll be there
15:15:03 <TravT> yeah.
15:15:08 <sjmc7> if it's 3 of us staring at each other, i at least want to be in a pub
15:15:09 <TravT> and how if overlaps with the other projects
15:15:59 <TravT> i think we'll need more time to talk than one working session, but we can try to meet informally as well.
15:16:13 <TravT> i want to be respectful of the many projects needing slots
15:17:15 <rosmaita> +1 to pub, +1 to multiregion searching session
15:17:52 <TravT> maybe i'll add in a request for one more working session but not a request for contributors meetup. we'll do that after hours.
15:18:05 <TravT> 1 fishbowl, 2 working sessions, 1 joint session with horizon.
15:18:10 <david-lyle> I would expect most of us have conflicts for contributors meetup, so that makes sense
15:18:21 <TravT> That may be more than we can get.
15:18:49 <TravT> okay, going once
15:18:58 <TravT> twice
15:19:04 <TravT> sold
15:19:23 <TravT> #action TravT send session summit request to ttx
15:19:44 <TravT> #topic Liberty 3 Deadlines
15:20:05 <TravT> As usual, end of cycle is upon us, which means at least two things.
15:20:16 <TravT> People are getting frantic
15:20:22 <TravT> Zuul jobs are taking a long time
15:20:56 <TravT> Feature Freeze: September 3rd
15:20:57 <TravT> RCs Start: September 21st
15:20:57 <TravT> Final RC September 9th
15:21:13 <TravT> I sent an email to thierry seeking advice on how we should handle things
15:21:46 <TravT> Here are some snippets:
15:21:52 <TravT> Given how new Searchlight is at this point, I'd say you don't really
15:21:53 <TravT> need to enforce a strict feature freeze. If you do, it's a tool to
15:21:53 <TravT> reduce the risk of introducing regressions by selecting which commits are acceptable as you get closer to the end of the dev cycle.
15:22:16 <sjmc7> that seems sensible
15:22:50 <TravT> I also asked about numbering scheme.  As you all probably know, OpenStack is moving to new scheme
15:22:52 <TravT> x.x.x
15:23:11 <TravT> many will be at 8.0.0
15:23:13 <TravT> in liberty
15:23:22 <TravT> but thierry said:
15:23:27 <TravT> I'd say the first release should be 1.0.0. If it's barely functional,
15:23:27 <TravT> you could even number it 0.1.0. Your choice really.
15:23:58 <TravT> I'm not sure of all the ramifications of choosing one vs the other.
15:24:05 <lakshmiS> 0.1.0 seems like beta
15:24:13 <nikhil_k> 0.1.0
15:24:21 <nikhil_k> seems better
15:24:29 <lakshmiS> would horizon use it if its 0.1.0
15:24:47 <nikhil_k> but then the rel versioning is being matched with cycle afaik
15:24:56 <david-lyle> the version # doesn't change the level of functionality
15:25:07 <nikhil_k> like first cycle of incubation was 1.0.0 but not sure if true for all prj
15:25:30 <david-lyle> lakshmiS: I would prefer it to come in as a plugin until more mature, honestly
15:25:32 <nikhil_k> rel-mgrs can better suggest the versioning coherent with os projs
15:25:56 <david-lyle> but horizon is trying to reduce scope
15:26:40 <TravT> david-lyle plugin external to horizon repo or not?  i think we always talked about it being a plugin, but you initially suggested still being in horizon repo.
15:26:56 <david-lyle> TravT: I'd be ok with it in /contrib
15:27:00 <TravT> a plugin panel is easy.
15:27:24 <TravT> but plugin search provider for APIs for various tables and global top nav, is a bit diff
15:28:07 <david-lyle> TravT: I agree, there are some extensibility hooks needed
15:28:16 <david-lyle> we can take this offline
15:28:27 <TravT> okay.
15:28:34 <david-lyle> but my argument is to horizon the version # is not important
15:28:58 <david-lyle> better to set valid expectations, IMO
15:29:08 <TravT> the point of this topic is actually for us to set a release cadence
15:29:45 <david-lyle> so let's pop two levels :)
15:29:50 <TravT> There are various tags for this in OpenStack governance
15:29:51 <TravT> https://github.com/openstack/governance/blob/master/reference/tags/release_independent.rst
15:30:03 <TravT> https://github.com/openstack/governance/blob/master/reference/tags/release_cycle-with-milestones.rst
15:30:20 <TravT> https://github.com/openstack/governance/blob/master/reference/tags/release_cycle-with-intermediary.rst
15:30:41 <TravT> https://github.com/openstack/governance/blob/master/reference/tags/release_managed.rst
15:31:12 <TravT> A lot to read through there
15:31:12 <TravT> https://github.com/openstack/governance/blob/master/reference/tags/release_has-stable-branches.rst
15:32:01 <rosmaita> i will admit i have only read the first one, but release:independent sounds good to me, at least to start with
15:32:19 <david-lyle> for where the project is, I think independent makes sense
15:32:42 <david-lyle> then move to align with release cycle with milestones as it matures
15:32:43 <rosmaita> are there any bad implications of that?  we can always change later, right?
15:32:59 <david-lyle> rosmaita: the only one I can think of is packaging
15:33:16 <david-lyle> most distros would likely not include searchlight with 8.0.0
15:33:35 <rosmaita> gotcha
15:33:41 <david-lyle> but that may be ok for 0.1.0 ??
15:34:15 <TravT> a certain company i'm affiliated with is wanting to include it in a release sooner than later
15:34:49 <david-lyle> that's a knife that cuts both ways
15:34:54 <rosmaita> what would our plan be, then ... 0.1.0, 0.2.0, 0.3.0 and then immediately 9.0.0 ? to make the packaging work, i mean
15:36:06 <david-lyle> that's a better transition than 1.0.0 2.0.0 9.0.0
15:36:19 <TravT> I think we should target releases for the end of cycles.  but, i like the idea of releasing intermediate releases at our own cadence.
15:36:57 <david-lyle> Ironic and Swift are the only two mainstream projects that have independent release cycle
15:37:04 <TravT> this initial release perhaps should be sub-1.0 though
15:37:04 <david-lyle> but they are standalone as well
15:37:27 <nikhil_k> agree
15:37:36 <TravT> i would not want to have to be held to a perfect API until we've actually integrated several searches from horizon
15:37:46 <david-lyle> but a lot of early project start with independent
15:38:10 <david-lyle> it gives us more flexibility
15:38:23 <david-lyle> just suggestions
15:39:19 <TravT> but we need a release to even let packagers start looking at the project, i believe
15:39:57 <TravT> let's revisit this in next weeks meeting, but please look through those release tags
15:40:31 <TravT> right now, the summary of this discussion seems to be people leaning toward 0.1.0 for first release, timed with liberty.
15:41:00 <rosmaita> so what we're looking for is a tag that indicates not-yet-ready-for-prime-time but nonetheless worthy of being included in a distro
15:41:10 <nikhil_k> I think that;s the right message
15:41:45 <nikhil_k> but I think there;s value to double check if we are communicating when our project got incubated with a number of particular style
15:42:01 <TravT> although
15:42:18 <TravT> if I read ttx's language again
15:42:26 <TravT> I'd say the first release should be 1.0.0. If it's barely functional,
15:42:26 <TravT> you could even number it 0.1.0. Your choice really.
15:42:34 <nikhil_k> yeah
15:42:43 <TravT> i don't like the implication that 0.1.0 is barely functional
15:42:52 <TravT> but, that said it has not been tested at scale.
15:43:04 <rosmaita> what would 0.9.9 mean?
15:43:08 <nikhil_k> ha
15:43:23 <TravT> based on glanceClient discussions, it would mean 5 years in and still not releasable to 1.0?
15:43:25 <TravT> :P
15:43:26 <nikhil_k> means, we had some alpha rel that never released
15:44:10 <nikhil_k> TravT: I doubt it. py-client consumers run legacy code
15:44:26 <nikhil_k> that's why slowness in upgrade to rel numbers
15:44:35 <TravT> nikhil_k: just a joke :)
15:44:41 <nikhil_k> we should ensure our plugin adopters stick to upstream
15:44:50 <nikhil_k> TravT: heh
15:45:00 <TravT> after watching some of last meeting
15:45:30 <nikhil_k> (continuing TravT )... feels like there are sad stories to tell
15:45:51 <TravT> #action All to read release tags.  We'll revisit this next week
15:46:03 <TravT> #topic review process
15:46:14 <TravT> Thank you everybody for the time on Tuesday
15:46:23 <TravT> I thought that went really well and we made good progress
15:46:57 <sjmc7> yeah, it was good to have everyone together
15:47:03 <TravT> would anybody be available for another hour next Tuesday or Wednesday for similar activities.
15:47:08 <nikhil_k> ++
15:47:12 <TravT> same bat cave same bat time
15:47:23 <TravT> ?
15:47:25 <nikhil_k> this tuesday starts liberty-3 rel (fyi)
15:47:52 <nikhil_k> fyi -- madness begins, bugs fixes, tagging, gate etc
15:48:13 <TravT> so, are you suggesting a different day?
15:48:25 <nikhil_k> earlier or later might help more
15:48:33 <nikhil_k> gate would be more reliable and faster
15:49:30 <TravT> lakshmiS, you have one of the tougher schedules being in India.
15:49:40 <TravT> do you have any suggestions?
15:50:06 <lakshmiS> around this time any day is fine with me
15:50:23 <nikhil_k> that was just some information, being independent of the gate also works :)
15:51:47 <TravT> #vote (what day next week works best for another hour review session) ? mon, tue, wed, thur, fri
15:51:56 <TravT> guess that didn't work.
15:52:03 <nikhil_k> startvote
15:52:11 <rosmaita> while y'all are discussing times, what is the general feeling about stable branches? or do we think people should always use the most recent? i am inclined to the latter, since we're heavily tied to an external project
15:52:19 <rosmaita> sorry, didn't mean to interrupt the vote
15:52:50 <nikhil_k> rosmaita: since this will be our first rel
15:52:51 <TravT> #startvote (what day next week works best for another hour review session) ? mon, tue, wed, thur, fri
15:52:52 <openstack> Begin voting on: (what day next week works best for another hour review session) ? Valid vote options are mon, tue, wed, thur, fri.
15:52:53 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:52:59 <nikhil_k> we won't need a stable branch at this point
15:53:36 <rosmaita> nikhil_k: right, but i mean for "the future"
15:53:40 <TravT> nikhil_k +1  i would vote against stable vote until M
15:53:42 <nikhil_k> #vote fri
15:53:45 <david-lyle> #vote any
15:53:46 <openstack> david-lyle: any is not a valid option. Valid options are mon, tue, wed, thur, fri.
15:53:52 <lakshmiS> #vote thu
15:53:53 <openstack> lakshmiS: thu is not a valid option. Valid options are mon, tue, wed, thur, fri.
15:54:00 <lakshmiS> #vote thur
15:54:01 <david-lyle> no but my point was made openstack
15:54:06 <TravT> lol
15:54:22 <rosmaita> what time are we thinking?
15:54:48 <sjmc7> :) any day is ok for me
15:55:05 <TravT> 7 PT, 8PT, 9PT i'd think would be some options
15:55:18 <nikhil_k> yeah, actually except tue and thur, others work for me
15:55:49 <TravT> #endvote
15:55:49 <openstack> Voted on "(what day next week works best for another hour review session) ?" Results are
15:55:51 <openstack> fri (1): nikhil_k
15:55:52 <openstack> thur (1): lakshmiS
15:55:59 <rosmaita> #vote wed
15:56:06 <TravT> I'll send something out.
15:56:21 <TravT> running out of time.
15:56:30 <TravT> So, I listed several items in the agenda
15:56:39 <david-lyle> so question, has anyone deployed searchlight on an environment for a period of time?
15:57:10 <TravT> beta ran in HOS env for a number of weeks pre-liberty.
15:57:16 <TravT> but none of the recent stuff
15:57:38 <david-lyle> would be good validation before release
15:57:42 <TravT> we just had a discussion with our mgmt who said they could have some people help with things like that.
15:58:01 <nikhil_k> no luck here yet
15:58:02 <TravT> good idea david-lyle
15:58:13 <TravT> #topic reviews
15:58:13 <david-lyle> TravT: great
15:58:13 <rosmaita> i agree
15:58:27 <TravT> Several on agenda
15:58:29 <TravT> will highlight one
15:58:38 <TravT> Please, look at nova plugin
15:58:38 <nikhil_k> nova?
15:58:39 <TravT> Nova instances plugin https://review.openstack.org/198852
15:58:57 <nikhil_k> I started it but couldn't finish review
15:58:57 <TravT> i beat up steve quite a bit now
15:59:06 <sjmc7> i feel bruised
15:59:43 <TravT> There are others to review and some bugs to triage. will copy paste here
15:59:53 <TravT> Bug review (Please add any bugs needing attention below) https://bugs.launchpad.net/searchlight
15:59:54 <TravT> Critical & High
15:59:54 <TravT> Sorting https://review.openstack.org/#/c/206268/
15:59:55 <TravT> Other
15:59:57 <TravT> https://review.openstack.org/#/c/210759/
15:59:59 <TravT> Needs Triage
16:00:01 <TravT> Glance images not searchable after update notification: https://bugs.launchpad.net/searchlight/+bug/1486781
16:00:02 <openstack> Launchpad bug 1486781 in OpenStack Search (Searchlight) "Glance images not searchable after update notification" [Undecided,New]
16:00:03 <TravT> Sorting name fields does not behave as expected: https://bugs.launchpad.net/searchlight/+bug/1488236
16:00:04 <openstack> Launchpad bug 1488236 in OpenStack Search (Searchlight) "Sorting name fields does not behave as expected" [Undecided,New]
16:00:05 <TravT> Blueprint review (Please add any blueprints needing attention below) https://blueprints.launchpad.net/searchlight
16:00:07 <TravT> Essential & High
16:00:10 <TravT> Nova instances plugin https://review.openstack.org/198852
16:00:11 <TravT> Designate Plugin https://review.openstack.org/#/c/199099/
16:00:18 <TravT> Ok, thanks everybody!
16:00:22 <nikhil_k> thanks!
16:00:34 <TravT> #endmeeting