15:02:32 <TravT> #startmeeting openstack search
15:02:35 <openstack> Meeting started Thu Oct  1 15:02:32 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:39 <openstack> The meeting name has been set to 'openstack_search'
15:02:46 <david-lyle> o/
15:02:51 <TravT> o/
15:03:11 <rosmaita> o/
15:03:27 <TravT> not sure if others already o/   I had to reboot my computer.
15:03:47 <david-lyle> no
15:03:52 <TravT> lakshmiS o/
15:03:59 <sjmc7> hey
15:04:01 <lakshmiS> o/
15:04:03 <nikhil> o/
15:04:17 <TravT> #link https://etherpad.openstack.org/p/search-team-meeting-agenda
15:04:28 <TravT> #topic RC1 Release
15:04:54 <TravT> last week we agree to make a go / no go vote for RC1 in todays meeting.
15:05:11 <TravT> so here's our current status #link https://launchpad.net/searchlight/+milestone/liberty-rc1
15:05:36 <TravT> we're in really good shape really.
15:06:10 <lakshmiS> release time then!
15:06:27 <TravT> yesterday we had an in room discussion to defer the one BP still in code review, but then itisha found a bug that would be solved by the BP being finished off.
15:06:47 <TravT> https://bugs.launchpad.net/bugs/1501508
15:06:47 <openstack> Launchpad bug 1501508 in OpenStack Search (Searchlight) "searchlight-manage does not work unless designate is installed" [High,In progress] - Assigned to Steve McLellan (sjmc7)
15:06:57 <TravT> https://blueprints.launchpad.net/searchlight/+spec/plugin-config-options
15:08:06 <sjmc7> the config patch fixes it; there's a simpler fix which is to disable those plugins in setup.cfg
15:09:01 <TravT> well, before we jump the gun to a hack, let's check the other items on the board.
15:09:27 <TravT> related: https://bugs.launchpad.net/bugs/1493975
15:09:27 <openstack> Launchpad bug 1493975 in OpenStack Search (Searchlight) "Need separate config sections for api and listener" [Medium,New] - Assigned to Steve McLellan (sjmc7)
15:09:44 <TravT> sjmc7: it doesn't look like you also included the fix for that in the confg change
15:09:57 <sjmc7> no
15:10:02 <TravT> are you thinking we should go ahead and defer than bug then?
15:10:11 <TravT> than -> that
15:10:57 <sjmc7> i'd like to fix it, but i'm under a load of time pressure on various things
15:12:01 <TravT> i suppose right now the workaround is to just specify the config file when launching either one and use a different config file
15:12:50 <sjmc7> yeah, or override it
15:12:56 <sjmc7> which is what i've been doing
15:13:02 <sjmc7> --log-file
15:13:36 <TravT> well, i'm thinking we can defer it.
15:14:16 <sjmc7> yeah. i can get a patch up in the next day or two but i don't know how crucial it is
15:14:21 <sjmc7> maybe if we need to do an RC 2 anyway
15:14:23 <TravT> if you happen to get a code review up that's super small and low risk before we do rc1, then reconsider.
15:14:29 <TravT> and if we need rc2, can consider it
15:15:17 <TravT> this next one is actually a little more important i think
15:15:18 <TravT> Facet options should limit to max amount
15:15:27 <TravT> https://bugs.launchpad.net/bugs/1501539
15:15:27 <openstack> Launchpad bug 1501539 in OpenStack Search (Searchlight) "Facet options should limit to max amount" [Undecided,New]
15:15:57 <TravT> just chatting with a couple guys in horizon, we should limit the number of possible options we return for facet requests
15:16:12 <TravT> if it goes over a certain amount, then not return them.
15:16:36 <TravT> it'll make an unworkable UI at the moment if we get in a situation where perhaps there are like 200 security groups to choose from.
15:16:57 <sjmc7> that's a one liner i think
15:17:06 <lakshmiS_> limiting the options might be confusing
15:17:45 <TravT> well, here's what I'm hoping out of it.  If there are more than X options, we just don't return them.  Leave it free form.
15:17:54 <TravT> you know, i could handle it on client side as well.
15:18:34 <TravT> if ES has an option to limit or something that also helps performance
15:18:51 <sjmc7> it does
15:19:27 <TravT> ok, well, let's keep that for the moment.
15:19:41 <TravT> https://bugs.launchpad.net/bugs/1479927
15:19:41 <openstack> Launchpad bug 1479927 in OpenStack Search (Searchlight) "Not indexing glance image tags from notifications" [High,Triaged]
15:20:15 <TravT> this patch is a forward looking patch.
15:20:39 <TravT> dependent on glance landing a patch.
15:20:57 <TravT> lakshmiS_: has been addressing the comments from flavio
15:21:12 <TravT> and i brought it up in the glance meeting this morning
15:21:47 <TravT> if we put this patch in on the searchlight side, then all a deployer needs to do is apply the glance patch to their liberty deployment
15:22:46 <TravT> i'm inclined to say we go ahead and land it.
15:23:02 <TravT> of course lakshmiS_ connection dropped right now...
15:23:38 <lakshmiS> sorry my netconnection is choppy today
15:23:48 <TravT> lakshmiS: i was just saying I think that we probably should just go ahead and put the notification patch into searchlight.
15:24:25 <lakshmiS> yeah it harmless even if there are no notifications from glance
15:24:51 <rosmaita> makes sense to land it then
15:24:53 <sjmc7> i'll review that
15:25:10 <TravT> it is slightly speculative, but the worst case scenario is that we have to put a patch into mitaka to correct something.  the best case scenario is searchlight is ready to receive notifications.
15:25:33 <TravT> rosmaita: good to hear your opinion
15:25:45 <TravT> ok, we'll keep that on and try to land today
15:25:51 <rosmaita> it's all i've got
15:26:10 <TravT> lol
15:26:16 <TravT> https://bugs.launchpad.net/bugs/1479927
15:26:16 <openstack> Launchpad bug 1479927 in OpenStack Search (Searchlight) "Not indexing glance image tags from notifications" [High,Triaged]
15:26:17 <rosmaita> i have a question, though, the patch i've seen at glance is for image member notifications, not image tags
15:26:27 <rosmaita> and there it is
15:26:33 <TravT> oh, you are right...
15:26:43 <TravT> that is a slightly diff bug
15:27:07 <TravT> with this one, we found it early on and I don't think we ever corrected it
15:27:24 <TravT> but it definitely occurs to me that if you are searching for images... tags would be an important thing to be able to search
15:27:40 <TravT> ;-)
15:28:14 <rosmaita> glance thinks tags are so important it gives you 2 diff api calls to handle them
15:28:36 <rosmaita> but it looks like the fix for this is all on the searchlight side?
15:28:44 <lakshmiS> so if i remember correctly tags are part of notification from glance
15:28:51 <TravT> yes, they are.
15:28:57 <rosmaita> but only if non-empty
15:29:05 <TravT> we just didn't grab them
15:29:10 <TravT> rosmaita: that's right
15:29:18 <TravT> which is what led to the initial confusion
15:30:01 <rosmaita> there was this crazy idea at the beginning of v2 that empty/null values should not be included in responses
15:30:09 <rosmaita> it has led to much confusion all around
15:30:41 <TravT> well, i can look at grabbing that later today and putting up a patch on it
15:30:52 <TravT> unless somebody beats me to it.
15:31:38 <TravT> So in summary, sjmc7: i'll assign the facet options to you
15:31:46 <sjmc7> :)
15:32:06 <TravT> and let's get the reviews / testing in on these last few patches.
15:32:18 <TravT> Do we think we can get these landed in the next few hours?
15:33:17 <lakshmiS> tags looks like a small patch
15:33:58 <TravT> i think the config options is the most difficult here
15:34:22 <TravT> but there is a review up for it
15:34:26 <TravT> we just need to go through it
15:35:23 <TravT> lakshmiS: you've been up late several days in a row
15:35:43 <TravT> don't want you to kill yourself on this...
15:36:17 <TravT> but if you did have any more review on any of these patches, then we could try to address
15:37:11 <TravT> https://review.openstack.org/223318
15:37:16 <lakshmiS> no problem. look like last set of reviews
15:37:25 <TravT> https://review.openstack.org/228998
15:37:39 <TravT> then we'll put up review for tags and review for facet options.
15:38:13 <TravT> rosmaita: i've got a doc patch that can land any time, but if you want to give it a once over for feedback
15:38:13 <TravT> https://review.openstack.org/228664
15:38:52 <TravT> ok, well, i think as soon as these last few patches land, we'll do RC1!
15:38:54 <rosmaita> will look right away
15:39:46 <TravT> #topic Mitaka Summit Sessions
15:40:05 <TravT> #link https://etherpad.openstack.org/p/searchlight-mitaka-summit
15:40:15 <TravT> i started an etherpad to start gathering ideas.
15:40:38 <TravT> we got 1 fishbowl slot
15:40:44 <TravT> 1 workroom slot
15:40:52 <TravT> 1 conference presentation
15:41:26 <TravT> #action take a look at the etherpad and put in ideas, notes, questions, comments
15:41:47 <TravT> and next week we'll go back over the etherpad and settle on them.
15:41:58 <TravT> i'll send a message to the mailing list asking for input on that etherpad as well.
15:42:43 <TravT> any questions on that before open discussion?
15:43:09 <lakshmiS> i think we discussed previously on inviting atleast one person from some services
15:43:35 <TravT> yeah, i put up two ideas for the fishbowl
15:43:49 <TravT> with either one, we would send out an invite i think.
15:44:08 <TravT> but just need to settle on the exact topic and description before figuring out who to invite.
15:44:25 <TravT> maybe they should be combined... i don't know
15:45:36 <TravT> go ahead and leave comments or whatever on the etherpad.
15:45:44 <TravT> and we can figure this out for sure next week.
15:45:52 <TravT> #topic open discussion
15:46:12 <TravT> anything else?  or should we adjourn to go deal with these last lingering rc1 bugs?
15:46:31 <lakshmiS> rosmaita: are you coming to summit. heard sigmavirus is not
15:46:37 <sjmc7> aww :(
15:46:49 <david-lyle> O.o
15:47:06 <rosmaita> lakshmiS: i will be there
15:47:12 <rosmaita> unfortunately, not sigmavirus24
15:47:48 <lakshmiS> cool
15:47:51 <TravT> huge bummer on sigmavirus24
15:47:59 <TravT> woot! that you'll be there
15:48:10 <rosmaita> i know, he has been working really hard, could use the break
15:48:22 <TravT> we should try to influence the session schedulers to not have glance / searchlight sessions overlap
15:48:39 <TravT> i'll mention that to them.
15:48:50 <rosmaita> +1
15:50:00 <TravT> all right, let's go get these last few items done!
15:50:17 <TravT> see you in the room.
15:50:22 <TravT> #endmeeting