15:00:27 <TravT> #startmeeting openstack search
15:00:28 <openstack> Meeting started Thu Nov 19 15:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:33 <openstack> The meeting name has been set to 'openstack_search'
15:01:06 <TravT> o/
15:01:22 <TravT> we'll give a few minutes for people join.
15:01:33 <yingjun> :)
15:01:38 <lakshmiS> o/
15:02:20 <TravT> yingjun: what time is it for you?
15:02:30 <yingjun> 23:00
15:03:07 <TravT> i know sjmc7 is on his way
15:03:26 <yingjun> after the meeting will go to sleep :)
15:03:56 <rosmaita> o/
15:04:15 <TravT> how's it going rosmaita?
15:04:25 <rosmaita> ok
15:04:31 <rosmaita> no action, though
15:04:44 <TravT> well, here's the agenda: https://etherpad.openstack.org/p/search-team-meeting-agenda
15:04:52 <sjmc7> morning, sorry i’m late
15:05:00 <TravT> morning sjmc7
15:05:04 <TravT> #topic general updates
15:05:21 <TravT> Just to get it logged here as FYI for everybody
15:05:37 <TravT> we spent nearly two hours doing BP prioritization in the room on Tuesday
15:05:51 <TravT> got through most of the list
15:05:56 <TravT> in giving initial priorities
15:06:22 <TravT> if there are any BPs that have a priority you disagree with, please mention it
15:07:12 <TravT> #topic client repo merged
15:08:08 <sjmc7> thanks for the help with that Li, if you’re here
15:08:12 <TravT> #link https://github.com/openstack/python-searchlightclient
15:08:17 <yingjun> just saw that, i’m working on the initial commit
15:08:23 <TravT> after some brief discussion, we thought it would be best for there to be a separate repo
15:08:33 <TravT> sjmc7 had some packaging concerns otherwsie
15:08:39 <david-lyle> o/
15:08:58 <TravT> o/
15:08:59 <sjmc7> yingjun add me as a reviewer and i’ll take a look; the first commit will need enough to pass the CI jobs
15:09:23 <yingjun> sjmc7, ok
15:09:30 <TravT> yingjun sounds great.  thanks for getting that started
15:09:43 <sjmc7> but appreciate the help getting it created
15:10:02 <TravT> i do think we should have some more design discussion on all the commands that should be supported
15:10:19 <TravT> obviously, we can get a couple base ones going.
15:11:12 <TravT> but then we should really think through what we can do to make it easy to use... maybe with some common queries.
15:12:20 <TravT> #topic spec repo started
15:12:32 <TravT> #link https://github.com/openstack/searchlight-specs
15:12:34 <TravT> just FYI
15:12:38 <TravT> that is merged in
15:12:57 <TravT> we have a few to discuss (later in the meeting)
15:13:11 <TravT> #topic Reno release notes
15:13:22 <TravT> https://review.openstack.org/#/c/247170/
15:13:30 <TravT> I put up one of the base patches
15:13:46 <TravT> but we will need to start adding release notes
15:14:15 <TravT> The guidelines are here: https://review.openstack.org/#/c/247170/3/doc/source/feature-requests-bugs.rst
15:14:18 <TravT> if you have feedback on those guidelines please provide it
15:14:40 <TravT> looks like I already have one comment to address
15:14:50 <TravT> #topic cinder plugin update
15:15:18 <TravT> we don't have duncanT on here, but i do have an update from him and from going to the cinder meeting yesterday
15:15:31 <TravT> he has the initial plugin done.
15:15:54 <TravT> but right now it works likes the nova one and has to make callbacks for more data
15:16:18 <sjmc7> boo
15:16:33 <TravT> so, he proposed to the cinder team that they improve the notification event data so we can avoid that
15:16:39 <TravT> and the discussion went really well
15:17:01 <TravT> so, he's proposing patches to cinder to improve the notification data
15:17:15 <TravT> and he'll modify his SL plugin to take advantage of that
15:17:30 <sjmc7> nice. chances of that getting into mitaka?
15:17:45 <TravT> probably pretty high, i think.
15:17:46 <TravT> it helps that he's a core on cinder
15:18:16 <TravT> maybe we should twist his arm and have him submit the patch based on API callbacks first
15:18:24 <TravT> and then update when the notifications are in
15:18:28 <TravT> what do you think?
15:19:01 <lakshmiS_> you mean add a second patch for notifications?
15:19:18 <TravT> yeah, get a SL plugin as-is with callbacks.
15:19:29 <TravT> And then update it once the notifications in cinder are improved
15:19:39 <lakshmiS_> i probably have to do similar to swift ;)
15:19:43 <sjmc7> i’d be ok with that
15:19:53 <sjmc7> swift i don’t think we can
15:20:09 <sjmc7> but that can be a separate discussion
15:20:14 <TravT> it would actually also give us some code for reference if somebody wants to deploy searchlight against liberty cinder
15:20:43 <TravT> ok, i'll mention this to duncan
15:20:48 <TravT> and see if he's agreeable
15:21:45 <TravT> #topic Swift integration updates
15:22:05 <lakshmiS_> I think its getting to a good shape. Will have a patch for review tomorrow.
15:22:21 <lakshmiS_> obviously without notifications
15:22:29 <TravT> so this is for initial indexing?
15:22:33 <lakshmiS_> yes
15:22:40 <TravT> cool
15:22:41 <sjmc7> i’ve got middleware that works for swift
15:22:45 <sjmc7> i need to tidy it up a bit
15:23:21 <sjmc7> and propose it to swift, though i think they will say no to it being in-tree
15:23:29 <sjmc7> then decide where it should live
15:23:35 <lakshmiS_> yeah we can add notifications as another patch once notifications land in swift(whenever that happens)
15:23:48 <TravT> sjmc7: so plug it in to the deploy pipeline and get oslo notifications?
15:23:57 <sjmc7> right
15:24:20 <TravT> well, this is pretty exciting!
15:24:40 <TravT> one thing i'm highly interested in, is what this may mean for an improved swift UI in horizon
15:25:27 <TravT> i also will need to look at the data model you've got lakshmiS_ to see how that might affect the current UI I'm on.
15:25:33 <TravT> did you use nesting, parents, etc?
15:26:19 <lakshmiS_> not much
15:26:36 <lakshmiS_> are you concerned about complex model?
15:27:12 <TravT> not sure if concerned is quite the right term...
15:27:20 <TravT> just want to make sure it is the right model
15:27:25 <lakshmiS_> oh ok
15:27:35 <TravT> which i'm sure you've put some good thought into
15:27:43 <TravT> we'll just have to see
15:28:17 <TravT> but what might be really helpful is that once we have it, i ensure that it can somewhat demo via the search panel
15:28:26 <TravT> then could record a quick youtube to show the swift team
15:28:27 <lakshmiS_> sure
15:28:44 * TravT needs to get back to coding on that panel
15:29:19 <TravT> i think anytime you have something concrete to interact with, it helps move the conversation along
15:29:30 <TravT> demonstrate the potential value
15:29:46 <lakshmiS_> yeah maybe they will accept our notification patch after that...
15:30:23 <TravT> maybe i'll prototype out a new swift specific panel with search, depending on the data structure
15:31:07 <TravT> ok, anything else to discuss on swift?
15:31:19 <TravT> i don't see briancline or daddyjoseph97 on here
15:31:35 <lakshmiS_> i will add them as reviewers
15:31:41 <TravT> sounds good
15:32:04 <TravT> #topic openstack tag assertions
15:32:28 <TravT> A message went out that we need to assert tags for the project
15:33:17 <TravT> since moving to the big tent, tags are the way people are supposed to be able to tell various characteristics about a project
15:33:32 <TravT> i didn't have time to run through them prior to this meeting
15:33:53 <TravT> but they are all listed here: http://governance.openstack.org/reference/tags/index.html
15:34:24 <TravT> we've already got the Release Management Tags applied
15:35:02 <TravT> the ones under "Project Assertions Tags" are things we'd need to discuss
15:35:28 <sjmc7> hmm :)
15:36:05 <TravT> i don't think we want to assert the feature deprecation yet
15:36:12 <TravT> that's why we released 0.1
15:36:45 <TravT> perhaps that one after the mitaka release
15:37:59 <TravT> maybe the upgrade one, but i'd still hesitate to add that until end of mitaka
15:38:31 <sjmc7> yes, i think that’d be premature
15:38:46 <lakshmiS_> for supporting upgrade we need to look at plugin versions too
15:39:00 <lakshmiS_> thats where our data model is
15:39:21 <TravT> true
15:40:02 <TravT> well, i think we need more work on this before asserting more tags for now
15:40:21 <TravT> sounds like you guys agree
15:40:31 <sjmc7> yep
15:40:35 <lakshmiS_> yes
15:40:46 <TravT> rosmaita: david-lyle: yingjun:  agree?
15:40:51 <yingjun> agree
15:41:26 <david-lyle> yeah
15:41:41 <TravT> ok.
15:41:54 <TravT> #topic oslo pools
15:42:34 <TravT> so, the background here is that our deployment architect was questioning why we didn't use multiple queues rather than require a new topic for searchlight notifications
15:43:04 <TravT> and our answer was the oslo only supported that through pools, and pools were apparently broken
15:43:16 <TravT> lakshmiS_: is that still our answer?
15:43:19 <lakshmiS_> yes
15:43:29 <lakshmiS_> we need to relook at that again
15:43:29 <sjmc7> does oslo know it’s broken?
15:43:41 <lakshmiS_> see anything changed since we spoke to ceilometer
15:44:31 <dims> sjmc7 unless there's a bug, oslo is clueless :)
15:44:31 <TravT> ok.
15:44:52 <sjmc7> yeah :)  we should file a bug with oslo if something’s broken
15:45:04 <dims> pretty please :)
15:45:19 <TravT> lakshmiS_: can you give dims a bit more info?
15:45:55 * TravT loves how dims always swoops into meetings when oslo is mentioned.
15:45:56 <lakshmiS_> oslo pools was basically not working as expected - for sending message to multiple consumers
15:46:16 <dims> TravT :)
15:46:28 <sjmc7> i can take a look at it again
15:46:39 <lakshmiS_> ceilometer and searchlight were both consuming glance info notifications and only one of them would get it(mostly ceilometer)
15:47:08 <dims> lakshmiS_ interesting, had not heard that
15:47:35 <lakshmiS_> dims: i can share the discussion we had with ceilometer team with you on that topic
15:48:04 <dims> sjmc7 lakshmiS_ yes, please log some details in a bug and add ceilometer and searchlight and oslo.messaging as affected
15:48:10 <dims> thanks lakshmiS_
15:48:16 <TravT> +1
15:48:18 <lakshmiS_> we would love to use the pools back though :)
15:49:01 <TravT> #action lakshmiS_ to log oslo pools bug
15:49:18 <TravT> #topic but review and blueprint review
15:49:37 <TravT> guess we are having a but review right now
15:50:03 <dims> lakshmiS_ should be easy to replicate using our simulator - https://github.com/openstack/oslo.messaging/blob/master/tools/simulator.py
15:50:20 <lakshmiS_> thanks dims:
15:50:25 <TravT> ooohh
15:50:33 <TravT> that simulator would be great for our tests!
15:50:39 <dims> TravT : ++
15:50:41 <TravT> could add that to our functional tests
15:51:48 <TravT> #action TravT add BP to pull in simulator for notification testing
15:52:19 <TravT> Ok, so there are three spec reviews up right now that all need feedback
15:52:36 <TravT> https://review.openstack.org/#/q/status:open+project:openstack/searchlight-specs,n,z
15:52:48 <TravT> two of them are essential
15:53:01 <TravT> Spec proposal for allowing searchable admin fields
15:53:07 <TravT> Zero Downtime Reindexing Proposal
15:53:12 <TravT> with architectural ramifications
15:53:28 <TravT> so, please take a look at them and give feedback
15:54:00 <TravT> #topic open discussion
15:54:10 <TravT> Anything else that people want to discuss?
15:54:21 <sjmc7> i’m hungry
15:54:36 <TravT> do you have waffles?
15:54:42 <sjmc7> i.. do not.
15:54:43 <yingjun> FYI, just upload the very first client base: https://review.openstack.org/#/c/247565/
15:54:52 <kragniz> I think the new python-searchlightclient repo needs to be added to the governance repo
15:54:57 <rosmaita> who has waffles?
15:54:57 <sjmc7> that was quick yingjun!
15:54:57 <kragniz> also o/
15:55:18 <sjmc7> yeah, it does. i’m surprised infra merged it without that. hi kragniz!
15:55:19 <TravT> kragniz: o/
15:55:42 <TravT> (rosmaita perks up)
15:55:53 <sjmc7> there are no waffles.
15:56:02 * rosmaita is very disappointed
15:56:06 <TravT> kragniz: i submitted a governance patch on that
15:56:26 <TravT> https://review.openstack.org/#/c/247271/
15:56:30 <TravT> also one for spec repo
15:56:45 <yingjun> :) sjmc7, please have a look at that, i put it workflow-1
15:57:00 <TravT> spec repo got some love
15:57:00 <sjmc7> will do
15:57:00 <TravT> https://review.openstack.org/#/c/244875/
15:57:31 <TravT> but i guess that since we got our repos, i don't know that it is urgent to push those through
15:57:45 <TravT> however, adding a +1 from you guys might pop it up in visibility
15:58:01 <TravT> #action sjmc7 to bring waffles to the next meeting
15:58:35 <sjmc7> oh, i will
15:58:48 <TravT> Oh one more thing
15:59:00 <TravT> m1 is December 3rd
15:59:08 <sjmc7> wow, that crept up fast
15:59:12 <TravT> yeah
15:59:32 <TravT> sjmc7: i think we will need a release note added for that plugin restructuring patch
16:00:00 <TravT> allright
16:00:00 <TravT> thanks everybody
16:00:00 <TravT> times up
16:00:04 <rosmaita> bye
16:00:06 <sjmc7> bye!
16:00:12 <yingjun> bye
16:00:13 <TravT> #endmeeting