18:08:48 <bdpayne> #startmeeting OpenStack Security Group
18:08:49 <openstack> Meeting started Thu Feb  7 18:08:48 2013 UTC.  The chair is bdpayne. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:08:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:08:52 <openstack> The meeting name has been set to 'openstack_security_group'
18:09:14 <bdpayne> Ok, let's begin
18:09:32 <bdpayne> #topic Storage Encryption Status
18:09:49 <bdpayne> Could the parties involved in the storage encryption efforts provide a status update?
18:09:55 <bdpayne> Intel and APL, if you're here
18:10:17 <rellerreller> Volume encryption code has been submitted, but we are still awaiting reviews and acceptance
18:10:46 <lglenden> #link https://review.openstack.org/#/c/21269/
18:10:51 <mtesauro> BTW, I have a bunch of feedback - enough that its not right for IRC, any idea on the mail list?  That would be a good place for this.
18:11:05 <lglenden> #link https://review.openstack.org/21264
18:11:15 <lglenden> #link https://review.openstack.org/21262
18:11:46 <rellerreller> What do you mean by any idea on mail list?
18:11:58 <bdpayne> ok, I'm happy to look over the code
18:12:12 <mtesauro> In our first IRC meeting, it was mentioned that a mail list was being setup for this group.
18:12:16 <bdpayne> but I assume you need reviews from specific parties?
18:12:30 <bdpayne> ahh, for this let's just use the general dev list
18:13:00 <rellerreller> I'm not exactly sure of the approval process.  I need core reviewers.
18:13:11 <rellerreller> But I appreciate feedback from everyone!
18:13:21 <bdpayne> ok, so here's what I will do:
18:13:30 <mtesauro> I have ping'ed the Swift developers we have at Rack - I'm waiting a response.
18:13:32 <bdpayne> #action Bryan to review the APL code
18:13:44 <mtesauro> I am book with threat models but can walk over there on Friday
18:13:53 <bdpayne> #action Bryan to figure out formal review process by talking with PTLs and help move that along
18:14:01 <rellerreller> Thanks!
18:14:12 <bdpayne> np
18:14:36 <rellerreller> Our spec for volume encryption will help to give you an idea for our code design
18:15:10 <bdpayne> sounds good
18:15:22 <bdpayne> any other things we should know about the APL side?
18:15:40 <bdpayne> if not, anyone from Intel here want to provide a status update?
18:15:42 <rellerreller> I can't think of anything off hand
18:16:05 <lglenden> I think it's also important to mention that, especially on the key management front, this is a first version to get people able to try out our code
18:16:18 <bdpayne> ok
18:16:19 <lglenden> We know that we haven't solved all the key management issues yet.
18:16:30 <bdpayne> with that said… are you wanting to get this into Grizzly or ?
18:16:43 <rellerreller> Yes, grizzly is our goal
18:16:49 <bdpayne> ok
18:17:03 <bdpayne> alright, I'm not hearing from Intel, so we can move on to the next topic
18:17:13 <bdpayne> #topic Hardening Guide
18:17:39 <bdpayne> The hardening guide hasn't move forward much since last week.  I've been a touch busy/
18:17:43 <hyakuhei> Did you take a look at the small changes I made to the outline?
18:17:52 <bdpayne> No, I missed that
18:18:05 <hyakuhei> I can spend some time putting the .tex files into a shape that reflects the outline over the weekend.
18:18:08 <bdpayne> Hrm, I need to get better notifications setup, aparently
18:18:16 <bdpayne> sounds great
18:18:23 <hyakuhei> Just a few small changes, don't recall exactly. Need more time to spend on these things.
18:18:38 <hyakuhei> In other news, HP Cloud should be adding some content in the near future.
18:18:45 <bdpayne> excellent
18:19:10 <bdpayne> I am planning to work on this some… just slowly bubbling up the stack
18:19:20 <hyakuhei> Need to get it out of this bootstrap phase.
18:19:22 <bdpayne> and I'm, of course, open to other's getting involved as well
18:19:28 <hyakuhei> Absolutely!
18:19:36 <bdpayne> someone from Red Hat expressed interest last week
18:19:42 <bdpayne> I'll resync with him as well
18:19:56 <hyakuhei> Cool. I spoke to a few people who were interested at the weekend while at FOSDEM.
18:20:14 <mtesauro> BTW, the OWASP OpenStack Security project was announced yesterday to ~36,000+ community members
18:20:25 <bdpayne> nice!
18:20:35 <mtesauro> I've already gotten some requests to join the project.  We'll see what happens by the next meeting
18:20:52 <bdpayne> #topic Open Discussion
18:21:05 <bdpayne> mtesauro can you provide details on that effort?
18:21:13 <bdpayne> should this group and that group sync in some way or ?
18:21:14 <hyakuhei> https://www.owasp.org/index.php/OWASP_OpenStack_Security_Project
18:21:32 <hyakuhei> Seems like mtesauro is the guy to talk to/sync with.
18:21:33 <bdpayne> #link https://www.owasp.org/index.php/OWASP_OpenStack_Security_Project
18:21:40 <mtesauro> Yup that's the URL.  I need to add some real content and I got the mail list info this AM
18:22:19 <mtesauro> It is basically an attempt to draw people from OWASP into OpenStack to help with security testing, review etc.
18:22:29 <mtesauro> I
18:22:31 <bdpayne> yeah, very much needed
18:22:39 <hyakuhei> Sounds like a good idea.
18:22:49 <mtesauro> I've been in both groups and there's a good opportunity for great interactions
18:23:22 <bdpayne> sounds good… please do keep this group posted and let us know if there's anything we can do to help facilitate that work
18:23:45 <mtesauro> No problem.  I'm going to give it a couple of days for people to join then rally the troups.
18:23:57 <bdpayne> ok
18:24:17 <mtesauro> Some of what happens will depend on the skill set/interest of the people from OWASP
18:24:26 <mtesauro> I'm not worried about running out of work
18:24:36 <bdpayne> Also wanted to briefly mention the Security Note on LXC since hyakuhei is here
18:24:54 <bdpayne> Per discussion at last week's meeting, I think that the note is ready to go, you want to push it out or ??
18:25:26 <bdpayne> you == hyakuhei :-)
18:25:28 <hyakuhei> Sure I'll do it tomorrow with any luck
18:25:33 <bdpayne> sounds good
18:25:44 <bdpayne> any other discussion?
18:25:50 <hyakuhei> Mailed to the -dev ML with a little boilerplate explaining what an OSN is etc.
18:26:24 <hyakuhei> I've no other business other than apologies for being late.
18:27:51 <bdpayne> ok, sounds good
18:27:57 <bdpayne> I was late too… it happens!
18:28:03 <bdpayne> thanks everyone!
18:28:11 <mtesauro> No worries.
18:28:11 <bdpayne> #endmeeting