18:00:17 <hyakuhei> #startmeeting Openstack Security Group
18:00:18 <openstack> Meeting started Thu Mar 28 18:00:17 2013 UTC.  The chair is hyakuhei. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:21 <openstack> The meeting name has been set to 'openstack_security_group'
18:00:40 <hyakuhei> Good Morning/Afternoon/Evening everyone.
18:00:57 <hyakuhei> Any agenda items you'd like adding while we wait for a few more folks to join?
18:01:00 <WayneL> quit
18:01:41 <hyakuhei> ok, we'll give it about a minute then get started
18:02:16 <hyakuhei> #topic OSSG meetup
18:02:55 <hyakuhei> So it looks like we're going to meet up for food/beer on the Monday night of the summit, we need to have a rough idea of how many people are coming.
18:03:11 <lglenden> 4 from APL
18:03:26 <hyakuhei> great, there'll be 2-3 from HP.
18:04:20 <hyakuhei> Ok, I'll send an email around to get a better idea on headcount.
18:04:50 <hyakuhei> #action hyakuhei to gather headcount for food.
18:05:14 <hyakuhei> #info I'll see what we can do about HP sponsoring the group meal
18:05:23 <hyakuhei> #topic Mailing List
18:05:42 <hyakuhei> We now have a super-shiny 'OpenStack Official' mailing list!
18:06:02 <hyakuhei> #info Go subscribe: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-security
18:06:39 <hyakuhei> For discussions on topics within OpenStack that require a strong security focus or issues that should be brought to the attention of the security community within OpenStack. Home of the OpenStack Security Group and a central point for co-ordinating security projects.
18:07:23 <hyakuhei> This list should also receive any 'security' tagged bugs that come in
18:07:41 <hyakuhei> Any thoughts/comments on this before we move on?
18:07:42 <Guest70823> $chan.usercount
18:08:03 <hyakuhei> Ok, exciting stuff.
18:08:13 <hyakuhei> #topic OpenStack Security Notes
18:08:49 <hyakuhei> As you probably know we maintain a list of 'Security Notes' like advisories.
18:09:04 <hyakuhei> They speak to common configuration issues, insecure 3rd party software and other fun stuff
18:09:21 <hyakuhei> #link https://launchpad.net/osn
18:10:00 <hyakuhei> We need ideas and content for a few more of these. Would anyone like to finish the Keystone OOM DoS one?
18:10:11 <hyakuhei> If not I'll do it tomorrow.
18:10:30 <hyakuhei> Quiet room today...
18:11:00 <hyakuhei> #action hyakuhei publish Keystone DoS OSN.
18:11:24 <hyakuhei> #topic OpenStack Summit
18:11:37 <hyakuhei> So we already touched on the summit with regard to everyone meeting up.
18:11:58 <hyakuhei> It strikes me that there are a bunch of interesting topics that we should probably make some progress on before the summit.
18:12:14 <lglenden> such as?
18:12:26 <hyakuhei> Perhaps some online presentations or walkthroughs for some of the more difficult issues, Volume Encryption being one.
18:12:32 <hyakuhei> The KeyManager being another
18:12:44 <hyakuhei> Summit sessions aren't particularly long afterall
18:13:10 <lglenden> true
18:13:32 <hyakuhei> And while all the content may be in the ML, reading those threads is an art in iteslf.
18:13:38 <lglenden> there isn't a lot of time before the summit itself, however, not sure how technically deep we'd be able to get
18:14:03 <rellerreller> ML?
18:14:33 <hyakuhei> MailingList
18:14:49 <rellerreller> Thanks
18:14:52 <hyakuhei> So last summit, because of the mixed audience, I found crypto discussions went nowhere fast.
18:15:13 <hyakuhei> With everyone who'd ever used certificates having an opinion.
18:16:22 <hyakuhei> #action hyakuhei to provide online meeting space, presentation and telecoms for anyone wanting to demo/preview/walkthrough content with the OSSG before the summit
18:16:39 <hyakuhei> Anyone else want an action while I'm handing them out?
18:16:59 <hyakuhei> #topic Hardening Guide
18:17:39 <hyakuhei> So thanks to Kieth for migrating the Hardening guide over to Markdown
18:17:45 <hyakuhei> #link https://github.com/hyakuhei/OSSG_Hardening_Guide
18:18:06 <hyakuhei> That should make contributing far less painful. I think I'll rm the .tex files soon
18:18:42 <hyakuhei> Bryan had mentioned engaging in a documentation sprint to try and drive forward progress on the guide. Any thoughts on that?
18:19:36 <hyakuhei> #topic AoB
18:19:48 <lglenden> while I can't speak for everyone, it would be hard for us to travel to attend a documentation sprint
18:19:55 <rellerreller> I think it's a good idea, but I don't think we can contribute
18:19:57 <lglenden> us = APL
18:20:27 <hyakuhei> Fair enough, well if a few of us can get some core documentation down then it should make it easier to contribute around the edges.
18:21:15 <hyakuhei> Ok, so lets do a quick roll-call. Who's here ?
18:21:43 <pentae> <- HPCS
18:22:54 <rellerreller> #link http://lists.openstack.org/pipermail/openstack-dev/2013-March/007023.html
18:22:55 <hyakuhei> <- HPCS
18:23:07 <rellerreller> There was an email thread on HSM.  I thought it was interesting.
18:23:20 <rellerreller> <- APL
18:24:41 <hyakuhei> Yeah, I did wonder if anyone had comments on the HSM stuff
18:25:03 <pentae> low attendance today it seems
18:25:07 <hyakuhei> I've been wondering about cloud HSM for a while, kind of thinking VPC with rack affinity and some nasty bridging.
18:25:20 <hyakuhei> Yeah, I guess a lot of people are taking a long weekend.
18:25:45 <hyakuhei> Well, we've got a few actions. Shame they're all against me.
18:25:58 <hyakuhei> Anyone got anything they'd like to bring up?
18:26:16 <rellerreller> Are you thinking of doing demos next week or the following week?
18:26:50 <hyakuhei> Can do any time, the sooner the better I suppose. Can provide a 'virtual room' which lets you present and an audio bridge with various international dial-ins.
18:27:25 <rellerreller> OK, just wondering because summit is not far away.
18:27:40 <rellerreller> Will you send an email out about how to set one up or how should we coordinate?
18:28:06 <hyakuhei> Sure, I'm just offering because with the volume encryption and key management discussions will barely get started in the 40-minute windows available.
18:28:14 <hyakuhei> I'll send a mail around the new ML
18:28:36 <hyakuhei> Similarly, you can reach out to me directly robert.clark@hp.com if you're interested in doing something
18:29:13 <rellerreller> Cool.  I think it will be a good idea to discuss these items more.
18:29:27 <hyakuhei> Great, progress!
18:29:48 <hyakuhei> Ok, I guess that'll do it for today. Any last-minute items?
18:30:10 <hyakuhei> #endmeeting