18:00:04 <bdpayne> #startmeeting OpenStack Security Group
18:00:05 <openstack> Meeting started Thu May  9 18:00:04 2013 UTC.  The chair is bdpayne. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <openstack> The meeting name has been set to 'openstack_security_group'
18:00:27 <bdpayne> good morning / afternoon / evening to OSSG
18:00:40 <hyakuhei> Hey bdpayne
18:00:45 <bdpayne> let's get started with a role call
18:00:52 <bdpayne> Bryan from Nebula is here
18:01:04 <bpb> Hi bdpayne
18:01:15 <hyakuhei> Rob from HP here.
18:01:27 <bpb> Bruce from APL
18:02:04 <bdpayne> anyone else here for the OSSG meeting?
18:02:13 <chair6> Jamie from HP
18:02:52 <bdpayne> well, hi everyone
18:02:56 <bdpayne> thanks for attending
18:03:01 <bdpayne> let's get started
18:03:11 <bdpayne> anyone have an item to put on the agenda?
18:03:50 <hyakuhei> Nothing new
18:04:28 <noslzzp> here..
18:04:46 <bpb> How about the pros and cons of a centralized message security key server -
18:04:55 <pentae> Heath here from HP also
18:05:00 <bdpayne> ok, I'd like to discuss the documentation sprint, open security tickets, and get updates on some ongoing projects (volume encryption, key manager, rpc security)
18:05:23 <bdpayne> bob sounds good, we'll add that too
18:05:33 <bdpayne> that's bpb
18:05:40 <bpb> yes
18:05:57 <bdpayne> #topic documentation sprint update
18:06:07 <bdpayne> Just a quick update on the doc sprint
18:06:30 <bdpayne> looks like we are locked in for June 24-28
18:06:37 <bdpayne> will be happening in Maryland
18:06:50 <bdpayne> I'm working to finalize the attendee list this week
18:06:58 <hyakuhei> Sounds good
18:07:04 <noslzzp> Yep.
18:07:06 <bdpayne> b/c it will be time for people to arrange travel shortly
18:07:34 <bdpayne> if you'd like to be involved and are not already chatting with me, please drop me an email
18:07:43 <bdpayne> any questions about the doc sprint?
18:08:16 <bdpayne> excellent, I'll move ahead
18:08:23 <bdpayne> #topic open security tickets
18:08:31 <bdpayne> https://bugs.launchpad.net/openstack/+bugs?field.tag=security
18:08:38 <bdpayne> that link is a useful one
18:08:53 <bdpayne> if you're on the openstack-security mailing list, you'll be seeing chatter on some of these too
18:08:55 <hyakuhei> There's only 19
18:09:09 <hyakuhei> A few of which are due to be closed off.
18:09:23 <bdpayne> yep
18:09:35 <bdpayne> this is a great place for people to contribute to the discussion
18:09:44 <bdpayne> if you'd like to do some security reviews, etc
18:09:50 <bdpayne> so I just wanted to call it out
18:10:18 <bdpayne> #topic ongoing projects
18:10:39 <hyakuhei> I don't suppose eric is lurking here somewhere?
18:10:45 <bdpayne> could we get some updates on volume encryption, key management, and the roc security discussions?
18:10:54 <bdpayne> if you're involved in any of the above, please just chime in
18:11:23 <hyakuhei> I heckle a little on the first two
18:11:37 <rellerreller> Volume encryption is progressing
18:12:00 <rellerreller> We are still shooting for Havana-1.  We are deciding on the interface for the key manager.
18:12:35 <rellerreller> Our first release will use a stubbed out KM for POC purposes.  Then we plan to integrate with barbican when they have a working prototype.
18:12:36 <hyakuhei> I think that's really exciting work. Do you have a documented set of assurance requirements that you're meeting?
18:13:09 <rellerreller> No, but you can email me more about what you are looking for.
18:13:30 <rellerreller> I think the barbican/KM team is looking to have something by Havana-3
18:13:33 <hyakuhei> i.e protect disks if they're physicaly taken away from the DC etc? I ask because I'm already getting questions from customers about this stuff and while I can tell them abit about what you're doing it'd be good to have a better picture
18:14:20 <hyakuhei> rellerreller: ping me your email and I'll follow-up
18:14:28 <bdpayne> I'd be interested in that too
18:14:34 <rellerreller> OK, I understand what you mean.  We can get in contact with you to see if we can get you something.
18:14:37 <bdpayne> perhaps it could just be done on the openstack-security list?
18:14:51 <bdpayne> or at least loop me in ;-)
18:14:59 <rellerreller> I think that would be ok.
18:15:03 <rellerreller> Will do
18:15:21 <hyakuhei> Sure
18:16:32 <bdpayne> great, so can anyone speak to the rpc discussions ?
18:17:18 <hyakuhei> I've not been involved in that for the last week. I've still got a bunch of concerns. I was hoping Eric might be here.
18:17:41 <bpb> The immediate need for secure RPC lends itself to a customized local key manager, but the design could include barbican later.  Since the keys are short lived, just curious how folks feel if this make sense?
18:17:44 <hyakuhei> Ok, lets see if we can get some discussion of the RPC stuff on openstack-security ML
18:18:03 <hyakuhei> bpb: define short lived?
18:18:06 <bdpayne> bob can you elaborate?
18:18:27 <bpb> Short lived meaning maybe a few hours?  point of discussion
18:18:33 <bdpayne> (sorry, my client keeps autocorrecting bpb and bob)
18:19:15 <bpb> There's an opportunity to build an interface for barbican, but the use case needs to make sense.
18:19:21 <bdpayne> bpb can give some context about how these keys are being used?
18:19:59 <hyakuhei> I don't think you can because that's not been worked out yet
18:20:02 <bpb> There are separate keys used for the RPC authentication (each direction) and optional encryption (each direction)
18:20:19 <hyakuhei> The CMS proposal and the two-key AES symettric are both on the table
18:20:48 <bdpayne> got it
18:21:01 <hyakuhei> both have (I think) quite different key requirements
18:21:14 <bdpayne> that email thread has scared me as I haven't had the time to keep up with it so now I have a pretty big backlog of reading to do
18:21:14 <hyakuhei> both of which are largely invalidated without some sort of host attestation
18:21:28 <hyakuhei> Yeah it's pretty horrible
18:21:46 <bpb> I think it's different also, and it makes sense from efficiency persective to have these separate
18:22:02 <hyakuhei> To have what separate bpb ?
18:22:18 <bpb> Separate key managers
18:22:46 <hyakuhei> Sure, we're all about choice after all
18:23:32 <bpb> So we need to consider some use cases to support different types of key managers I think
18:24:06 <bdpayne> perhaps we also need to lay down what we are and are not trying to achieve with the rpc security?
18:24:08 <hyakuhei> yarp
18:24:45 <bpb> Characterizing the threats would be a good start
18:25:46 <hyakuhei> That sounds like an action to me
18:26:09 <bdpayne> #action guide the rpc discussion with some actual threat models
18:26:12 <bdpayne> very well then
18:26:17 <bdpayne> anything else for today?
18:26:55 <randy_perryman> :q
18:27:39 <bdpayne> well, thanks for stopping by
18:27:44 <bdpayne> have a great day everyone
18:27:52 <bdpayne> #endmeeting