18:01:47 <bdpayne> #startmeeting OpenStack Security Group
18:01:48 <sdague> thanks for comming folks, lets talk on #openstack-qa
18:01:48 <openstack> Meeting started Thu Sep 12 18:01:47 2013 UTC and is due to finish in 60 minutes.  The chair is bdpayne. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:52 <openstack> The meeting name has been set to 'openstack_security_group'
18:02:08 <bdpayne> Hi OSSG
18:02:12 <thomasbiege> hey!
18:02:21 <bdpayne> I know I've been out for a couple of weeks, so I have some catching up to do
18:02:23 <sriramhere> hello!
18:02:31 <malini1> Good morning!
18:02:49 <bdpayne> #topic Status of Action Items
18:03:01 <bdpayne> Let's start by reviewing where everyone is at with their work
18:03:05 <bdpayne> Anyone have somethign to report?
18:03:51 <bdpayne> sriramhere would you like to update on the security tagged of blueprints and what you learned there?
18:04:02 <thomasbiege> no progress on the automatic testing, too much work for my company ATM ;)
18:04:03 <sriramhere> couple of things there
18:04:17 <sriramhere> 1) blueprints don't provide any easy way out there
18:04:56 <sriramhere> 2) so the work around was security group to actively track blueprints and followup with bugs to trigger notifications
18:05:15 <sriramhere> i think rellerreller took action to look in to a way to trawl blueprints
18:05:28 <bdpayne> crawl?
18:05:53 <bdpayne> ah yes, I see that action from 8/29
18:05:54 <sriramhere> yes
18:06:02 <bdpayne> excellent
18:06:10 <bdpayne> the APL people couldn't make it today
18:06:17 <bdpayne> so we can sync on that next week
18:06:26 <sriramhere> ok
18:06:34 <bdpayne> so I have a few updates on my end
18:06:50 <bdpayne> First, I got the wiki page up to help people with how to get involved
18:06:59 <sriramhere> gr8 - where is the link?
18:07:13 <bdpayne> https://wiki.openstack.org/wiki/Security/How_To_Contribute
18:07:24 <bdpayne> since it is a wiki, feel free to update and improve
18:07:42 <bdpayne> I tried to take people's comments from the google doc into account, but didn't get everything in there
18:08:08 <sriramhere> i have a followup action on that - to add section on how OSSG can get involved early on
18:08:11 <bdpayne> I also linked to this from the general how to contibute page https://wiki.openstack.org/wiki/How_To_Contribute
18:08:26 <sriramhere> i couldn't make progress on that, will try to get something out before monday
18:08:42 <sriramhere> great bpayne!
18:08:47 <sriramhere> bpayne
18:08:48 <bdpayne> by early on you mean during design phase?
18:08:49 <sriramhere> sorry
18:08:53 <sriramhere> yes
18:09:03 <bdpayne> ah, excellent
18:09:24 <bdpayne> personally, I'd like to take a couple of passes to make it more words and less bullets
18:09:31 <bdpayne> but this is a nice starting place
18:09:36 <bdpayne> and I'm happy to refine over time
18:10:00 <bdpayne> #action sriramhere to add info to wiki about getting involved early in the design process
18:10:22 <bdpayne> #action bdpayne to continue improving presentation / wording on how to contribute wiki page
18:10:46 <bdpayne> My other news is about the OpenStack Security Guide
18:11:20 <bdpayne> a few of the authors (myself included) were on a panel at a government conference last week
18:11:30 <bdpayne> on a whim, we decided to do a book signing
18:11:42 <bdpayne> Red Hat pitched in a bought 100 copies to give away
18:11:47 <sriramhere> neat!
18:11:51 <randy_perryman> nicde
18:11:54 <randy_perryman> nice
18:12:06 <bdpayne> the net result… we had a line out the door and gave away all of the books, signing them all, to very happy recipients
18:12:39 <bdpayne> we also collected donations for the OpenStack Foundation, so a little money made it's way back to the cause
18:12:40 <sriramhere> wow! have any pic? would be a great slide
18:12:53 <bdpayne> you know, a pic would have been great, but I didn't get one
18:13:20 <malini1> WOW!!!!!!!!!!!!
18:13:41 <sriramhere> neat - can u share more abt the conference please (if its sharable)?
18:13:43 <malini1> I am totally psyched, that was such a gcool idea and a line to grab the book signed!
18:14:01 <bdpayne> oh, and there are pictures online from the book sprint now too http://www.flickr.com/photos/101584348@N06/
18:14:05 <bdpayne> for anyone interested
18:14:21 <bdpayne> those are from all booksprints by our facilitator… but if you scroll down you'll see us in there
18:14:34 <malini1> BTW,  I pitched our book at Intel Developer Conference in San Francisco this week during my presentation
18:14:40 <bdpayne> this was the conference http://www.oss-institute.org/calendar/upcoming-events/event/47
18:15:11 <malini1> Mentioned the book at a customer visit too
18:15:15 <sriramhere> awesome malini, how was the response?
18:15:23 <DennyZhang> /msg mtreinish hi matthew, I thanks for your comment in https://review.openstack.org/#/c/46315/. After abandon that one, I send a new one: https://review.openstack.org/#/c/46324/
18:15:26 <DennyZhang> 
18:15:39 <malini1> 150 attendees, hopefully some will get to the link
18:16:04 <bdpayne> excellent
18:16:22 <bdpayne> the book has been a great tool to get more people excited about OpenStack security and perhaps to get some involved
18:16:39 <bdpayne> My other update is with the logo
18:16:45 <sriramhere> absolutely!
18:16:49 <bdpayne> I'm *still* awaiting approval from the powers that be
18:17:03 <bdpayne> they tell me that they are discussing it and haven't forgotten about me
18:17:06 <malini1> It turns out Dell has a product called Crossbar to set up among other things trusted book of platform, but for general openstack consumption it needs to be more a part of Chef/puppet
18:17:09 <bdpayne> so, I'll continue to wait
18:17:30 <malini1> :-) :-)
18:17:35 <bdpayne> any other updates?
18:17:46 <sriramhere> crowbar or crossbar?
18:18:00 <bdpayne> crowbar, I imagine
18:18:10 <randy_perryman> I know of Crowbar as I am on that project
18:18:16 <malini1> Thanks Bryan for looking at the glossary, my TODO there is to make references in the chapters to the Glossary, been busy with other things .. hopefully over the weekend a little more time on it
18:18:50 <bdpayne> #action malini1 to work on linking glossary into security guide
18:18:57 <malini1> Wow! we have experts on crowbar here
18:19:03 <bdpayne> malini1 any update on the slide deck?
18:19:24 <malini1> Randy-perryman -- do you thing we can make some openstack-friendly thing or would that be conflict of interest
18:19:47 <bdpayne> malini1 I think Brian Schott may be able to help you with the slides, if that's useful
18:20:14 <malini1> :-) slow, extremely sorry, i put in a few slides for customer visit, so we have more but not complete
18:20:43 <bdpayne> perhaps for content generation we could put the slides up as a Google Doc?
18:20:48 <malini1> i will ping Brian. SriramHere was SriramNoWhere .. on slides ..
18:20:49 <sriramhere> i am also sorry, couldn't add more slides as malini and i were planning on?
18:21:09 <bdpayne> I probably have a few that would be applicable that I could drop in
18:21:21 <malini1> that would be good instead of flating around as a powerpoint
18:21:44 <malini1> bryan, can powerpoint port to googledocs with a click?
18:22:02 <bdpayne> yes
18:22:16 <bdpayne> then you can export back to pptx when you are done with google docs, if you want
18:22:19 <malini1> End of day will send you my latest set and then lets work via google docs on it
18:22:26 <bdpayne> sounds good
18:22:50 <bdpayne> ok great
18:22:55 <bdpayne> so that was a lot of catching up
18:22:57 <sriramhere> sriramnowhere will try be sriramhere
18:23:04 <sriramhere> on slides :)
18:23:10 <bdpayne> ha nice!
18:23:10 <malini1> :-)
18:23:30 <bdpayne> summit talk accepts / rejects should come out soon
18:23:50 <sriramhere> do we have a google site somewhere, or just individual google drive, shared via email?
18:23:56 <bdpayne> and I believe dev sessions are open for submission at this time?
18:24:02 <sriramhere> <bpayne> fingers crossed
18:24:11 <sriramhere> yes, they are
18:24:13 <bdpayne> sriramhere just the latter
18:24:39 <bdpayne> #action so, next week I'd like to chat a bit in this meeting about our strategy for the summit
18:25:00 <bdpayne> anything else on people's minds for today?
18:25:46 <sriramhere> any dev/ test submissions planned?
18:26:01 <bdpayne> not that I'm aware of
18:26:15 <bdpayne> but, I bet *someone* is
18:26:32 <bdpayne> I may be involved in some RBAC work this cycle… stay tuned ;-)
18:26:59 <bdpayne> really more security policy than RBAC… details are evolving a bit
18:27:11 <sriramhere> cool! just to be clear, security related is what i meant.
18:27:30 <bdpayne> yeah, I know that there's been some talk about automated security dev / test
18:27:34 <sriramhere> open thought - may need to brainstorm
18:27:49 <bdpayne> but I haven't seen anything concrete in place yes
18:27:53 <bdpayne> s/yes/yet/
18:27:58 <sriramhere> any interest in compliance engine kind of work?
18:28:14 <bdpayne> you mean to validate the compliance of a particular deployment?
18:28:25 <sriramhere> an engine or appliance that would monitor your cloud to validate/ warn for compliance
18:28:26 <sriramhere> yes
18:28:36 <sriramhere> not just SCAP kind of
18:28:51 <bdpayne> oh, heh
18:29:01 <bdpayne> I was about to mention that the SCAP guys are working on some openstack specific stuff
18:29:05 <bdpayne> but that's not what you mean?
18:29:33 <sriramhere> yes
18:30:03 <bdpayne> so yeah, there's work happening there
18:30:05 <sriramhere> like, can scap monitor violations coming from guests?
18:30:16 <malini1> bdpayne -- on the how to get involved "bullets" are fine, they are pithy and to the point
18:30:27 <sriramhere> ok - may be needs a snippet, follow up via email
18:30:37 <bdpayne> from guests… you'd probably want to run SCAP inside the guests then
18:30:42 <sriramhere> cool - good to know on SCAP work
18:30:59 <bdpayne> ok, thanks everyone… I think that's all for today
18:31:05 <bdpayne> #endmeeting