18:00:38 <bdpayne> #startmeeting OpenStack Security Group
18:00:39 <openstack> Meeting started Thu Sep 19 18:00:38 2013 UTC and is due to finish in 60 minutes.  The chair is bdpayne. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:42 <openstack> The meeting name has been set to 'openstack_security_group'
18:00:53 <bdpayne> hi everyone, time for OSSG meeting
18:00:57 <thomasbiege> hi
18:01:20 <bdpayne> do we have others in attendance?
18:01:29 <thomasbiege> brb
18:01:46 <hyakuhei> whaddup
18:01:55 <elo> yes.
18:01:55 <malini2> hey there!
18:02:04 <bdpayne> ah, hyakuhei nice to see you here :-)
18:02:07 <hyakuhei> :) I've missed this place
18:02:15 <bdpayne> alright, let's begin
18:02:29 <bdpayne> #topic Previous Action Items
18:02:47 <malini2> elo -- greetings
18:02:48 <bdpayne> We had a few action items from last week
18:03:11 <bdpayne> malini1 any update on the glossary?
18:03:27 <bdpayne> malini2 ^^
18:03:37 <hyakuhei> Oh yes, I'm happy to review that tomorrow if it's still in review.
18:03:44 * bdpayne gets confused when people change user names :-)
18:03:55 <malini2> sorry, not had chance to work much on it .. thus no updates to patch
18:03:59 <malini2> but a little progress
18:04:03 <bdpayne> ok
18:04:04 <thomasbiege> re
18:04:11 <malini2> same malini .. i must register a nickname
18:04:21 <bdpayne> no worries
18:04:34 <bdpayne> the other action items were releated to polishing up the wiki page
18:04:39 <bdpayne> the how to contribute page
18:04:43 <bdpayne> I didn't get to that this week
18:04:50 <bdpayne> but, it remains on my todo list
18:05:06 <bdpayne> Also, I quick logo update
18:05:07 <malini2> hyakuhei -- no do not review, we got help from doc folks on how to use the master glossary, now just need to update our chapters to use that
18:05:14 <hyakuhei> So I had a todo list but I burnt it
18:05:32 <hyakuhei> oh ok cool, is that documented somewhere nice? I'll contribute where I can
18:05:41 <bdpayne> I heard back from the foundation and they have denied our request for an OSSG logo that is a derivative of the OS logo
18:06:09 <bdpayne> We can, however, use the OS logo… subject to the normal usage guidelines
18:06:23 <bdpayne> So that project has come to a conclusion.
18:06:37 <bdpayne> ok, moving on...
18:06:43 <bdpayne> #topic Ongoing Work
18:06:46 <hyakuhei> :( I guess that means we've got freedom to come up with something more creative? Just using the OpenStack logo on it's own isn't very exciting
18:07:04 <malini2> bdpayne -- they decided this based on our rough draft or after we spent good money to make a fancy logo?
18:07:04 <bdpayne> Yes, we could certainly do a completely fresh logo
18:07:15 <bdpayne> They decided this on the rough draft
18:07:51 <malini2> bdpayne -- a tad bit mollified
18:07:52 <bdpayne> Personally, I'm a little logo'd out, but it someone else wants to push this effort ahead with another logo design, I'm ok with that
18:08:07 <hyakuhei> It'd be nice to have _something_ for the summit
18:08:14 <hyakuhei> but not massively important
18:08:24 <bdpayne> I'm ok just using the OS logo
18:08:32 <bdpayne> but, that's just me
18:08:51 <malini2> i am logo-ed out .. we can stick a little lock image on the footer of our presentations
18:09:04 <bdpayne> heh
18:09:06 <bdpayne> ok
18:09:21 <bdpayne> hyakuhei I saw you did some OSSN updating today, care to provide an update here?
18:09:42 <malini2> may be they felt the original logo becomes "insecure" if we have a "secure" version
18:09:57 <hyakuhei> There are no more outstanding OSSNs at the moment. Some of them weren't perfect but they'd been in a draft state for far too long
18:10:08 <hyakuhei> Things I'd like: Someone who can commit to proof reading all OSSNs
18:10:28 <hyakuhei> Someone to write OSSNs when I'm not around / share the load - We should be publishing more than we are
18:10:34 <malini2> hyakuhei -- I read all of yours
18:10:39 <hyakuhei> I still need to go through the security guide and add the OSSN references
18:11:00 <hyakuhei> Thanks malini2 - the help is appreciated but I'd like to formalize the process a little
18:11:18 <bdpayne> hyakuhei you looking for a committed team?
18:11:44 <hyakuhei> A little more process perhaps, I'd like to not be a single point of failure
18:11:52 <hyakuhei> other than that I'm looking for ways to speed it up is all
18:11:53 <malini2> hyakuhei -- I will be out all of November, other than conference, will commit in Jan, I apologize.
18:12:02 <hyakuhei> Heh
18:12:16 <hyakuhei> I'll draft something up, it'll be good fodder for the 'get involved' wiki
18:12:24 <bdpayne> sounds good
18:12:49 <bdpayne> also, there's been some discussion on slides
18:12:59 <bdpayne> malini2 care to provide an update there?
18:13:08 <malini2> i just sent a few of you link to google doc
18:13:22 <hyakuhei> Sure, whats it in relation to? Did the panel discussion get accepted?
18:13:46 <bdpayne> this is the general slide deck for OSSG
18:13:54 <hyakuhei> Aaaah nice
18:14:01 <bdpayne> malini2 care to share the link here?
18:14:20 <hyakuhei> I remember now. The deck is looking reasonably tidy already, Lots of tidying required and a few gaps but I like the looks of it
18:14:26 <bdpayne> or would you like further review first?
18:15:07 <hyakuhei> "OpenStack is made up of defensible technologes" - That again!
18:15:09 <malini2> do not know how to share
18:15:22 <hyakuhei> bdpayne: I completely hold you responsible for that (as your boss isn't here)(
18:15:43 <hyakuhei> Ahaha. Ok I should read the whole slide - my reply is there.
18:15:48 <bdpayne> lol
18:15:49 <bdpayne> https://docs.google.com/file/d/0B7YGqQvPhrazaHkxdTVFdmc5UDg/edit?usp=sharing
18:15:55 <bdpayne> ^^ link to view the slides
18:15:58 <uvirtbot> bdpayne: Error: "^" is not a valid command.
18:16:02 <elo> taking a look now
18:16:05 <bdpayne> sorry Mr Bot
18:16:26 <bdpayne> anyway, this is worth reviewing and improving for anyone who is interested
18:16:37 <hyakuhei> Looks good
18:16:39 <bdpayne> the goal here is to have a slide deck that we, as a group, keep up to date
18:16:41 <hyakuhei> Edit on google docs?
18:16:58 <bdpayne> then people could talk openstack security in user groups and such more easily
18:17:02 <elo> looks good
18:17:06 <bdpayne> direct edits seems fine
18:17:06 <malini2> :-) thanks bdpayne!  networking etc not fleshed out .. the book is loaded with good stuff, but on the bright side I have read book cover to cover
18:17:06 <hyakuhei> Obviously a lot of work has gone into this already, malini2 was this mainly your effort?
18:17:39 <hyakuhei> Are you ok with us all diving in and changing things?
18:17:42 <malini2> yes :-) :-)
18:17:52 <elo> and networking adds new services in Havana
18:17:54 <bdpayne> thanks malini2!
18:18:02 <malini2> cutting and pasting nice pictures from git
18:18:03 <hyakuhei> Superb work!
18:18:24 <hyakuhei> Do we want crib notes for each slide?
18:18:40 <malini2> absolutely -- dig in
18:18:42 <bdpayne> I think that would be nice
18:18:53 <malini2> do add crib notes
18:18:53 <bdpayne> #action everyone to help review / edit slides
18:19:12 <elo> yes… so we all know what are the main points to highligh in each slide...
18:19:22 <hyakuhei> Ok cool, we'll I'll look to present this at FOSDEM, so I'll put some effort in over the next few months.
18:19:22 <bdpayne> any other ongoing work that people would like to discuss?
18:19:46 <malini2> i thought if we each add a slide or two, this will get done just like the book, and if you do not mind, I will edit, so it does not get too verbose
18:19:58 <bdpayne> sounds reasonable
18:20:51 <bdpayne> #topic Summit
18:21:05 <bdpayne> I'd like to discuss the summit a litlte bit today
18:21:19 <bdpayne> I had thought we would know which talks were accepted by now
18:21:28 <bdpayne> Looks like that may not happen until next week
18:21:35 <bdpayne> Nevertheless…
18:21:46 <bdpayne> Is anyone submitting a dev session topic?
18:21:48 <hyakuhei> Christ. I've got _so_ many things to write!
18:21:56 <elo> someone said to me by the 23rd
18:22:20 <bdpayne> elo 23rd is what I've heard as welll, for the summit talks
18:22:31 <elo> I'm working on Neutron HOL with my coworker
18:22:34 <hyakuhei> The format of the summit this year is making life hard for security folks
18:22:36 <bdpayne> design session submissions are open http://summit.openstack.org/
18:23:23 <bdpayne> I'd like for the OSSG to put together a google doc spreadsheet to track these
18:23:38 <hyakuhei> As in a security-related list?
18:23:48 <bdpayne> listing both summit sessions and -- more importantly -- design sessions that are security relavent
18:23:51 <bdpayne> yeah
18:24:09 <bdpayne> and then we should aim to get some good coverage from the group in attending the sessions we think are most important
18:24:25 <malini2> good idea on spreadsheet
18:24:27 <bdpayne> there will be too many for any one person to cover
18:24:46 <bdpayne> I'm happy to take the lead on putting that together
18:24:55 <hyakuhei> Are you thinking that we do a roundup afterwards?
18:25:05 <bdpayne> #action bdpayne to put together spreadsheet for tracking security related sessions at summit
18:25:12 <bdpayne> yes
18:25:17 <hyakuhei> This scares me: http://summit.openstack.org/cfp/details/45
18:25:27 <bdpayne> after the summit, we should sync on what we heard and next steps
18:25:34 <bdpayne> we can do that here in these meetings
18:25:36 <hyakuhei> Sounds good
18:26:21 <bdpayne> hyakuhei yeah… there are people pushing lxc as a good (and secure?!?!) alternative to VMs
18:26:26 <bdpayne> which is prolematic
18:26:30 <bdpayne> *problematic
18:26:47 <bdpayne> ok, that's all I have for today… anything else ?
18:26:56 <elo> nope.
18:26:59 <hyakuhei> nope.
18:27:29 <malini2> yes yes, one more thing. intel has microservers .. say 8 atom servers, while they can run VMs, their best use is low power, high IO etc
18:28:12 <malini2> at intel idf there was interest in them .. t hey come into the data center .. they will come into cloud and thier performance/watt may make them good bare
18:28:16 <malini2> metal candidate
18:28:52 <bdpayne> interesting, though bare metal scares me
18:28:54 <malini2> sso we need to watch and guide the LXC/barenetal stuff
18:29:13 <bdpayne> agreed
18:29:18 <bdpayne> there's a time and place for these solutions
18:29:27 <bdpayne> but the security implications aren't obvious to most people
18:29:29 <hyakuhei> Same for Moonshot I guess
18:29:42 <bdpayne> so I think our role is to help provide clarity around that
18:30:07 <malini2> the microservers came into existence for bing-like workloads ..
18:30:45 <malini2> will send offline some specs/data so we could discuss next meeting
18:30:51 <bdpayne> sounds good, thanks
18:30:59 <bdpayne> ok, have a great week everyone
18:31:07 <thomasbiege> bye
18:31:10 <bdpayne> #endmeeting