14:01:25 <gothicmindfood> #startmeeting openstack-swg
14:01:26 <openstack> Meeting started Thu Jan 5 14:01:25 2017 UTC and is due to finish in 60 minutes. The chair is gothicmindfood. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:30 <openstack> The meeting name has been set to 'openstack_swg'
14:01:41 <EmilienM> o/
14:01:52 <gothicmindfood> amrith, dhellmann, gothicmindfood, ttx, jroll, johnthetubaguy, sdague, mordred, carolbarrett, nikhil, mugsie, thingee, alexismonville, edleafe, EmilienM, harlowja, devananda, bastafidli
14:01:56 <gothicmindfood> those are our courtesy pings
14:01:59 <jroll> \o
14:02:00 <johnthetubaguy> o/
14:02:07 <alexismonville> o/
14:02:07 <gothicmindfood> my sincere apologies for not updating the agenda, folks
14:02:12 <alexismonville> happy new year :)
14:02:14 <gothicmindfood> It's been a rather long month for me here
14:02:20 <gothicmindfood> happy new year and post-holidays to you all
14:02:37 <gothicmindfood> I do think we probably know a bit about what we need to talk about based on our last meeting
14:03:06 <ttx> johnthetubaguy posted https://etherpad.openstack.org/p/AtlantaPTG-SWG-TCVision
14:03:36 <gothicmindfood> yup
14:03:43 <johnthetubaguy> yeah, sorry that took a month, but moving it out of gerrit, so we can start work on it
14:03:44 <ttx> I started to list on that etherpad what the TC actually does, and which we should probably cover in the vision somehow
14:03:48 <gothicmindfood> and I have some news on the Atlanta visioning ront as well
14:03:59 <johnthetubaguy> tried to collect some questions from the last meeting too
14:04:09 <johnthetubaguy> ttx: liking that list, thanks
14:04:25 <ttx> I like to put things into categories :)
14:04:47 <gothicmindfood> what do you all say that I start with a couple announcements, and then we move on to talking through our overarching vision for the PTG (as the SWG) and then dig into the beginnings of the TC vision etherpad?
14:04:57 <gothicmindfood> does that sound like a decent plan for the hour?
14:05:26 <fungi> wfm
14:05:27 <EmilienM> ++
14:05:30 <gothicmindfood> sweet.
14:05:33 <jroll> ++
14:05:36 <gothicmindfood> Okay - so on the training/PTG front
14:05:55 <gothicmindfood> I had a great convo with Timo over at ZingTrain about the week of April 10th being targeted for leadership training
14:05:58 <gothicmindfood> which is awesome
14:06:03 <EmilienM> gothicmindfood: maybe use #topic so we have a nice summary at the end
14:06:09 <gothicmindfood> EmilienM: ah, cool
14:06:18 <gothicmindfood> I do when we have an agenda, just failed this time at that :)
14:06:30 <gothicmindfood> #topic Leadership training & PTG announcements
14:06:56 * edleafe shuffles in late
14:07:05 <gothicmindfood> so - April 10th is the week we're targeting for training
14:07:24 <gothicmindfood> it'll be 3 days again - 2 days facilitated and 1 day of after-training discussion hosted for attendees
14:07:51 <alexismonville> great!
14:08:03 <gothicmindfood> I'm still working on getting the full list of invitees together, but ostensibly it'll be any TC members who haven't done it, plus ttx, plus some user committee and hopefully board folks plus anyone else who is interested
14:08:23 <gothicmindfood> I got a quote for 20 people to attend again
14:08:41 <gothicmindfood> and also managed to get a quote combined with that for a 1 day vision facilitation at the Atlanta PTG
14:08:48 <gothicmindfood> which ZingTrain is very interested in helpig us out on
14:09:26 <gothicmindfood> from their perspective: having an outsider facilitate a vision is pretty important, and also having folks who've done large scale visions before might help us in areas where we falter, especially w/r/t keeping on task
14:09:51 <gothicmindfood> so I wanted to check in with this group before going to the TC about it - how would we feel about taking one day of the PTG for vision facilitation there?
14:10:46 <ttx> We'll have a one-day SWG room there
14:10:53 <ttx> so that fits the agenda
14:11:21 <johnthetubaguy> I guess there are quite a few TC folks who will be at other horizontal stuff than the SWG, but its probably the best shot we have
14:11:22 <gothicmindfood> ttx: kinda. I'm worried about making this vision our whole agenda, especially when so many others in the community seemed to want to learn skills/various things about what we're up to
14:11:34 <EmilienM> do we know which day ? (during horizontal sessions)
14:11:37 <ttx> just creates a bit of constraints as I have a pretty busy Monday/Tuesday
14:11:51 <gothicmindfood> we would choose the day for the vision stuff
14:11:53 <gothicmindfood> it could be any day
14:12:01 <ttx> EmilienM: Monday or Tuesday, undecided yet. Architecture WG is supposed to take the other day
14:12:09 <EmilienM> ttx: cool
14:12:12 <johnthetubaguy> ttx: ah, that makes sense
14:12:12 <ttx> By default I'd say Monday for SWG
14:12:21 <ttx> since ArchWG is likely to attract more people
14:12:29 <fungi> yeah, monday/tuesday i'll be running infra stuff all day
14:12:30 <johnthetubaguy> yeah
14:12:30 <ttx> (people who might want to travel on Monday)
14:12:47 <ttx> could also be a one-day thing on Friday
14:12:54 <gothicmindfood> I was wondering about Friday
14:12:55 <ttx> out of the SWG room
14:12:59 <gothicmindfood> or Thursday
14:13:06 <ttx> in some corner of the venue
14:13:09 <johnthetubaguy> I can't do friday, but that might give you a bigger number of folks
14:13:10 <gothicmindfood> I know people will be pretty exhausted
14:13:27 * fungi expects to start the week exhausted
14:13:27 <EmilienM> I'm not sure we can satifsfy everyone. Thursday is vertical sessions, some folks will also be busy
14:13:36 <ttx> Thursday I'll likely be stuck releasing the thing known as OpenStack
14:13:44 <ttx> same for dhellmann
14:13:47 <gothicmindfood> yeah
14:13:53 <johnthetubaguy> EmilienM: +1 right, people are going to be busy on every day at this point
14:13:54 <EmilienM> ttx: during PTG?
14:13:59 <fungi> oh, right, i forgot thursday at the ptg is release day ;)
14:14:08 <gothicmindfood> So - the biggest thing I'm concerned about is 100% TC attendance
14:14:12 <ttx> EmilienM: we like difficulty
14:14:26 <gothicmindfood> at least at pieces of the day-long session
14:14:28 <EmilienM> (out of topic but releasing OpenStack during PTG is not the best idea ever)
14:14:28 <jroll> I seem to remember TC folks thoguht they'd be too tired for a board meeting, I can't imagine they wouldn't be too tired for a full day visioning session
14:14:31 <gothicmindfood> so that everyone gets a chance to participate
14:14:42 <fungi> actually, being able to get all the release team in a room together physically on release day sounds pretty helpful</offtopic>
14:14:47 <jroll> (but don't remember the final decision on that board meeting thing)
14:14:48 <ttx> EmilienM: when we discussed it at past Summits it sounded like a good idea
14:15:03 <ttx> (fwiw we won't do that for the second PTG)
14:15:04 <EmilienM> cool then :-) good luck!
14:15:22 <ttx> we prefer the PTG week to the week just before or after
14:15:30 <alexismonville> I will not be at the PTG (personal reason) but I would like to say that I would start with the visioning when people are fresh
14:15:38 <gothicmindfood> so it sounds like Monday or Friday are the best options for a potential day long visioning session
14:15:43 <gothicmindfood> and I lean towards Monday
14:15:44 <johnthetubaguy> yeah, I had it in my head we do the release the week after the ptg, duno why
14:16:03 <ttx> the week after ptg I'll be sleeping
14:16:11 <johnthetubaguy> ttx: good point
14:16:13 <gothicmindfood> ttx: you sleep?
14:16:14 <gothicmindfood> ;)
14:16:19 <ttx> gothicmindfood: the week after events yes
14:16:32 <gothicmindfood> week-after-openstack-event-ttx-hibernation
14:16:44 <fungi> while 100% tc attendance is a great goal, i have serious doubts we'll ever get all 13 tc members' attention so accepting <100% would be more practical
14:16:58 <jroll> fungi: ++
14:17:01 <ttx> only way to get 75% of tc would be to do it outside of PTG week
14:17:05 <johnthetubaguy> fungi: +!
14:17:13 <ttx> we've been on that discussion about a Board+TC meeting
14:17:35 <gothicmindfood> fungi: totally get that. My concern is getting 70% of them in the room doing the work and then having the other 30% lacking context and getting upset about the work post-PTG
14:17:37 <ttx> the PTg week is basically already more than full for cross-project people
14:17:45 <johnthetubaguy> so, I had always assumed we would have to find some way to make visioning async, I know thats not normal
14:18:00 <gothicmindfood> johnthetubaguy: I think it can be, and should be during a phase of it
14:18:11 <fungi> we always find ways to make everything async in our community. sometimes it doesn't work out great, but it's by necessity
14:18:12 <gothicmindfood> but for initial drafting, I think it's best to have folks as syncronous as possible
14:18:29 <johnthetubaguy> now a selection of folks kick starting things, in a traditional method, responsible for helping the the draft makes sense
14:18:42 <gothicmindfood> but - I certainly understand the crazy schedules at the PTG
14:19:16 <johnthetubaguy> trouble is, anything synchronous will always exclude folks, I am just saying 50% attendance might be considered a win here, and it has less value, but its better than not doing it
14:19:17 <gothicmindfood> okay - alexismonville had a point about freshness/perspective, too, that makes me lean even harder towards the monday
14:19:26 <EmilienM> right, meeting in person to bootstrap things is best than emails/irc
14:19:33 <EmilienM> s/best/better/ (imho)
14:19:43 <fungi> maybe if we took turns as "meeting secretary" recording minutes so that people who missed have more context than just the draft output?
14:19:54 <gothicmindfood> ttx: how do we confirm that we want an all-day session monday - just with you? :)
14:20:11 <fungi> (whereby "we" i don't necessarily mean to imply that i'm assuming i'll be present)
14:20:15 <gothicmindfood> fungi: we'll be doing a lot of writing and pasting up on walls, so I'm sure we can preserve that
14:20:23 <gothicmindfood> in pictures and with transcriptions if necessary
14:20:49 <fungi> if i get to write on walls in crayon, i'll find a way to be tehre ;)
14:21:00 <johnthetubaguy> I think promising lots of pictures, a various folks blogs on the event would certainly help
14:21:00 <gothicmindfood> fungi: I bet it's scratch-n-sniff sharpies :)
14:21:03 <johnthetubaguy> fungi: heh
14:21:04 <ttx> gothicmindfood: it's the default situation
14:21:13 <gothicmindfood> ttx: okay cool.
14:21:18 <ttx> We have a room earmarked for SWG/ArchWG on Monday/Tuesday
14:21:37 <gothicmindfood> so I just have to reconfirm with the foundation that we can wrap this into training funding, and then reach out to ZingTrain to coordinate scheduling on that side
14:21:39 <ttx> as mentioned on http://www.openstack.org/ptg
14:21:58 <ttx> So who gets monday and who gets tuesday can be arranged between ArchWG and SWG
14:22:01 <gothicmindfood> #action gothicmindfood to finalize TC Vision Facilitation timing with Foundation/ZingTrain/TC
14:22:32 <gothicmindfood> okay awesome. Thank you for the advice everyone
14:22:40 <fungi> just to clarify, i don't expect to have any time to be in the swg room monday/tuesday due to ptl responsibilities, but have faith others who are there can do a bang-up job drafting something i'll read and help polish later
14:22:44 <gothicmindfood> and please pencil in that week of April 10 on your calendars for leadership training if you'd like to attend
14:22:55 <johnthetubaguy> I vote we just try it with who can be there, certainly shouldn't be exclusive to TC members
14:23:20 <gothicmindfood> johnthetubaguy: I'm definitely open to that, too
14:23:39 <gothicmindfood> #topic SWG's PTG Vision
14:23:47 <gothicmindfood> #link https://etherpad.openstack.org/p/AtlantaPTG-SWG
14:24:03 <ttx> we could do a TC visioning dinner too. But we all know how that usually turns out
14:24:34 <gothicmindfood> so - my next question is if we do a full day visioning session - does that mean our other sessions/ideas get pushed back to another time?
14:25:16 <ttx> We seem to have a vision track -> SWG vision -> TC vision -> OpenStack vision. Is tehre anything else we want to actively pursue in the coming months ?
14:25:57 <gothicmindfood> ttx: I think that's probably the most important goal, but I would like to start digging into a leadership "passport" for OpenStack and what that might look like
14:26:01 <gothicmindfood> even though I think that's a longer term project
14:26:40 <ttx> ok
14:26:53 <gothicmindfood> it might be nice to write an SWG vision that goes beyond our presence at events, too :)
14:27:18 <gothicmindfood> I think we'll all learn a lot from the vision facilitation at the PTG, though
14:27:41 <gothicmindfood> are we of a mind that we might have a TC vision finalized by Boston?
14:27:47 <johnthetubaguy> honestly, I was assuming lots of the TC vision would end up needing signification support from the SWG, and would help drive a lot of what we do
14:28:01 <gothicmindfood> johnthetubaguy: totally agree with that
14:28:18 <johnthetubaguy> so I tried to write questions on that etherpad, based on this kind of thing
14:28:48 <johnthetubaguy> I was thinking there is initial draft, vs finalized
14:28:50 <gothicmindfood> #link https://etherpad.openstack.org/p/AtlantaPTG-SWG-TCVision
14:28:56 <gothicmindfood> johnthetubaguy: that one ^^ ?
14:28:58 <johnthetubaguy> initial draft means the TC has signed off on it maybe?
14:28:59 <johnthetubaguy> yeah
14:29:04 <johnthetubaguy> sorry, missing context there
14:30:05 <johnthetubaguy> we were talking about getting UC and board reviews, I was thinking we should get the TC on roughly the same page first, but maybe thats too waterfall?
14:30:20 <gothicmindfood> do we think that the TC vision, once a draft is accepted by the TC, should also be pushed to the community more broadly for feedback?
14:30:23 <gothicmindfood> as a separate cycle?
14:30:48 <gothicmindfood> ha. Same question, sorta.
14:31:14 <gothicmindfood> I mean, it feels like this whole thing will be iterative in terms of opening up the feedback loops to different groups while we align ourselves with one another
14:31:28 <johnthetubaguy> I think everyone can be involved in the first cycle
14:31:31 <alexismonville> I think one of the success criteria could be that the TC is committed to publish a first version of the vision by 30 days after the PTG
14:31:37 <gothicmindfood> each group will be inspired to think about how the vision aligns with their own (or doesn't)
14:31:42 <gothicmindfood> as they write htem down for the first time
14:31:43 <johnthetubaguy> I just really wondering what finalised means
14:31:46 <jroll> given this is a vision for the TC, I think it makes sense to get TC on board first :)
14:31:50 <alexismonville> so yes a draft should be available for feedback before
14:32:14 <fungi> "final" is probably a poor term for the goal there
14:32:20 <gothicmindfood> johnthetubaguy: yeah, right? :) I imagine finalized might mean, in an official sense, committed to an official governance repo and posted for the world to see
14:32:25 <gothicmindfood> but that doesn't mean it can't change from there, obvs
14:32:34 <fungi> (i don't expect there will ever be a completely final version of any document in our community)
14:32:49 <fungi> right, that
14:32:52 <gothicmindfood> and one of the powers of a vision is that it expires and you have to make a new one
14:32:57 <johnthetubaguy> so I think the TC should all agree on something by Boston
14:32:57 <persia> Perhaps we could call it an "approved" revision?
14:32:59 <gothicmindfood> because it's really just about a point in time
14:33:03 <johnthetubaguy> maybe thats a better way to look at it?
14:33:20 <alexismonville> +1 for approved revision
14:33:28 <gothicmindfood> johnthetubaguy: I was hoping that by Boston we could have already had a larger community involvement as well
14:33:43 <fungi> approved sounds good. an agreed-upon and consensual initial revision
14:33:47 <johnthetubaguy> ttx: when is TC elections?
14:33:54 <gothicmindfood> bootstrapping the TC in post-PTG by April or so, and then asking for feedback pre-Boston to maybe finalize/publish there?
14:33:58 <johnthetubaguy> would that be a good aim, get it aggreed before?
14:34:29 <fungi> #link https://governance.openstack.org/election/
14:34:32 <fungi> johnthetubaguy: ^
14:34:34 <alexismonville> I think that is needed to give a direction to the different project
14:34:48 <fungi> we don't have finalized tc election dates listed yet
14:34:49 <gothicmindfood> johnthetubaguy: yeah, I think agreed on before and then publicized/asking UC & Board for feedback so Boston can be a discussion
14:35:00 <fungi> but they'll be at least after the ptl elections
14:35:06 <ttx> johnthetubaguy: weeks before Boston
14:35:29 <johnthetubaguy> ttx: right, we were re-aligning with that
14:35:44 <johnthetubaguy> well, not changing it
14:36:43 * gothicmindfood just added a thing in th etherpad for timing
14:37:28 <gothicmindfood> looking at q 1.1 - was there ever a decision made between 18 months and 24 months?
14:38:28 <gothicmindfood> it'd be nice to walk into the PTG knowing what our vision timescale is
14:38:48 <johnthetubaguy> my original thinking was agree it for a timeframe after all those who have voted on it will be re-elected
14:38:51 <johnthetubaguy> that being the minimum amount of time
14:39:21 <johnthetubaguy> gothicmindfood: what more normal, longer term?
14:39:41 <gothicmindfood> yeah, usually 5-10 years is a common visioning timeframe
14:39:48 <gothicmindfood> but I think there's absolutely a case to do 2 years here
14:40:43 <johnthetubaguy> leaning longer seems to make sense, so lets start off with two years?
14:40:49 <gothicmindfood> is anyone uncomfortable with a 2 year vision?
14:41:14 <EmilienM> it sounds a lot, but it seems "normal" (/me learning here)
14:41:25 <gothicmindfood> I think it works for us pretty well, given the uniqueness of our community
14:41:39 <gothicmindfood> (changing tech, fluctuating members based on corporate interest, etc.)
14:41:58 <gothicmindfood> so let's say 2 years going into the PTG
14:42:15 <gothicmindfood> we may decide that doesn't work when we get in the room, but I think that's okay too :)
14:42:20 <johnthetubaguy> seems like a good starting point
14:42:53 <alexismonville> ++
14:44:08 <jroll> 2 years sounds good to me
14:44:19 <gothicmindfood> so - out of curiosity - has everyone here read a vision that's outside of OpenStack context before?
14:44:28 <gothicmindfood> I think that might be a good thing to recommend, too, before the PTG
14:44:49 <johnthetubaguy> gothicmindfood: can you put those links you sent me before in there as pre-work, thats a good idea
14:44:55 <gothicmindfood> maybe I will post them in the etherpad for folks to read?
14:44:59 <jroll> ++
14:45:09 <gothicmindfood> #action gothicmindfood to post some visions-as-reference in TC Vision etherpad
14:45:43 <johnthetubaguy> gothicmindfood: added a Recomended Preparation work section
14:45:45 <alexismonville> great
14:45:56 <johnthetubaguy> ttx: I wonder if we should turn your list on its head?
14:46:17 <ttx> johnthetubaguy: what do you mean ?
14:46:25 <johnthetubaguy> ttx: that one you are typing now is more what I was thinking, like listing categorised "problems"
14:46:42 <johnthetubaguy> right now lots of them are solutions we have proposed
14:47:03 <ttx> johnthetubaguy: I built the list based on things we have done in the past, as I summarize them in annual Foundation reports
14:47:13 <johnthetubaguy> like documenting existing culture helps ensure an inclusive and welcoming environment for open collaboration
14:47:21 <ttx> clearly there is still room for things we are not doing and should be doing :)
14:47:31 <johnthetubaguy> yeah, its a good starting point, I guess what I am proposing is a second list
14:47:41 <ttx> It's just that we probably need to cover what we are actually doing, too
14:47:48 <johnthetubaguy> ++ covering that
14:47:51 <ttx> johnthetubaguy: sounds like a good idea
14:48:06 <johnthetubaguy> not throwing the baby out with the bathwater, as they save over here
14:48:12 <johnthetubaguy> s/save/say/
14:49:42 <gothicmindfood> I'm really excited that we might get a draft vision by the end of the PTG
14:50:19 <gothicmindfood> do we want to talk any more about this TC Vision etherpad, or should we move to open discussion for the last 10 minutes?
14:50:57 <ttx> johnthetubaguy: the inverted list will be interesting to make sure we identify improvements/aspirations
14:51:07 <johnthetubaguy> I guess I am curious what the next steps
14:51:26 <johnthetubaguy> ttx: cool, yeah, I like having both lists now I see a little bit of both
14:51:40 <johnthetubaguy> gothicmindfood you are talking to the facilitators
14:51:59 <johnthetubaguy> rest of us are filling out the lists and questions on the etherpad to get the creative juices flowing, so to speak
14:52:08 <johnthetubaguy> are we missing an action there?
14:52:18 <gothicmindfood> yup. I may ask them to take a peek at that etherpad, too :)
14:52:32 <gothicmindfood> I don't think so - I just have to follow through with that setup I mentioned earlier btwn foundation and zingtrain
14:52:39 <gothicmindfood> and I already action'd that
14:52:51 <gothicmindfood> do you think I should show up at a TC meeting and like, talk about this stuff?
14:53:00 <gothicmindfood> or does someone else want to bring it up there?
14:53:01 <gothicmindfood> ;)
14:53:23 * gothicmindfood jokes, but will have a much more normal schedule starting next week and will actually be able to go to meetings again
14:53:24 <persia> I think there are enough TC members here that it would be sensible for one of them to represent to the TC
14:53:44 <persia> (unless that creates unwanted impression of bias)
14:53:49 <johnthetubaguy> yeah, lets get this on the agenda for next time, as a heads up
14:53:58 <gothicmindfood> johnthetubaguy: dyou want to take that action?
14:54:15 <ttx> johnthetubaguy: we can mention it in open discussion
14:54:24 <johnthetubaguy> ttx: yeah, lets do that, simpler
14:54:27 <gothicmindfood> yay.
14:54:32 <johnthetubaguy> I can take that action
14:54:35 <fungi> seems fine to me (tc hat on)
14:54:46 <gothicmindfood> and as a context-filler, I've been remarkably absent from work life because I've been working on this: http://publictheater.org/Tickets/Calendar/PlayDetailsCollection/UTR/UTR-2017/Hundred-Days/
14:54:53 <gothicmindfood> if anyone's in NYC in the next week and wants to come :)
14:55:09 <gothicmindfood> now that we're open, I get my life back
14:55:11 <johnthetubaguy> governance repo patches are getting abandoned with a note to see the etherpad too
14:55:48 <gothicmindfood> #action ttx and johnthetubaguy to bring up vision planning at TC meeting open discussion
14:56:05 <alexismonville> congrats gothicmindfood
14:56:14 <gothicmindfood> alexismonville: thanks! :)
14:56:48 <gothicmindfood> anything else for our last 4 minutes?
14:57:41 <gothicmindfood> alright - I'm going to give folks a couple minutes back, then. we can take the rest of convo over to #openstack-swg as usual
14:57:44 <gothicmindfood> thanks so much everyone!
14:57:57 <gothicmindfood> #endmeeting