20:00:29 <ildikov> #startmeeting openstack-upstream-institute
20:00:30 <openstack> Meeting started Mon Mar 27 20:00:29 2017 UTC and is due to finish in 60 minutes.  The chair is ildikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:34 <openstack> The meeting name has been set to 'openstack_upstream_institute'
20:00:38 <jaypipes> o./
20:00:41 <jungleboyj> o/
20:01:00 * diablo_rojo is back from Mexico :)
20:01:03 <mlavalle> o/
20:01:07 <ildikov> bauzas: are you around too?
20:01:18 <bauzas> yup
20:01:22 <ildikov> diablo_rojo: welcome back :)
20:01:27 <blancos> o/
20:01:40 <diablo_rojo> ildikov, thanks :)
20:01:43 * bauzas waves even if DST-impacted :)
20:01:49 <spotz> \o/
20:01:53 <ildikov> bauzas: I hear ya!
20:02:47 <ildikov> let's wait one more minute and then start
20:03:58 <spotz> We have a git section don't we?
20:04:06 <ildikov> ok, let's get into it
20:04:22 <mrhillsman> o/
20:04:27 <ildikov> spotz: you mean the follow up session we talked about?
20:04:31 * mrhillsman being a fly on the wall
20:05:08 <spotz> ildikov: No during training, just contacted github to get cheat sheets for the lunch and learn, I'll ask for me if we need them for the weekend too:)
20:05:17 <spotz> me=more
20:05:32 <diablo_rojo> spotz, yes we have a section on git
20:05:51 <spotz> diablo_rojo: Ok I'll bump my request by 50? when I hear back
20:05:57 <diablo_rojo> spotz, all the sections are here: https://docs.openstack.org/upstream-training/
20:06:06 <ildikov> spotz: I think an advanced session would be better as that lunch slot or a follow up during the week
20:06:18 <diablo_rojo> ildikov, +1
20:06:24 <ildikov> if we do that as a lunch session during the training people's head will fall off :)
20:06:28 <spotz> ildikov: Ok we can just send folks to the Lunch and Learn on Wednesday
20:06:37 <ildikov> spotz: +1
20:06:54 <diablo_rojo> spotz, yeah it might be good to collect all of those sessions and promote them towards the end of the training as possible next steps
20:07:02 <ildikov> spotz: we can add material about it though and if everyone turns out to be experienced we can switch to that
20:08:30 <jungleboyj> ildikov:  ++
20:08:49 <ildikov> spotz: jungleboyj: I'm not holding my breath though :)
20:08:57 <spotz> heheh
20:09:01 <jungleboyj> Probably true.
20:09:07 <ildikov> mrhillsman: glad you joined! :)
20:09:23 <jungleboyj> None the less, information we will need for the future.
20:09:28 <ildikov> ok, let's switch to the first topic
20:09:31 <ildikov> jungleboyj: +1
20:09:40 <ildikov> #topic Training exercises
20:09:53 <ildikov> so we have an etherpad for that
20:09:57 <ildikov> #link https://etherpad.openstack.org/p/upstream-training-exercises
20:10:30 * smcginnis sneaks in late...
20:10:33 <ildikov> it would be great to revitalize them as much as possible
20:10:45 * jungleboyj gives smcginnis the evil eye
20:10:49 <ildikov> smcginnis: hi, thanks for joining :)
20:11:19 <ildikov> the plan is to try to teach the most things as part of an exercise
20:11:20 <diablo_rojo> If people can generate ideas for more exercises I am willing to make the changes in the slides.
20:11:29 <ildikov> let people find the info and figure out things for themselves
20:11:50 <jungleboyj> ildikov:  Like that idea.
20:11:58 <jungleboyj> Keep them engaged and busy.
20:11:59 <ildikov> also the driving force for updating the slides should be the exercises
20:12:05 <ildikov> jungleboyj: +1
20:12:54 <diablo_rojo> ildikov, agreed :)
20:13:41 <ildikov> in Barcelona we spent a lot of time with introductions, we should change this for Boston
20:13:41 <diablo_rojo> I think we need to reduce the content in favor of exercises and then maybe add the things we want them to learn as notes on the exercises so that we know to highlight those things as we are having students do the exercises
20:13:59 <spotz> diablo_rojo: +1
20:14:11 <ildikov> diablo_rojo: +1
20:14:13 <jungleboyj> ildikov:  Yeah, that was pretty consistent feedback that we didn't need so much of that.
20:14:15 <spotz> ildikov: Was there any specific feedback from Barcelona that needs to be addresses?
20:14:28 <jungleboyj> diablo_rojo:  Makes sense.
20:14:34 <ildikov> spending time on the slides can be boring and people start to disengage quickly
20:14:44 <jungleboyj> Yep.
20:14:55 <ildikov> spotz: we had too many people in the room, the intro took ages
20:15:18 <spotz> ildikov: Students or 'instructors/helpers'?
20:15:23 <ildikov> so my thinking is to have the trainers/coaches introduce themselves to the whole group
20:15:46 <diablo_rojo> Works for me
20:15:47 <jaypipes> ildikov: ++
20:16:03 <jungleboyj> Yeah, can't have everyone introduce themselves.
20:16:09 <spotz> I usually do a slide with the main instructors, then one with the other folks in the room with their companies and they just kind of wave when they're name is read
20:16:11 <ildikov> and as we ask students in advance about what's their area of interest we can split them into groups before the training
20:16:17 <ildikov> we will have round tables in the room
20:16:21 <jungleboyj> They will all get to know each other through the exercises and breaks.
20:16:32 <jungleboyj> That is a good idea.
20:16:42 <ildikov> so we can give ten minutes to the groups to introduce themselves within those smaller groups
20:17:00 <ildikov> mentors can check where everyone is and then move to the next thing when everyone's finished
20:17:16 <ildikov> so people in the smaller groups have ideas on who they're sitting together with
20:17:22 <ildikov> can come up with a team name
20:17:24 <ildikov> etc.
20:17:40 <jungleboyj> ildikov:  ++
20:17:41 <ildikov> what do you think?
20:17:48 <diablo_rojo> Sounds like a more efficient use of time to me
20:17:52 <spotz> yeah
20:17:57 <jungleboyj> Much more effiecient.
20:18:14 <jungleboyj> More like other training sessions I have been in.
20:18:45 <jaypipes> yup, ++ from me
20:19:34 <ildikov> ok, cool, then I will get the intro slides updated with that
20:19:59 <ildikov> #action Ildiko to update the Intro slides with the introduction plans
20:20:37 <ildikov> we have a short exercise on joining IRC
20:20:54 <ildikov> I think we will keep that as is and do it after the intros
20:21:02 <ildikov> if there's no objection
20:21:30 <spotz> Sounds good
20:21:33 <diablo_rojo> No objections here
20:21:37 <ildikov> the point is to open up an extra communication channel for those who're shy to ask in front of the whole group, or speak English in written form better, etc
20:22:10 <ildikov> #info Keep joining to IRC as a first exercise after the intros
20:22:15 <jungleboyj> Yeah, that is a good starting point.
20:22:16 <spotz> ildikov: Would it be a good idea in that case to make a channel for the training or also utilize 101?
20:22:31 <ildikov> spotz: we used #openstack-101
20:22:39 <spotz> +1
20:22:43 <ildikov> spotz: we will just keep that
20:23:01 <ildikov> #info use #openstack-101 as the IRC channel during the training
20:23:28 <ildikov> we had a very short intro section in Barcelona to introduce the training and OpenStack in just a few words
20:23:42 <ildikov> to get to a common ground
20:24:11 <jungleboyj> ildikov: I think we would still want that.
20:24:26 <ildikov> jungleboyj: +1
20:24:35 <ildikov> after that we talked a little bit about Agile as we tried to find connection points between the daily work and the upstream/community work
20:24:53 <ildikov> I think this one got various feedback
20:25:00 <jaypipes> heh, I can imagine.
20:25:03 <jungleboyj> Yeah.
20:25:27 <ildikov> in my view it's still worth having something like this, but we can figure out something else if you all hate it
20:25:48 <ildikov> it was a good block to get people to discuss a topic within groups
20:27:34 <jungleboyj> ildikov:  Wonder if that could be more integrated into the small group work?
20:27:54 <jungleboyj> Don't hit them with a hammer about it but just gently tap at the idea?
20:28:21 <ildikov> as people will sit in groups, that would be a group discussion
20:28:28 <ildikov> I mean small group discussion
20:28:49 <ildikov> we can open it up to the whole group if good ideas come out of in at the tables
20:28:57 <ildikov> don't want to waste too much time with it
20:29:08 <ildikov> jaypipes: do you think it's a bad idea overall?
20:29:17 <jungleboyj> ildikov: I guess that would be a time for the small groups to get to know each other.  Who is agile, who is not?
20:29:25 <jungleboyj> What the companies are thinking.
20:30:24 <jaypipes> ildikov: no, just that agile can bring in the tangential discussions that can take a conversation sideways very quickly ;)
20:30:52 <ildikov> jaypipes: my thinking with it was to find out what parts of lean/agile we're using, what not, so people can get an idea how we operate without talking about it too much
20:31:05 <ildikov> jaypipes: oh, I see :)
20:31:05 <diablo_rojo> We try to keep the discussions short so as to avoid that :)
20:31:23 <jungleboyj> :-)
20:31:28 <ildikov> jaypipes: last time we had a few people not that familiar with Agile, so were at the basics and had a few good chats
20:31:40 <ildikov> but I'm happy to re-think this part
20:32:12 <smcginnis> I think a short section on that would be good.
20:32:17 <jaypipes> ildikov: or I can stay quiet during that part :P
20:32:26 <smcginnis> ;)
20:32:54 <jungleboyj> Keep it short.  Get talking started in the groups.
20:33:15 <ildikov> jaypipes: haha, you could share your views with this group at least if we keep this
20:33:17 <spotz> poor jaypipes:)
20:33:46 <ildikov> jaypipes: so at least we know who stands where and why you're so quiet during that part :)
20:33:52 <jungleboyj> Did I miss that it was pick on jaypipes  Day?
20:34:23 <bauzas> man, had a network issue...
20:35:37 <ildikov> should we vote on whether or not to keep this part?
20:35:39 <jaypipes> :)
20:36:00 <jaypipes> keep it, but keep it short I guess?
20:36:08 <jungleboyj> jaypipes:  ++
20:36:18 <bauzas> we can honestly cut it
20:36:44 <bauzas> at YVR, I saw my attendees looking at other things :p
20:37:15 <ildikov> bauzas: it would be mostly a discussion
20:37:27 <ildikov> bauzas: not a long presentation or anything
20:37:49 <ildikov> jaypipes: ok, cool :)
20:37:52 <smcginnis> I think in Paris we had a short overview at least.
20:38:06 <bauzas> a very small one
20:38:12 <bauzas> I was in Paris too
20:38:23 <bauzas> but meh
20:38:27 <smcginnis> I think I actually took the training from you bauzas :)
20:38:38 <ildikov> :)
20:38:48 <bauzas> I mean, we can disucss on how to work upstream vs. your team, but maybe not saying "Agile"
20:38:58 <smcginnis> Biggest point I think is to highlight whatever corporate waterfall method they may be using is not how things get done in OpenStack.
20:39:16 <bauzas> smcginnis: orly ? :p
20:39:20 <jungleboyj> smcginnis: ++
20:39:37 <ildikov> bauzas: we tried to use Agile as something many people know therefore they get a basic idea of a few things
20:39:46 <ildikov> smcginnis: +1
20:39:59 <spotz> +1
20:40:11 <blancos> smcginnis: ++ I think it's more important that they get an idea of how things work in the community
20:40:34 <bauzas> okay, then just saying that Agile is an example :)
20:40:48 <ildikov> we asked them to think about what Agile methods are out and what makes sense to use in the community and what not and why
20:41:10 <ildikov> what practices, not the whole methodology I mean
20:41:32 <bauzas> lemme review the slides
20:42:07 <ildikov> bauzas: that would be great, an update would surely be useful there
20:42:24 <ildikov> so as a summary
20:42:53 <ildikov> #info Keep the Agile part, use Agile as some sort of an example, let people discuss it. Should be a short section.
20:43:45 <ildikov> ok, let's move to the next section
20:43:48 <diablo_rojo> 17 min left heads up
20:43:55 <ildikov> diablo_rojo: tnx
20:44:05 <ildikov> we have a section on official projects
20:44:26 <bauzas> ++
20:44:31 <ildikov> we might shorten it down as people does not necessarily need to know on day one how to create a new project, etc.
20:44:59 <smcginnis> Probably better not to tell them how to start new projects.
20:45:06 <ildikov> if someone could look up what material we have on the web we can have an exercise that people find out what projects we have in the Big Tent
20:45:09 <diablo_rojo> ildikov, agreed. People do regular talks on that type of thing every summit so there isnt much need to go into detail here.
20:45:15 <jungleboyj> ildikov:  Yeah, quick intro to the projects but not how to create one.
20:45:33 <ildikov> even what Big Tent is and what they can find out about it in 10 minutes and then we clarify the main idea and move on
20:45:50 <smcginnis> ildikov: +1
20:45:54 <jungleboyj> ildikov:  +1
20:46:08 <diablo_rojo> Who wants that action?
20:46:52 <jungleboyj> I don't fully understand big tent yet.  :-)
20:47:09 <bauzas> maybe just putting them to cookiecutter and the docs ? :p
20:47:18 <ildikov> jungleboyj: then just write up the exercise in the slides and you can figure it out with your group ;)
20:47:28 <ildikov> bauzas: lol :)
20:47:42 <jungleboyj> ildikov:  :-)  Sure, I can take it if you want.  I will learn.
20:48:25 <ildikov> jungleboyj: cool :)
20:48:29 <bauzas> I mean the project contributor guide
20:48:37 <jungleboyj> Had a feeling by noting I needed to learn I would be volunteering myself.  :-)
20:48:53 <spotz> hehe
20:49:01 <ildikov> jungleboyj: cut out most of the content and start with the exercise
20:49:14 <jungleboyj> ildikov: Will do.
20:49:15 <ildikov> bauzas: got it
20:49:59 <bauzas> FWIW for the context https://docs.openstack.org/contributor-guide/project-install-guide.html
20:50:10 <ildikov> #action jungleboy looks into the Big Tent section and updates the exercise and content
20:50:33 <jungleboyj> Will do.
20:50:46 <diablo_rojo> Offical Projects section actually :)
20:51:02 <ildikov> diablo_rojo: Oooops :)
20:51:06 <jungleboyj> diablo_rojo:  I know what she meant
20:51:14 <diablo_rojo> Close enough :)
20:51:44 <ildikov> bauzas: ah ok, I know this one
20:51:58 <ildikov> ok, we have 9 minutes left
20:52:12 <ildikov> let's try to deal with the Governance section too
20:52:28 <ildikov> I have less ideas on how to keep that one interesting...
20:52:38 <ildikov> anyone has anything in mind?
20:52:59 <jungleboyj> Do we really want to cover that at the beginning?
20:53:03 <bauzas> yup
20:53:10 <bauzas> it's a very important topic IMHO
20:53:33 <diablo_rojo> I think its important too. The structure of the community helps you understand how it functions.
20:53:34 <jungleboyj> bauzas:  I suppose that is true.  Keep it short.
20:53:57 <spotz> Go over high lights, code of conduct, etc
20:53:58 <bauzas> jungleboyj: "short" can be 20 mins
20:54:05 <bauzas> not less
20:54:22 <bauzas> depending on what you wanna talk of course
20:54:28 <jungleboyj> bauzas: It is important to understand the role of TC and UC.  How people are elected, etc.
20:54:41 <bauzas> but honestly, I'd prefer to see more time for that than Agile for example :p
20:54:56 <diablo_rojo> Looking at the slides there isn't any info about the AUC's. Also..not sure that APC is a real thing- someone correct me if I am wrong.
20:55:04 <diablo_rojo> bauzas, +1
20:55:27 <jungleboyj> bauzas: Ok.  You volunteering?
20:55:32 <jungleboyj> :-)
20:55:32 <bauzas> APC is a thing for PTL elections
20:55:52 <ildikov> could we somehow get the teams structured in a way to help understanding the community structure?
20:56:03 <ildikov> I mean get a PTL for each group, etc.
20:56:24 <diablo_rojo> bauzas, huh, okay. Doesnt sound any different than ATC
20:56:27 <smcginnis> ildikov: That's not a bad idea. Do a little PTL election for each group?
20:56:27 <bauzas> jungleboyj: we already have slides describing that
20:56:36 <jungleboyj> ildikov:  Would it be silly to select a PTL, a core and use that as an example to work through the process?
20:56:48 <spotz> ildikov: I'm sure there will be PTLs at summit, but they may not be coming early enough to be at the training
20:56:53 <jungleboyj> ildikov: With people at the table ?
20:56:54 <bauzas> we did that for the lego playroles
20:56:58 <blancos> jungleboyj: I think that's a good idea. It makes the topic more interesting, I think
20:57:08 <diablo_rojo> ildikov, that would be fun
20:57:16 <smcginnis> ildikov: Are you going to bring a few cases of legos? :)
20:57:22 <bauzas> one team was the upstream one, electing a PTL and cores
20:57:31 <ildikov> I meant the election
20:57:35 <bauzas> not saying we should resurrect the lego playgame
20:57:54 <bauzas> just explaining that presenting it in a roleplay is a good idea
20:57:55 <ildikov> we can bring parts back of the lego game
20:58:01 <jungleboyj> Sounds like something to consider though?
20:58:05 <ildikov> but in a less concentrated way
20:58:06 <smcginnis> bauzas: It was entertaining, but probably not worth the hassle.
20:58:13 <bauzas> smcginnis: agreed
20:58:23 <ildikov> so take some parts and build it up during the 1.5 days
20:58:25 <bauzas> taking 2 important hours off your agenda
20:58:33 <ildikov> bauzas: +1
20:58:43 <ildikov> ok, we need to wrap up
20:58:59 <ildikov> let's think about the governance part a bit more and start with that next week
20:59:13 <jungleboyj> I think I did the Release Cycle part in BCN.  I can look through that.
20:59:21 <ildikov> jungleboyj: +1
20:59:24 <ildikov> thanks
20:59:35 <jungleboyj> ildikov: No problem.
20:59:58 <ildikov> let's try to finish the common parts next week and get to the tools and deep dives the week after the latest
21:00:02 <diablo_rojo> I made some updates to the events section removing mentions of the old format and focusing on the new.
21:00:12 <diablo_rojo> ildikov, +1
21:00:19 <ildikov> please do reviews and drop ideas to either the etherpad or Gerrit
21:00:29 <ildikov> diablo_rojo: +1, thanks
21:00:38 <ildikov> thanks everyone for today!
21:00:40 <diablo_rojo> Times up
21:00:41 <ildikov> good progress
21:00:48 <jungleboyj> Good meeting.  Thanks!
21:00:51 <ildikov> see you next week the latest! :)
21:00:52 <diablo_rojo> ildikov, Agreed :)
21:00:56 <ildikov> #endmeeting