20:00:10 <ildikov> #startmeeting openstack_upstream_institute
20:00:11 <openstack> Meeting started Mon Apr 17 20:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is ildikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:14 <openstack> The meeting name has been set to 'openstack_upstream_institute'
20:00:52 <vkmc> o/
20:00:57 <skelso> o/
20:01:43 <spotz> \o/
20:01:55 <jungleboyj> o/
20:02:21 <ildikov> hi all :)
20:02:53 <jungleboyj> Happy Monday.
20:03:01 <ildikov> let's wait a quick minute to see if we get more people
20:03:18 <marst> o/
20:03:30 <marst> sorry for being late
20:04:10 <ildikov> marst: all good, we're just warming up :)
20:04:22 <jaypipes> hola
20:04:32 <ildikov> so the agenda is here: https://etherpad.openstack.org/p/openstack-upstream-institute-meetings
20:04:48 <ildikov> #topic Announcements
20:05:06 * mlavalle slides in quietly
20:05:12 <ildikov> so the announcement this week is that we have the Summit only three weeks from now
20:05:48 <spotz> woot!
20:05:58 <vkmc> D:
20:06:09 <ildikov> please keep on looking into the content and upload more updates or just get familiar with what we have especially if you're available to join us in the classroom in Boston
20:06:16 <jungleboyj> Can't believe it is coming so quickly.
20:06:20 <ildikov> spotz: sorry to freak you out :/ :)
20:06:30 * jaypipes been working on my slides for presentations...
20:06:54 <ildikov> jaypipes: you're so early with that :)
20:07:01 <jaypipes> heh, I need to be..
20:07:19 <ildikov> jaypipes: all good, I just envy you :)
20:07:19 <spotz> I need to do my COA panel, but lunch and learn is pretty much done
20:07:22 * jungleboyj is happy to have 2 out of 3 presos mostly done.
20:07:43 <jungleboyj> I just pushed up changes for the release-cycle slides today.
20:07:54 <ildikov> as I don't have more announcements for today let's move on
20:08:01 <ildikov> #topic Open Reviews
20:08:02 <jaypipes> ildikov: do we have any notes anywhere on which trainers/helpers will talk about various things?
20:08:17 <ildikov> jaypipes: not yet
20:08:39 <jaypipes> ildikov: k. for instance, if we were to volunteer to talk about a certain area, would that help or hinder you?
20:08:45 <ildikov> jaypipes: we can either add it to the wiki or maybe an etherpad would be easier to sign up
20:09:23 <ildikov> jaypipes: so in Barcelona we had several speakers
20:09:26 <jaypipes> ildikov: whatever you prefer is cool by me :)
20:09:58 <ildikov> jaypipes: which mostly worked out well except that not everyone was familiar with the slide content, which is a bit unfortunate
20:10:02 <jungleboyj> I am happy to talk about the slides I have updated.
20:10:16 <jaypipes> ildikov: k. doing reviews on the slides should help me.
20:10:23 <jungleboyj> I also got flights set up so I will be there, hopefully, by 1 on Saturday.  :-)
20:10:40 <ildikov> jaypipes: jungleboyj: I will create an etherpad with the sections we have and send it out to the ML so people can sign up
20:10:47 <jaypipes> coolio.
20:10:48 <spotz> Yeah I can do accounts and git/gerrit
20:10:53 <jungleboyj> ildikov: ++
20:11:02 <ildikov> jungleboyj: awesome, tnx for the update
20:11:18 <jungleboyj> More to come.
20:11:28 <ildikov> open reviews are here: https://review.openstack.org/#/q/project:openstack/training-guides
20:11:42 <jungleboyj> One other quick thing before we dig into reviews ...
20:11:55 <ildikov> please take a look at them, many of these are in pretty good shape and close to be ready to get merged
20:12:37 <jungleboyj> I am going to be presenting a quick overview of the content we have right now to the team here at Lenovo.  Many of them are at the level of our students.  Going to take their input and also propose improvements based on that.
20:12:50 <ildikov> Jenkins does the publishing, so you can check the rendered version by clicking on the job and then choose upstream-training
20:12:51 <jaypipes> jungleboyj: nice.
20:13:20 <jungleboyj> jaypipes:  Yeah, obviously can't present all the content, but going to do an overview and get input.
20:13:24 <ildikov> you will be redirected to the website and can find the updated version of the section the review is for at the bottom of the page
20:13:35 <jungleboyj> ildikov: Nice, I didn't know that.
20:13:53 <ildikov> jungleboyj: sounds good, thanks!
20:14:29 <marst> ildikov: can you share the link?
20:14:31 <ildikov> does anyone has anything to add/discuss here about the open reviews?
20:15:03 <ildikov> marst: to the published build?
20:15:09 <marst> yes. if possible
20:15:13 <spotz> I just reviewed where I hadn't
20:15:21 <jungleboyj> Same here.
20:15:25 <ildikov> marst: that's per review
20:15:55 <ildikov> marst: so you need to click on "gate-training-guides-tox-doc-publish-checkbuild" under Jenkins check on the open review
20:16:00 <jungleboyj> marst:  I.E. http://docs-draft.openstack.org/33/457333/1/check/gate-training-guides-tox-doc-publish-checkbuild/0b19abd//publish-docs/upstream-training/
20:16:04 <marst> ildikov: got it, thanks!
20:16:42 <jungleboyj> That is nice.
20:16:43 <ildikov> checking the rendered version makes it easier to check the links embedded in the slides
20:17:20 <ildikov> you can also switch to presenter mode by using the letter "c" on your keyboard
20:17:21 <marst> jungleboyj: thank you!
20:17:29 <ildikov> so you can check the notes in the slides as well
20:17:52 <ildikov> ok, I think we an move on
20:18:04 <ildikov> #topic Topics
20:18:25 <ildikov> we still have a bunch of topics/sections we haven't discussed here
20:18:37 <ildikov> the first is Jenkins
20:18:52 <jungleboyj> This should be fun.  ;-)
20:18:52 <ildikov> #link https://docs.openstack.org/upstream-training/workflow-jenkins.html#1
20:19:27 <ildikov> so here I think we could talk about Zuul rather than Jenkins
20:20:03 <ildikov> and just show people how they can get to the logs
20:20:12 <jungleboyj> ildikov:  That makes sense.
20:20:16 <ildikov> and maybe describe the "recheck" mechanism
20:21:25 <ildikov> any other comments to the section?
20:21:35 <ildikov> or the ideas I listed? :)
20:22:02 <jungleboyj> What are you thinking to cover on Zuul?
20:22:35 <ildikov> mainly just the basic idea behind it and the dashboard
20:22:57 <clarkb> explaining gating is probably worthwhile
20:22:58 <jungleboyj> Cool.  Yeah, there is useful stuff there so that is good.
20:23:00 <ildikov> so some info people can find on http://status.openstack.org/zuul/
20:23:25 <ildikov> clarkb: you mean like check and gate queues for instance?
20:23:43 <jungleboyj> clarkb:  Yeah, I think describing check vs gate is more useful than what we have righ tnow.
20:23:52 <ildikov> clarkb: we are trying to figure out what's the necessary info someone would need on day one
20:24:00 <clarkb> yup
20:24:07 <clarkb> since its important to understanding how to get your code to merge
20:24:16 <jungleboyj> clarkb  ++
20:24:27 <ildikov> clarkb: sounds good, thanks for the heads up
20:25:17 <ildikov> so as a summary we want to cover basics of gating, dashboard and logs here
20:25:27 <jungleboyj> Sounds good to me.
20:25:37 <ildikov> coolio
20:25:46 <ildikov> is there anyone, who would like to take this one?
20:25:53 <jungleboyj> I think we need to change the topic then.
20:26:18 <ildikov> jungleboyj: yep, we need to do that too
20:26:27 <jungleboyj> I can take it if clarkb doesn't want to.
20:27:17 <clarkb> oh ya sorry I wasn't volunteering, just providing feedback/input :)
20:27:38 <jungleboyj> Ok.  I will take it.  :-)
20:27:45 <ildikov> jungleboyj: cool, tnx :)
20:27:53 <jungleboyj> ildikov:  Welcome.
20:28:06 <ildikov> #action jungleboyj to rename and update the Jenkins section
20:28:36 <ildikov> if nothing else the next one is the Metrics section
20:28:40 <ildikov> #link https://docs.openstack.org/upstream-training/workflow-metrics.html#1
20:29:06 <ildikov> I think we couldn't get there in Barcelona to talk about this one
20:29:47 <ildikov> the intention behind this was to show Stackalytics and get people to use it for a good purpose rather than just gaming the numbers and compete
20:30:30 <ildikov> as we have a Forum session now whether or not to kill Stackalytics, I wonder how much we want to keep it?
20:31:03 <jungleboyj> They are talking about Killing Stackalytics!?!
20:31:42 <ildikov> jungleboyj: http://forumtopics.openstack.org/cfp/details/78
20:32:07 <ildikov> regardless of the tool, what's the general feeling about this section?
20:32:39 <jungleboyj> Wow.  Interesting.
20:33:06 <jungleboyj> Ah, maybe if we are looking to cut content this is a good place to start then?
20:33:19 <marst> I'd skip it completely or mention it only briely.
20:33:23 <ildikov> jungleboyj: it can be
20:33:26 <marst> *briefly
20:34:04 <ildikov> who else is on the side of skipping it?
20:34:31 <ildikov> jaypipes: vkmc: mlavalle: spotz: skelso: ^^
20:35:09 <jungleboyj> I am ok with skipping it.  Wonder if it would be better to put something on how to find the PTL and Cores or a project and what that means.
20:35:15 <mlavalle> agree, we csn cut it, not esential for newbies
20:35:16 <jaypipes> ildikov: yeah, I don't really care about stackalytics numbers, frankly.
20:35:16 <spotz> I don't know but my stackalytics is wrong:)
20:35:27 <jungleboyj> A couple of slides on core team organization.
20:35:32 <jaypipes> ildikov: I don't use it when evaluating contributions.
20:35:55 <ildikov> jaypipes: I think one of the best things about it that it shows when someone is active so you can guess the time zone they are in
20:36:06 <jungleboyj> :-)
20:36:42 <ildikov> jaypipes: the other intention is to tell people it's not a numbers contest, so try to find the useful info like what areas people are active in and when, etc.
20:36:48 <ildikov> spotz: :)
20:37:17 <ildikov> jungleboyj: we can do the core team stuff with Gerrit for instance
20:37:36 <ildikov> jungleboyj: like seeing who can approve your patch
20:37:45 <ildikov> jungleboyj: can be too much info though
20:37:47 <jaypipes> ildikov: sure, that all makes sense.
20:38:09 <jungleboyj> ildikov: Ah, good thought.  I will maybe look at those slides and see if there is a good place to slip that in.
20:38:35 <ildikov> jungleboyj: sounds good
20:38:56 <ildikov> ok, so we're not that much in love with the metrics part in general
20:39:09 <skelso> I do think we need to help the students explain how they should be measured to their managers back home. It's always a question they'll have to answer..."how do I know you're generating value for me?"
20:39:21 <skelso> But I
20:39:40 <skelso> 'm not sure how to say that other than "Don't go overboard with Stackalytics"
20:40:13 <ildikov> skelso: good point, I had managers earlier who used those metrics in a pretty bad way... :(
20:40:53 <jungleboyj> Stackalytics for good, not evil!
20:41:15 <ildikov> jungleboyj: the toughest one!
20:41:49 <ildikov> ok, I can take this one to get updated with what skelso mentioned and ensure that it's a short one
20:41:53 <skelso> Yeah, it's the natural tendency, I think. Time is short, work is impersonal, and measurements are what matter. This kind of blends in with the "why contribute" teaching, I feel like.
20:42:12 <ildikov> #action ildikov to update the Metrics section
20:42:20 <ildikov> skelso: +1
20:42:32 <jungleboyj> Thanks for taking it ildikov .
20:42:52 <ildikov> jungleboyj: :)
20:43:06 <ildikov> next one is Guide to SetUp and Push First Patch
20:43:19 <ildikov> #link https://docs.openstack.org/upstream-training/workflow-setup-and-first-patch.html#1
20:44:12 <ildikov> I'm slightly unsure at this point how many places we have information that overlaps with this section
20:44:19 <spotz> looks pretty good, I do a few more steps but hits the basics
20:45:00 <ildikov> spotz: what would you add there?
20:45:44 <spotz> ildikov: I check out and pull master, then checkout my branch and then rebase before git review
20:45:59 <jungleboyj> I don't know that there is much that overlaps there.  I will find out more when I go through all the slides.
20:46:05 <spotz> also some projects testing is with tox
20:46:24 <jungleboyj> spotz:  Oh yeah, that is a new change
20:46:27 <ildikov> spotz: you don't necessarily want to rebase your branch every time
20:46:30 <jungleboyj> We should fix that.
20:47:01 <spotz> ildikov: It's my flow:)
20:47:09 <jungleboyj> Yeah, the unit tests page should change to tox -e py27,py35,pep8
20:47:11 <ildikov> yep, tox would be needed
20:47:26 <jungleboyj> Is there anyone that still uses run_tests ?
20:47:38 <ildikov> spotz: I do that many times too, but TBH rebase should be a separate patch set
20:47:44 <spotz> none of the projects I've contributed to:)
20:47:55 <ildikov> spotz: so you can follow the changes from one patch set to the other
20:48:10 <spotz> ildikov: good to know:)
20:49:22 <ildikov> spotz: for smaller changes it doesn't matter that much, but for bigger ones when you compare for instance the latest patch set and the previous one to see whether things got fixed, etc it can drive you crazy if there was also a rebase
20:49:43 <ildikov> ok, so basically beyond tox we are mostly ok with this one, right?
20:49:44 <jungleboyj> ildikov:  Yes!  That drives me nuts!
20:49:51 <spotz> I do little changes:)
20:49:58 <spotz> Yes
20:50:06 <jungleboyj> ildikov:  Yes.
20:50:41 <jungleboyj> And we need to educate spotz  on workflow.  ;-)
20:50:44 <ildikov> any of you want to quick fix tox?
20:50:54 <ildikov> jungleboyj: :)
20:51:05 <jungleboyj> ildikov:  Is that a hint to me?
20:51:07 <jungleboyj> I can.
20:51:10 <spotz> jungleboyj: Hey my work flow was given to me by the barbican folks!
20:51:27 <jungleboyj> spotz: Oh, that explains it.  ;-)
20:51:31 <ildikov> spotz: then we need to educate them too :)
20:51:38 <spotz> bah!
20:51:40 <ildikov> jungleboyj: tnx for taking the task :)
20:51:41 <mlavalle> lol
20:52:01 <ildikov> #action jungleboyj to update first patch slide with running tests with tox
20:52:04 <jungleboyj> ildikov: Oh did I?  You are welcome.  :-p
20:52:35 <spotz> hehehe
20:52:37 <ildikov> I though the 'I can" indicates that you did :)
20:52:42 <ildikov> jungleboyj: ^
20:53:00 <jungleboyj> ildikov:  I am just teasing you.  I will take it.
20:53:10 <ildikov> jungleboyj: lol, tnx :)
20:53:32 <ildikov> the last one for today quickly is Using Sandbox for Practice
20:53:48 <ildikov> #link https://docs.openstack.org/upstream-training/workflow-using-sandbox.html#1
20:54:08 <ildikov> so I think it's waaaay too long and we will get people braindead if we want to go through this as is
20:54:24 <ildikov> I wonder what others' view on this one is :)
20:55:17 <ildikov> also, we have 5 minutes left
20:55:49 <jungleboyj> Yikes.
20:56:19 <jungleboyj> So, in barcelona, what people really wanted to see was how to make a change in devstack and test it.
20:56:30 <ildikov> so we can have this as homework to think about along with the Closing Exercise one
20:56:48 <jungleboyj> That was at least what my group was looking for.
20:57:10 <ildikov> I think we should keep the material for the whole workflow, but not as a section for the meeting but more for use offline
20:57:15 <ildikov> jungleboyj: +1
20:57:35 <jungleboyj> ildikov:  Agreed but we have covered a lot of this material in earlier slides.
20:57:43 <ildikov> and we should go into the deep dives and figure out how to include some of the steps of this one into that part
20:57:53 <jungleboyj> ildikov:  ++
20:58:30 <ildikov> jungleboyj: that's the other part, so it's a good summary but I wouldn't use it during the training
20:58:50 <jungleboyj> ildikov:  Agreed.
20:58:56 <ildikov> ok, we can check on these next week at the beginning of the meeting
20:59:08 <ildikov> let's jump to the last item for today as a quick heads up
20:59:09 <jungleboyj> Let me think about what to do with this as I am working through other things.
20:59:24 <spotz> Links to further education:)
20:59:25 <ildikov> #topic Projects we need representation
20:59:36 <ildikov> jungleboyj: sounds good
20:59:56 <ildikov> so on the etherpad you can see the projects we need mentors/coaches from
21:00:20 <ildikov> I will add this to the wiki and see what we have coverage for already
21:00:36 <ildikov> and we can work on finding people for the rest in the upcoming three weeks
21:00:41 <jungleboyj> We are good on Cinder.
21:00:43 <ildikov> and with this we're out of time for today
21:00:49 <ildikov> thanks everyone!
21:00:52 <jungleboyj> I will reach out to Manila and Swift in this week's meetings.
21:01:01 <marst> ildikov: thank you!
21:01:05 <ildikov> let's catch up on the channel if there's anything more for today
21:01:09 <ildikov> #endmeeting