15:01:29 <jasondotstar> #startmeeting openstack-vahana
15:01:30 <openstack> Meeting started Wed Dec  2 15:01:29 2015 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:33 <openstack> The meeting name has been set to 'openstack_vahana'
15:01:37 <Ng> .o/
15:01:43 <jasondotstar> o/
15:01:52 <jasondotstar> #topic Introduction
15:02:21 <jasondotstar> This week is our 2nd meeting for the openstack-vahana project
15:02:39 <jasondotstar> #info The OpenStack Vahana project is an attempt to re-ignite the OpenStack iOS Client project
15:03:12 <jasondotstar> we've got an etherpad where we are collecting thoughts around the project
15:03:29 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-mobile-ios-brainstorm
15:04:09 <jasondotstar> obvs if you've any ideas or feedback to add it's encouraged to add them there
15:04:12 <jasondotstar> also....
15:04:28 <jasondotstar> interested parties are encouraged to join the #openstack-vahana IRC channel
15:05:19 <jasondotstar> again, this has been an effort constructed since summit, so we're at the *very* early stages of establishing this
15:05:29 <jasondotstar> Ng: anything to add?
15:05:39 <Ng> nope!
15:06:03 <jasondotstar> cool.
15:06:05 <jasondotstar> moving on....
15:06:15 <jasondotstar> #topic Action Items from Last Meeting
15:06:57 <jasondotstar> first up
15:07:02 * jasondotstar someone to loop in UX folk - updates?
15:07:18 <jasondotstar> i think the premise here
15:07:26 <jasondotstar> was to keep the api devs in api land
15:07:43 <jasondotstar> and not have us worry about design related tasks
15:07:56 <jasondotstar> i know for me, they wouldn't be that great :-)
15:08:15 <jasondotstar> Ng: you have contacts w/ the UX folk?
15:08:32 <Ng> jasondotstar: none directly, but I think I can make indirect contact
15:09:06 <jasondotstar> cool. you want to try and stir one of them up? see if we can get somebody to give us a few cycles to think about this?
15:09:24 <Ng> sure thing
15:09:48 <jasondotstar> #action Ng to make contact with the UX team
15:09:55 <jasondotstar> awesome, thx
15:10:11 <jasondotstar> next up
15:10:32 * jasondotstar someone to figure out who we should talk to about identifying specific use cases
15:10:49 <Ng> this one I don't think I have anything for
15:10:59 <jasondotstar> ok....
15:11:04 <jasondotstar> perhaps someone in -infra
15:11:13 <jasondotstar> we can talk to
15:11:21 <jasondotstar> I can touch base with someone there
15:11:31 <jasondotstar> and we can talk to a horizon team member as well
15:11:35 <jasondotstar> I can tackle that one
15:11:54 <jasondotstar> anyone else who may be good?
15:12:13 <jasondotstar> if not I'll add it to my list.
15:12:45 <jasondotstar> #action jasondotstar to make contact with either the infra team or the horizon team to identify use cases
15:13:14 <jasondotstar> ok, next up
15:13:28 * jasondotstar someone to start talking to large/public OpenStack installs for testing and use-case-gathering
15:13:50 <jasondotstar> we need a testbed besides devstack
15:14:13 <jasondotstar> *maybe* there's a racker we can hit up?
15:14:26 <Ng> there's still a few more weeks of HP Cloud :D
15:14:31 <jasondotstar> ah!
15:14:33 <jasondotstar> true
15:14:52 <jasondotstar> well then, that give us the next 30-45days
15:15:13 <jasondotstar> #agreed HP Public Cloud is available to us for the next 30-45 days for testing purposes
15:15:30 <jasondotstar> beyond that, we'll have to figure out something
15:16:52 <jasondotstar> so, I'm thinking we should try to talk to Rackspace (or someone similar) and see if we can figure something out
15:17:13 <jasondotstar> educate me here.... I'm sure there are other teams
15:17:25 <jasondotstar> that test stuff in public cloud deployments
15:17:42 <Ng> well Infra gets to test stuff in lots of public cloud places
15:17:49 <jasondotstar> wonder if we can figure out which teams are doing so, and see if we can get some insight on who they're using?
15:17:55 <jasondotstar> ack.
15:18:02 <jasondotstar> I'll talk to infra about it
15:18:05 <Ng> most other teams are doing their testing indirectly through infra
15:18:24 <jasondotstar> #action jasondotstar to chat with -infra about public cloud API testing environment(s)
15:18:41 <jasondotstar> Ng: +1
15:19:01 <jasondotstar> that finishes out the items from the last meeting
15:19:08 <jasondotstar> anything else to add?
15:19:59 <Ng> I have nothing, I've had very little time for vahana this week :(
15:19:59 <jasondotstar> ok, moving on
15:20:21 <jasondotstar> i hear ya.  last week was a bit of a wash
15:20:26 <jasondotstar> with the US holiday and all
15:20:41 <jasondotstar> but it's good to get into a healthy rhythm
15:20:47 <jasondotstar> (typo?)
15:20:48 <Ng> yup!
15:20:49 <jasondotstar> lol
15:21:12 <jasondotstar> #topic Additional Goals and Use Cases
15:21:46 <jasondotstar> so we've got questions that we're posting up on the etherpad
15:21:58 <jasondotstar> in some cases, we're starting to answer them
15:22:04 <jasondotstar> as well as question the questions :-)
15:22:17 <jasondotstar> i have a personal goal of adding more items to the feature list
15:23:27 <jasondotstar> nothing sticks out as notable atm
15:23:47 <jasondotstar> regarding additions to the questions list
15:23:59 <jasondotstar> but the feature list could use some love
15:24:15 <jasondotstar> however
15:24:23 <jasondotstar> that totally depends on the direction we take
15:24:36 <jasondotstar> are we building a mobile app
15:24:40 <jasondotstar> or a set of libraries
15:24:53 <Ng> I wonder if we should have some short term goals to get us thinking in the right directions
15:25:03 <jasondotstar> the END goal could be either or
15:25:06 <Ng> like I guess the first thing we have to have is the ability to authenticate with Keystone
15:25:15 <jasondotstar> +1
15:25:30 <jasondotstar> that makes ALOT of sense
15:25:41 <jasondotstar> let's put together a list of short term goals
15:25:47 <jasondotstar> things to try out
15:25:49 <jasondotstar> small wins
15:26:38 <jasondotstar> #agreed we should have a list of short-term goals to get the project progressing in the right direction
15:26:44 <Ng> from there I guess the next step might be a very bare bones Compute class that can get a list of VMs from Nova
15:27:24 <jasondotstar> #action come up with a list of short-term MVP goals
15:28:04 <jasondotstar> Ng: +1
15:28:27 <jasondotstar> let's carve out a section of the etherpad
15:28:36 <jasondotstar> and add the goals there
15:28:49 <jasondotstar> then that way for each meeting we can go through that list
15:28:59 <jasondotstar> see where we are and what shakes out
15:29:54 <jasondotstar> any more thoughts on that?
15:30:06 <Ng> nope
15:30:14 <jasondotstar> if not we'll keep the train moving...
15:30:32 <jasondotstar> cool!
15:30:38 <jasondotstar> #topic Current R&D
15:31:21 <jasondotstar> so I got Alamofire working in a Playground
15:31:23 <jasondotstar> w00t!
15:31:25 <Ng> woot
15:31:34 <Ng> nothing particularly relevant to report here :/
15:31:38 <jasondotstar> other than that, haven't had much time to do anything else
15:31:58 <jasondotstar> ok cool. we'll keep this section short this week.
15:32:11 <jasondotstar> last topic
15:32:20 <jasondotstar> #topic Q&A
15:32:30 <jasondotstar> floor is open
15:33:06 <Ng> we should maybe get ourselves a git repo somewhere
15:33:18 <jasondotstar> you know
15:33:24 <jasondotstar> i started a git project
15:33:29 <jasondotstar> and a launchpad project
15:33:38 <jasondotstar> but i think it was a bit premature to do it
15:33:47 <jasondotstar> so I'll probably scrap them
15:33:55 <jasondotstar> s/git/github
15:34:29 <jasondotstar> i do think that if we're to be agile about this
15:34:36 <jasondotstar> we should be coding sooner than later.
15:36:32 <jasondotstar> #action look into what we need to setup a project repositiory
15:36:51 <jasondotstar> s/repositiory/repository
15:37:09 <jasondotstar> any other thoughts? ideas? questions?
15:37:22 <jasondotstar> (short meeting this week I guess....)
15:38:20 <jasondotstar> if nothing else, we can end the meeting here, give about 20mins back to the channel
15:38:31 <jasondotstar> Ng++
15:39:25 <jasondotstar> going once? twice?
15:39:39 <jasondotstar> ok thanks all for attending. chat next week.
15:39:42 <jasondotstar> #endmeeting