19:01:12 <dtroyer> #startmeeting OpenStackClient
19:01:13 <openstack> Meeting started Thu Apr  2 19:01:12 2015 UTC and is due to finish in 60 minutes.  The chair is dtroyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:17 <openstack> The meeting name has been set to 'openstackclient'
19:01:33 <dtroyer> Hey all, thanks for coming
19:01:56 <dtroyer> first off, stevemar, you didn't end up starting a meeting last week?
19:02:03 <stevemar> dtroyer, correct
19:02:15 <dtroyer> ok, cool.  I kept forgetting to ask
19:02:16 <stevemar> no one showed in the first 5-10
19:02:30 <stevemar> lhcheng, showed up later, but by then i canned it
19:03:43 <dtroyer> I did put up an agenda this morning:  https://wiki.openstack.org/wiki/Meetings/OpenStackClient#02_Apr_2015
19:03:53 <dtroyer> let me know if there is something to add and we'll get it in
19:04:50 <stevemar> sigmavirus24, courtesy ping
19:04:59 <sigmavirus24> Thanks stevemar :D
19:05:14 <dtroyer> sigmavirus24: want to be added to The List?
19:05:21 <stevemar> "The List"
19:05:25 <sigmavirus24> that sounds ominous, but sure
19:05:51 <dtroyer> no more ominous than your nic ;)
19:05:58 <sigmavirus24> =D
19:06:09 <dtroyer> #topic open actions
19:06:11 <sigmavirus24> All the previous (alpha, beta, gamma, etc.) viruses failed
19:06:12 <sigmavirus24> =P
19:06:12 <stevemar> dtroyer, i don't recall signing up for moving fakes to fixtures :P
19:06:31 <dtroyer> I thought you were just going to write up a bp?
19:06:55 <stevemar> i don't recall having a convo with you about this
19:07:17 <dtroyer> last meeting…my bad then, I'll change that
19:07:42 <stevemar> we can chat about it, is there a dire need to use fixtures instead?
19:08:13 <dtroyer> IIRC it was around having something stable for plugins to use for testing.  not dire, but would be useful.
19:08:39 <stevemar> ohhh
19:08:59 <stevemar> hmm, so other libs can use one of our fixtures
19:09:05 <stevemar> yah, i totally forgot about that
19:09:20 <dtroyer> right
19:09:39 <stevemar> that needs to be fleshed out more, i don't know enough about fixtures or plugins to create a bp
19:10:20 <dtroyer> I'm weak on the fixtures part but can learn.
19:10:32 <stevemar> if we have extra time during the summit, i wouldn't mind chatting about it; but it's not super high on my priority list
19:10:53 <dtroyer> #info talk about fixtures and plugins at summit
19:11:01 <dtroyer> sounds good to me
19:11:44 <dtroyer> on the JSON BP, no action occurred
19:12:14 <dtroyer> #action dtroyer carry forward JSON input BP
19:12:30 <stevemar> is that someone we want to do though?
19:12:40 <stevemar> seems like we'll open a new can of worms
19:12:51 <stevemar> expectations, flow, etc
19:12:52 <dtroyer> low priority but I can see where it would be useful
19:13:22 <dtroyer> I'd rather have a BP with an outline than lose it altogether
19:13:29 <stevemar> fair enough
19:13:54 <stevemar> next
19:14:01 <dtroyer> on the timing in the bug:  https://bugs.launchpad.net/python-openstackclient/+bug/1431649
19:14:02 <openstack> Launchpad bug 1431649 in python-keystoneclient "openstackclient is really slow" [Undecided,In progress] - Assigned to Robert Collins (lifeless)
19:14:24 <dtroyer> I did a boatload of import timings, very unscientific-like, but didn't add any to the bug itself
19:14:55 <dtroyer> and heard about https://github.com/boris-42/profimp this morning, which might be more useful if we persue this further
19:15:42 <dtroyer> talking to jogo last week I think we've concluded that this is a small return for the time spent as far as that specific bug goes, but I think OSC needs to look at this and see what we can improve anyway
19:16:59 <stevemar> dtroyer, referring to timing or speeding up OSC?
19:17:23 <dtroyer> the end result of shortening our load times
19:17:35 <terrylhowe> seems lik ksc reading versions would be the most likely slowdown
19:17:45 <terrylhowe> that could be saved at least
19:18:03 <dtroyer> that is a big part of it, I didn't break that down too much, but —timing lets you see how much of those were the actual REST round-trip
19:18:20 <jogo> dtroyer: so profimp may not help. if foo and bar  both import zed
19:18:23 <jogo> and zed is slow
19:18:52 <jogo> if you do 'import foo; import bar' you get very different results when compared to 'import bar; import foo'
19:19:19 <dtroyer> possibly.  I'm just looking for something better than me doing log output (which is also slow) with timestamps…
19:19:51 <dtroyer> jogo: regarding that bug, you ok with dropping it to low or wishlist for now?
19:20:05 <jogo> dtroyer: sure
19:20:14 <jogo> dtroyer: there are a few ways to generate timing graphs
19:20:16 <jogo> forgot how though
19:20:27 <dtroyer> I just did ;)
19:21:15 <dtroyer> last action was for me to check on ML tags and IIRC that happened right after the meeting.
19:21:25 <jogo> https://pypi.python.org/pypi/bprofile/1.3.1 is one
19:22:27 <stevemar> dtroyer, yep, reed created the tag for us
19:22:47 <dtroyer> stevemar: Was it OpenStackClient or OSC?
19:23:37 <stevemar> OSC
19:23:56 <stevemar> .*\[Osc\].*| .*\[OSC\].*| .*\[osc\].*
19:24:07 <dtroyer> cool
19:24:19 <stevemar> openstackclient was too many letters anyway
19:24:34 <dtroyer> who came up with that name anyway???
19:24:50 <dtroyer> #topic summit sessions
19:25:11 <stevemar> oh nice topic
19:25:24 <dtroyer> There are two types of design summit sessions, I'll let y'all read ttx's emails about that
19:25:36 <dtroyer> I asked for one of eash: fishbowl and work session
19:25:53 <dtroyer> not really knowing what we need to talk about.
19:26:07 <dtroyer> so that's the second thing, set up the etherpad to discuss
19:26:56 <dtroyer> #link https://etherpad.openstack.org/p/liberty-osc-summit-topics
19:27:41 <dtroyer> The question I have is do we think we'll need the large room for an audience, and if so, what would it target topic-wise?
19:27:58 <sigmavirus24> dtroyer: good question
19:28:11 <stevemar> let topics be proposed on the etherpad
19:28:17 <stevemar> pick the most popular topics
19:29:08 <dtroyer> ok…I stated that question there too
19:30:11 <dtroyer> I think if we want to add more sessions we need to do it Real Soon.  Like last week even while I was away
19:31:05 <stevemar> ttx's email: http://lists.openstack.org/pipermail/openstack-dev/2015-January/054122.html
19:31:25 <stevemar> i think 1 fishbowl might be a bit light
19:32:02 <stevemar> every time there OSC gets a space we end up getting full and running out of time for topics
19:32:10 <stevemar> i'd push for another if possible
19:33:13 <dtroyer> topics?  last time we did that kind of session we had two but we included SDK stuff too…and at that point there were 3 or 4 of those to talk about
19:33:15 <stevemar> how long do we have a working session space for? 40 minutes?
19:33:41 <dtroyer> unsure, some of those are half day…dang I'm not sure what the default is
19:34:00 <dtroyer> which is bad because I like having defaults
19:34:11 <stevemar> i imagine the fishbowl sessions are 40 mins, in which case i'd go for 2.
19:34:21 <stevemar> if the working group is a half day, we are fine with 1.
19:34:58 <dtroyer> I'd like to have an idea of the topics we want to cover for 2 sessions.
19:36:06 <dtroyer> we didn't do one in Paris, and I think going to other project client sessions was productive.  that could negate some of our need
19:36:20 * stevemar copies like of bps to etherpad
19:36:23 <stevemar> list*
19:38:03 <stevemar> i'd really like to cover the following: 1) caching tokens, 2) os-cloud-config, and 3) buy in from other projects (and whats stopping them)
19:38:36 <terrylhowe> ehterpad stevemar ?
19:38:54 <terrylhowe> those are all good topics
19:39:21 <stevemar> yeah, adding those now, i'm trying to do too many things at once (as usual) and failing on most (as usual)
19:39:28 <dtroyer> I do expect os-client-config to be released by then and that would be educational rather than feature driven, no?
19:39:49 <stevemar> maybe, the summit is closer than ya think
19:40:11 <dtroyer> that particular review is listed in the next topic for a reason…
19:41:09 <stevemar> what about dot files that are in the users home directory that contain credentials
19:41:25 <stevemar> or is that crossing into occ territory
19:41:27 <sigmavirus24> stevemar: like ".openrc"?
19:41:32 <dtroyer> that's one of the things that —os-cloud does
19:41:52 <stevemar> sigmavirus24, yep, like that. but as dtroyer says ^
19:43:18 <dtroyer> ok, let's keep that going in the etherpad and move on here
19:43:28 <dtroyer> #topic review reviews
19:43:37 <dtroyer> since the review for —os-cloud is next anyway
19:43:47 <dtroyer> #link https://review.openstack.org/129795
19:44:07 <dtroyer> It's been up for a while and I've been using it, anyone else tried it yet?
19:44:38 <terrylhowe> not since patch 9
19:44:39 <patchbot> terrylhowe: https://review.openstack.org/#/c/9/
19:44:40 <stevemar> i have not had the time to play around with it yet
19:44:41 <dtroyer> as I said a bit ago, I would really like to get it merged so we have some time with it before the next release, which should be a minor rev anyway
19:45:40 <lhcheng> haven't tried it yet, will add to my to-do list
19:46:01 <stevemar> we need to doc how to use --os-cloud :P
19:46:18 <dtroyer> thanks, I'd appreciate it.  I'm afraid that there are usage patterns that I haven't thought about yet…
19:46:20 <stevemar> look at that, its a follow on patch!
19:46:31 * dtroyer throws darts at stevemar
19:46:43 * stevemar ouch!
19:46:46 <dtroyer> nerf darts cause that's all they'll let me have now
19:47:02 <dtroyer> any other reviews that need the groups attention?
19:47:58 <stevemar> this one is interesting: https://review.openstack.org/#/c/161097/
19:49:31 <dtroyer> yeah, I need to look at that closer in the occ context, I think there is some overlap and jamie wants to do more of the option handling that I'd like.
19:49:49 <stevemar> dtroyer, you can re-review this one: https://review.openstack.org/#/c/158779/ the requirement should be updated now
19:50:28 <dtroyer> ah, right, I promised to look at that last night before the yesterday afternoon happened
19:50:53 <stevemar> no biggie
19:51:42 <stevemar> also, there was a patch for heat stack CRUD a while back
19:51:45 <dtroyer> I think https://review.openstack.org/#/c/166373/ should be straightforward
19:52:05 <dtroyer> I'd like heat to be in a plugin
19:52:08 <stevemar> do we want to draw a line in the sand stating that we won't support Heat
19:52:20 <stevemar> err support them as a plugin*
19:52:51 <stevemar> might be worth stating that in the patch, and giving them set of steps to plug into us
19:53:03 <dtroyer> my working line has been to only consider layer 1 and maybe 2 services as built-ins
19:53:32 <dtroyer> stevemar: yup.  I should also get the plugin template out of my github and into stackforge
19:53:51 <stevemar> ye
19:53:52 <stevemar> yep
19:54:04 <dtroyer> ok, seven minute warning…
19:54:10 <stevemar> 6!
19:54:12 <dtroyer> #topic bug review
19:54:26 <dtroyer> stevemar: I noticed Canada seems to be a minute ahead
19:54:42 <terrylhowe> are plugins going to fall under OSC?
19:54:45 <stevemar> the few patches related to identity / service providers has to wait until another KSC is made
19:54:55 <stevemar> KSC release*
19:55:04 <dtroyer> terrylhowe: good question.
19:55:23 <stevemar> will the plugins be like ... openstack/heat-osc-plugin
19:55:26 <terrylhowe> it might be useful to help people build their plugins at least
19:55:38 <stevemar> we could provide a cookie cutter
19:55:42 <dtroyer> my default answer is that project might want to keep the plugin bits with their client lib (ala congress) but if they go to the sdk then maybe separate repos.
19:56:22 <dtroyer> stevemar: ah, that's what osc-plugin should become.  I'll retroactively say that's why haven't put it into stackforge uet ;)
19:56:51 <stevemar> dtroyer, what about projects that already have an existing CLI
19:56:59 <stevemar> like ceilometer or heat
19:57:27 <dtroyer> I'd still put it with their lib
19:57:33 <stevemar> muddying up python-heatclient with their own CLI and an OSC plugin might be overkill
19:57:38 <stevemar> hmm okay
19:57:41 <terrylhowe> it would be nice if osc-plugin was at least stackfoge
19:57:43 <dtroyer> CLI or not I think that's the best place for it
19:57:59 <dtroyer> really, its their call
19:58:02 <stevemar> how would the plugins get installed after
19:58:18 <dtroyer> pip install joe-plugin
19:58:27 <dtroyer> yum install joe-plugin
19:58:46 <dtroyer> whatever.  the plugin might want a dep on osc, but I'm not sure if that's a good idea or not
19:59:20 <stevemar> so assume heatclient starts creating their own osc directory that is a plugin. if i did pip install osc, then pip install python-heatclient, i'd get both osc and the plugin?
19:59:36 <lhcheng> 1 minute left
19:59:41 <dtroyer> right.  that's how congressclient works today
19:59:51 <dtroyer> #open discussion
19:59:59 <stevemar> okay, maybe we have to communicate that better :)
20:00:10 <stevemar> call out examples and such
20:00:49 <dtroyer> ok, we're out of time
20:00:51 <dtroyer> later…
20:00:54 <dtroyer> #endmeeting