19:02:30 <dtroyer> #startmeeting OpenStackclient
19:02:31 <openstack> Meeting started Thu Apr 23 19:02:30 2015 UTC and is due to finish in 60 minutes.  The chair is dtroyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:34 <openstack> The meeting name has been set to 'openstackclient'
19:02:44 <briancurtin> i'm sort of here
19:02:59 <dtroyer> Good afternoon all… agenda: https://wiki.openstack.org/wiki/Meetings/OpenStackClient#23_Apr_2015
19:03:16 <dtroyer> not a heavy one, hopefully interesting though
19:03:57 <sigmavirus24> ohai
19:03:58 <dtroyer> #topic open actions
19:04:19 <dtroyer> there were two from two meeting ago, stevemar has them both…
19:04:31 <dtroyer> translate bug 1406470 to a dev docs entry
19:04:31 <openstack> bug 1406470 in python-openstackclient "track backwards incompatible changes" [High,Confirmed] https://launchpad.net/bugs/1406470
19:05:56 <stevemar> they are still TODOs on my end :\
19:06:02 <dtroyer> both?
19:06:26 <stevemar> yeah
19:06:56 <dtroyer> #action stevemar (carry forward) translate bug 1406470 to a dev docs entry
19:06:56 <openstack> bug 1406470 in python-openstackclient "track backwards incompatible changes" [High,Confirmed] https://launchpad.net/bugs/1406470
19:07:34 <dtroyer> er, those ere dupes actually, there is just one
19:07:47 <dtroyer> #topic Releases
19:08:11 <sigmavirus24> dtroyer: if you carried both forward, then stevemar would be twice as productive
19:08:17 <stevemar> qq about the latest release
19:08:22 <dtroyer> On Tuesday dhellmann releases 1.1.0 as part of the minor bump for all client & libs for Liberty
19:08:33 <dtroyer> s/releases/released/
19:09:02 <stevemar> dtroyer, related.. with that done now, i think this will go through: https://review.openstack.org/#/c/168187/
19:09:06 <dtroyer> however, it went out with no release notes, etc, so the plan is to do 1.1.1 soon with the docs
19:09:11 <dhellmann> yeah, we needed to release all lib-like things that had capped requirements so we could uncap the requirements
19:09:26 * dhellmann apologizes again for the rush on that
19:09:41 <dtroyer> np, this was an odd week all around
19:09:59 <dhellmann> yep, just stating it for the record :-)
19:10:13 <dtroyer> stevemar: remind me what is blocked on that?
19:10:38 <stevemar> dtroyer, this one: https://review.openstack.org/#/c/168562/
19:10:56 <stevemar> err... this one: https://review.openstack.org/#/c/165755/11
19:11:10 <stevemar> bad copy pasting this week
19:11:14 <dhellmann> I think we'll be approving some requirements updates after we have the sync jobs turned back on
19:11:29 <stevemar> dhellmann, okay, when do you figure that is?
19:11:38 <dtroyer> stevemar: should we wait on this for 1.1.1?
19:11:50 <dhellmann> stevemar: that job is in the queue right now, but if failed on a large-ops test so I'm running it a second time
19:11:50 <stevemar> dtroyer, thats what i was alluding to
19:11:59 <dhellmann> #link https://review.openstack.org/#/c/174447/1
19:12:01 <dtroyer> other way around, wait on 1.1.1 for 165755?
19:12:03 <dtroyer> ok
19:12:30 <stevemar> dtroyer, i think it's worth waiting til the patch is in before 1.1.1 is released
19:12:33 <stevemar> if you'd be so kind
19:12:36 <dtroyer> so it sounds like this should all be cleared early next week
19:12:38 <dtroyer> np
19:13:10 <dtroyer> #agreed hold 1.1.1 release until https://review.openstack.org/#/c/165755/11 merges
19:13:23 <dtroyer> note for me to make sure it's in the milestone later
19:13:36 <stevemar> which in turn depends on a global ksc bump
19:13:59 <dhellmann> a new feature would technically make that 1.2.0
19:14:25 <dtroyer> it would
19:14:38 <stevemar> i suppose it would
19:14:42 <dtroyer> so I'll just say m10 release then ;)
19:14:45 <dhellmann> heh
19:15:17 <dtroyer> while requirements are on my mind, both osc and cliff have stable/kilo requirements updates
19:15:24 <dtroyer> dhellmann: safe to merge those?
19:15:29 <dhellmann> dtroyer: links?
19:15:42 <dtroyer> cliff: https://review.openstack.org/173812
19:15:53 <dtroyer> osc: https://review.openstack.org/#/c/174341/
19:16:19 <dhellmann> dtroyer: let's hold off. I'll chat with ttx and sdague about how we want to handle caps in dependencies of libs
19:16:37 <dtroyer> I'm guessing merging is safe, it's the stable release that needs to be careful?
19:16:45 <dtroyer> ok, np.  I'll admin -2 them for now then
19:17:36 <dhellmann> k
19:18:48 <dhellmann> technically the cliff change will require a min version bump of cliff, which would put it outside of the stable release series
19:19:05 <dhellmann> the osc one introduces caps, which might be ok
19:19:52 <dtroyer> so how do we handle minor bumps in stable?
19:20:05 <dhellmann> we don't -- that's the point of having the stable branch
19:20:14 <dtroyer> I thought that was supposed to be a unicorn?
19:20:17 <dtroyer> ok, right
19:21:16 <dtroyer> to wrap up the next release, m10, I've targeted what is in progress and completed in https://launchpad.net/python-openstackclient/+milestone/m10
19:22:40 <dtroyer> other than what stevemar mentioned I don't think the remaining in progress bugs are release blocking, if they're complete they'll go in
19:22:54 <dtroyer> anything else we should wait on?
19:23:24 <dhellmann> seems ok to me
19:24:40 <dtroyer> I did have one question on https://bugs.launchpad.net/python-openstackclient/+bug/1443089 that was still on m9
19:24:40 <openstack> Launchpad bug 1443089 in python-openstackclient "image list displays a maximum of 25 images" [High,Confirmed]
19:24:50 <dtroyer> did https://review.openstack.org/#/c/173420/ fix that?
19:25:13 <dtroyer> stevemar, terrylhowe?
19:25:22 <terrylhowe> it does for me
19:25:44 <terrylhowe> etoews: reported not sure if he has looked at it
19:26:07 <dtroyer> shall I hold off on closing it?  the patch is merged
19:26:13 <stevemar> dtroyer, i tried it, worked
19:26:18 <stevemar> close it up
19:26:24 <dtroyer> roger that
19:27:16 <dtroyer> so I went out of order, that was in
19:27:19 <dtroyer> #topic bugs
19:27:23 <etoews> i trust y'all
19:27:27 <dtroyer> any others while were there?
19:27:51 <etoews> plus, if there's still an issue i can always report another bug. ;)
19:28:18 <dtroyer> please do, we have a ways to go to catch up to Nova
19:29:00 <dtroyer> ok, if there are no other bugs that need to be brought up…
19:29:53 <dtroyer> #topic Vancouver Summit planning
19:30:06 <dtroyer> the etherpad is at https://etherpad.openstack.org/p/osc-liberty-summit-planning
19:30:36 <dtroyer> I've added a couple of things…let's plan to do a bit more discussion next week
19:30:45 <stevemar> oh theres actually stuff there
19:31:00 <dtroyer> I think the session schedule will be firmed up by then
19:31:12 <dtroyer> I'm mostly worried about conflicts there
19:31:51 <dtroyer> next week we can sort what is a fishbowl and what is a working session
19:33:07 <dtroyer> There is a proposed session for cross-project that wants to include OSC
19:33:17 <dtroyer> https://docs.google.com/spreadsheets/d/1vCTZBJKCMZ2xBhglnuK3ciKo3E8UMFo5S5lmIAYMCSE/edit#gid=827503418 line 19
19:33:56 <dtroyer> and for completeness, also an SDK proposal of line 14
19:34:49 <dtroyer> anything else about Vancouver?
19:34:59 <dtroyer> besides me getting a hotel within two blocks for the first time in two years?
19:36:05 <dtroyer> #topic open discussion
19:36:19 <dhellmann> dtroyer: congrats on the hotel! :-)
19:36:37 <dtroyer> thank Intel ;)
19:36:43 <dtroyer> so, just curious, am I going too fast in these meetings?
19:36:56 <dhellmann> I think you're moving at a good pace
19:37:00 <terrylhowe> yeh, everything was booked close by
19:37:08 <terrylhowe> yeh, pace is fien
19:37:12 <stevemar> no, pace is good, i'm just distracted
19:37:13 <clarkb> dtroyer: earlier today you mentioned that osc can do the swift keystoen danc e properly for rax. But you said its not meant to be used as a lib
19:37:16 <dhellmann> it sounded like several of us have multiple things going on at once today
19:37:35 <stevemar> dhellmann, yeah
19:37:46 <clarkb> dtroyer: our goal with shade was to stop rewriting those workarounds everywhere. I take it that you would prefer osc to not be used for that?
19:37:56 <clarkb> dhellmann: and instead focus on console interaction?
19:38:02 <clarkb> er dtroyer ^
19:38:07 <dtroyer> clarkb: ideally not, I don't want to repeat the cli/lib mess
19:38:16 <clarkb> ok
19:38:35 <dtroyer> but yeah, the ClientManager handles all of the client juggling and forces them all to use ksc's auth plugins
19:38:57 <clarkb> dtroyer: does it determine the correct tenant id for swift which is different than the one for nova on rax?
19:39:09 <clarkb> dtroyer: ^ that specifically is the workaround I have in mind
19:39:19 <stevemar> dtroyer, we still ended up writing our own apis and not pulling in swiftclient :\
19:39:20 <clarkb> also if anyone works at rax it would be awesome to fix that
19:39:47 <terrylhowe> raxers are just lurking
19:39:51 <dtroyer> is there specialness for swift/rax?
19:39:55 <clarkb> dtroyer: yes
19:40:04 <dtroyer> I don't think we do that specifc bit then
19:40:05 <clarkb> dtroyer: you are given two tenants for swift and nova
19:40:20 <clarkb> this is completely undocumented and the first time you try to use swift its full of wtf
19:40:20 <dtroyer> earlier I was just referring to the general client lib wrangling
19:40:23 <clarkb> dtroyer: gotcha
19:40:50 <dtroyer> it would be easier to add to osc though as all of our obejct store code is internal as stevemar said
19:40:58 <dtroyer> but that doesn't help shade
19:41:13 <dtroyer> unless we split this out…then we have another sdk.
19:41:21 <clarkb> nah I think shade can handle the crazy
19:41:26 <dtroyer> and we've looped back aound again
19:41:30 <dtroyer> ok
19:41:43 <clarkb> it started life as "well for rax we have to do this and for hpcloud we do that and now we have copied this code everywhere lets just make it a lib"
19:42:16 <dtroyer> if nothing else, if we can write this stuff so a (cover your ears dhellmann) copy-n-paste would be simple
19:42:48 <dhellmann> dtroyer: I find that a perfectly appropriate way of operating in some cases :-)
19:42:56 * dhellmann long live oslo-incubator!
19:44:11 <dtroyer> so that was quick, anything else?  I'm sure I missed something
19:44:41 <dhellmann> I hope I am able to participate in more OSC sessions at this summit
19:45:49 <dtroyer> that would be great…  we have Thursday just before and after lunch, then Friday morning
19:46:34 <dhellmann> looks like there are oslo and infra overlaps in some of those times, but I'll see what I can do
19:47:18 <dtroyer> that's the morning one, the fishbowl
19:48:24 <dhellmann> k
19:48:40 <dhellmann> most of thursday seems to have oslo sessions, but I should be able to step out of some of them
19:49:06 <dtroyer> actually, there's one immediately before us in the fishbowl
19:49:40 <dtroyer> okh, there is overlap with the afternoon too, i missed that
19:49:55 <dhellmann> yeah, we have a couple of work sessions it looks like
19:50:17 <dtroyer> anyway, if there is nothing else, we'll get 10 minutes back
19:50:22 <dhellmann> ++
19:50:40 <terrylhowe> sounds good
19:51:02 <dtroyer> ok, thanks everyone, spend your free time wisely!
19:51:08 <dtroyer> #endmeeting