19:07:20 <stevemar> #startmeeting openstackclient
19:07:21 <openstack> Meeting started Thu Aug  6 19:07:20 2015 UTC and is due to finish in 60 minutes.  The chair is stevemar. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:07:24 <openstack> The meeting name has been set to 'openstackclient'
19:07:32 <stevemar> #link https://wiki.openstack.org/wiki/Meetings/OpenStackClient
19:07:35 <terrylhowe> o/
19:08:23 <lhcheng> o/
19:08:28 <dolphm> \o/
19:08:36 <stevemar> terrylhowe: chat about what we want 1.6.0 to look like and work our way backward?
19:08:46 <terrylhowe> sure
19:09:05 <stevemar> for sure, i want the rest of the volume commands in
19:09:26 <stevemar> jiaxi and heha are working on a patch each
19:09:58 <stevemar> https://review.openstack.org/#/c/204364/ and https://review.openstack.org/#/c/204325/
19:10:25 <stevemar> and i think at that point, we're parity with volume v1 and v2 - or pretty darn close anyway
19:12:02 <terrylhowe> should we wait for those two? might be a while.
19:12:28 <stevemar> they are fairly straightforward
19:12:42 <stevemar> i'll do the list one if you do the set/unset one :P
19:13:01 <stevemar> we could get them approved in an hour or two :P
19:13:02 <lhcheng> I'm still not sure about the display_name in the list volumes v2, I'll test it later after the meeting
19:13:19 <lhcheng> thought the display_name changed to names in the volume v2 api
19:13:24 <lhcheng> *name
19:13:28 <stevemar> lhcheng: i think it did
19:13:48 <stevemar> i'll be exercising a bunch of the volume v2 commands manually soon
19:13:48 <terrylhowe> I think so too
19:13:56 <stevemar> just to make sure we're not being silly
19:14:20 <stevemar> secondly, i'm OK with https://review.openstack.org/#/c/203280/ not making the cut
19:14:32 <stevemar> dtroyer had some fairly large concerns about it
19:14:50 <lhcheng> okay, I'll try to play around with the commands too
19:15:43 <stevemar> and lastly we should review + play around with the logging patch from the folks at fujitsu
19:15:56 <stevemar> https://review.openstack.org/#/c/186720/
19:16:50 <stevemar> i think once those 3 are in, we can cut 1.6.0
19:16:59 <terrylhowe> The docs on the log patch, I’m not happy with using operation_log: I don’t like either
19:17:13 <terrylhowe> I’d love to get the log patch through though
19:17:29 <stevemar> terrylhowe: propose another name
19:18:05 <terrylhowe> well part of the problem I don’t think this is going to work with our current command line options overriding OCC
19:18:21 <terrylhowe> my proposed othername would be ‘openstackclient’
19:18:30 <stevemar> this will probably be our largest release, 30 bugs and 2 blueprints
19:18:51 <stevemar> and a change in cliff, too
19:18:52 <terrylhowe> yeh, pretty producting release
19:19:02 <stevemar> so get ready for something to break lol
19:19:03 <terrylhowe> we are still waiting on cliff, no?
19:19:50 <stevemar> did it not release?
19:19:55 <terrylhowe> yeh, we need another cliff release
19:19:56 <stevemar> dhellmann: q about cliff release?
19:20:14 <terrylhowe> last release was 6/9 and we were waiting on something I think
19:22:25 <stevemar> yeah, we're waiting on the --help fix, and the git style help when you have a typo
19:22:52 <stevemar> #action stevemar to bug dhellmann about a cliff release
19:23:01 <stevemar> were we waiting on another lib...
19:23:24 <terrylhowe> occ released
19:23:29 <stevemar> oh occ
19:23:32 <stevemar> it released?
19:23:36 <terrylhowe> yes
19:24:02 <stevemar> yeah, we're using 1.4.0 now
19:24:21 * lhcheng sneaks out for office meeting
19:24:30 * stevemar waves bye to lhcheng
19:24:45 <stevemar> terrylhowe: so i think we're getting super close
19:24:52 <terrylhowe> yes
19:25:00 <stevemar> i'll focus on the volume stuff
19:25:05 <stevemar> lets get those + logging in
19:25:07 <stevemar> and call it
19:25:32 <terrylhowe> I’ll work on getting that logging stuff through
19:25:45 <stevemar> cool, i'll focus on OSC for a day or two to get it in shape
19:25:54 * stevemar apologizes to keystone
19:26:17 <stevemar> end meeting early, lets get those patches in
19:26:30 <stevemar> did you have anything else you wanted to chat about?
19:29:17 <terrylhowe> I was jsut looking at the latest bugs and I don’t see much that needs to be discussed
19:29:36 <terrylhowe> I guess I am g2g
19:29:53 <mriedem> you guys broke everything!
19:30:00 <mriedem> https://bugs.launchpad.net/openstack-gate/+bug/1482350
19:30:00 <openstack> Launchpad bug 1482350 in OpenStack-Gate "gate-tempest-dsvm-large-ops fails in stable/juno due to uncapped dep problems with osc" [Undecided,Confirmed]
19:30:00 <uvirtbot> Launchpad bug 1482350 in openstack-gate "gate-tempest-dsvm-large-ops fails in stable/juno due to uncapped dep problems with osc" [Undecided,Confirmed]
19:30:02 <uvirtbot> Launchpad bug 1482350 in openstack-gate "gate-tempest-dsvm-large-ops fails in stable/juno due to uncapped dep problems with osc" [Undecided,Confirmed] https://launchpad.net/bugs/1482350
19:30:43 <terrylhowe> oh, is that all
19:31:21 <stevemar> mriedem: ohhh
19:32:08 <terrylhowe> we need to do a quick cap on ksc for stable/juno?
19:32:19 <stevemar> mriedem: i hate stable branches
19:32:30 <stevemar> and how we do crazy things with dependencies
19:32:31 <terrylhowe> “stable”
19:32:36 <stevemar> forreal
19:32:48 <stevemar> mriedem: do we need to cap ksc?
19:32:51 <stevemar> for juno
19:32:52 <mriedem> yeah
19:32:59 <mriedem> why isn't there a stable/juno branch for osc?
19:33:19 <terrylhowe> no idea
19:33:21 <mriedem> sorry to barge into your meeting, but i felt like being dramatic
19:33:31 <mriedem> we can yap in -dev
19:33:41 <stevemar> mriedem: it's fine, we were going to finish up
19:34:07 <stevemar> mriedem: we only made one for stable/kilo because thats when all the libraries were making stable branches
19:34:33 <stevemar> dhellmann made the branch i think, around the same time he made stable branches for all oslo libraries
19:34:48 <stevemar> i guess we didn't need one for juno at the time
19:34:49 <mriedem> hrm,
19:34:54 <mriedem> yeah novaclient doesn't have a stable/juno branch either
19:35:02 <mriedem> osc 1.0.1 has uncapped deps i guess
19:35:08 <mriedem> and that's the cap for osc in stable/juno
19:35:12 <stevemar> python-*clients only got stable releases last release i think
19:35:41 <mriedem> mtreinish: maybe https://github.com/openstack/requirements/blob/stable/juno/global-requirements.txt#L119 needs to be <1.2
19:35:48 <mriedem> *<1.1
19:35:53 <mriedem> so we could do a 1.0.2
19:36:13 <stevemar> mriedem: yeah, we weren't think of capping deps back in our 1.0.1 days
19:36:13 <mriedem> we'd need a stable/juno for osc to cap it's reqs and release 1.0.2 though
19:36:25 <mriedem> things were so willy nilly back in those days
19:36:35 <stevemar> so willy and so nilly
19:36:39 <terrylhowe> yeh, I’ve never understood why there is a bug number in those
19:37:38 <mriedem> ok, so it sounds like the path forward is (1) stable/juno branch for osc, (2) cap reqs on stable/juno for osc, (3) release that as 1.0.2, (4) raise cap in g-r to <1.1
19:38:09 <terrylhowe> stevemar: are you in the release group for osc?
19:38:17 <terrylhowe> I don’t think I am
19:38:31 <stevemar> terrylhowe: i am, but i've never released it before, dtroyer always did it
19:38:44 <stevemar> i had a TODO to chat with dhellmann about the process
19:39:06 <stevemar> looks like now is the time!
19:39:10 <mtreinish> mriedem: maybe, I don't know enough about what changed between 1.0.1 and 1.2 to weigh on whether thats a good idea or not
19:39:17 <mriedem> <1.1
19:39:21 <mriedem> mtreinish: yeah, we'd have to look i guess
19:39:28 <terrylhowe> stevemar: https://wiki.openstack.org/wiki/Nova/Client_Release_Process
19:39:39 <mtreinish> mriedem: i mean I guess we can push a test patch to find out one way or the other
19:39:48 <mtreinish> I think theres a tempest job on g-r
19:39:57 <terrylhowe> git tag -s 1.0.2&& git push gerrit 1.0.2
19:40:14 <mriedem> mtreinish: yeah, we have some other steps before we get there though
19:40:23 <mriedem> i have the steps in here https://etherpad.openstack.org/p/stable-tracker
19:41:03 <mriedem> it's 2:40 and my wife wants to go test drive cars, doesn't she know juno is wedged and it's not a good time?!
19:41:50 <mriedem> stevemar: terrylhowe: what would we create a stable/juno branch from?  the 1.0.1 tag?
19:42:03 <terrylhowe> the sha1 I guess
19:42:11 <terrylhowe> yeh, teh tag
19:42:25 <mriedem> i guess there is a 1.0.2 already
19:42:51 <mriedem> will semver allow 1.0.1.1?
19:43:00 <mriedem> s/semver/pbr
19:43:16 <stevemar> mriedem: can you explain more about step 3? "release that as 1.0.2"? did you think we didn't have 1.0.2?
19:43:26 <mriedem> stevemar: yeah
19:43:43 <stevemar> mriedem: yeah, we do, i see now... 1.0.1.1 might work
19:43:56 <mriedem> i'm not so sure on 1.0.1.1
19:44:00 <mriedem> pbr 0.11 might barf
19:44:26 <stevemar> right, we're limited to old pbr since we're in juno land
19:44:29 <mriedem> lifeless: will pbr 0.11 with semver allow a release of 1.0.1.1?
19:44:38 <terrylhowe> uughh
19:44:47 <mriedem> stevemar: no, it's just that pbr since 0.11 started enforcing that
19:44:54 <mriedem> latest pbr would barf too i think
19:45:43 <stevemar> well this is getting ugly fast
19:46:32 <terrylhowe> things might work with a 1.0.5 with a capped ksc
19:46:36 <mriedem> i'm also wondering why this only started blowing up since 8/5
19:47:07 <mriedem> i don't really see anything related released yesterday
19:47:59 <stevemar> might it be easier to limit the ksc/ksm/novaclient versions in juno?
19:48:22 <stevemar> or we'll still need a stable/juno release of osc anyway?
19:49:21 <mriedem> those are already all capped
19:49:31 <mriedem> it's osc 1.0.1 that is bringing in novaclient 2.26
19:49:36 <mriedem> since it's uncapped in osc 1.0.1
19:50:14 <mriedem> dhellmann: are you around?
19:51:08 <stevemar> mriedem: we called his name a few times during the meeting and he normally replies, but not today
19:51:24 <mriedem> ok, and mordred is on vacation i think
19:51:38 <mriedem> so, i'm going to tinker with 1.0.1.1 in setup.cfg of osc 1.0.1 and see how that works
19:51:51 <stevemar> go for it, i'll be online to help
19:53:06 <stevemar> any other topics? or dramatic entrances?
19:53:59 * terrylhowe : looks around nervously
19:54:11 <stevemar> #endmeeting