19:01:07 <dtroyer> #startmeeting OpenStackClient
19:01:09 <openstack> Meeting started Thu Jan 14 19:01:07 2016 UTC and is due to finish in 60 minutes.  The chair is dtroyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:12 <openstack> The meeting name has been set to 'openstackclient'
19:01:14 <dtroyer> Anyone here for an OSC meeting?
19:01:25 <rtheis> o/
19:01:36 <dtroyer> courtesy ping: dhellmann, stevemar, briancurtin, terrylhowe, lhcheng, dstanek, MeganR
19:01:49 <terrylhowe> o/
19:02:12 <MeganR> o/
19:02:15 <stevemar> o/
19:02:28 <stevemar> you got me in the middle of a nasty rebase of a backport :)
19:02:35 <dtroyer> Hi everyone, long time no me-here-on-time
19:02:52 <MeganR> Happy 2016!
19:03:05 <dtroyer> woot!  even years rock!
19:03:06 <dstanek> o/
19:03:32 <stevemar> \o/
19:03:34 <dtroyer> ok, lets get started
19:03:46 <dtroyer> I have one thing not os the usual short list
19:04:00 <dtroyer> #topic CLI deploy guide updates
19:04:33 <dtroyer> annegentle asked me about our plans to update the user docs re CLI to use OSc rather than the project clients
19:04:51 <dtroyer> we really haven't talked about that before now, so this is a good time to start
19:05:08 <stevemar> dtroyer: like porting over all the first time setup commands to use osc?
19:05:24 <dtroyer> some of the updates will be simple (install OSC)
19:05:31 <dtroyer> and some will be what stevemar just mentioned
19:06:00 <dtroyer> step one is to ask if there is anyone interested in taking on that work
19:06:03 <stevemar> so if the user guide says "cinder create" we can replace it with "openstack volume create" ?
19:06:21 <dtroyer> stevemar: that is my assumption, yes
19:06:29 <stevemar> thats a bold move
19:07:07 <dtroyer> it is, but it seems that there may be acceptance for it at least in some corners
19:07:33 <dtroyer> we may do it on  a per-project basis as projects sign on, say as they deprecate their project CLI
19:08:00 <dtroyer> I think we need someone to first do a look-over and see just how much work this really is though
19:08:28 <stevemar> that leads to another point... https://review.openstack.org/#/c/243348/ cross-project initiative to do just that
19:09:29 <dtroyer> yes…I hadn't looked at that in a week or two, it's getting supprot now, good
19:09:54 <stevemar> dtroyer: not entirely
19:10:02 <stevemar> theres some push back from cinder still
19:10:26 <stevemar> which is unfortunate, since i think that's the next closest project
19:10:36 <dtroyer> at a glance (heh) though it seems addressable, not digging-in-heels pushback
19:10:40 <stevemar> i get the feeling they think things are half-baked
19:11:21 <dtroyer> volume v2 is still young and there may be details missing yet.  but actually doing the deprecation isn't the same as stating a goal
19:11:36 <dtroyer> well, more than goal but not quite picy
19:11:38 <dtroyer> policy
19:13:58 <stevemar> i suppose
19:14:52 <dtroyer> so back to the docs, I'll post a note to the ML looking for volunteers
19:15:01 <stevemar> ++
19:15:17 <stevemar> i would love to help, but i don't scale :(
19:15:19 <dtroyer> re changing the project CLI commands, we probably need to let proejcts take that lead
19:15:40 * dtroyer wants a stevemar.clone() method
19:16:06 <rtheis> would this be an all or nothing approach to updating user docs for a project?  That is, move all "cinder" to "openstack" so there isn't a mix of the two.
19:16:30 <stevemar> rtheis: i think an all or nothing approach is good for docs
19:16:34 <dtroyer> rtheis: I suspect one a project is OK with the change, they'll want to do it all
19:16:48 <stevemar> it'll also show us where we are lacking
19:16:49 <dtroyer> I'm more confident the docs folks will want that
19:17:03 <rtheis> stevemar: exactly
19:17:37 <stevemar> we should try and fill in those cinder *blocking* points - eh eh ?
19:18:24 <dtroyer> that looks like a fun list to do proper commands for ;)
19:18:49 <stevemar> all the commands walter lists in that review
19:20:36 <dtroyer> the comment about making everything a plugin was interesting too…they already are, just a few are included in the box
19:21:06 <dtroyer> I'd like to shift gears just a bit
19:21:12 <dtroyer> #topic release planning
19:21:51 <dtroyer> Thinking about the next release, now that SDK is a dependency we have to consider releasing with it still pre-1.0
19:22:15 <dtroyer> maybe that isn't a concern, but I'm not sure I know enough right now to decide that
19:22:36 <stevemar> dtroyer: worth it to get networking commands
19:22:55 <stevemar> if sdk folks change things up on us, we work closely enough with them to get things fixed quickly
19:23:03 <dtroyer> terrylhowe: I saw briancurtin mention one more major change before 1.0, do you have any idea how much impact that will have on what we have implemented so far?
19:23:38 <dtroyer> stevemar: right, I just want to be care about how tightly we need to keep the two tied together
19:24:29 <dtroyer> the remainig pre-1.0 work may be a don't care for OSc, in which case my worries go away
19:24:37 <terrylhowe> I think he was talking about generating urls for resources that have a key in them, it is internal
19:24:39 <rtheis> I don't think the remaining sdk work for 1.0 should impact osc's usage.  But showing osc network quotas is broken until we get and sdk release
19:24:50 <terrylhowe> stuff like metadata
19:24:57 <dtroyer> ok, cool.  I haven't kept as up-to-date on that as I'd like
19:24:57 <dtroyer> thanks
19:25:31 <dtroyer> so the next question is picking a point where the new bits are sufficiently coherent to do a release.  Just making sure we don't put something half-baked out
19:26:26 <dtroyer> again, that may be a moot concern on my part
19:26:55 <stevemar> new bits meaning osc bits or sdk bits?
19:27:01 <dtroyer> osc
19:27:09 <dtroyer> the network stuff specifically
19:27:16 <terrylhowe> I doubt there will be many changes to the existing network stuff
19:27:31 <terrylhowe> we’ve had a lot of time to beat on that
19:27:42 <dtroyer> but are there things in the pipeline right now that someone wants included sooner than later?
19:27:49 <rtheis> https://launchpad.net/bugs/1528249 is the only break in network that I am aware of
19:27:50 <openstack> Launchpad bug 1528249 in python-openstackclient "Failed to show network quotas for a project" [High,In progress] - Assigned to Richard Theis (rtheis)
19:28:02 <dtroyer> I'm just looking for a list of "when x,y,z are done we can release" if it exists
19:28:12 <stevemar> oh gotcha
19:29:21 <dtroyer> things like https://review.openstack.org/#/c/84782/
19:30:02 <stevemar> lets get the port CRUD in
19:30:02 <stevemar> and the subnet CRUD
19:30:29 <rtheis> here's start of port CRUD: https://review.openstack.org/#/c/260568/
19:31:06 <terrylhowe> I need to rework the subnet tests to the new pattern, it is time consuming and all I do is shovel snow lately
19:31:27 <stevemar> lol
19:31:36 <dtroyer> that's where all of our snow went
19:31:45 <stevemar> terrylhowe: get a snow blower
19:31:59 <terrylhowe> snow blower broke :-/
19:32:08 <stevemar> oh jeez
19:32:21 <dtroyer> alternative, get a 15 year old
19:32:39 <terrylhowe> anyway, personal problems, I’ll get to it.  I started last weekend and didn’t finish.
19:33:09 <dtroyer> ok, I'll keep an eye out for those two topics for priority
19:33:24 <stevemar> dtroyer: i think just the networky bits are high priority for the next release
19:33:29 <stevemar> everything else can wait
19:33:41 <dtroyer> as a side note, we need to start encouraging the inclusion of release note info for user-visible stuff
19:33:45 <stevemar> fwiw, theres a new keystoneclient and keystoneauth, i cut them yesterday
19:33:47 <dtroyer> stevemar: right
19:34:05 <dtroyer> is that the ksa that has the py35 fix in it?
19:34:07 <stevemar> dtroyer: i did them for a few patches
19:34:17 <stevemar> dtroyer: i wasn't aware of a py35 problem
19:34:39 <dtroyer> there is a one-liner that ksa needed, I think it was fixed in Dec
19:34:48 <dtroyer> oh, wait, it's already released
19:35:02 <dtroyer> that was the only thing I needed to run OSC on py35
19:35:56 <dtroyer> #agreed network API subnet and port CRUD are the blockers for next release
19:36:15 <dtroyer> #topic  open reviews
19:36:24 <stevemar> dtroyer: thanks for confirming i haven't gone insane yet
19:36:30 <dtroyer> are there any other reviews anyone wants to bring attention to?
19:36:42 <dtroyer> stevemar: I wouldn't trust that I could confirm that ;)
19:38:55 <stevemar> dtroyer: nothing else from my end re: osc
19:38:59 <rtheis> Just a follow-up from last meeting before new year. I reworked https://review.openstack.org/#/c/257543/ when folks have time to take a look.
19:39:00 <stevemar> i'm swamped with keystoney bits
19:39:41 <stevemar> rtheis: terrylhowe lhcheng_ this is an open invitation to ping me for reviews
19:40:04 <stevemar> i haven't checked my OSC review queue in a while, but if you need a quick look, please ping me
19:40:11 <terrylhowe> I’ve got nothing at the moment
19:40:13 <rtheis> stevemar: ok, thanks
19:40:19 <stevemar> dtroyer: you can wait -_-
19:40:39 <dtroyer> rtheis: added to today's short list
19:40:47 <rtheis> thanks
19:41:28 <dtroyer> ok, next...
19:41:35 <dtroyer> #topic open bugs
19:42:02 <dtroyer> I intend to look at the bug list this afternoon during some waiting-room time
19:42:22 <dtroyer> are there any we should discuss now though?
19:42:52 <stevemar> https://bugs.launchpad.net/python-openstackclient/+bug/1531574 is worth a look
19:42:53 <openstack> Launchpad bug 1531574 in python-openstackclient "liberty: two json/yaml formatters for list/show command if cliff 1.15.0 (and cliff-tablib) is installed" [Undecided,New]
19:43:49 <dtroyer> yeah, I thought cliff-tablib was on the don't-do-that list
19:43:54 <stevemar> it is
19:44:07 <stevemar> but "what if it's already installed on my system"
19:44:20 <stevemar> i've had 2 issues with this now
19:44:21 <dtroyer> do we need to do anything since this is a stable release issue?
19:44:26 <dtroyer> so maybe we do
19:44:28 * stevemar shrugs
19:44:38 <dtroyer> low priority though
19:44:39 <stevemar> i told them both to remove cliff-tablib
19:44:53 <stevemar> and the problem magically goes away
19:45:03 <dtroyer> maybe just a release note if/when we do another stable?
19:45:57 <stevemar> that could work
19:46:17 <dtroyer> is this actually just a cliff issue?  If so, putting in a check there magically fixes everything using it
19:46:52 <stevemar> i dont think so, its the fact that they share the same entrypoint/namespace thingy
19:47:04 <dtroyer> well, having a known good workaround is enough for now
19:47:12 <dtroyer> ah, I wondered if that might play into it, ok
19:47:24 <stevemar> oh, in other news, my osc-command-checker should be a voting job in our gate
19:47:43 <dhellmann> we could update stevedore to have a feature to ignore entry points from a given python dist or something, but that would be a lot more work than telling folks not to install the extra package
19:48:16 <dtroyer> dhellmann: thanks, I think I agree
19:48:20 <dhellmann> you know, we could release a new cliff-tablib that doesn't have the conflicting plugins, too
19:48:33 <stevemar> dhellmann: i was thinking that too
19:48:43 <stevemar> dhellmann: but it doesn't pass build atm
19:48:48 <stevemar> dhellmann: unless you want to nuke it
19:49:04 <dtroyer> wold that give the false impression that it really shouldn't be used?
19:49:20 <dtroyer> uh, parse error in that question...
19:49:36 <dhellmann> I haven't looked at the code in a while, I'll see if I can figure out why it's failing builds
19:49:50 <dhellmann> stevemar : which plugins? just table?
19:50:02 <dhellmann> er, I mean json?
19:50:11 <dhellmann> ah, json and yaml
19:50:12 <dhellmann> ok
19:50:14 <dtroyer> dhellmann: don't make it too high a priority, I think removing it is fine
19:50:41 <dhellmann> k
19:51:14 <dtroyer> other bugs?
19:51:35 <stevemar> yeah, json and yaml, but without those, is cliff-tablib particularly useful?
19:52:06 <dhellmann> no, not really
19:52:18 <dhellmann> there's the HTML formatter, but I have  no idea if anyone uses that
19:52:26 <stevemar> yeah
19:52:32 * stevemar shrugs
19:52:58 <stevemar> stepping aside for a bit
19:53:08 <stevemar> nothing else to mention, thanks for hosting again dtroyer
19:53:25 <dtroyer> thanks stevemar, later
19:53:30 <dtroyer> ok…
19:53:35 <dtroyer> #topic open discussion
19:53:45 <dtroyer> does anyone have anything else to bring up?
19:54:47 <rtheis> is there a guide on how to write a release note?
19:55:01 <dtroyer> there is…
19:55:04 * dtroyer looks through notes
19:56:43 <dtroyer> here is what Keystone has in their docs: http://docs.openstack.org/developer/keystone/developing.html#release-notes
19:56:56 <rtheis> dtroyer: thank you
19:57:09 <dtroyer> the project team docs are at: http://docs.openstack.org/project-team-guide/release-management.html#managing-release-notes
19:57:33 <dtroyer> and dhellmann's announcement is http://lists.openstack.org/pipermail/openstack-dev/2015-November/078301.html
19:57:37 <dtroyer> that should cover most of it
19:58:31 <dtroyer> time is almost done, if nothing else I'll close
19:58:53 <terrylhowe> nothing here
19:59:11 <MeganR> I'm good, thank you
19:59:20 <dtroyer> ok, thanks everyone!
19:59:34 <dtroyer> #endmeeting